Setting tag plcapi-5.3-2
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 Requires: SOAPpy
36 Requires: python-simplejson
37 # for the RebootNodeWithPCU method
38 Requires: pcucontrol >= 1.0-6
39 # for OMF integration
40 Requires: pyaspects >= 0.4
41 Requires: python-twisted-words
42 Requires: python-twisted-web
43 # ldap
44 Requires: python-ldap
45 # for memcache
46 Requires: memcached python-memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 # for building the wsdl interface we used to require PyXML
58 # but this has gone with f20 so turning this off for now
59 BuildRequires: php-devel python-simplejson
60 Obsoletes: php-xmlrpc
61 Provides: php-xmlrpc
62
63 # PostgreSQL and SOAPpy are necessary to run the API server, but not
64 # plcsh. Since the only supported method of running the server is via
65 # MyPLC anyway, don't be so stringent about binary requirements, in
66 # case people want to install this package just for plcsh.
67 # Requires: postgresql-server, SOAPpy
68 AutoReqProv: no
69
70 %description
71 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
72 PlanetLab Central (PLC) database. The API may be accessed directly via
73 the Python shell program plcsh, through a toy standalone server, or
74 through Apache mod_python.
75
76 %prep
77 %setup -q
78
79 %build
80 # python-pycurl and python-psycopg2 avail. from fedora 5
81 # we used to ship our own version of psycopg2 and pycurl, for fedora4
82 # starting with 4.3, support for these two modules is taken out
83
84 # Build __init__.py metafiles and PHP API. 
85 %{__make} %{?_smp_mflags}
86 %{__make} -C wsdl
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
91
92 # Install shell symlink
93 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
94 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
95
96 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
97 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
98 ; Enable xmlrpc extension module
99 extension=xmlrpc.so
100 EOF
101
102 # Install initscripts
103 echo "* Installing initscripts"
104 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
105 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
106
107 # Install db-config.d files
108 echo "* Installing db-config.d files"
109 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
111 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
112
113 # Install wsdl
114 echo "* Installing wsdl"
115 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
116
117 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
118 ## Install omf_slicemgr.py
119 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
120 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
121 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
122
123 # Install ratelimit log
124 mkdir -p $RPM_BUILD_ROOT/var/log
125 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
126 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %define php_extension_dir %(php-config --extension-dir)
132
133 %files
134 %defattr(-,root,root,-)
135 %dir %{_datadir}/plc_api
136 #%dir /var/log/omf/
137 %{_datadir}/plc_api/*
138 %{_bindir}/plcsh
139 %{php_extension_dir}/xmlrpc.so
140 %{_sysconfdir}/php.d/xmlrpc.ini
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 #/usr/bin/omf_slicemgr.py*
146 #/usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plc_api_ratelimit.log
148
149
150 %changelog
151 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
152 - don't use PyXML that is deprecated in f20, use lxml instead
153 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
154
155 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
156 - create accessor 'hrn' for site as well
157 - create accessors 'sfa_created' for site/slice/person
158 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
159 - UpdatePerson() updates Person HRN according to updated email.
160 - UpdateSite() updates Site HRN according to updated login_base.
161 - Fix AddPersonToSite().
162 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
163 - RefreshPeer() manages Site*Person and Person*Role relationships.
164
165 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
166 - provide a slicename_to_hrn function
167
168 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
169 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
170
171 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
172 - fix for wsgi-based deployments, each thread has its own api()
173
174 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
175 - also cleanup omf-slicemgr initscript
176
177 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
178 - tear down omf-related aspects as this is no longer needed with omfv6
179
180 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
181 - also expose 'expires' in ResolveSlices
182
183 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
184 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
185
186 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
187 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
188
189 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
190 - use SFA code for computing hrn's when available
191
192 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
193 - new slice tag 'interface' for configuring a virtual interface
194 - new builtin 030-interface_tags
195 - new node accessor and tag 'virt' for mixing lxc & vs nodes
196 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
197 - moved ModPypthon and plc.wsgi in the apache/ subdir
198 - renamed PLCAPI.spec into plcapi.spec
199 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
200 - support for php-5.4
201
202 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
203 - implement PLC_VSYS_DEFAULTS in AddSlice
204
205 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
206 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
207 - AddPerson and UpdatePerson are now tag-aware
208 - as a side-effect AddPerson is more picky and rejects invalid fields
209 - which results in a requirement to use sfa-2.1-22 with this tag
210 - marginal improvement on the xml doc on tags
211
212 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
213 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
214 - reset_xmpp_pubsub_nodes now hos options and usage
215 - new Accessors for vicci
216
217 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
218 - fixed imports for tags management with sites and persons
219 - add predefined 'cpu_freezable' tag
220
221 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
222 - tweaks in interface initialization
223 - has 'vsys_vnet' as a predefined tagtype
224 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
225 - bugfix: GetSlivers & nodegroups
226 - bugfix: in jabber groups management
227
228 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
229 - fix gpg-authentication for Persons (thanks Jordan)
230 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
231 - ip address/network check: v4 or v6
232 - customized DB Message survive upgrade
233 - make sync works in lxc-hosted tests
234 - no svn keywords anymore
235
236 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
237 - fix sorting for methods list in docs
238 - untested but needed tweak for postgres startup in f16
239
240 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
241 - tweaks in postgresql setup - in line with sfa
242
243 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
244 - slight tweaks in Persons.py
245
246 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
247 - GetSession has support for more than one day sessions
248 - reset_xmpp_pubsub_nodes is much more efficient
249 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
250 - bugfix - deleting a person in the middle of the signup process
251
252 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
253 - ratelimit aspects
254 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
255 - requires Django for cache_utils
256 - attempt to expose 'pldistro' to sfa
257 - last_time_spent_online, last_time_spent_offline: new fields in Node
258 - new slice tags 'isolate_loopback' and 'cpu_cores'
259 - refresh-peer federation logs dump exceptions
260 - modpython logs have a timestamp
261 - more verbose/accurate php error reporting
262 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
263 - AddNode, UpdateNode: manage tags directly rather than through another method
264 - BootUpdateNode: only update once
265 - GetPersons: techs can access the list of persons on their site
266 - GetSlices and GetSliceTags: techs can see slices on their nodes
267 - GetSlivers: isrootonsite tag; cacheable
268
269 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
270 - rename initscript_body into initscript_code
271
272 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
273 - new initscript_body tag
274
275 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
276 - working draft for GetSliceSshKeys
277
278 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
279 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
280 - (this is for people who cancel their download)
281
282 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
283 - fix db-config sequence : accessors step now merged in, and occurs at the right time
284 - db-config also more robust
285 - no more explicit 'accessors' step in plc.d
286
287 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
288 - session auth: do *not* delete session when node runs a method that does not have 'node' role
289 - session auth: remove support for bootonce in old boot CDs
290 - give a reason when caller_may_write_slice_tag fails
291 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
292
293 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
294 - SetSliceVref needed the node role
295 - protect GetSliceFamily
296 - Fix bugs in tag authorizations
297
298 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
299 - altered checking of optional fields in Interfaces
300 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
301 - has pyxml and python-simplejson as new deps
302
303 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
304 - tweak doc extraction for fedora14
305
306 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
307 - builtin accessors for the myslice page
308 - Get{Node,Interface}Tags allowed to techs
309 - tweak in ratelimitaspect.py
310
311 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
312 - add admin role to accessor-related tags (arch, {fc,pl}distro)
313
314 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
315 - bugfix in {Update,Delete}PersonTag
316 - updated xml doc for filters, accessors and tagtypes
317 - more explicit msg in case of missing roles
318 - improvements in ratelimitaspects.py
319
320 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
321 - fix the roles for ssh_key and hmac tags
322
323 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
324 - tag permissions system based on roles and not min_role_ids
325 - accessors simplified accordingly (no more min_role_id)
326 - new methods AddRoleToTagType and DeleteRoleFromTagType
327 - accessor-related tagtypes are created sooner, and enforced
328 - cleaned up redundancy between db-config.d and accessors
329
330 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
331 - fix RefreshPeer that was not working in 5.0-17
332
333 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
334 - RefreshPeer is able to cope with 2 peers running different releases of the api
335 - DeletePerson can be used on duplicates
336 - first appearance of ModPythonJson.py
337
338 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
339 - set accessors return the new value
340 - tweaks in the pubsub groups management
341
342 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
343 - convert hostnames to lower case and use ILIKE instead of LIKE
344
345 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
346 - use hrn in pubsub groups
347
348 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
349 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
350 - OMF fixes
351
352 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
353 - automatically set vsys tag for omf controlled slices
354
355 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
356 - addition of the 'ssh_key' slice tag
357 - first draft of the LDAP interface
358
359 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
360 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
361 - and readable through GetLeaseGranularity
362 - GetSlivers to expose reservation_policy and lease_granularity
363 - GetBootMedium fixed for reservable nodes
364 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
365 - new Apache mod_wsgi python interface
366
367 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
368 - the leases system
369
370 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
371 - previous tag had gone wrong
372
373 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
374 - fix pubsub hostname
375
376 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
377 - tweaks for the omf support (xmpp groups and RC-controlled slices)
378 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
379 - GetNodeFlavour exposes fcdistro
380
381 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
382 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
383
384 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
385 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
386 - pyaspect hooks allow to  maintain the namespace xmpp groups
387 - new omf_slicemgr is a proxy to xmpp, used by these hooks
388 - nodes have their hrn exposed in the 'hrn' tag
389 - node hrn exposed in GetSlivers, as well as the overall xmpp config
390 - system slice 'drl' gets created by db-config
391 - daniel's changes to Filter for supporting wildcards in lists
392 - AddSliceTag consistency check tweaked
393
394 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
395 - major cleanup
396 - get rid of all 4.2-related legacy code
397 - reset the migrations code, planetlab5.sql somes with (5,100)
398 - uses hashlib module when available
399
400 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
401 - first working version of 5.0:
402 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
403 - nodefamily is 3-fold with pldistro-fcdistro-arch
404 - site and person tags
405 - new methods GetSliceFamily and GetNodeFlavour
406 - deprecated the dummynet stuff that were for the external dummyboxes
407 - tags definition : more consistency between db-config scripts and accessors
408 - (get accessor to create the tag type too if absent)
409 - logging an event for AddSliceToNodes
410
411 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
412 - support for fedora 12
413 - fix subtle bug in filtering with ] and quotes
414
415 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
416 - * patch for php-5.3 (the one in f12)
417 - * validate email addresses with regex
418 - * add PersonTags and SiteTags
419 - * add additional accessors for node tags (kvariant, serial, ..)
420
421 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
422 - Redacting password, session, and authstring values from the event log.
423
424 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
425 - let AddSite set ext_consortium_id - required for the poorman registration pages
426 - drop version constraint on Requires: postgresql-python
427 - don't log system calls nor ReportRunLevel
428
429 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
430 - Fix requires for CentOS.
431
432 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
433 - Require postgresql 8.2 (for array operators && and @>)
434
435 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
436 - Filter now supports the | and & features to match in sequence values
437 - bugfix in the postgresql wrapper for sequence filter values
438 - reviewed GetSlivers to export admin keys more efficiently
439 - fix checking roles in UpdateSliceTag
440
441 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
442 - - Some typos in the documentation were fixed.
443 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
444 - to the tag's min_role_id.
445
446 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
447
448 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
449 - Ongoing work to add upcalls, using new SFA class
450 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
451 - reviewed type-checking for the 3 taggable classes node-interface-slice
452 - cleanup ald dummynet stuff
453 - expose the 'extensions' accessors to the API
454 - tweaked checks in AddSliceTag
455 - GetPersons exposes roles by default
456 - bugfix in ReportRunLevel for non-string levels
457 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
458
459 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
460 - new BindObjectToPeer method for sfa
461 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
462
463 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
464 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
465 - reportrunlevel logs its calls only when run_level changes
466 - pycurl more robust wrt to xmlrpclib.Transport
467
468 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
469 - produce a wsdl interface
470 - bugfix in getbootmedium for nodes with interface tags
471
472 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
473 - bugfix for some rare pattern-based filters
474
475 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
476 - improvements in the 4.2 legacy layer
477
478 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
479 - bugfix required for slice tags set on nodegroups
480
481 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
482 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
483
484 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
485 - more powerful legacy layer with 4.2
486
487 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
488 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
489 - migration script has an option for running interactively
490
491 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
492 - skips already added entries
493
494 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
495 - yet another set of fixes for external dummynet boxes
496
497 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
498 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
499 - and tmp file is cleaned up
500
501 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
502 - restore missing ResolveSlices
503
504 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
505 - new method GetDummyBoxMedium
506
507 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
508 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
509
510 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
511 - support for external dummynet boxes back in 4.3 - first draft
512
513 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
514 - fixes for smooth federation between 4.2 and 4.3
515 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
516
517 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
518 - support for BootCD variants (GetBootMedium ['variant:centos5'])
519 - fix corner case with filters like {'~slice_id':[]}
520 - fix transaction leak that caused the db connections pool to exhaust
521 - properly expose all methods, including Legacy/, and not only Methods/
522
523 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
524 - renumbered as 4.3
525 - nodes have new fields run_level (in addition to boot_state) and verified
526 - tweaked migration from 4.2
527 - tuned rpm dependencies
528 - doc generation more explicit about errors like missing python modules
529 - removed obsolete method GetSlicesMD5
530
531 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
532 - unified all tags
533 - renamed interface settings into interface tags and slice attributes into slice tags
534 - nodes have a node_type
535 - various changes on the way to 4.3
536
537 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
538 - Checkpointing : this version still has interface settings and slice attributes
539
540 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
541 - first iteration with taggable nodes/interfaces/slices
542 - embryo for ilinks
543 - cleaned up boot states
544 - migration script moslty complete
545
546 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
547 - fixed doc build by locating locally installed DTDs at build-time
548
549 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
550 - no more doc packaged outside of myplc-docs - doc/ cleaned up
551 - enhancements in doc on filters 
552 - bootcd-aware GetBootMedium merged from onelab
553
554 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
555 - checkpoint while the new myplc-docs package is underway
556 - bugfix: GetSlivers & conf files
557 - doc: removed target files 
558
559 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
560 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
561 - the non-deleted fields were index, resulting in massivly slow queries.
562
563
564 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
565 - plcsh: better handling of options when running as a shell script
566 - getbootmedium exports compute_key
567 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
568
569 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
570 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
571 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
572
573 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
574 - refresh peer script to use a month-dependent logfile
575 - tracking the starting point for UniPi integration of the dummynet boxes
576
577 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
578 - plcsh adds its own path to sys.path
579 - fix so GetNodes can be called from a Node
580
581 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
582 - Initial build.
583
584 %define module_current_branch 4.3