Setting tag plcapi-5.3-5
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 Requires: SOAPpy
36 Requires: python-simplejson
37 # for the RebootNodeWithPCU method
38 Requires: pcucontrol >= 1.0-6
39 # for OMF integration
40 Requires: pyaspects >= 0.4
41 Requires: python-twisted-words
42 Requires: python-twisted-web
43 # ldap
44 Requires: python-ldap
45 # for memcache
46 Requires: memcached python-memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 # for building the wsdl interface we used to require PyXML
58 # but this has gone with f20 so turning this off for now
59 BuildRequires: php-devel python-simplejson
60 Obsoletes: php-xmlrpc
61 Provides: php-xmlrpc
62
63 # PostgreSQL and SOAPpy are necessary to run the API server, but not
64 # plcsh. Since the only supported method of running the server is via
65 # MyPLC anyway, don't be so stringent about binary requirements, in
66 # case people want to install this package just for plcsh.
67 # Requires: postgresql-server, SOAPpy
68 AutoReqProv: no
69
70 %description
71 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
72 PlanetLab Central (PLC) database. The API may be accessed directly via
73 the Python shell program plcsh, through a toy standalone server, or
74 through Apache mod_python.
75
76 %prep
77 %setup -q
78
79 %build
80 # python-pycurl and python-psycopg2 avail. from fedora 5
81 # we used to ship our own version of psycopg2 and pycurl, for fedora4
82 # starting with 4.3, support for these two modules is taken out
83
84 # Build __init__.py metafiles and PHP API. 
85 %{__make} %{?_smp_mflags}
86 %{__make} -C wsdl
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
91
92 # Install shell symlink
93 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
94 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
95
96 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
97 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
98 ; Enable xmlrpc extension module
99 extension=xmlrpc.so
100 EOF
101
102 # Install initscripts
103 echo "* Installing initscripts"
104 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
105 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
106
107 # Install db-config.d files
108 echo "* Installing db-config.d files"
109 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
111 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
112
113 # Install wsdl
114 echo "* Installing wsdl"
115 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
116
117 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
118 ## Install omf_slicemgr.py
119 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
120 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
121 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
122
123 # Install ratelimit log
124 mkdir -p $RPM_BUILD_ROOT/var/log
125 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
126 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %define php_extension_dir %(php-config --extension-dir)
132
133 %files
134 %defattr(-,root,root,-)
135 %dir %{_datadir}/plc_api
136 #%dir /var/log/omf/
137 %{_datadir}/plc_api/*
138 %{_bindir}/plcsh
139 %{php_extension_dir}/xmlrpc.so
140 %{_sysconfdir}/php.d/xmlrpc.ini
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 #/usr/bin/omf_slicemgr.py*
146 #/usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plc_api_ratelimit.log
148
149
150 %changelog
151 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
152 - allow GetSlices to filter on tags as well
153
154 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
155 - enable filtering on tags (like hrn) with GetPersons and GetSites
156
157 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
158 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
159
160 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
161 - don't use PyXML that is deprecated in f20, use lxml instead
162 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
163
164 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
165 - create accessor 'hrn' for site as well
166 - create accessors 'sfa_created' for site/slice/person
167 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
168 - UpdatePerson() updates Person HRN according to updated email.
169 - UpdateSite() updates Site HRN according to updated login_base.
170 - Fix AddPersonToSite().
171 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
172 - RefreshPeer() manages Site*Person and Person*Role relationships.
173
174 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
175 - provide a slicename_to_hrn function
176
177 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
178 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
179
180 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
181 - fix for wsgi-based deployments, each thread has its own api()
182
183 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
184 - also cleanup omf-slicemgr initscript
185
186 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
187 - tear down omf-related aspects as this is no longer needed with omfv6
188
189 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
190 - also expose 'expires' in ResolveSlices
191
192 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
193 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
194
195 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
196 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
197
198 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
199 - use SFA code for computing hrn's when available
200
201 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
202 - new slice tag 'interface' for configuring a virtual interface
203 - new builtin 030-interface_tags
204 - new node accessor and tag 'virt' for mixing lxc & vs nodes
205 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
206 - moved ModPypthon and plc.wsgi in the apache/ subdir
207 - renamed PLCAPI.spec into plcapi.spec
208 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
209 - support for php-5.4
210
211 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
212 - implement PLC_VSYS_DEFAULTS in AddSlice
213
214 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
215 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
216 - AddPerson and UpdatePerson are now tag-aware
217 - as a side-effect AddPerson is more picky and rejects invalid fields
218 - which results in a requirement to use sfa-2.1-22 with this tag
219 - marginal improvement on the xml doc on tags
220
221 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
222 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
223 - reset_xmpp_pubsub_nodes now hos options and usage
224 - new Accessors for vicci
225
226 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
227 - fixed imports for tags management with sites and persons
228 - add predefined 'cpu_freezable' tag
229
230 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
231 - tweaks in interface initialization
232 - has 'vsys_vnet' as a predefined tagtype
233 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
234 - bugfix: GetSlivers & nodegroups
235 - bugfix: in jabber groups management
236
237 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
238 - fix gpg-authentication for Persons (thanks Jordan)
239 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
240 - ip address/network check: v4 or v6
241 - customized DB Message survive upgrade
242 - make sync works in lxc-hosted tests
243 - no svn keywords anymore
244
245 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
246 - fix sorting for methods list in docs
247 - untested but needed tweak for postgres startup in f16
248
249 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
250 - tweaks in postgresql setup - in line with sfa
251
252 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
253 - slight tweaks in Persons.py
254
255 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
256 - GetSession has support for more than one day sessions
257 - reset_xmpp_pubsub_nodes is much more efficient
258 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
259 - bugfix - deleting a person in the middle of the signup process
260
261 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
262 - ratelimit aspects
263 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
264 - requires Django for cache_utils
265 - attempt to expose 'pldistro' to sfa
266 - last_time_spent_online, last_time_spent_offline: new fields in Node
267 - new slice tags 'isolate_loopback' and 'cpu_cores'
268 - refresh-peer federation logs dump exceptions
269 - modpython logs have a timestamp
270 - more verbose/accurate php error reporting
271 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
272 - AddNode, UpdateNode: manage tags directly rather than through another method
273 - BootUpdateNode: only update once
274 - GetPersons: techs can access the list of persons on their site
275 - GetSlices and GetSliceTags: techs can see slices on their nodes
276 - GetSlivers: isrootonsite tag; cacheable
277
278 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
279 - rename initscript_body into initscript_code
280
281 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
282 - new initscript_body tag
283
284 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
285 - working draft for GetSliceSshKeys
286
287 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
288 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
289 - (this is for people who cancel their download)
290
291 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
292 - fix db-config sequence : accessors step now merged in, and occurs at the right time
293 - db-config also more robust
294 - no more explicit 'accessors' step in plc.d
295
296 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
297 - session auth: do *not* delete session when node runs a method that does not have 'node' role
298 - session auth: remove support for bootonce in old boot CDs
299 - give a reason when caller_may_write_slice_tag fails
300 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
301
302 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
303 - SetSliceVref needed the node role
304 - protect GetSliceFamily
305 - Fix bugs in tag authorizations
306
307 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
308 - altered checking of optional fields in Interfaces
309 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
310 - has pyxml and python-simplejson as new deps
311
312 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
313 - tweak doc extraction for fedora14
314
315 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
316 - builtin accessors for the myslice page
317 - Get{Node,Interface}Tags allowed to techs
318 - tweak in ratelimitaspect.py
319
320 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
321 - add admin role to accessor-related tags (arch, {fc,pl}distro)
322
323 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
324 - bugfix in {Update,Delete}PersonTag
325 - updated xml doc for filters, accessors and tagtypes
326 - more explicit msg in case of missing roles
327 - improvements in ratelimitaspects.py
328
329 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
330 - fix the roles for ssh_key and hmac tags
331
332 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
333 - tag permissions system based on roles and not min_role_ids
334 - accessors simplified accordingly (no more min_role_id)
335 - new methods AddRoleToTagType and DeleteRoleFromTagType
336 - accessor-related tagtypes are created sooner, and enforced
337 - cleaned up redundancy between db-config.d and accessors
338
339 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
340 - fix RefreshPeer that was not working in 5.0-17
341
342 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
343 - RefreshPeer is able to cope with 2 peers running different releases of the api
344 - DeletePerson can be used on duplicates
345 - first appearance of ModPythonJson.py
346
347 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
348 - set accessors return the new value
349 - tweaks in the pubsub groups management
350
351 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
352 - convert hostnames to lower case and use ILIKE instead of LIKE
353
354 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
355 - use hrn in pubsub groups
356
357 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
358 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
359 - OMF fixes
360
361 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
362 - automatically set vsys tag for omf controlled slices
363
364 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
365 - addition of the 'ssh_key' slice tag
366 - first draft of the LDAP interface
367
368 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
369 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
370 - and readable through GetLeaseGranularity
371 - GetSlivers to expose reservation_policy and lease_granularity
372 - GetBootMedium fixed for reservable nodes
373 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
374 - new Apache mod_wsgi python interface
375
376 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
377 - the leases system
378
379 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
380 - previous tag had gone wrong
381
382 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
383 - fix pubsub hostname
384
385 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
386 - tweaks for the omf support (xmpp groups and RC-controlled slices)
387 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
388 - GetNodeFlavour exposes fcdistro
389
390 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
391 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
392
393 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
394 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
395 - pyaspect hooks allow to  maintain the namespace xmpp groups
396 - new omf_slicemgr is a proxy to xmpp, used by these hooks
397 - nodes have their hrn exposed in the 'hrn' tag
398 - node hrn exposed in GetSlivers, as well as the overall xmpp config
399 - system slice 'drl' gets created by db-config
400 - daniel's changes to Filter for supporting wildcards in lists
401 - AddSliceTag consistency check tweaked
402
403 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
404 - major cleanup
405 - get rid of all 4.2-related legacy code
406 - reset the migrations code, planetlab5.sql somes with (5,100)
407 - uses hashlib module when available
408
409 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
410 - first working version of 5.0:
411 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
412 - nodefamily is 3-fold with pldistro-fcdistro-arch
413 - site and person tags
414 - new methods GetSliceFamily and GetNodeFlavour
415 - deprecated the dummynet stuff that were for the external dummyboxes
416 - tags definition : more consistency between db-config scripts and accessors
417 - (get accessor to create the tag type too if absent)
418 - logging an event for AddSliceToNodes
419
420 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
421 - support for fedora 12
422 - fix subtle bug in filtering with ] and quotes
423
424 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
425 - * patch for php-5.3 (the one in f12)
426 - * validate email addresses with regex
427 - * add PersonTags and SiteTags
428 - * add additional accessors for node tags (kvariant, serial, ..)
429
430 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
431 - Redacting password, session, and authstring values from the event log.
432
433 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
434 - let AddSite set ext_consortium_id - required for the poorman registration pages
435 - drop version constraint on Requires: postgresql-python
436 - don't log system calls nor ReportRunLevel
437
438 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
439 - Fix requires for CentOS.
440
441 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
442 - Require postgresql 8.2 (for array operators && and @>)
443
444 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
445 - Filter now supports the | and & features to match in sequence values
446 - bugfix in the postgresql wrapper for sequence filter values
447 - reviewed GetSlivers to export admin keys more efficiently
448 - fix checking roles in UpdateSliceTag
449
450 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
451 - - Some typos in the documentation were fixed.
452 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
453 - to the tag's min_role_id.
454
455 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
456
457 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
458 - Ongoing work to add upcalls, using new SFA class
459 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
460 - reviewed type-checking for the 3 taggable classes node-interface-slice
461 - cleanup ald dummynet stuff
462 - expose the 'extensions' accessors to the API
463 - tweaked checks in AddSliceTag
464 - GetPersons exposes roles by default
465 - bugfix in ReportRunLevel for non-string levels
466 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
467
468 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
469 - new BindObjectToPeer method for sfa
470 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
471
472 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
473 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
474 - reportrunlevel logs its calls only when run_level changes
475 - pycurl more robust wrt to xmlrpclib.Transport
476
477 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
478 - produce a wsdl interface
479 - bugfix in getbootmedium for nodes with interface tags
480
481 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
482 - bugfix for some rare pattern-based filters
483
484 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
485 - improvements in the 4.2 legacy layer
486
487 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
488 - bugfix required for slice tags set on nodegroups
489
490 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
491 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
492
493 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
494 - more powerful legacy layer with 4.2
495
496 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
497 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
498 - migration script has an option for running interactively
499
500 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
501 - skips already added entries
502
503 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
504 - yet another set of fixes for external dummynet boxes
505
506 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
507 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
508 - and tmp file is cleaned up
509
510 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
511 - restore missing ResolveSlices
512
513 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
514 - new method GetDummyBoxMedium
515
516 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
517 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
518
519 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
520 - support for external dummynet boxes back in 4.3 - first draft
521
522 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
523 - fixes for smooth federation between 4.2 and 4.3
524 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
525
526 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
527 - support for BootCD variants (GetBootMedium ['variant:centos5'])
528 - fix corner case with filters like {'~slice_id':[]}
529 - fix transaction leak that caused the db connections pool to exhaust
530 - properly expose all methods, including Legacy/, and not only Methods/
531
532 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
533 - renumbered as 4.3
534 - nodes have new fields run_level (in addition to boot_state) and verified
535 - tweaked migration from 4.2
536 - tuned rpm dependencies
537 - doc generation more explicit about errors like missing python modules
538 - removed obsolete method GetSlicesMD5
539
540 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
541 - unified all tags
542 - renamed interface settings into interface tags and slice attributes into slice tags
543 - nodes have a node_type
544 - various changes on the way to 4.3
545
546 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
547 - Checkpointing : this version still has interface settings and slice attributes
548
549 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
550 - first iteration with taggable nodes/interfaces/slices
551 - embryo for ilinks
552 - cleaned up boot states
553 - migration script moslty complete
554
555 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
556 - fixed doc build by locating locally installed DTDs at build-time
557
558 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
559 - no more doc packaged outside of myplc-docs - doc/ cleaned up
560 - enhancements in doc on filters 
561 - bootcd-aware GetBootMedium merged from onelab
562
563 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
564 - checkpoint while the new myplc-docs package is underway
565 - bugfix: GetSlivers & conf files
566 - doc: removed target files 
567
568 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
569 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
570 - the non-deleted fields were index, resulting in massivly slow queries.
571
572
573 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
574 - plcsh: better handling of options when running as a shell script
575 - getbootmedium exports compute_key
576 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
577
578 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
579 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
580 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
581
582 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
583 - refresh peer script to use a month-dependent logfile
584 - tracking the starting point for UniPi integration of the dummynet boxes
585
586 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
587 - plcsh adds its own path to sys.path
588 - fix so GetNodes can be called from a Node
589
590 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
591 - Initial build.
592
593 %define module_current_branch 4.3