Setting tag plcapi-5.2-7
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 7
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 mkdir -p $RPM_BUILD_ROOT/var/log
123 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %define php_extension_dir %(php-config --extension-dir)
130
131 %files
132 %defattr(-,root,root,-)
133 %dir %{_datadir}/plc_api
134 #%dir /var/log/omf/
135 %{_datadir}/plc_api/*
136 %{_bindir}/plcsh
137 %{php_extension_dir}/xmlrpc.so
138 %{_sysconfdir}/php.d/xmlrpc.ini
139 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
140 /etc/plc.d
141 /etc/planetlab/db-config.d
142 /var/www/html/wsdl/plcapi.wsdl
143 #/usr/bin/omf_slicemgr.py*
144 #/usr/bin/reset_xmpp_pubsub_nodes.py*
145 /var/log/plc_api_ratelimit.log
146
147
148 %changelog
149 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
150 - also cleanup omf-slicemgr initscript
151
152 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
153 - tear down omf-related aspects as this is no longer needed with omfv6
154
155 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
156 - also expose 'expires' in ResolveSlices
157
158 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
159 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
160
161 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
162 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
163
164 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
165 - use SFA code for computing hrn's when available
166
167 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
168 - new slice tag 'interface' for configuring a virtual interface
169 - new builtin 030-interface_tags
170 - new node accessor and tag 'virt' for mixing lxc & vs nodes
171 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
172 - moved ModPypthon and plc.wsgi in the apache/ subdir
173 - renamed PLCAPI.spec into plcapi.spec
174 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
175 - support for php-5.4
176
177 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
178 - implement PLC_VSYS_DEFAULTS in AddSlice
179
180 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
181 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
182 - AddPerson and UpdatePerson are now tag-aware
183 - as a side-effect AddPerson is more picky and rejects invalid fields
184 - which results in a requirement to use sfa-2.1-22 with this tag
185 - marginal improvement on the xml doc on tags
186
187 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
188 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
189 - reset_xmpp_pubsub_nodes now hos options and usage
190 - new Accessors for vicci
191
192 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
193 - fixed imports for tags management with sites and persons
194 - add predefined 'cpu_freezable' tag
195
196 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
197 - tweaks in interface initialization
198 - has 'vsys_vnet' as a predefined tagtype
199 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
200 - bugfix: GetSlivers & nodegroups
201 - bugfix: in jabber groups management
202
203 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
204 - fix gpg-authentication for Persons (thanks Jordan)
205 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
206 - ip address/network check: v4 or v6
207 - customized DB Message survive upgrade
208 - make sync works in lxc-hosted tests
209 - no svn keywords anymore
210
211 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
212 - fix sorting for methods list in docs
213 - untested but needed tweak for postgres startup in f16
214
215 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
216 - tweaks in postgresql setup - in line with sfa
217
218 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
219 - slight tweaks in Persons.py
220
221 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
222 - GetSession has support for more than one day sessions
223 - reset_xmpp_pubsub_nodes is much more efficient
224 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
225 - bugfix - deleting a person in the middle of the signup process
226
227 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
228 - ratelimit aspects
229 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
230 - requires Django for cache_utils
231 - attempt to expose 'pldistro' to sfa
232 - last_time_spent_online, last_time_spent_offline: new fields in Node
233 - new slice tags 'isolate_loopback' and 'cpu_cores'
234 - refresh-peer federation logs dump exceptions
235 - modpython logs have a timestamp
236 - more verbose/accurate php error reporting
237 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
238 - AddNode, UpdateNode: manage tags directly rather than through another method
239 - BootUpdateNode: only update once
240 - GetPersons: techs can access the list of persons on their site
241 - GetSlices and GetSliceTags: techs can see slices on their nodes
242 - GetSlivers: isrootonsite tag; cacheable
243
244 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
245 - rename initscript_body into initscript_code
246
247 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
248 - new initscript_body tag
249
250 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
251 - working draft for GetSliceSshKeys
252
253 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
254 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
255 - (this is for people who cancel their download)
256
257 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
258 - fix db-config sequence : accessors step now merged in, and occurs at the right time
259 - db-config also more robust
260 - no more explicit 'accessors' step in plc.d
261
262 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
263 - session auth: do *not* delete session when node runs a method that does not have 'node' role
264 - session auth: remove support for bootonce in old boot CDs
265 - give a reason when caller_may_write_slice_tag fails
266 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
267
268 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
269 - SetSliceVref needed the node role
270 - protect GetSliceFamily
271 - Fix bugs in tag authorizations
272
273 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
274 - altered checking of optional fields in Interfaces
275 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
276 - has pyxml and python-simplejson as new deps
277
278 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
279 - tweak doc extraction for fedora14
280
281 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
282 - builtin accessors for the myslice page
283 - Get{Node,Interface}Tags allowed to techs
284 - tweak in ratelimitaspect.py
285
286 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
287 - add admin role to accessor-related tags (arch, {fc,pl}distro)
288
289 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
290 - bugfix in {Update,Delete}PersonTag
291 - updated xml doc for filters, accessors and tagtypes
292 - more explicit msg in case of missing roles
293 - improvements in ratelimitaspects.py
294
295 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
296 - fix the roles for ssh_key and hmac tags
297
298 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
299 - tag permissions system based on roles and not min_role_ids
300 - accessors simplified accordingly (no more min_role_id)
301 - new methods AddRoleToTagType and DeleteRoleFromTagType
302 - accessor-related tagtypes are created sooner, and enforced
303 - cleaned up redundancy between db-config.d and accessors
304
305 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
306 - fix RefreshPeer that was not working in 5.0-17
307
308 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
309 - RefreshPeer is able to cope with 2 peers running different releases of the api
310 - DeletePerson can be used on duplicates
311 - first appearance of ModPythonJson.py
312
313 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
314 - set accessors return the new value
315 - tweaks in the pubsub groups management
316
317 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
318 - convert hostnames to lower case and use ILIKE instead of LIKE
319
320 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
321 - use hrn in pubsub groups
322
323 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
324 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
325 - OMF fixes
326
327 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
328 - automatically set vsys tag for omf controlled slices
329
330 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
331 - addition of the 'ssh_key' slice tag
332 - first draft of the LDAP interface
333
334 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
335 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
336 - and readable through GetLeaseGranularity
337 - GetSlivers to expose reservation_policy and lease_granularity
338 - GetBootMedium fixed for reservable nodes
339 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
340 - new Apache mod_wsgi python interface
341
342 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
343 - the leases system
344
345 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
346 - previous tag had gone wrong
347
348 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
349 - fix pubsub hostname
350
351 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
352 - tweaks for the omf support (xmpp groups and RC-controlled slices)
353 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
354 - GetNodeFlavour exposes fcdistro
355
356 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
357 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
358
359 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
360 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
361 - pyaspect hooks allow to  maintain the namespace xmpp groups
362 - new omf_slicemgr is a proxy to xmpp, used by these hooks
363 - nodes have their hrn exposed in the 'hrn' tag
364 - node hrn exposed in GetSlivers, as well as the overall xmpp config
365 - system slice 'drl' gets created by db-config
366 - daniel's changes to Filter for supporting wildcards in lists
367 - AddSliceTag consistency check tweaked
368
369 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
370 - major cleanup
371 - get rid of all 4.2-related legacy code
372 - reset the migrations code, planetlab5.sql somes with (5,100)
373 - uses hashlib module when available
374
375 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
376 - first working version of 5.0:
377 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
378 - nodefamily is 3-fold with pldistro-fcdistro-arch
379 - site and person tags
380 - new methods GetSliceFamily and GetNodeFlavour
381 - deprecated the dummynet stuff that were for the external dummyboxes
382 - tags definition : more consistency between db-config scripts and accessors
383 - (get accessor to create the tag type too if absent)
384 - logging an event for AddSliceToNodes
385
386 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
387 - support for fedora 12
388 - fix subtle bug in filtering with ] and quotes
389
390 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
391 - * patch for php-5.3 (the one in f12)
392 - * validate email addresses with regex
393 - * add PersonTags and SiteTags
394 - * add additional accessors for node tags (kvariant, serial, ..)
395
396 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
397 - Redacting password, session, and authstring values from the event log.
398
399 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
400 - let AddSite set ext_consortium_id - required for the poorman registration pages
401 - drop version constraint on Requires: postgresql-python
402 - don't log system calls nor ReportRunLevel
403
404 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
405 - Fix requires for CentOS.
406
407 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
408 - Require postgresql 8.2 (for array operators && and @>)
409
410 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
411 - Filter now supports the | and & features to match in sequence values
412 - bugfix in the postgresql wrapper for sequence filter values
413 - reviewed GetSlivers to export admin keys more efficiently
414 - fix checking roles in UpdateSliceTag
415
416 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
417 - - Some typos in the documentation were fixed.
418 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
419 - to the tag's min_role_id.
420
421 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
422
423 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
424 - Ongoing work to add upcalls, using new SFA class
425 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
426 - reviewed type-checking for the 3 taggable classes node-interface-slice
427 - cleanup ald dummynet stuff
428 - expose the 'extensions' accessors to the API
429 - tweaked checks in AddSliceTag
430 - GetPersons exposes roles by default
431 - bugfix in ReportRunLevel for non-string levels
432 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
433
434 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
435 - new BindObjectToPeer method for sfa
436 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
437
438 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
439 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
440 - reportrunlevel logs its calls only when run_level changes
441 - pycurl more robust wrt to xmlrpclib.Transport
442
443 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
444 - produce a wsdl interface
445 - bugfix in getbootmedium for nodes with interface tags
446
447 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
448 - bugfix for some rare pattern-based filters
449
450 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
451 - improvements in the 4.2 legacy layer
452
453 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
454 - bugfix required for slice tags set on nodegroups
455
456 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
457 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
458
459 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
460 - more powerful legacy layer with 4.2
461
462 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
463 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
464 - migration script has an option for running interactively
465
466 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
467 - skips already added entries
468
469 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
470 - yet another set of fixes for external dummynet boxes
471
472 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
473 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
474 - and tmp file is cleaned up
475
476 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
477 - restore missing ResolveSlices
478
479 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
480 - new method GetDummyBoxMedium
481
482 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
483 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
484
485 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
486 - support for external dummynet boxes back in 4.3 - first draft
487
488 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
489 - fixes for smooth federation between 4.2 and 4.3
490 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
491
492 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
493 - support for BootCD variants (GetBootMedium ['variant:centos5'])
494 - fix corner case with filters like {'~slice_id':[]}
495 - fix transaction leak that caused the db connections pool to exhaust
496 - properly expose all methods, including Legacy/, and not only Methods/
497
498 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
499 - renumbered as 4.3
500 - nodes have new fields run_level (in addition to boot_state) and verified
501 - tweaked migration from 4.2
502 - tuned rpm dependencies
503 - doc generation more explicit about errors like missing python modules
504 - removed obsolete method GetSlicesMD5
505
506 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
507 - unified all tags
508 - renamed interface settings into interface tags and slice attributes into slice tags
509 - nodes have a node_type
510 - various changes on the way to 4.3
511
512 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
513 - Checkpointing : this version still has interface settings and slice attributes
514
515 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
516 - first iteration with taggable nodes/interfaces/slices
517 - embryo for ilinks
518 - cleaned up boot states
519 - migration script moslty complete
520
521 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
522 - fixed doc build by locating locally installed DTDs at build-time
523
524 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
525 - no more doc packaged outside of myplc-docs - doc/ cleaned up
526 - enhancements in doc on filters 
527 - bootcd-aware GetBootMedium merged from onelab
528
529 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
530 - checkpoint while the new myplc-docs package is underway
531 - bugfix: GetSlivers & conf files
532 - doc: removed target files 
533
534 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
535 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
536 - the non-deleted fields were index, resulting in massivly slow queries.
537
538
539 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
540 - plcsh: better handling of options when running as a shell script
541 - getbootmedium exports compute_key
542 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
543
544 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
545 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
546 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
547
548 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
549 - refresh peer script to use a month-dependent logfile
550 - tracking the starting point for UniPi integration of the dummynet boxes
551
552 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
553 - plcsh adds its own path to sys.path
554 - fix so GetNodes can be called from a Node
555
556 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
557 - Initial build.
558
559 %define module_current_branch 4.3