noreal change, just nicer requires
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.4
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 Requires: SOAPpy
36 Requires: python-simplejson
37 # for the RebootNodeWithPCU method
38 Requires: pcucontrol >= 1.0-6
39 # for OMF integration
40 Requires: pyaspects >= 0.4
41 Requires: python-twisted-words
42 Requires: python-twisted-web
43 # ldap
44 Requires: python-ldap
45 # for memcache
46 Requires: memcached python-memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 # for building the wsdl interface we used to require PyXML
58 # but this has gone with f20 so turning this off for now
59 BuildRequires: php-devel python-simplejson
60 Obsoletes: php-xmlrpc
61 Provides: php-xmlrpc
62
63 # PostgreSQL and SOAPpy are necessary to run the API server, but not
64 # plcsh. Since the only supported method of running the server is via
65 # MyPLC anyway, don't be so stringent about binary requirements, in
66 # case people want to install this package just for plcsh.
67 # Requires: postgresql-server, SOAPpy
68 AutoReqProv: no
69
70 %description
71 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
72 PlanetLab Central (PLC) database. The API may be accessed directly via
73 the Python shell program plcsh, through a toy standalone server, or
74 through Apache mod_python.
75
76 %prep
77 %setup -q
78
79 %build
80 # python-pycurl and python-psycopg2 avail. from fedora 5
81 # we used to ship our own version of psycopg2 and pycurl, for fedora4
82 # starting with 4.3, support for these two modules is taken out
83
84 # Build __init__.py metafiles and PHP API. 
85 %{__make} %{?_smp_mflags}
86 %{__make} -C wsdl
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
91
92 # Install shell symlink
93 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
94 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
95
96 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
97 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
98 ; Enable xmlrpc extension module
99 extension=xmlrpc.so
100 EOF
101
102 # Install initscripts
103 echo "* Installing initscripts"
104 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
105 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
106
107 # Install db-config.d files
108 echo "* Installing db-config.d files"
109 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
111 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
112
113 # Install wsdl
114 echo "* Installing wsdl"
115 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
116
117 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
118 ## Install omf_slicemgr.py
119 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
120 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
121 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
122
123 # Install ratelimit log
124 mkdir -p $RPM_BUILD_ROOT/var/log
125 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
126 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %define php_extension_dir %(php-config --extension-dir)
132
133 %files
134 %defattr(-,root,root,-)
135 %dir %{_datadir}/plc_api
136 #%dir /var/log/omf/
137 %{_datadir}/plc_api/*
138 %{_bindir}/plcsh
139 %{php_extension_dir}/xmlrpc.so
140 %{_sysconfdir}/php.d/xmlrpc.ini
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 #/usr/bin/omf_slicemgr.py*
146 #/usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plc_api_ratelimit.log
148
149
150 %changelog
151 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
152 - create accessor 'hrn' for site as well
153 - create accessors 'sfa_created' for site/slice/person
154 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
155 - UpdatePerson() updates Person HRN according to updated email.
156 - UpdateSite() updates Site HRN according to updated login_base.
157 - Fix AddPersonToSite().
158 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
159 - RefreshPeer() manages Site*Person and Person*Role relationships.
160
161 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
162 - provide a slicename_to_hrn function
163
164 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
165 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
166
167 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
168 - fix for wsgi-based deployments, each thread has its own api()
169
170 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
171 - also cleanup omf-slicemgr initscript
172
173 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
174 - tear down omf-related aspects as this is no longer needed with omfv6
175
176 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
177 - also expose 'expires' in ResolveSlices
178
179 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
180 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
181
182 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
183 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
184
185 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
186 - use SFA code for computing hrn's when available
187
188 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
189 - new slice tag 'interface' for configuring a virtual interface
190 - new builtin 030-interface_tags
191 - new node accessor and tag 'virt' for mixing lxc & vs nodes
192 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
193 - moved ModPypthon and plc.wsgi in the apache/ subdir
194 - renamed PLCAPI.spec into plcapi.spec
195 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
196 - support for php-5.4
197
198 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
199 - implement PLC_VSYS_DEFAULTS in AddSlice
200
201 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
202 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
203 - AddPerson and UpdatePerson are now tag-aware
204 - as a side-effect AddPerson is more picky and rejects invalid fields
205 - which results in a requirement to use sfa-2.1-22 with this tag
206 - marginal improvement on the xml doc on tags
207
208 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
209 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
210 - reset_xmpp_pubsub_nodes now hos options and usage
211 - new Accessors for vicci
212
213 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
214 - fixed imports for tags management with sites and persons
215 - add predefined 'cpu_freezable' tag
216
217 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
218 - tweaks in interface initialization
219 - has 'vsys_vnet' as a predefined tagtype
220 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
221 - bugfix: GetSlivers & nodegroups
222 - bugfix: in jabber groups management
223
224 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
225 - fix gpg-authentication for Persons (thanks Jordan)
226 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
227 - ip address/network check: v4 or v6
228 - customized DB Message survive upgrade
229 - make sync works in lxc-hosted tests
230 - no svn keywords anymore
231
232 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
233 - fix sorting for methods list in docs
234 - untested but needed tweak for postgres startup in f16
235
236 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
237 - tweaks in postgresql setup - in line with sfa
238
239 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
240 - slight tweaks in Persons.py
241
242 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
243 - GetSession has support for more than one day sessions
244 - reset_xmpp_pubsub_nodes is much more efficient
245 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
246 - bugfix - deleting a person in the middle of the signup process
247
248 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
249 - ratelimit aspects
250 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
251 - requires Django for cache_utils
252 - attempt to expose 'pldistro' to sfa
253 - last_time_spent_online, last_time_spent_offline: new fields in Node
254 - new slice tags 'isolate_loopback' and 'cpu_cores'
255 - refresh-peer federation logs dump exceptions
256 - modpython logs have a timestamp
257 - more verbose/accurate php error reporting
258 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
259 - AddNode, UpdateNode: manage tags directly rather than through another method
260 - BootUpdateNode: only update once
261 - GetPersons: techs can access the list of persons on their site
262 - GetSlices and GetSliceTags: techs can see slices on their nodes
263 - GetSlivers: isrootonsite tag; cacheable
264
265 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
266 - rename initscript_body into initscript_code
267
268 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
269 - new initscript_body tag
270
271 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
272 - working draft for GetSliceSshKeys
273
274 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
275 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
276 - (this is for people who cancel their download)
277
278 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
279 - fix db-config sequence : accessors step now merged in, and occurs at the right time
280 - db-config also more robust
281 - no more explicit 'accessors' step in plc.d
282
283 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
284 - session auth: do *not* delete session when node runs a method that does not have 'node' role
285 - session auth: remove support for bootonce in old boot CDs
286 - give a reason when caller_may_write_slice_tag fails
287 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
288
289 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
290 - SetSliceVref needed the node role
291 - protect GetSliceFamily
292 - Fix bugs in tag authorizations
293
294 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
295 - altered checking of optional fields in Interfaces
296 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
297 - has pyxml and python-simplejson as new deps
298
299 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
300 - tweak doc extraction for fedora14
301
302 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
303 - builtin accessors for the myslice page
304 - Get{Node,Interface}Tags allowed to techs
305 - tweak in ratelimitaspect.py
306
307 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
308 - add admin role to accessor-related tags (arch, {fc,pl}distro)
309
310 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
311 - bugfix in {Update,Delete}PersonTag
312 - updated xml doc for filters, accessors and tagtypes
313 - more explicit msg in case of missing roles
314 - improvements in ratelimitaspects.py
315
316 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
317 - fix the roles for ssh_key and hmac tags
318
319 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
320 - tag permissions system based on roles and not min_role_ids
321 - accessors simplified accordingly (no more min_role_id)
322 - new methods AddRoleToTagType and DeleteRoleFromTagType
323 - accessor-related tagtypes are created sooner, and enforced
324 - cleaned up redundancy between db-config.d and accessors
325
326 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
327 - fix RefreshPeer that was not working in 5.0-17
328
329 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
330 - RefreshPeer is able to cope with 2 peers running different releases of the api
331 - DeletePerson can be used on duplicates
332 - first appearance of ModPythonJson.py
333
334 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
335 - set accessors return the new value
336 - tweaks in the pubsub groups management
337
338 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
339 - convert hostnames to lower case and use ILIKE instead of LIKE
340
341 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
342 - use hrn in pubsub groups
343
344 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
345 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
346 - OMF fixes
347
348 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
349 - automatically set vsys tag for omf controlled slices
350
351 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
352 - addition of the 'ssh_key' slice tag
353 - first draft of the LDAP interface
354
355 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
356 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
357 - and readable through GetLeaseGranularity
358 - GetSlivers to expose reservation_policy and lease_granularity
359 - GetBootMedium fixed for reservable nodes
360 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
361 - new Apache mod_wsgi python interface
362
363 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
364 - the leases system
365
366 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
367 - previous tag had gone wrong
368
369 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
370 - fix pubsub hostname
371
372 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
373 - tweaks for the omf support (xmpp groups and RC-controlled slices)
374 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
375 - GetNodeFlavour exposes fcdistro
376
377 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
378 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
379
380 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
381 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
382 - pyaspect hooks allow to  maintain the namespace xmpp groups
383 - new omf_slicemgr is a proxy to xmpp, used by these hooks
384 - nodes have their hrn exposed in the 'hrn' tag
385 - node hrn exposed in GetSlivers, as well as the overall xmpp config
386 - system slice 'drl' gets created by db-config
387 - daniel's changes to Filter for supporting wildcards in lists
388 - AddSliceTag consistency check tweaked
389
390 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
391 - major cleanup
392 - get rid of all 4.2-related legacy code
393 - reset the migrations code, planetlab5.sql somes with (5,100)
394 - uses hashlib module when available
395
396 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
397 - first working version of 5.0:
398 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
399 - nodefamily is 3-fold with pldistro-fcdistro-arch
400 - site and person tags
401 - new methods GetSliceFamily and GetNodeFlavour
402 - deprecated the dummynet stuff that were for the external dummyboxes
403 - tags definition : more consistency between db-config scripts and accessors
404 - (get accessor to create the tag type too if absent)
405 - logging an event for AddSliceToNodes
406
407 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
408 - support for fedora 12
409 - fix subtle bug in filtering with ] and quotes
410
411 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
412 - * patch for php-5.3 (the one in f12)
413 - * validate email addresses with regex
414 - * add PersonTags and SiteTags
415 - * add additional accessors for node tags (kvariant, serial, ..)
416
417 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
418 - Redacting password, session, and authstring values from the event log.
419
420 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
421 - let AddSite set ext_consortium_id - required for the poorman registration pages
422 - drop version constraint on Requires: postgresql-python
423 - don't log system calls nor ReportRunLevel
424
425 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
426 - Fix requires for CentOS.
427
428 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
429 - Require postgresql 8.2 (for array operators && and @>)
430
431 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
432 - Filter now supports the | and & features to match in sequence values
433 - bugfix in the postgresql wrapper for sequence filter values
434 - reviewed GetSlivers to export admin keys more efficiently
435 - fix checking roles in UpdateSliceTag
436
437 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
438 - - Some typos in the documentation were fixed.
439 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
440 - to the tag's min_role_id.
441
442 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
443
444 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
445 - Ongoing work to add upcalls, using new SFA class
446 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
447 - reviewed type-checking for the 3 taggable classes node-interface-slice
448 - cleanup ald dummynet stuff
449 - expose the 'extensions' accessors to the API
450 - tweaked checks in AddSliceTag
451 - GetPersons exposes roles by default
452 - bugfix in ReportRunLevel for non-string levels
453 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
454
455 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
456 - new BindObjectToPeer method for sfa
457 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
458
459 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
460 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
461 - reportrunlevel logs its calls only when run_level changes
462 - pycurl more robust wrt to xmlrpclib.Transport
463
464 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
465 - produce a wsdl interface
466 - bugfix in getbootmedium for nodes with interface tags
467
468 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
469 - bugfix for some rare pattern-based filters
470
471 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
472 - improvements in the 4.2 legacy layer
473
474 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
475 - bugfix required for slice tags set on nodegroups
476
477 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
478 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
479
480 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
481 - more powerful legacy layer with 4.2
482
483 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
484 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
485 - migration script has an option for running interactively
486
487 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
488 - skips already added entries
489
490 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
491 - yet another set of fixes for external dummynet boxes
492
493 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
494 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
495 - and tmp file is cleaned up
496
497 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
498 - restore missing ResolveSlices
499
500 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
501 - new method GetDummyBoxMedium
502
503 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
504 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
505
506 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
507 - support for external dummynet boxes back in 4.3 - first draft
508
509 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
510 - fixes for smooth federation between 4.2 and 4.3
511 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
512
513 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
514 - support for BootCD variants (GetBootMedium ['variant:centos5'])
515 - fix corner case with filters like {'~slice_id':[]}
516 - fix transaction leak that caused the db connections pool to exhaust
517 - properly expose all methods, including Legacy/, and not only Methods/
518
519 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
520 - renumbered as 4.3
521 - nodes have new fields run_level (in addition to boot_state) and verified
522 - tweaked migration from 4.2
523 - tuned rpm dependencies
524 - doc generation more explicit about errors like missing python modules
525 - removed obsolete method GetSlicesMD5
526
527 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
528 - unified all tags
529 - renamed interface settings into interface tags and slice attributes into slice tags
530 - nodes have a node_type
531 - various changes on the way to 4.3
532
533 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
534 - Checkpointing : this version still has interface settings and slice attributes
535
536 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
537 - first iteration with taggable nodes/interfaces/slices
538 - embryo for ilinks
539 - cleaned up boot states
540 - migration script moslty complete
541
542 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
543 - fixed doc build by locating locally installed DTDs at build-time
544
545 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
546 - no more doc packaged outside of myplc-docs - doc/ cleaned up
547 - enhancements in doc on filters 
548 - bootcd-aware GetBootMedium merged from onelab
549
550 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
551 - checkpoint while the new myplc-docs package is underway
552 - bugfix: GetSlivers & conf files
553 - doc: removed target files 
554
555 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
556 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
557 - the non-deleted fields were index, resulting in massivly slow queries.
558
559
560 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
561 - plcsh: better handling of options when running as a shell script
562 - getbootmedium exports compute_key
563 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
564
565 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
566 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
567 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
568
569 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
570 - refresh peer script to use a month-dependent logfile
571 - tracking the starting point for UniPi integration of the dummynet boxes
572
573 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
574 - plcsh adds its own path to sys.path
575 - fix so GetNodes can be called from a Node
576
577 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
578 - Initial build.
579
580 %define module_current_branch 4.3