Merge branch 'master' of ssh://git.onelab.eu/git/plcapi
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 mkdir -p $RPM_BUILD_ROOT/var/log
123 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %define php_extension_dir %(php-config --extension-dir)
130
131 %files
132 %defattr(-,root,root,-)
133 %dir %{_datadir}/plc_api
134 #%dir /var/log/omf/
135 %{_datadir}/plc_api/*
136 %{_bindir}/plcsh
137 %{php_extension_dir}/xmlrpc.so
138 %{_sysconfdir}/php.d/xmlrpc.ini
139 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
140 /etc/plc.d
141 /etc/planetlab/db-config.d
142 /var/www/html/wsdl/plcapi.wsdl
143 #/usr/bin/omf_slicemgr.py*
144 #/usr/bin/reset_xmpp_pubsub_nodes.py*
145 /var/log/plc_api_ratelimit.log
146
147
148 %changelog
149 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
150 - tear down omf-related aspects as this is no longer needed with omfv6
151
152 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
153 - also expose 'expires' in ResolveSlices
154
155 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
156 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
157
158 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
159 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
160
161 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
162 - use SFA code for computing hrn's when available
163
164 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
165 - new slice tag 'interface' for configuring a virtual interface
166 - new builtin 030-interface_tags
167 - new node accessor and tag 'virt' for mixing lxc & vs nodes
168 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
169 - moved ModPypthon and plc.wsgi in the apache/ subdir
170 - renamed PLCAPI.spec into plcapi.spec
171 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
172 - support for php-5.4
173
174 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
175 - implement PLC_VSYS_DEFAULTS in AddSlice
176
177 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
178 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
179 - AddPerson and UpdatePerson are now tag-aware
180 - as a side-effect AddPerson is more picky and rejects invalid fields
181 - which results in a requirement to use sfa-2.1-22 with this tag
182 - marginal improvement on the xml doc on tags
183
184 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
185 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
186 - reset_xmpp_pubsub_nodes now hos options and usage
187 - new Accessors for vicci
188
189 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
190 - fixed imports for tags management with sites and persons
191 - add predefined 'cpu_freezable' tag
192
193 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
194 - tweaks in interface initialization
195 - has 'vsys_vnet' as a predefined tagtype
196 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
197 - bugfix: GetSlivers & nodegroups
198 - bugfix: in jabber groups management
199
200 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
201 - fix gpg-authentication for Persons (thanks Jordan)
202 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
203 - ip address/network check: v4 or v6
204 - customized DB Message survive upgrade
205 - make sync works in lxc-hosted tests
206 - no svn keywords anymore
207
208 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
209 - fix sorting for methods list in docs
210 - untested but needed tweak for postgres startup in f16
211
212 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
213 - tweaks in postgresql setup - in line with sfa
214
215 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
216 - slight tweaks in Persons.py
217
218 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
219 - GetSession has support for more than one day sessions
220 - reset_xmpp_pubsub_nodes is much more efficient
221 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
222 - bugfix - deleting a person in the middle of the signup process
223
224 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
225 - ratelimit aspects
226 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
227 - requires Django for cache_utils
228 - attempt to expose 'pldistro' to sfa
229 - last_time_spent_online, last_time_spent_offline: new fields in Node
230 - new slice tags 'isolate_loopback' and 'cpu_cores'
231 - refresh-peer federation logs dump exceptions
232 - modpython logs have a timestamp
233 - more verbose/accurate php error reporting
234 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
235 - AddNode, UpdateNode: manage tags directly rather than through another method
236 - BootUpdateNode: only update once
237 - GetPersons: techs can access the list of persons on their site
238 - GetSlices and GetSliceTags: techs can see slices on their nodes
239 - GetSlivers: isrootonsite tag; cacheable
240
241 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
242 - rename initscript_body into initscript_code
243
244 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
245 - new initscript_body tag
246
247 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
248 - working draft for GetSliceSshKeys
249
250 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
251 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
252 - (this is for people who cancel their download)
253
254 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
255 - fix db-config sequence : accessors step now merged in, and occurs at the right time
256 - db-config also more robust
257 - no more explicit 'accessors' step in plc.d
258
259 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
260 - session auth: do *not* delete session when node runs a method that does not have 'node' role
261 - session auth: remove support for bootonce in old boot CDs
262 - give a reason when caller_may_write_slice_tag fails
263 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
264
265 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
266 - SetSliceVref needed the node role
267 - protect GetSliceFamily
268 - Fix bugs in tag authorizations
269
270 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
271 - altered checking of optional fields in Interfaces
272 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
273 - has pyxml and python-simplejson as new deps
274
275 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
276 - tweak doc extraction for fedora14
277
278 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
279 - builtin accessors for the myslice page
280 - Get{Node,Interface}Tags allowed to techs
281 - tweak in ratelimitaspect.py
282
283 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
284 - add admin role to accessor-related tags (arch, {fc,pl}distro)
285
286 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
287 - bugfix in {Update,Delete}PersonTag
288 - updated xml doc for filters, accessors and tagtypes
289 - more explicit msg in case of missing roles
290 - improvements in ratelimitaspects.py
291
292 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
293 - fix the roles for ssh_key and hmac tags
294
295 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
296 - tag permissions system based on roles and not min_role_ids
297 - accessors simplified accordingly (no more min_role_id)
298 - new methods AddRoleToTagType and DeleteRoleFromTagType
299 - accessor-related tagtypes are created sooner, and enforced
300 - cleaned up redundancy between db-config.d and accessors
301
302 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
303 - fix RefreshPeer that was not working in 5.0-17
304
305 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
306 - RefreshPeer is able to cope with 2 peers running different releases of the api
307 - DeletePerson can be used on duplicates
308 - first appearance of ModPythonJson.py
309
310 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
311 - set accessors return the new value
312 - tweaks in the pubsub groups management
313
314 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
315 - convert hostnames to lower case and use ILIKE instead of LIKE
316
317 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
318 - use hrn in pubsub groups
319
320 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
321 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
322 - OMF fixes
323
324 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
325 - automatically set vsys tag for omf controlled slices
326
327 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
328 - addition of the 'ssh_key' slice tag
329 - first draft of the LDAP interface
330
331 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
332 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
333 - and readable through GetLeaseGranularity
334 - GetSlivers to expose reservation_policy and lease_granularity
335 - GetBootMedium fixed for reservable nodes
336 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
337 - new Apache mod_wsgi python interface
338
339 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
340 - the leases system
341
342 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
343 - previous tag had gone wrong
344
345 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
346 - fix pubsub hostname
347
348 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
349 - tweaks for the omf support (xmpp groups and RC-controlled slices)
350 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
351 - GetNodeFlavour exposes fcdistro
352
353 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
354 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
355
356 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
357 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
358 - pyaspect hooks allow to  maintain the namespace xmpp groups
359 - new omf_slicemgr is a proxy to xmpp, used by these hooks
360 - nodes have their hrn exposed in the 'hrn' tag
361 - node hrn exposed in GetSlivers, as well as the overall xmpp config
362 - system slice 'drl' gets created by db-config
363 - daniel's changes to Filter for supporting wildcards in lists
364 - AddSliceTag consistency check tweaked
365
366 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
367 - major cleanup
368 - get rid of all 4.2-related legacy code
369 - reset the migrations code, planetlab5.sql somes with (5,100)
370 - uses hashlib module when available
371
372 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
373 - first working version of 5.0:
374 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
375 - nodefamily is 3-fold with pldistro-fcdistro-arch
376 - site and person tags
377 - new methods GetSliceFamily and GetNodeFlavour
378 - deprecated the dummynet stuff that were for the external dummyboxes
379 - tags definition : more consistency between db-config scripts and accessors
380 - (get accessor to create the tag type too if absent)
381 - logging an event for AddSliceToNodes
382
383 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
384 - support for fedora 12
385 - fix subtle bug in filtering with ] and quotes
386
387 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
388 - * patch for php-5.3 (the one in f12)
389 - * validate email addresses with regex
390 - * add PersonTags and SiteTags
391 - * add additional accessors for node tags (kvariant, serial, ..)
392
393 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
394 - Redacting password, session, and authstring values from the event log.
395
396 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
397 - let AddSite set ext_consortium_id - required for the poorman registration pages
398 - drop version constraint on Requires: postgresql-python
399 - don't log system calls nor ReportRunLevel
400
401 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
402 - Fix requires for CentOS.
403
404 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
405 - Require postgresql 8.2 (for array operators && and @>)
406
407 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
408 - Filter now supports the | and & features to match in sequence values
409 - bugfix in the postgresql wrapper for sequence filter values
410 - reviewed GetSlivers to export admin keys more efficiently
411 - fix checking roles in UpdateSliceTag
412
413 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
414 - - Some typos in the documentation were fixed.
415 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
416 - to the tag's min_role_id.
417
418 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
419
420 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
421 - Ongoing work to add upcalls, using new SFA class
422 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
423 - reviewed type-checking for the 3 taggable classes node-interface-slice
424 - cleanup ald dummynet stuff
425 - expose the 'extensions' accessors to the API
426 - tweaked checks in AddSliceTag
427 - GetPersons exposes roles by default
428 - bugfix in ReportRunLevel for non-string levels
429 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
430
431 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
432 - new BindObjectToPeer method for sfa
433 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
434
435 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
436 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
437 - reportrunlevel logs its calls only when run_level changes
438 - pycurl more robust wrt to xmlrpclib.Transport
439
440 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
441 - produce a wsdl interface
442 - bugfix in getbootmedium for nodes with interface tags
443
444 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
445 - bugfix for some rare pattern-based filters
446
447 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
448 - improvements in the 4.2 legacy layer
449
450 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
451 - bugfix required for slice tags set on nodegroups
452
453 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
454 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
455
456 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
457 - more powerful legacy layer with 4.2
458
459 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
460 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
461 - migration script has an option for running interactively
462
463 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
464 - skips already added entries
465
466 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
467 - yet another set of fixes for external dummynet boxes
468
469 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
470 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
471 - and tmp file is cleaned up
472
473 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
474 - restore missing ResolveSlices
475
476 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
477 - new method GetDummyBoxMedium
478
479 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
480 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
481
482 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
483 - support for external dummynet boxes back in 4.3 - first draft
484
485 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
486 - fixes for smooth federation between 4.2 and 4.3
487 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
488
489 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
490 - support for BootCD variants (GetBootMedium ['variant:centos5'])
491 - fix corner case with filters like {'~slice_id':[]}
492 - fix transaction leak that caused the db connections pool to exhaust
493 - properly expose all methods, including Legacy/, and not only Methods/
494
495 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
496 - renumbered as 4.3
497 - nodes have new fields run_level (in addition to boot_state) and verified
498 - tweaked migration from 4.2
499 - tuned rpm dependencies
500 - doc generation more explicit about errors like missing python modules
501 - removed obsolete method GetSlicesMD5
502
503 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
504 - unified all tags
505 - renamed interface settings into interface tags and slice attributes into slice tags
506 - nodes have a node_type
507 - various changes on the way to 4.3
508
509 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
510 - Checkpointing : this version still has interface settings and slice attributes
511
512 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
513 - first iteration with taggable nodes/interfaces/slices
514 - embryo for ilinks
515 - cleaned up boot states
516 - migration script moslty complete
517
518 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
519 - fixed doc build by locating locally installed DTDs at build-time
520
521 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
522 - no more doc packaged outside of myplc-docs - doc/ cleaned up
523 - enhancements in doc on filters 
524 - bootcd-aware GetBootMedium merged from onelab
525
526 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
527 - checkpoint while the new myplc-docs package is underway
528 - bugfix: GetSlivers & conf files
529 - doc: removed target files 
530
531 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
532 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
533 - the non-deleted fields were index, resulting in massivly slow queries.
534
535
536 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
537 - plcsh: better handling of options when running as a shell script
538 - getbootmedium exports compute_key
539 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
540
541 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
542 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
543 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
544
545 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
546 - refresh peer script to use a month-dependent logfile
547 - tracking the starting point for UniPi integration of the dummynet boxes
548
549 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
550 - plcsh adds its own path to sys.path
551 - fix so GetNodes can be called from a Node
552
553 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
554 - Initial build.
555
556 %define module_current_branch 4.3