Requires: python-lxml
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 # used in GPG.py as a replacement to PyXML's Canonicalize
31 Requires: python-lxml
32 Requires: httpd
33 # requirement to mod_python or mod_wsgi: deferred to myplc
34 Requires: mod_ssl
35 Requires: SOAPpy
36 Requires: python-simplejson
37 # for the RebootNodeWithPCU method
38 Requires: pcucontrol >= 1.0-6
39 # for OMF integration
40 Requires: pyaspects >= 0.4
41 Requires: python-twisted-words
42 Requires: python-twisted-web
43 # ldap
44 Requires: python-ldap
45 # for memcache
46 Requires: python-memcached
47 Requires: memcached
48 Requires: Django
49 ### avoid having yum complain about updates, as stuff is moving around
50 # plc.d/api
51 Conflicts: MyPLC <= 4.3
52
53 # We use psycopg2
54 #
55 # but we don't need to rebuild it as we depend on distro's packages - baris
56 # BuildRequires: postgresql-devel
57
58 # Standard xmlrpc.so that ships with PHP does not marshal NULL
59 # for building the wsdl interface we used to require PyXML
60 # but this has gone with f20 so turning this off for now
61 BuildRequires: php-devel python-simplejson
62 Obsoletes: php-xmlrpc
63 Provides: php-xmlrpc
64
65 # PostgreSQL and SOAPpy are necessary to run the API server, but not
66 # plcsh. Since the only supported method of running the server is via
67 # MyPLC anyway, don't be so stringent about binary requirements, in
68 # case people want to install this package just for plcsh.
69 # Requires: postgresql-server, SOAPpy
70 AutoReqProv: no
71
72 %description
73 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
74 PlanetLab Central (PLC) database. The API may be accessed directly via
75 the Python shell program plcsh, through a toy standalone server, or
76 through Apache mod_python.
77
78 %prep
79 %setup -q
80
81 %build
82 # python-pycurl and python-psycopg2 avail. from fedora 5
83 # we used to ship our own version of psycopg2 and pycurl, for fedora4
84 # starting with 4.3, support for these two modules is taken out
85
86 # Build __init__.py metafiles and PHP API. 
87 %{__make} %{?_smp_mflags}
88 %{__make} -C wsdl
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
93
94 # Install shell symlink
95 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
96 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
97
98 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
99 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
100 ; Enable xmlrpc extension module
101 extension=xmlrpc.so
102 EOF
103
104 # Install initscripts
105 echo "* Installing initscripts"
106 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
107 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
108
109 # Install db-config.d files
110 echo "* Installing db-config.d files"
111 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
112 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
114
115 # Install wsdl
116 echo "* Installing wsdl"
117 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
118
119 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
120 ## Install omf_slicemgr.py
121 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
122 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
123 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
124
125 # Install ratelimit log
126 mkdir -p $RPM_BUILD_ROOT/var/log
127 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
128 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %define php_extension_dir %(php-config --extension-dir)
134
135 %files
136 %defattr(-,root,root,-)
137 %dir %{_datadir}/plc_api
138 #%dir /var/log/omf/
139 %{_datadir}/plc_api/*
140 %{_bindir}/plcsh
141 %{php_extension_dir}/xmlrpc.so
142 %{_sysconfdir}/php.d/xmlrpc.ini
143 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
144 /etc/plc.d
145 /etc/planetlab/db-config.d
146 /var/www/html/wsdl/plcapi.wsdl
147 #/usr/bin/omf_slicemgr.py*
148 #/usr/bin/reset_xmpp_pubsub_nodes.py*
149 /var/log/plc_api_ratelimit.log
150
151
152 %changelog
153 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
154 - create accessor 'hrn' for site as well
155 - create accessors 'sfa_created' for site/slice/person
156 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
157 - UpdatePerson() updates Person HRN according to updated email.
158 - UpdateSite() updates Site HRN according to updated login_base.
159 - Fix AddPersonToSite().
160 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
161 - RefreshPeer() manages Site*Person and Person*Role relationships.
162
163 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
164 - provide a slicename_to_hrn function
165
166 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
167 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
168
169 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
170 - fix for wsgi-based deployments, each thread has its own api()
171
172 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
173 - also cleanup omf-slicemgr initscript
174
175 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
176 - tear down omf-related aspects as this is no longer needed with omfv6
177
178 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
179 - also expose 'expires' in ResolveSlices
180
181 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
182 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
183
184 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
185 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
186
187 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
188 - use SFA code for computing hrn's when available
189
190 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
191 - new slice tag 'interface' for configuring a virtual interface
192 - new builtin 030-interface_tags
193 - new node accessor and tag 'virt' for mixing lxc & vs nodes
194 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
195 - moved ModPypthon and plc.wsgi in the apache/ subdir
196 - renamed PLCAPI.spec into plcapi.spec
197 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
198 - support for php-5.4
199
200 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
201 - implement PLC_VSYS_DEFAULTS in AddSlice
202
203 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
204 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
205 - AddPerson and UpdatePerson are now tag-aware
206 - as a side-effect AddPerson is more picky and rejects invalid fields
207 - which results in a requirement to use sfa-2.1-22 with this tag
208 - marginal improvement on the xml doc on tags
209
210 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
211 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
212 - reset_xmpp_pubsub_nodes now hos options and usage
213 - new Accessors for vicci
214
215 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
216 - fixed imports for tags management with sites and persons
217 - add predefined 'cpu_freezable' tag
218
219 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
220 - tweaks in interface initialization
221 - has 'vsys_vnet' as a predefined tagtype
222 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
223 - bugfix: GetSlivers & nodegroups
224 - bugfix: in jabber groups management
225
226 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
227 - fix gpg-authentication for Persons (thanks Jordan)
228 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
229 - ip address/network check: v4 or v6
230 - customized DB Message survive upgrade
231 - make sync works in lxc-hosted tests
232 - no svn keywords anymore
233
234 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
235 - fix sorting for methods list in docs
236 - untested but needed tweak for postgres startup in f16
237
238 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
239 - tweaks in postgresql setup - in line with sfa
240
241 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
242 - slight tweaks in Persons.py
243
244 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
245 - GetSession has support for more than one day sessions
246 - reset_xmpp_pubsub_nodes is much more efficient
247 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
248 - bugfix - deleting a person in the middle of the signup process
249
250 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
251 - ratelimit aspects
252 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
253 - requires Django for cache_utils
254 - attempt to expose 'pldistro' to sfa
255 - last_time_spent_online, last_time_spent_offline: new fields in Node
256 - new slice tags 'isolate_loopback' and 'cpu_cores'
257 - refresh-peer federation logs dump exceptions
258 - modpython logs have a timestamp
259 - more verbose/accurate php error reporting
260 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
261 - AddNode, UpdateNode: manage tags directly rather than through another method
262 - BootUpdateNode: only update once
263 - GetPersons: techs can access the list of persons on their site
264 - GetSlices and GetSliceTags: techs can see slices on their nodes
265 - GetSlivers: isrootonsite tag; cacheable
266
267 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
268 - rename initscript_body into initscript_code
269
270 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
271 - new initscript_body tag
272
273 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
274 - working draft for GetSliceSshKeys
275
276 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
277 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
278 - (this is for people who cancel their download)
279
280 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
281 - fix db-config sequence : accessors step now merged in, and occurs at the right time
282 - db-config also more robust
283 - no more explicit 'accessors' step in plc.d
284
285 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
286 - session auth: do *not* delete session when node runs a method that does not have 'node' role
287 - session auth: remove support for bootonce in old boot CDs
288 - give a reason when caller_may_write_slice_tag fails
289 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
290
291 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
292 - SetSliceVref needed the node role
293 - protect GetSliceFamily
294 - Fix bugs in tag authorizations
295
296 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
297 - altered checking of optional fields in Interfaces
298 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
299 - has pyxml and python-simplejson as new deps
300
301 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
302 - tweak doc extraction for fedora14
303
304 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
305 - builtin accessors for the myslice page
306 - Get{Node,Interface}Tags allowed to techs
307 - tweak in ratelimitaspect.py
308
309 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
310 - add admin role to accessor-related tags (arch, {fc,pl}distro)
311
312 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
313 - bugfix in {Update,Delete}PersonTag
314 - updated xml doc for filters, accessors and tagtypes
315 - more explicit msg in case of missing roles
316 - improvements in ratelimitaspects.py
317
318 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
319 - fix the roles for ssh_key and hmac tags
320
321 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
322 - tag permissions system based on roles and not min_role_ids
323 - accessors simplified accordingly (no more min_role_id)
324 - new methods AddRoleToTagType and DeleteRoleFromTagType
325 - accessor-related tagtypes are created sooner, and enforced
326 - cleaned up redundancy between db-config.d and accessors
327
328 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
329 - fix RefreshPeer that was not working in 5.0-17
330
331 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
332 - RefreshPeer is able to cope with 2 peers running different releases of the api
333 - DeletePerson can be used on duplicates
334 - first appearance of ModPythonJson.py
335
336 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
337 - set accessors return the new value
338 - tweaks in the pubsub groups management
339
340 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
341 - convert hostnames to lower case and use ILIKE instead of LIKE
342
343 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
344 - use hrn in pubsub groups
345
346 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
347 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
348 - OMF fixes
349
350 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
351 - automatically set vsys tag for omf controlled slices
352
353 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
354 - addition of the 'ssh_key' slice tag
355 - first draft of the LDAP interface
356
357 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
358 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
359 - and readable through GetLeaseGranularity
360 - GetSlivers to expose reservation_policy and lease_granularity
361 - GetBootMedium fixed for reservable nodes
362 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
363 - new Apache mod_wsgi python interface
364
365 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
366 - the leases system
367
368 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
369 - previous tag had gone wrong
370
371 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
372 - fix pubsub hostname
373
374 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
375 - tweaks for the omf support (xmpp groups and RC-controlled slices)
376 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
377 - GetNodeFlavour exposes fcdistro
378
379 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
380 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
381
382 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
383 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
384 - pyaspect hooks allow to  maintain the namespace xmpp groups
385 - new omf_slicemgr is a proxy to xmpp, used by these hooks
386 - nodes have their hrn exposed in the 'hrn' tag
387 - node hrn exposed in GetSlivers, as well as the overall xmpp config
388 - system slice 'drl' gets created by db-config
389 - daniel's changes to Filter for supporting wildcards in lists
390 - AddSliceTag consistency check tweaked
391
392 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
393 - major cleanup
394 - get rid of all 4.2-related legacy code
395 - reset the migrations code, planetlab5.sql somes with (5,100)
396 - uses hashlib module when available
397
398 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
399 - first working version of 5.0:
400 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
401 - nodefamily is 3-fold with pldistro-fcdistro-arch
402 - site and person tags
403 - new methods GetSliceFamily and GetNodeFlavour
404 - deprecated the dummynet stuff that were for the external dummyboxes
405 - tags definition : more consistency between db-config scripts and accessors
406 - (get accessor to create the tag type too if absent)
407 - logging an event for AddSliceToNodes
408
409 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
410 - support for fedora 12
411 - fix subtle bug in filtering with ] and quotes
412
413 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
414 - * patch for php-5.3 (the one in f12)
415 - * validate email addresses with regex
416 - * add PersonTags and SiteTags
417 - * add additional accessors for node tags (kvariant, serial, ..)
418
419 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
420 - Redacting password, session, and authstring values from the event log.
421
422 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
423 - let AddSite set ext_consortium_id - required for the poorman registration pages
424 - drop version constraint on Requires: postgresql-python
425 - don't log system calls nor ReportRunLevel
426
427 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
428 - Fix requires for CentOS.
429
430 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
431 - Require postgresql 8.2 (for array operators && and @>)
432
433 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
434 - Filter now supports the | and & features to match in sequence values
435 - bugfix in the postgresql wrapper for sequence filter values
436 - reviewed GetSlivers to export admin keys more efficiently
437 - fix checking roles in UpdateSliceTag
438
439 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
440 - - Some typos in the documentation were fixed.
441 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
442 - to the tag's min_role_id.
443
444 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
445
446 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
447 - Ongoing work to add upcalls, using new SFA class
448 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
449 - reviewed type-checking for the 3 taggable classes node-interface-slice
450 - cleanup ald dummynet stuff
451 - expose the 'extensions' accessors to the API
452 - tweaked checks in AddSliceTag
453 - GetPersons exposes roles by default
454 - bugfix in ReportRunLevel for non-string levels
455 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
456
457 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
458 - new BindObjectToPeer method for sfa
459 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
460
461 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
462 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
463 - reportrunlevel logs its calls only when run_level changes
464 - pycurl more robust wrt to xmlrpclib.Transport
465
466 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
467 - produce a wsdl interface
468 - bugfix in getbootmedium for nodes with interface tags
469
470 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
471 - bugfix for some rare pattern-based filters
472
473 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
474 - improvements in the 4.2 legacy layer
475
476 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
477 - bugfix required for slice tags set on nodegroups
478
479 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
480 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
481
482 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
483 - more powerful legacy layer with 4.2
484
485 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
486 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
487 - migration script has an option for running interactively
488
489 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
490 - skips already added entries
491
492 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
493 - yet another set of fixes for external dummynet boxes
494
495 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
496 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
497 - and tmp file is cleaned up
498
499 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
500 - restore missing ResolveSlices
501
502 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
503 - new method GetDummyBoxMedium
504
505 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
506 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
507
508 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
509 - support for external dummynet boxes back in 4.3 - first draft
510
511 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
512 - fixes for smooth federation between 4.2 and 4.3
513 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
514
515 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
516 - support for BootCD variants (GetBootMedium ['variant:centos5'])
517 - fix corner case with filters like {'~slice_id':[]}
518 - fix transaction leak that caused the db connections pool to exhaust
519 - properly expose all methods, including Legacy/, and not only Methods/
520
521 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
522 - renumbered as 4.3
523 - nodes have new fields run_level (in addition to boot_state) and verified
524 - tweaked migration from 4.2
525 - tuned rpm dependencies
526 - doc generation more explicit about errors like missing python modules
527 - removed obsolete method GetSlicesMD5
528
529 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
530 - unified all tags
531 - renamed interface settings into interface tags and slice attributes into slice tags
532 - nodes have a node_type
533 - various changes on the way to 4.3
534
535 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
536 - Checkpointing : this version still has interface settings and slice attributes
537
538 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
539 - first iteration with taggable nodes/interfaces/slices
540 - embryo for ilinks
541 - cleaned up boot states
542 - migration script moslty complete
543
544 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
545 - fixed doc build by locating locally installed DTDs at build-time
546
547 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
548 - no more doc packaged outside of myplc-docs - doc/ cleaned up
549 - enhancements in doc on filters 
550 - bootcd-aware GetBootMedium merged from onelab
551
552 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
553 - checkpoint while the new myplc-docs package is underway
554 - bugfix: GetSlivers & conf files
555 - doc: removed target files 
556
557 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
558 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
559 - the non-deleted fields were index, resulting in massivly slow queries.
560
561
562 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
563 - plcsh: better handling of options when running as a shell script
564 - getbootmedium exports compute_key
565 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
566
567 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
568 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
569 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
570
571 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
572 - refresh peer script to use a month-dependent logfile
573 - tracking the starting point for UniPi integration of the dummynet boxes
574
575 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
576 - plcsh adds its own path to sys.path
577 - fix so GetNodes can be called from a Node
578
579 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
580 - Initial build.
581
582 %define module_current_branch 4.3