Setting tag plcapi-5.2-1
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 # Install ratelimit log
121 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143 /var/log/plc_api_ratelimit.log
144
145
146 %changelog
147 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
148 - new slice tag 'interface' for configuring a virtual interface
149 - new builtin 030-interface_tags
150 - new node accessor and tag 'virt' for mixing lxc & vs nodes
151 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
152 - moved ModPypthon and plc.wsgi in the apache/ subdir
153 - renamed PLCAPI.spec into plcapi.spec
154 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
155 - support for php-5.4
156
157 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
158 - implement PLC_VSYS_DEFAULTS in AddSlice
159
160 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
161 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
162 - AddPerson and UpdatePerson are now tag-aware
163 - as a side-effect AddPerson is more picky and rejects invalid fields
164 - which results in a requirement to use sfa-2.1-22 with this tag
165 - marginal improvement on the xml doc on tags
166
167 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
168 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
169 - reset_xmpp_pubsub_nodes now hos options and usage
170 - new Accessors for vicci
171
172 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
173 - fixed imports for tags management with sites and persons
174 - add predefined 'cpu_freezable' tag
175
176 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
177 - tweaks in interface initialization
178 - has 'vsys_vnet' as a predefined tagtype
179 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
180 - bugfix: GetSlivers & nodegroups
181 - bugfix: in jabber groups management
182
183 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
184 - fix gpg-authentication for Persons (thanks Jordan)
185 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
186 - ip address/network check: v4 or v6
187 - customized DB Message survive upgrade
188 - make sync works in lxc-hosted tests
189 - no svn keywords anymore
190
191 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
192 - fix sorting for methods list in docs
193 - untested but needed tweak for postgres startup in f16
194
195 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
196 - tweaks in postgresql setup - in line with sfa
197
198 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
199 - slight tweaks in Persons.py
200
201 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
202 - GetSession has support for more than one day sessions
203 - reset_xmpp_pubsub_nodes is much more efficient
204 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
205 - bugfix - deleting a person in the middle of the signup process
206
207 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
208 - ratelimit aspects
209 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
210 - requires Django for cache_utils
211 - attempt to expose 'pldistro' to sfa
212 - last_time_spent_online, last_time_spent_offline: new fields in Node
213 - new slice tags 'isolate_loopback' and 'cpu_cores'
214 - refresh-peer federation logs dump exceptions
215 - modpython logs have a timestamp
216 - more verbose/accurate php error reporting
217 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
218 - AddNode, UpdateNode: manage tags directly rather than through another method
219 - BootUpdateNode: only update once
220 - GetPersons: techs can access the list of persons on their site
221 - GetSlices and GetSliceTags: techs can see slices on their nodes
222 - GetSlivers: isrootonsite tag; cacheable
223
224 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
225 - rename initscript_body into initscript_code
226
227 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
228 - new initscript_body tag
229
230 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
231 - working draft for GetSliceSshKeys
232
233 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
234 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
235 - (this is for people who cancel their download)
236
237 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
238 - fix db-config sequence : accessors step now merged in, and occurs at the right time
239 - db-config also more robust
240 - no more explicit 'accessors' step in plc.d
241
242 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
243 - session auth: do *not* delete session when node runs a method that does not have 'node' role
244 - session auth: remove support for bootonce in old boot CDs
245 - give a reason when caller_may_write_slice_tag fails
246 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
247
248 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
249 - SetSliceVref needed the node role
250 - protect GetSliceFamily
251 - Fix bugs in tag authorizations
252
253 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
254 - altered checking of optional fields in Interfaces
255 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
256 - has pyxml and python-simplejson as new deps
257
258 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
259 - tweak doc extraction for fedora14
260
261 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
262 - builtin accessors for the myslice page
263 - Get{Node,Interface}Tags allowed to techs
264 - tweak in ratelimitaspect.py
265
266 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
267 - add admin role to accessor-related tags (arch, {fc,pl}distro)
268
269 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
270 - bugfix in {Update,Delete}PersonTag
271 - updated xml doc for filters, accessors and tagtypes
272 - more explicit msg in case of missing roles
273 - improvements in ratelimitaspects.py
274
275 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
276 - fix the roles for ssh_key and hmac tags
277
278 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
279 - tag permissions system based on roles and not min_role_ids
280 - accessors simplified accordingly (no more min_role_id)
281 - new methods AddRoleToTagType and DeleteRoleFromTagType
282 - accessor-related tagtypes are created sooner, and enforced
283 - cleaned up redundancy between db-config.d and accessors
284
285 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
286 - fix RefreshPeer that was not working in 5.0-17
287
288 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
289 - RefreshPeer is able to cope with 2 peers running different releases of the api
290 - DeletePerson can be used on duplicates
291 - first appearance of ModPythonJson.py
292
293 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
294 - set accessors return the new value
295 - tweaks in the pubsub groups management
296
297 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
298 - convert hostnames to lower case and use ILIKE instead of LIKE
299
300 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
301 - use hrn in pubsub groups
302
303 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
304 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
305 - - OMF fixes
306
307 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
308 - automatically set vsys tag for omf controlled slices
309
310 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
311 - addition of the 'ssh_key' slice tag
312 - first draft of the LDAP interface
313
314 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
315 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
316 - and readable through GetLeaseGranularity
317 - GetSlivers to expose reservation_policy and lease_granularity
318 - GetBootMedium fixed for reservable nodes
319 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
320 - new Apache mod_wsgi python interface
321
322 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
323 - the leases system
324
325 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
326 - previous tag had gone wrong
327
328 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
329 - fix pubsub hostname
330
331 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
332 - tweaks for the omf support (xmpp groups and RC-controlled slices)
333 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
334 - GetNodeFlavour exposes fcdistro
335
336 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
337 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
338
339 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
340 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
341 - pyaspect hooks allow to  maintain the namespace xmpp groups
342 - new omf_slicemgr is a proxy to xmpp, used by these hooks
343 - nodes have their hrn exposed in the 'hrn' tag
344 - node hrn exposed in GetSlivers, as well as the overall xmpp config
345 - system slice 'drl' gets created by db-config
346 - daniel's changes to Filter for supporting wildcards in lists
347 - AddSliceTag consistency check tweaked
348
349 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
350 - major cleanup
351 - get rid of all 4.2-related legacy code
352 - reset the migrations code, planetlab5.sql somes with (5,100)
353 - uses hashlib module when available
354
355 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
356 - first working version of 5.0:
357 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
358 - nodefamily is 3-fold with pldistro-fcdistro-arch
359 - site and person tags
360 - new methods GetSliceFamily and GetNodeFlavour
361 - deprecated the dummynet stuff that were for the external dummyboxes
362 - tags definition : more consistency between db-config scripts and accessors
363 - (get accessor to create the tag type too if absent)
364 - logging an event for AddSliceToNodes
365
366 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
367 - support for fedora 12
368 - fix subtle bug in filtering with ] and quotes
369
370 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
371 - * patch for php-5.3 (the one in f12)
372 - * validate email addresses with regex
373 - * add PersonTags and SiteTags
374 - * add additional accessors for node tags (kvariant, serial, ..)
375
376 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
377 - Redacting password, session, and authstring values from the event log.
378
379 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
380 - let AddSite set ext_consortium_id - required for the poorman registration pages
381 - drop version constraint on Requires: postgresql-python
382 - don't log system calls nor ReportRunLevel
383
384 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
385 - Fix requires for CentOS.
386
387 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
388 - Require postgresql 8.2 (for array operators && and @>)
389
390 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
391 - Filter now supports the | and & features to match in sequence values
392 - bugfix in the postgresql wrapper for sequence filter values
393 - reviewed GetSlivers to export admin keys more efficiently
394 - fix checking roles in UpdateSliceTag
395
396 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
397 - - Some typos in the documentation were fixed.
398 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
399 - to the tag's min_role_id.
400
401 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
402
403 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
404 - Ongoing work to add upcalls, using new SFA class
405 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
406 - reviewed type-checking for the 3 taggable classes node-interface-slice
407 - cleanup ald dummynet stuff
408 - expose the 'extensions' accessors to the API
409 - tweaked checks in AddSliceTag
410 - GetPersons exposes roles by default
411 - bugfix in ReportRunLevel for non-string levels
412 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
413
414 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
415 - new BindObjectToPeer method for sfa
416 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
417
418 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
419 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
420 - reportrunlevel logs its calls only when run_level changes
421 - pycurl more robust wrt to xmlrpclib.Transport
422
423 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
424 - produce a wsdl interface
425 - bugfix in getbootmedium for nodes with interface tags
426
427 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
428 - bugfix for some rare pattern-based filters
429
430 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
431 - improvements in the 4.2 legacy layer
432
433 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
434 - bugfix required for slice tags set on nodegroups
435
436 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
437 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
438
439 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
440 - more powerful legacy layer with 4.2
441
442 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
443 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
444 - migration script has an option for running interactively
445
446 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
447 - skips already added entries
448
449 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
450 - yet another set of fixes for external dummynet boxes
451
452 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
453 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
454 - and tmp file is cleaned up
455
456 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
457 - restore missing ResolveSlices
458
459 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
460 - new method GetDummyBoxMedium
461
462 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
463 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
464
465 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
466 - support for external dummynet boxes back in 4.3 - first draft
467
468 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
469 - fixes for smooth federation between 4.2 and 4.3
470 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
471
472 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
473 - support for BootCD variants (GetBootMedium ['variant:centos5'])
474 - fix corner case with filters like {'~slice_id':[]}
475 - fix transaction leak that caused the db connections pool to exhaust
476 - properly expose all methods, including Legacy/, and not only Methods/
477
478 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
479 - renumbered as 4.3
480 - nodes have new fields run_level (in addition to boot_state) and verified
481 - tweaked migration from 4.2
482 - tuned rpm dependencies
483 - doc generation more explicit about errors like missing python modules
484 - removed obsolete method GetSlicesMD5
485
486 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
487 - unified all tags
488 - renamed interface settings into interface tags and slice attributes into slice tags
489 - nodes have a node_type
490 - various changes on the way to 4.3
491
492 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
493 - Checkpointing : this version still has interface settings and slice attributes
494
495 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
496 - first iteration with taggable nodes/interfaces/slices
497 - embryo for ilinks
498 - cleaned up boot states
499 - migration script moslty complete
500
501 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
502 - fixed doc build by locating locally installed DTDs at build-time
503
504 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
505 - no more doc packaged outside of myplc-docs - doc/ cleaned up
506 - enhancements in doc on filters 
507 - bootcd-aware GetBootMedium merged from onelab
508
509 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
510 - checkpoint while the new myplc-docs package is underway
511 - bugfix: GetSlivers & conf files
512 - doc: removed target files 
513
514 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
515 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
516 - the non-deleted fields were index, resulting in massivly slow queries.
517
518
519 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
520 - plcsh: better handling of options when running as a shell script
521 - getbootmedium exports compute_key
522 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
523
524 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
525 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
526 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
527
528 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
529 - refresh peer script to use a month-dependent logfile
530 - tracking the starting point for UniPi integration of the dummynet boxes
531
532 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
533 - plcsh adds its own path to sys.path
534 - fix so GetNodes can be called from a Node
535
536 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
537 - Initial build.
538
539 %define module_current_branch 4.3