Setting tag plcapi-5.3-4
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 Requires: SOAPpy
36 Requires: python-simplejson
37 # for the RebootNodeWithPCU method
38 Requires: pcucontrol >= 1.0-6
39 # for OMF integration
40 Requires: pyaspects >= 0.4
41 Requires: python-twisted-words
42 Requires: python-twisted-web
43 # ldap
44 Requires: python-ldap
45 # for memcache
46 Requires: memcached python-memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 # for building the wsdl interface we used to require PyXML
58 # but this has gone with f20 so turning this off for now
59 BuildRequires: php-devel python-simplejson
60 Obsoletes: php-xmlrpc
61 Provides: php-xmlrpc
62
63 # PostgreSQL and SOAPpy are necessary to run the API server, but not
64 # plcsh. Since the only supported method of running the server is via
65 # MyPLC anyway, don't be so stringent about binary requirements, in
66 # case people want to install this package just for plcsh.
67 # Requires: postgresql-server, SOAPpy
68 AutoReqProv: no
69
70 %description
71 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
72 PlanetLab Central (PLC) database. The API may be accessed directly via
73 the Python shell program plcsh, through a toy standalone server, or
74 through Apache mod_python.
75
76 %prep
77 %setup -q
78
79 %build
80 # python-pycurl and python-psycopg2 avail. from fedora 5
81 # we used to ship our own version of psycopg2 and pycurl, for fedora4
82 # starting with 4.3, support for these two modules is taken out
83
84 # Build __init__.py metafiles and PHP API. 
85 %{__make} %{?_smp_mflags}
86 %{__make} -C wsdl
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
91
92 # Install shell symlink
93 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
94 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
95
96 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
97 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
98 ; Enable xmlrpc extension module
99 extension=xmlrpc.so
100 EOF
101
102 # Install initscripts
103 echo "* Installing initscripts"
104 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
105 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
106
107 # Install db-config.d files
108 echo "* Installing db-config.d files"
109 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
111 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
112
113 # Install wsdl
114 echo "* Installing wsdl"
115 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
116
117 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
118 ## Install omf_slicemgr.py
119 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
120 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
121 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
122
123 # Install ratelimit log
124 mkdir -p $RPM_BUILD_ROOT/var/log
125 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
126 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %define php_extension_dir %(php-config --extension-dir)
132
133 %files
134 %defattr(-,root,root,-)
135 %dir %{_datadir}/plc_api
136 #%dir /var/log/omf/
137 %{_datadir}/plc_api/*
138 %{_bindir}/plcsh
139 %{php_extension_dir}/xmlrpc.so
140 %{_sysconfdir}/php.d/xmlrpc.ini
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 #/usr/bin/omf_slicemgr.py*
146 #/usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plc_api_ratelimit.log
148
149
150 %changelog
151 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
152 - enable filtering on tags (like hrn) with GetPersons and GetSites
153
154 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
155 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
156
157 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
158 - don't use PyXML that is deprecated in f20, use lxml instead
159 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
160
161 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
162 - create accessor 'hrn' for site as well
163 - create accessors 'sfa_created' for site/slice/person
164 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
165 - UpdatePerson() updates Person HRN according to updated email.
166 - UpdateSite() updates Site HRN according to updated login_base.
167 - Fix AddPersonToSite().
168 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
169 - RefreshPeer() manages Site*Person and Person*Role relationships.
170
171 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
172 - provide a slicename_to_hrn function
173
174 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
175 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
176
177 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
178 - fix for wsgi-based deployments, each thread has its own api()
179
180 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
181 - also cleanup omf-slicemgr initscript
182
183 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
184 - tear down omf-related aspects as this is no longer needed with omfv6
185
186 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
187 - also expose 'expires' in ResolveSlices
188
189 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
190 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
191
192 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
193 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
194
195 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
196 - use SFA code for computing hrn's when available
197
198 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
199 - new slice tag 'interface' for configuring a virtual interface
200 - new builtin 030-interface_tags
201 - new node accessor and tag 'virt' for mixing lxc & vs nodes
202 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
203 - moved ModPypthon and plc.wsgi in the apache/ subdir
204 - renamed PLCAPI.spec into plcapi.spec
205 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
206 - support for php-5.4
207
208 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
209 - implement PLC_VSYS_DEFAULTS in AddSlice
210
211 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
212 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
213 - AddPerson and UpdatePerson are now tag-aware
214 - as a side-effect AddPerson is more picky and rejects invalid fields
215 - which results in a requirement to use sfa-2.1-22 with this tag
216 - marginal improvement on the xml doc on tags
217
218 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
219 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
220 - reset_xmpp_pubsub_nodes now hos options and usage
221 - new Accessors for vicci
222
223 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
224 - fixed imports for tags management with sites and persons
225 - add predefined 'cpu_freezable' tag
226
227 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
228 - tweaks in interface initialization
229 - has 'vsys_vnet' as a predefined tagtype
230 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
231 - bugfix: GetSlivers & nodegroups
232 - bugfix: in jabber groups management
233
234 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
235 - fix gpg-authentication for Persons (thanks Jordan)
236 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
237 - ip address/network check: v4 or v6
238 - customized DB Message survive upgrade
239 - make sync works in lxc-hosted tests
240 - no svn keywords anymore
241
242 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
243 - fix sorting for methods list in docs
244 - untested but needed tweak for postgres startup in f16
245
246 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
247 - tweaks in postgresql setup - in line with sfa
248
249 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
250 - slight tweaks in Persons.py
251
252 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
253 - GetSession has support for more than one day sessions
254 - reset_xmpp_pubsub_nodes is much more efficient
255 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
256 - bugfix - deleting a person in the middle of the signup process
257
258 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
259 - ratelimit aspects
260 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
261 - requires Django for cache_utils
262 - attempt to expose 'pldistro' to sfa
263 - last_time_spent_online, last_time_spent_offline: new fields in Node
264 - new slice tags 'isolate_loopback' and 'cpu_cores'
265 - refresh-peer federation logs dump exceptions
266 - modpython logs have a timestamp
267 - more verbose/accurate php error reporting
268 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
269 - AddNode, UpdateNode: manage tags directly rather than through another method
270 - BootUpdateNode: only update once
271 - GetPersons: techs can access the list of persons on their site
272 - GetSlices and GetSliceTags: techs can see slices on their nodes
273 - GetSlivers: isrootonsite tag; cacheable
274
275 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
276 - rename initscript_body into initscript_code
277
278 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
279 - new initscript_body tag
280
281 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
282 - working draft for GetSliceSshKeys
283
284 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
285 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
286 - (this is for people who cancel their download)
287
288 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
289 - fix db-config sequence : accessors step now merged in, and occurs at the right time
290 - db-config also more robust
291 - no more explicit 'accessors' step in plc.d
292
293 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
294 - session auth: do *not* delete session when node runs a method that does not have 'node' role
295 - session auth: remove support for bootonce in old boot CDs
296 - give a reason when caller_may_write_slice_tag fails
297 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
298
299 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
300 - SetSliceVref needed the node role
301 - protect GetSliceFamily
302 - Fix bugs in tag authorizations
303
304 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
305 - altered checking of optional fields in Interfaces
306 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
307 - has pyxml and python-simplejson as new deps
308
309 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
310 - tweak doc extraction for fedora14
311
312 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
313 - builtin accessors for the myslice page
314 - Get{Node,Interface}Tags allowed to techs
315 - tweak in ratelimitaspect.py
316
317 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
318 - add admin role to accessor-related tags (arch, {fc,pl}distro)
319
320 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
321 - bugfix in {Update,Delete}PersonTag
322 - updated xml doc for filters, accessors and tagtypes
323 - more explicit msg in case of missing roles
324 - improvements in ratelimitaspects.py
325
326 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
327 - fix the roles for ssh_key and hmac tags
328
329 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
330 - tag permissions system based on roles and not min_role_ids
331 - accessors simplified accordingly (no more min_role_id)
332 - new methods AddRoleToTagType and DeleteRoleFromTagType
333 - accessor-related tagtypes are created sooner, and enforced
334 - cleaned up redundancy between db-config.d and accessors
335
336 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
337 - fix RefreshPeer that was not working in 5.0-17
338
339 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
340 - RefreshPeer is able to cope with 2 peers running different releases of the api
341 - DeletePerson can be used on duplicates
342 - first appearance of ModPythonJson.py
343
344 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
345 - set accessors return the new value
346 - tweaks in the pubsub groups management
347
348 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
349 - convert hostnames to lower case and use ILIKE instead of LIKE
350
351 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
352 - use hrn in pubsub groups
353
354 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
355 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
356 - OMF fixes
357
358 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
359 - automatically set vsys tag for omf controlled slices
360
361 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
362 - addition of the 'ssh_key' slice tag
363 - first draft of the LDAP interface
364
365 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
366 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
367 - and readable through GetLeaseGranularity
368 - GetSlivers to expose reservation_policy and lease_granularity
369 - GetBootMedium fixed for reservable nodes
370 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
371 - new Apache mod_wsgi python interface
372
373 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
374 - the leases system
375
376 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
377 - previous tag had gone wrong
378
379 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
380 - fix pubsub hostname
381
382 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
383 - tweaks for the omf support (xmpp groups and RC-controlled slices)
384 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
385 - GetNodeFlavour exposes fcdistro
386
387 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
388 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
389
390 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
391 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
392 - pyaspect hooks allow to  maintain the namespace xmpp groups
393 - new omf_slicemgr is a proxy to xmpp, used by these hooks
394 - nodes have their hrn exposed in the 'hrn' tag
395 - node hrn exposed in GetSlivers, as well as the overall xmpp config
396 - system slice 'drl' gets created by db-config
397 - daniel's changes to Filter for supporting wildcards in lists
398 - AddSliceTag consistency check tweaked
399
400 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
401 - major cleanup
402 - get rid of all 4.2-related legacy code
403 - reset the migrations code, planetlab5.sql somes with (5,100)
404 - uses hashlib module when available
405
406 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
407 - first working version of 5.0:
408 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
409 - nodefamily is 3-fold with pldistro-fcdistro-arch
410 - site and person tags
411 - new methods GetSliceFamily and GetNodeFlavour
412 - deprecated the dummynet stuff that were for the external dummyboxes
413 - tags definition : more consistency between db-config scripts and accessors
414 - (get accessor to create the tag type too if absent)
415 - logging an event for AddSliceToNodes
416
417 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
418 - support for fedora 12
419 - fix subtle bug in filtering with ] and quotes
420
421 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
422 - * patch for php-5.3 (the one in f12)
423 - * validate email addresses with regex
424 - * add PersonTags and SiteTags
425 - * add additional accessors for node tags (kvariant, serial, ..)
426
427 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
428 - Redacting password, session, and authstring values from the event log.
429
430 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
431 - let AddSite set ext_consortium_id - required for the poorman registration pages
432 - drop version constraint on Requires: postgresql-python
433 - don't log system calls nor ReportRunLevel
434
435 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
436 - Fix requires for CentOS.
437
438 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
439 - Require postgresql 8.2 (for array operators && and @>)
440
441 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
442 - Filter now supports the | and & features to match in sequence values
443 - bugfix in the postgresql wrapper for sequence filter values
444 - reviewed GetSlivers to export admin keys more efficiently
445 - fix checking roles in UpdateSliceTag
446
447 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
448 - - Some typos in the documentation were fixed.
449 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
450 - to the tag's min_role_id.
451
452 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
453
454 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
455 - Ongoing work to add upcalls, using new SFA class
456 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
457 - reviewed type-checking for the 3 taggable classes node-interface-slice
458 - cleanup ald dummynet stuff
459 - expose the 'extensions' accessors to the API
460 - tweaked checks in AddSliceTag
461 - GetPersons exposes roles by default
462 - bugfix in ReportRunLevel for non-string levels
463 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
464
465 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
466 - new BindObjectToPeer method for sfa
467 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
468
469 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
470 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
471 - reportrunlevel logs its calls only when run_level changes
472 - pycurl more robust wrt to xmlrpclib.Transport
473
474 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
475 - produce a wsdl interface
476 - bugfix in getbootmedium for nodes with interface tags
477
478 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
479 - bugfix for some rare pattern-based filters
480
481 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
482 - improvements in the 4.2 legacy layer
483
484 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
485 - bugfix required for slice tags set on nodegroups
486
487 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
488 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
489
490 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
491 - more powerful legacy layer with 4.2
492
493 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
494 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
495 - migration script has an option for running interactively
496
497 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
498 - skips already added entries
499
500 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
501 - yet another set of fixes for external dummynet boxes
502
503 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
504 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
505 - and tmp file is cleaned up
506
507 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
508 - restore missing ResolveSlices
509
510 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
511 - new method GetDummyBoxMedium
512
513 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
514 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
515
516 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
517 - support for external dummynet boxes back in 4.3 - first draft
518
519 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
520 - fixes for smooth federation between 4.2 and 4.3
521 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
522
523 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
524 - support for BootCD variants (GetBootMedium ['variant:centos5'])
525 - fix corner case with filters like {'~slice_id':[]}
526 - fix transaction leak that caused the db connections pool to exhaust
527 - properly expose all methods, including Legacy/, and not only Methods/
528
529 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
530 - renumbered as 4.3
531 - nodes have new fields run_level (in addition to boot_state) and verified
532 - tweaked migration from 4.2
533 - tuned rpm dependencies
534 - doc generation more explicit about errors like missing python modules
535 - removed obsolete method GetSlicesMD5
536
537 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
538 - unified all tags
539 - renamed interface settings into interface tags and slice attributes into slice tags
540 - nodes have a node_type
541 - various changes on the way to 4.3
542
543 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
544 - Checkpointing : this version still has interface settings and slice attributes
545
546 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
547 - first iteration with taggable nodes/interfaces/slices
548 - embryo for ilinks
549 - cleaned up boot states
550 - migration script moslty complete
551
552 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
553 - fixed doc build by locating locally installed DTDs at build-time
554
555 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
556 - no more doc packaged outside of myplc-docs - doc/ cleaned up
557 - enhancements in doc on filters 
558 - bootcd-aware GetBootMedium merged from onelab
559
560 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
561 - checkpoint while the new myplc-docs package is underway
562 - bugfix: GetSlivers & conf files
563 - doc: removed target files 
564
565 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
566 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
567 - the non-deleted fields were index, resulting in massivly slow queries.
568
569
570 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
571 - plcsh: better handling of options when running as a shell script
572 - getbootmedium exports compute_key
573 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
574
575 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
576 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
577 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
578
579 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
580 - refresh peer script to use a month-dependent logfile
581 - tracking the starting point for UniPi integration of the dummynet boxes
582
583 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
584 - plcsh adds its own path to sys.path
585 - fix so GetNodes can be called from a Node
586
587 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
588 - Initial build.
589
590 %define module_current_branch 4.3