mkdir var/log
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 mkdir -p $RPM_BUILD_ROOT/var/log
123 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %define php_extension_dir %(php-config --extension-dir)
130
131 %files
132 %defattr(-,root,root,-)
133 %dir %{_datadir}/plc_api
134 #%dir /var/log/omf/
135 %{_datadir}/plc_api/*
136 %{_bindir}/plcsh
137 %{php_extension_dir}/xmlrpc.so
138 %{_sysconfdir}/php.d/xmlrpc.ini
139 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
140 /etc/plc.d
141 /etc/planetlab/db-config.d
142 /var/www/html/wsdl/plcapi.wsdl
143 #/usr/bin/omf_slicemgr.py*
144 #/usr/bin/reset_xmpp_pubsub_nodes.py*
145 /var/log/plc_api_ratelimit.log
146
147
148 %changelog
149 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
150 - also expose 'expires' in ResolveSlices
151
152 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
153 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
154
155 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
156 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
157
158 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
159 - use SFA code for computing hrn's when available
160
161 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
162 - new slice tag 'interface' for configuring a virtual interface
163 - new builtin 030-interface_tags
164 - new node accessor and tag 'virt' for mixing lxc & vs nodes
165 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
166 - moved ModPypthon and plc.wsgi in the apache/ subdir
167 - renamed PLCAPI.spec into plcapi.spec
168 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
169 - support for php-5.4
170
171 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
172 - implement PLC_VSYS_DEFAULTS in AddSlice
173
174 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
175 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
176 - AddPerson and UpdatePerson are now tag-aware
177 - as a side-effect AddPerson is more picky and rejects invalid fields
178 - which results in a requirement to use sfa-2.1-22 with this tag
179 - marginal improvement on the xml doc on tags
180
181 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
182 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
183 - reset_xmpp_pubsub_nodes now hos options and usage
184 - new Accessors for vicci
185
186 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
187 - fixed imports for tags management with sites and persons
188 - add predefined 'cpu_freezable' tag
189
190 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
191 - tweaks in interface initialization
192 - has 'vsys_vnet' as a predefined tagtype
193 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
194 - bugfix: GetSlivers & nodegroups
195 - bugfix: in jabber groups management
196
197 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
198 - fix gpg-authentication for Persons (thanks Jordan)
199 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
200 - ip address/network check: v4 or v6
201 - customized DB Message survive upgrade
202 - make sync works in lxc-hosted tests
203 - no svn keywords anymore
204
205 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
206 - fix sorting for methods list in docs
207 - untested but needed tweak for postgres startup in f16
208
209 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
210 - tweaks in postgresql setup - in line with sfa
211
212 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
213 - slight tweaks in Persons.py
214
215 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
216 - GetSession has support for more than one day sessions
217 - reset_xmpp_pubsub_nodes is much more efficient
218 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
219 - bugfix - deleting a person in the middle of the signup process
220
221 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
222 - ratelimit aspects
223 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
224 - requires Django for cache_utils
225 - attempt to expose 'pldistro' to sfa
226 - last_time_spent_online, last_time_spent_offline: new fields in Node
227 - new slice tags 'isolate_loopback' and 'cpu_cores'
228 - refresh-peer federation logs dump exceptions
229 - modpython logs have a timestamp
230 - more verbose/accurate php error reporting
231 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
232 - AddNode, UpdateNode: manage tags directly rather than through another method
233 - BootUpdateNode: only update once
234 - GetPersons: techs can access the list of persons on their site
235 - GetSlices and GetSliceTags: techs can see slices on their nodes
236 - GetSlivers: isrootonsite tag; cacheable
237
238 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
239 - rename initscript_body into initscript_code
240
241 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
242 - new initscript_body tag
243
244 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
245 - working draft for GetSliceSshKeys
246
247 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
248 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
249 - (this is for people who cancel their download)
250
251 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
252 - fix db-config sequence : accessors step now merged in, and occurs at the right time
253 - db-config also more robust
254 - no more explicit 'accessors' step in plc.d
255
256 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
257 - session auth: do *not* delete session when node runs a method that does not have 'node' role
258 - session auth: remove support for bootonce in old boot CDs
259 - give a reason when caller_may_write_slice_tag fails
260 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
261
262 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
263 - SetSliceVref needed the node role
264 - protect GetSliceFamily
265 - Fix bugs in tag authorizations
266
267 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
268 - altered checking of optional fields in Interfaces
269 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
270 - has pyxml and python-simplejson as new deps
271
272 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
273 - tweak doc extraction for fedora14
274
275 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
276 - builtin accessors for the myslice page
277 - Get{Node,Interface}Tags allowed to techs
278 - tweak in ratelimitaspect.py
279
280 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
281 - add admin role to accessor-related tags (arch, {fc,pl}distro)
282
283 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
284 - bugfix in {Update,Delete}PersonTag
285 - updated xml doc for filters, accessors and tagtypes
286 - more explicit msg in case of missing roles
287 - improvements in ratelimitaspects.py
288
289 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
290 - fix the roles for ssh_key and hmac tags
291
292 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
293 - tag permissions system based on roles and not min_role_ids
294 - accessors simplified accordingly (no more min_role_id)
295 - new methods AddRoleToTagType and DeleteRoleFromTagType
296 - accessor-related tagtypes are created sooner, and enforced
297 - cleaned up redundancy between db-config.d and accessors
298
299 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
300 - fix RefreshPeer that was not working in 5.0-17
301
302 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
303 - RefreshPeer is able to cope with 2 peers running different releases of the api
304 - DeletePerson can be used on duplicates
305 - first appearance of ModPythonJson.py
306
307 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
308 - set accessors return the new value
309 - tweaks in the pubsub groups management
310
311 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
312 - convert hostnames to lower case and use ILIKE instead of LIKE
313
314 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
315 - use hrn in pubsub groups
316
317 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
318 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
319 - OMF fixes
320
321 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
322 - automatically set vsys tag for omf controlled slices
323
324 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
325 - addition of the 'ssh_key' slice tag
326 - first draft of the LDAP interface
327
328 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
329 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
330 - and readable through GetLeaseGranularity
331 - GetSlivers to expose reservation_policy and lease_granularity
332 - GetBootMedium fixed for reservable nodes
333 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
334 - new Apache mod_wsgi python interface
335
336 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
337 - the leases system
338
339 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
340 - previous tag had gone wrong
341
342 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
343 - fix pubsub hostname
344
345 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
346 - tweaks for the omf support (xmpp groups and RC-controlled slices)
347 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
348 - GetNodeFlavour exposes fcdistro
349
350 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
351 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
352
353 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
354 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
355 - pyaspect hooks allow to  maintain the namespace xmpp groups
356 - new omf_slicemgr is a proxy to xmpp, used by these hooks
357 - nodes have their hrn exposed in the 'hrn' tag
358 - node hrn exposed in GetSlivers, as well as the overall xmpp config
359 - system slice 'drl' gets created by db-config
360 - daniel's changes to Filter for supporting wildcards in lists
361 - AddSliceTag consistency check tweaked
362
363 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
364 - major cleanup
365 - get rid of all 4.2-related legacy code
366 - reset the migrations code, planetlab5.sql somes with (5,100)
367 - uses hashlib module when available
368
369 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
370 - first working version of 5.0:
371 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
372 - nodefamily is 3-fold with pldistro-fcdistro-arch
373 - site and person tags
374 - new methods GetSliceFamily and GetNodeFlavour
375 - deprecated the dummynet stuff that were for the external dummyboxes
376 - tags definition : more consistency between db-config scripts and accessors
377 - (get accessor to create the tag type too if absent)
378 - logging an event for AddSliceToNodes
379
380 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
381 - support for fedora 12
382 - fix subtle bug in filtering with ] and quotes
383
384 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
385 - * patch for php-5.3 (the one in f12)
386 - * validate email addresses with regex
387 - * add PersonTags and SiteTags
388 - * add additional accessors for node tags (kvariant, serial, ..)
389
390 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
391 - Redacting password, session, and authstring values from the event log.
392
393 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
394 - let AddSite set ext_consortium_id - required for the poorman registration pages
395 - drop version constraint on Requires: postgresql-python
396 - don't log system calls nor ReportRunLevel
397
398 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
399 - Fix requires for CentOS.
400
401 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
402 - Require postgresql 8.2 (for array operators && and @>)
403
404 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
405 - Filter now supports the | and & features to match in sequence values
406 - bugfix in the postgresql wrapper for sequence filter values
407 - reviewed GetSlivers to export admin keys more efficiently
408 - fix checking roles in UpdateSliceTag
409
410 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
411 - - Some typos in the documentation were fixed.
412 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
413 - to the tag's min_role_id.
414
415 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
416
417 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
418 - Ongoing work to add upcalls, using new SFA class
419 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
420 - reviewed type-checking for the 3 taggable classes node-interface-slice
421 - cleanup ald dummynet stuff
422 - expose the 'extensions' accessors to the API
423 - tweaked checks in AddSliceTag
424 - GetPersons exposes roles by default
425 - bugfix in ReportRunLevel for non-string levels
426 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
427
428 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
429 - new BindObjectToPeer method for sfa
430 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
431
432 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
433 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
434 - reportrunlevel logs its calls only when run_level changes
435 - pycurl more robust wrt to xmlrpclib.Transport
436
437 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
438 - produce a wsdl interface
439 - bugfix in getbootmedium for nodes with interface tags
440
441 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
442 - bugfix for some rare pattern-based filters
443
444 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
445 - improvements in the 4.2 legacy layer
446
447 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
448 - bugfix required for slice tags set on nodegroups
449
450 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
451 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
452
453 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
454 - more powerful legacy layer with 4.2
455
456 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
457 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
458 - migration script has an option for running interactively
459
460 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
461 - skips already added entries
462
463 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
464 - yet another set of fixes for external dummynet boxes
465
466 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
467 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
468 - and tmp file is cleaned up
469
470 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
471 - restore missing ResolveSlices
472
473 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
474 - new method GetDummyBoxMedium
475
476 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
477 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
478
479 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
480 - support for external dummynet boxes back in 4.3 - first draft
481
482 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
483 - fixes for smooth federation between 4.2 and 4.3
484 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
485
486 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
487 - support for BootCD variants (GetBootMedium ['variant:centos5'])
488 - fix corner case with filters like {'~slice_id':[]}
489 - fix transaction leak that caused the db connections pool to exhaust
490 - properly expose all methods, including Legacy/, and not only Methods/
491
492 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
493 - renumbered as 4.3
494 - nodes have new fields run_level (in addition to boot_state) and verified
495 - tweaked migration from 4.2
496 - tuned rpm dependencies
497 - doc generation more explicit about errors like missing python modules
498 - removed obsolete method GetSlicesMD5
499
500 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
501 - unified all tags
502 - renamed interface settings into interface tags and slice attributes into slice tags
503 - nodes have a node_type
504 - various changes on the way to 4.3
505
506 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
507 - Checkpointing : this version still has interface settings and slice attributes
508
509 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
510 - first iteration with taggable nodes/interfaces/slices
511 - embryo for ilinks
512 - cleaned up boot states
513 - migration script moslty complete
514
515 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
516 - fixed doc build by locating locally installed DTDs at build-time
517
518 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
519 - no more doc packaged outside of myplc-docs - doc/ cleaned up
520 - enhancements in doc on filters 
521 - bootcd-aware GetBootMedium merged from onelab
522
523 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
524 - checkpoint while the new myplc-docs package is underway
525 - bugfix: GetSlivers & conf files
526 - doc: removed target files 
527
528 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
529 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
530 - the non-deleted fields were index, resulting in massivly slow queries.
531
532
533 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
534 - plcsh: better handling of options when running as a shell script
535 - getbootmedium exports compute_key
536 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
537
538 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
539 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
540 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
541
542 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
543 - refresh peer script to use a month-dependent logfile
544 - tracking the starting point for UniPi integration of the dummynet boxes
545
546 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
547 - plcsh adds its own path to sys.path
548 - fix so GetNodes can be called from a Node
549
550 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
551 - Initial build.
552
553 %define module_current_branch 4.3