Setting tag plcapi-5.3-6
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 # We use psycopg2
57 #
58 # but we don't need to rebuild it as we depend on distro's packages - baris
59 # BuildRequires: postgresql-devel
60
61 # Standard xmlrpc.so that ships with PHP does not marshal NULL
62 # for building the wsdl interface we used to require PyXML
63 # but this has gone with f20 so turning this off for now
64 BuildRequires: php-devel python-simplejson
65 Obsoletes: php-xmlrpc
66 Provides: php-xmlrpc
67
68 # PostgreSQL and SOAPpy are necessary to run the API server, but not
69 # plcsh. Since the only supported method of running the server is via
70 # MyPLC anyway, don't be so stringent about binary requirements, in
71 # case people want to install this package just for plcsh.
72 # Requires: postgresql-server, SOAPpy
73 AutoReqProv: no
74
75 %description
76 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
77 PlanetLab Central (PLC) database. The API may be accessed directly via
78 the Python shell program plcsh, through a toy standalone server, or
79 through Apache mod_python.
80
81 %prep
82 %setup -q
83
84 %build
85 # python-pycurl and python-psycopg2 avail. from fedora 5
86 # we used to ship our own version of psycopg2 and pycurl, for fedora4
87 # starting with 4.3, support for these two modules is taken out
88
89 # Build __init__.py metafiles and PHP API. 
90 %{__make} %{?_smp_mflags}
91 %{__make} -C wsdl
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
96
97 # Install shell symlink
98 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
99 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
100
101 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
102 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
103 ; Enable xmlrpc extension module
104 extension=xmlrpc.so
105 EOF
106
107 # Install initscripts
108 echo "* Installing initscripts"
109 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
110 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
111
112 # Install db-config.d files
113 echo "* Installing db-config.d files"
114 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
115 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
116 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
117
118 # Install wsdl
119 echo "* Installing wsdl"
120 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
121
122 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
123 ## Install omf_slicemgr.py
124 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
125 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
126 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
127
128 # Install ratelimit log
129 mkdir -p $RPM_BUILD_ROOT/var/log
130 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
131 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %define php_extension_dir %(php-config --extension-dir)
137
138 %files
139 %defattr(-,root,root,-)
140 %dir %{_datadir}/plc_api
141 #%dir /var/log/omf/
142 %{_datadir}/plc_api/*
143 %{_bindir}/plcsh
144 %{php_extension_dir}/xmlrpc.so
145 %{_sysconfdir}/php.d/xmlrpc.ini
146 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
147 /etc/plc.d
148 /etc/planetlab/db-config.d
149 /var/www/html/wsdl/plcapi.wsdl
150 #/usr/bin/omf_slicemgr.py*
151 #/usr/bin/reset_xmpp_pubsub_nodes.py*
152 /var/log/plc_api_ratelimit.log
153
154
155 %changelog
156 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
157 - extensions for the ipv6 feature
158 - DeleteSliceTag can be run with the 'node' auth
159 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
160 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
161
162 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
163 - allow GetSlices to filter on tags as well
164
165 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
166 - enable filtering on tags (like hrn) with GetPersons and GetSites
167
168 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
169 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
170
171 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
172 - don't use PyXML that is deprecated in f20, use lxml instead
173 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
174
175 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
176 - create accessor 'hrn' for site as well
177 - create accessors 'sfa_created' for site/slice/person
178 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
179 - UpdatePerson() updates Person HRN according to updated email.
180 - UpdateSite() updates Site HRN according to updated login_base.
181 - Fix AddPersonToSite().
182 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
183 - RefreshPeer() manages Site*Person and Person*Role relationships.
184
185 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
186 - provide a slicename_to_hrn function
187
188 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
189 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
190
191 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
192 - fix for wsgi-based deployments, each thread has its own api()
193
194 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
195 - also cleanup omf-slicemgr initscript
196
197 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
198 - tear down omf-related aspects as this is no longer needed with omfv6
199
200 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
201 - also expose 'expires' in ResolveSlices
202
203 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
204 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
205
206 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
207 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
208
209 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
210 - use SFA code for computing hrn's when available
211
212 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
213 - new slice tag 'interface' for configuring a virtual interface
214 - new builtin 030-interface_tags
215 - new node accessor and tag 'virt' for mixing lxc & vs nodes
216 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
217 - moved ModPypthon and plc.wsgi in the apache/ subdir
218 - renamed PLCAPI.spec into plcapi.spec
219 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
220 - support for php-5.4
221
222 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
223 - implement PLC_VSYS_DEFAULTS in AddSlice
224
225 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
226 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
227 - AddPerson and UpdatePerson are now tag-aware
228 - as a side-effect AddPerson is more picky and rejects invalid fields
229 - which results in a requirement to use sfa-2.1-22 with this tag
230 - marginal improvement on the xml doc on tags
231
232 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
233 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
234 - reset_xmpp_pubsub_nodes now hos options and usage
235 - new Accessors for vicci
236
237 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
238 - fixed imports for tags management with sites and persons
239 - add predefined 'cpu_freezable' tag
240
241 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
242 - tweaks in interface initialization
243 - has 'vsys_vnet' as a predefined tagtype
244 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
245 - bugfix: GetSlivers & nodegroups
246 - bugfix: in jabber groups management
247
248 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
249 - fix gpg-authentication for Persons (thanks Jordan)
250 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
251 - ip address/network check: v4 or v6
252 - customized DB Message survive upgrade
253 - make sync works in lxc-hosted tests
254 - no svn keywords anymore
255
256 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
257 - fix sorting for methods list in docs
258 - untested but needed tweak for postgres startup in f16
259
260 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
261 - tweaks in postgresql setup - in line with sfa
262
263 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
264 - slight tweaks in Persons.py
265
266 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
267 - GetSession has support for more than one day sessions
268 - reset_xmpp_pubsub_nodes is much more efficient
269 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
270 - bugfix - deleting a person in the middle of the signup process
271
272 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
273 - ratelimit aspects
274 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
275 - requires Django for cache_utils
276 - attempt to expose 'pldistro' to sfa
277 - last_time_spent_online, last_time_spent_offline: new fields in Node
278 - new slice tags 'isolate_loopback' and 'cpu_cores'
279 - refresh-peer federation logs dump exceptions
280 - modpython logs have a timestamp
281 - more verbose/accurate php error reporting
282 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
283 - AddNode, UpdateNode: manage tags directly rather than through another method
284 - BootUpdateNode: only update once
285 - GetPersons: techs can access the list of persons on their site
286 - GetSlices and GetSliceTags: techs can see slices on their nodes
287 - GetSlivers: isrootonsite tag; cacheable
288
289 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
290 - rename initscript_body into initscript_code
291
292 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
293 - new initscript_body tag
294
295 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
296 - working draft for GetSliceSshKeys
297
298 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
299 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
300 - (this is for people who cancel their download)
301
302 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
303 - fix db-config sequence : accessors step now merged in, and occurs at the right time
304 - db-config also more robust
305 - no more explicit 'accessors' step in plc.d
306
307 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
308 - session auth: do *not* delete session when node runs a method that does not have 'node' role
309 - session auth: remove support for bootonce in old boot CDs
310 - give a reason when caller_may_write_slice_tag fails
311 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
312
313 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
314 - SetSliceVref needed the node role
315 - protect GetSliceFamily
316 - Fix bugs in tag authorizations
317
318 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
319 - altered checking of optional fields in Interfaces
320 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
321 - has pyxml and python-simplejson as new deps
322
323 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
324 - tweak doc extraction for fedora14
325
326 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
327 - builtin accessors for the myslice page
328 - Get{Node,Interface}Tags allowed to techs
329 - tweak in ratelimitaspect.py
330
331 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
332 - add admin role to accessor-related tags (arch, {fc,pl}distro)
333
334 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
335 - bugfix in {Update,Delete}PersonTag
336 - updated xml doc for filters, accessors and tagtypes
337 - more explicit msg in case of missing roles
338 - improvements in ratelimitaspects.py
339
340 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
341 - fix the roles for ssh_key and hmac tags
342
343 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
344 - tag permissions system based on roles and not min_role_ids
345 - accessors simplified accordingly (no more min_role_id)
346 - new methods AddRoleToTagType and DeleteRoleFromTagType
347 - accessor-related tagtypes are created sooner, and enforced
348 - cleaned up redundancy between db-config.d and accessors
349
350 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
351 - fix RefreshPeer that was not working in 5.0-17
352
353 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
354 - RefreshPeer is able to cope with 2 peers running different releases of the api
355 - DeletePerson can be used on duplicates
356 - first appearance of ModPythonJson.py
357
358 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
359 - set accessors return the new value
360 - tweaks in the pubsub groups management
361
362 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
363 - convert hostnames to lower case and use ILIKE instead of LIKE
364
365 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
366 - use hrn in pubsub groups
367
368 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
369 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
370 - OMF fixes
371
372 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
373 - automatically set vsys tag for omf controlled slices
374
375 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
376 - addition of the 'ssh_key' slice tag
377 - first draft of the LDAP interface
378
379 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
380 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
381 - and readable through GetLeaseGranularity
382 - GetSlivers to expose reservation_policy and lease_granularity
383 - GetBootMedium fixed for reservable nodes
384 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
385 - new Apache mod_wsgi python interface
386
387 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
388 - the leases system
389
390 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
391 - previous tag had gone wrong
392
393 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
394 - fix pubsub hostname
395
396 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
397 - tweaks for the omf support (xmpp groups and RC-controlled slices)
398 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
399 - GetNodeFlavour exposes fcdistro
400
401 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
402 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
403
404 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
405 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
406 - pyaspect hooks allow to  maintain the namespace xmpp groups
407 - new omf_slicemgr is a proxy to xmpp, used by these hooks
408 - nodes have their hrn exposed in the 'hrn' tag
409 - node hrn exposed in GetSlivers, as well as the overall xmpp config
410 - system slice 'drl' gets created by db-config
411 - daniel's changes to Filter for supporting wildcards in lists
412 - AddSliceTag consistency check tweaked
413
414 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
415 - major cleanup
416 - get rid of all 4.2-related legacy code
417 - reset the migrations code, planetlab5.sql somes with (5,100)
418 - uses hashlib module when available
419
420 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
421 - first working version of 5.0:
422 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
423 - nodefamily is 3-fold with pldistro-fcdistro-arch
424 - site and person tags
425 - new methods GetSliceFamily and GetNodeFlavour
426 - deprecated the dummynet stuff that were for the external dummyboxes
427 - tags definition : more consistency between db-config scripts and accessors
428 - (get accessor to create the tag type too if absent)
429 - logging an event for AddSliceToNodes
430
431 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
432 - support for fedora 12
433 - fix subtle bug in filtering with ] and quotes
434
435 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
436 - * patch for php-5.3 (the one in f12)
437 - * validate email addresses with regex
438 - * add PersonTags and SiteTags
439 - * add additional accessors for node tags (kvariant, serial, ..)
440
441 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
442 - Redacting password, session, and authstring values from the event log.
443
444 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
445 - let AddSite set ext_consortium_id - required for the poorman registration pages
446 - drop version constraint on Requires: postgresql-python
447 - don't log system calls nor ReportRunLevel
448
449 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
450 - Fix requires for CentOS.
451
452 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
453 - Require postgresql 8.2 (for array operators && and @>)
454
455 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
456 - Filter now supports the | and & features to match in sequence values
457 - bugfix in the postgresql wrapper for sequence filter values
458 - reviewed GetSlivers to export admin keys more efficiently
459 - fix checking roles in UpdateSliceTag
460
461 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
462 - - Some typos in the documentation were fixed.
463 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
464 - to the tag's min_role_id.
465
466 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
467
468 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
469 - Ongoing work to add upcalls, using new SFA class
470 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
471 - reviewed type-checking for the 3 taggable classes node-interface-slice
472 - cleanup ald dummynet stuff
473 - expose the 'extensions' accessors to the API
474 - tweaked checks in AddSliceTag
475 - GetPersons exposes roles by default
476 - bugfix in ReportRunLevel for non-string levels
477 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
478
479 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
480 - new BindObjectToPeer method for sfa
481 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
482
483 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
484 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
485 - reportrunlevel logs its calls only when run_level changes
486 - pycurl more robust wrt to xmlrpclib.Transport
487
488 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
489 - produce a wsdl interface
490 - bugfix in getbootmedium for nodes with interface tags
491
492 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
493 - bugfix for some rare pattern-based filters
494
495 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
496 - improvements in the 4.2 legacy layer
497
498 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
499 - bugfix required for slice tags set on nodegroups
500
501 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
502 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
503
504 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
505 - more powerful legacy layer with 4.2
506
507 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
508 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
509 - migration script has an option for running interactively
510
511 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
512 - skips already added entries
513
514 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
515 - yet another set of fixes for external dummynet boxes
516
517 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
518 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
519 - and tmp file is cleaned up
520
521 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
522 - restore missing ResolveSlices
523
524 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
525 - new method GetDummyBoxMedium
526
527 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
528 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
529
530 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
531 - support for external dummynet boxes back in 4.3 - first draft
532
533 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
534 - fixes for smooth federation between 4.2 and 4.3
535 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
536
537 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
538 - support for BootCD variants (GetBootMedium ['variant:centos5'])
539 - fix corner case with filters like {'~slice_id':[]}
540 - fix transaction leak that caused the db connections pool to exhaust
541 - properly expose all methods, including Legacy/, and not only Methods/
542
543 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
544 - renumbered as 4.3
545 - nodes have new fields run_level (in addition to boot_state) and verified
546 - tweaked migration from 4.2
547 - tuned rpm dependencies
548 - doc generation more explicit about errors like missing python modules
549 - removed obsolete method GetSlicesMD5
550
551 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
552 - unified all tags
553 - renamed interface settings into interface tags and slice attributes into slice tags
554 - nodes have a node_type
555 - various changes on the way to 4.3
556
557 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
558 - Checkpointing : this version still has interface settings and slice attributes
559
560 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
561 - first iteration with taggable nodes/interfaces/slices
562 - embryo for ilinks
563 - cleaned up boot states
564 - migration script moslty complete
565
566 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
567 - fixed doc build by locating locally installed DTDs at build-time
568
569 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
570 - no more doc packaged outside of myplc-docs - doc/ cleaned up
571 - enhancements in doc on filters 
572 - bootcd-aware GetBootMedium merged from onelab
573
574 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
575 - checkpoint while the new myplc-docs package is underway
576 - bugfix: GetSlivers & conf files
577 - doc: removed target files 
578
579 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
580 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
581 - the non-deleted fields were index, resulting in massivly slow queries.
582
583
584 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
585 - plcsh: better handling of options when running as a shell script
586 - getbootmedium exports compute_key
587 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
588
589 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
590 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
591 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
592
593 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
594 - refresh peer script to use a month-dependent logfile
595 - tracking the starting point for UniPi integration of the dummynet boxes
596
597 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
598 - plcsh adds its own path to sys.path
599 - fix so GetNodes can be called from a Node
600
601 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
602 - Initial build.
603
604 %define module_current_branch 4.3