package the whole contents of the phpxmlrpc git repo
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 11
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 #Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 ####################
57 # obsolete
58 ####################
59 # standard xmlrpc.so that ships with PHP does not marshal NULL
60 # prior to May 2017 we used to ship our own brew of xmlrpc but
61 # that does not build anymore on f25
62 # So bottom line is:
63 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
64 # * don't use our own that is way too old
65 # * instead - thank you Ciro - we pull it as a git subtree from
66 # https://github.com/gggeek/phpxmlrpc.git
67 # Requires: php-xmlrpc
68 ####################
69
70
71 # PostgreSQL and SOAPpy are necessary to run the API server, but not
72 # plcsh. Since the only supported method of running the server is via
73 # MyPLC anyway, don't be so stringent about binary requirements, in
74 # case people want to install this package just for plcsh.
75 # Requires: postgresql-server, SOAPpy
76 AutoReqProv: no
77
78 %description
79 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
80 PlanetLab Central (PLC) database. The API may be accessed directly via
81 the Python shell program plcsh, through a toy standalone server, or
82 through Apache mod_python.
83
84 %prep
85 %setup -q
86
87 %build
88 # python-pycurl and python-psycopg2 avail. from fedora 5
89 # we used to ship our own version of psycopg2 and pycurl, for fedora4
90 # starting with 4.3, support for these two modules is taken out
91
92 # Build __init__.py metafiles and PHP API. 
93 %{__make} %{?_smp_mflags}
94 %{__make} -C wsdl
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
99
100 # Install shell symlink
101 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
102 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
103
104 # Install initscripts
105 echo "* Installing initscripts"
106 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
107 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
108
109 # Install db-config.d files
110 echo "* Installing db-config.d files"
111 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
112 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
114
115 # Install wsdl
116 echo "* Installing wsdl"
117 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
118
119 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
120 ## Install omf_slicemgr.py
121 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
122 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
123 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
124
125 # Create log file for plcapi
126 mkdir -p $RPM_BUILD_ROOT/var/log
127 touch $RPM_BUILD_ROOT/var/log/plcapi.log
128 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
129
130 # Install ratelimit log
131 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
132 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 ###%define php_extension_dir %(php-config --extension-dir)
138
139 %files
140 %defattr(-,root,root,-)
141 %dir %{_datadir}/plc_api
142 #%dir /var/log/omf/
143 %{_datadir}/plc_api/*
144 %{_bindir}/plcsh
145 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
146 /etc/plc.d
147 /etc/planetlab/db-config.d
148 /var/www/html/wsdl/plcapi.wsdl
149 #/usr/bin/omf_slicemgr.py*
150 #/usr/bin/reset_xmpp_pubsub_nodes.py*
151 /var/log/plcapi.log
152 /var/log/plc_api_ratelimit.log
153
154
155 %changelog
156 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
157 - mostly issued for the R2lab deployment
158 - *** major
159 - * dots allowed in login_base and slice name
160 - * new lease filter 'day'
161 - *** minor
162 - * more explicit message in case of overlapping resas
163 - * bugfix: escaping unicode in xml
164 - * GetLeases allowed to anonymous callers
165 - *** miscell
166 - * use plain json library
167
168 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
169 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
170
171 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
172 - new bootstate 'upgrade' is like reinstall but leaves slices intact
173
174 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
175 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
176
177 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
178 - reviewed logging strategy, no more direct print but use log instead
179
180 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
181 - extensions for the ipv6 feature
182 - DeleteSliceTag can be run with the 'node' auth
183 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
184 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
185
186 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
187 - allow GetSlices to filter on tags as well
188
189 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
190 - enable filtering on tags (like hrn) with GetPersons and GetSites
191
192 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
193 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
194
195 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
196 - don't use PyXML that is deprecated in f20, use lxml instead
197 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
198
199 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
200 - create accessor 'hrn' for site as well
201 - create accessors 'sfa_created' for site/slice/person
202 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
203 - UpdatePerson() updates Person HRN according to updated email.
204 - UpdateSite() updates Site HRN according to updated login_base.
205 - Fix AddPersonToSite().
206 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
207 - RefreshPeer() manages Site*Person and Person*Role relationships.
208
209 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
210 - provide a slicename_to_hrn function
211
212 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
213 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
214
215 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
216 - fix for wsgi-based deployments, each thread has its own api()
217
218 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
219 - also cleanup omf-slicemgr initscript
220
221 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
222 - tear down omf-related aspects as this is no longer needed with omfv6
223
224 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
225 - also expose 'expires' in ResolveSlices
226
227 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
228 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
229
230 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
231 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
232
233 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
234 - use SFA code for computing hrn's when available
235
236 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
237 - new slice tag 'interface' for configuring a virtual interface
238 - new builtin 030-interface_tags
239 - new node accessor and tag 'virt' for mixing lxc & vs nodes
240 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
241 - moved ModPypthon and plc.wsgi in the apache/ subdir
242 - renamed PLCAPI.spec into plcapi.spec
243 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
244 - support for php-5.4
245
246 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
247 - implement PLC_VSYS_DEFAULTS in AddSlice
248
249 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
250 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
251 - AddPerson and UpdatePerson are now tag-aware
252 - as a side-effect AddPerson is more picky and rejects invalid fields
253 - which results in a requirement to use sfa-2.1-22 with this tag
254 - marginal improvement on the xml doc on tags
255
256 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
257 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
258 - reset_xmpp_pubsub_nodes now hos options and usage
259 - new Accessors for vicci
260
261 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
262 - fixed imports for tags management with sites and persons
263 - add predefined 'cpu_freezable' tag
264
265 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
266 - tweaks in interface initialization
267 - has 'vsys_vnet' as a predefined tagtype
268 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
269 - bugfix: GetSlivers & nodegroups
270 - bugfix: in jabber groups management
271
272 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
273 - fix gpg-authentication for Persons (thanks Jordan)
274 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
275 - ip address/network check: v4 or v6
276 - customized DB Message survive upgrade
277 - make sync works in lxc-hosted tests
278 - no svn keywords anymore
279
280 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
281 - fix sorting for methods list in docs
282 - untested but needed tweak for postgres startup in f16
283
284 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
285 - tweaks in postgresql setup - in line with sfa
286
287 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
288 - slight tweaks in Persons.py
289
290 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
291 - GetSession has support for more than one day sessions
292 - reset_xmpp_pubsub_nodes is much more efficient
293 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
294 - bugfix - deleting a person in the middle of the signup process
295
296 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
297 - ratelimit aspects
298 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
299 - requires Django for cache_utils
300 - attempt to expose 'pldistro' to sfa
301 - last_time_spent_online, last_time_spent_offline: new fields in Node
302 - new slice tags 'isolate_loopback' and 'cpu_cores'
303 - refresh-peer federation logs dump exceptions
304 - modpython logs have a timestamp
305 - more verbose/accurate php error reporting
306 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
307 - AddNode, UpdateNode: manage tags directly rather than through another method
308 - BootUpdateNode: only update once
309 - GetPersons: techs can access the list of persons on their site
310 - GetSlices and GetSliceTags: techs can see slices on their nodes
311 - GetSlivers: isrootonsite tag; cacheable
312
313 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
314 - rename initscript_body into initscript_code
315
316 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
317 - new initscript_body tag
318
319 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
320 - working draft for GetSliceSshKeys
321
322 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
323 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
324 - (this is for people who cancel their download)
325
326 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
327 - fix db-config sequence : accessors step now merged in, and occurs at the right time
328 - db-config also more robust
329 - no more explicit 'accessors' step in plc.d
330
331 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
332 - session auth: do *not* delete session when node runs a method that does not have 'node' role
333 - session auth: remove support for bootonce in old boot CDs
334 - give a reason when caller_may_write_slice_tag fails
335 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
336
337 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
338 - SetSliceVref needed the node role
339 - protect GetSliceFamily
340 - Fix bugs in tag authorizations
341
342 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
343 - altered checking of optional fields in Interfaces
344 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
345 - has pyxml and python-simplejson as new deps
346
347 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
348 - tweak doc extraction for fedora14
349
350 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
351 - builtin accessors for the myslice page
352 - Get{Node,Interface}Tags allowed to techs
353 - tweak in ratelimitaspect.py
354
355 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
356 - add admin role to accessor-related tags (arch, {fc,pl}distro)
357
358 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
359 - bugfix in {Update,Delete}PersonTag
360 - updated xml doc for filters, accessors and tagtypes
361 - more explicit msg in case of missing roles
362 - improvements in ratelimitaspects.py
363
364 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
365 - fix the roles for ssh_key and hmac tags
366
367 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
368 - tag permissions system based on roles and not min_role_ids
369 - accessors simplified accordingly (no more min_role_id)
370 - new methods AddRoleToTagType and DeleteRoleFromTagType
371 - accessor-related tagtypes are created sooner, and enforced
372 - cleaned up redundancy between db-config.d and accessors
373
374 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
375 - fix RefreshPeer that was not working in 5.0-17
376
377 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
378 - RefreshPeer is able to cope with 2 peers running different releases of the api
379 - DeletePerson can be used on duplicates
380 - first appearance of ModPythonJson.py
381
382 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
383 - set accessors return the new value
384 - tweaks in the pubsub groups management
385
386 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
387 - convert hostnames to lower case and use ILIKE instead of LIKE
388
389 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
390 - use hrn in pubsub groups
391
392 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
393 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
394 - OMF fixes
395
396 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
397 - automatically set vsys tag for omf controlled slices
398
399 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
400 - addition of the 'ssh_key' slice tag
401 - first draft of the LDAP interface
402
403 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
404 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
405 - and readable through GetLeaseGranularity
406 - GetSlivers to expose reservation_policy and lease_granularity
407 - GetBootMedium fixed for reservable nodes
408 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
409 - new Apache mod_wsgi python interface
410
411 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
412 - the leases system
413
414 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
415 - previous tag had gone wrong
416
417 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
418 - fix pubsub hostname
419
420 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
421 - tweaks for the omf support (xmpp groups and RC-controlled slices)
422 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
423 - GetNodeFlavour exposes fcdistro
424
425 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
426 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
427
428 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
429 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
430 - pyaspect hooks allow to  maintain the namespace xmpp groups
431 - new omf_slicemgr is a proxy to xmpp, used by these hooks
432 - nodes have their hrn exposed in the 'hrn' tag
433 - node hrn exposed in GetSlivers, as well as the overall xmpp config
434 - system slice 'drl' gets created by db-config
435 - daniel's changes to Filter for supporting wildcards in lists
436 - AddSliceTag consistency check tweaked
437
438 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
439 - major cleanup
440 - get rid of all 4.2-related legacy code
441 - reset the migrations code, planetlab5.sql somes with (5,100)
442 - uses hashlib module when available
443
444 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
445 - first working version of 5.0:
446 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
447 - nodefamily is 3-fold with pldistro-fcdistro-arch
448 - site and person tags
449 - new methods GetSliceFamily and GetNodeFlavour
450 - deprecated the dummynet stuff that were for the external dummyboxes
451 - tags definition : more consistency between db-config scripts and accessors
452 - (get accessor to create the tag type too if absent)
453 - logging an event for AddSliceToNodes
454
455 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
456 - support for fedora 12
457 - fix subtle bug in filtering with ] and quotes
458
459 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
460 - * patch for php-5.3 (the one in f12)
461 - * validate email addresses with regex
462 - * add PersonTags and SiteTags
463 - * add additional accessors for node tags (kvariant, serial, ..)
464
465 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
466 - Redacting password, session, and authstring values from the event log.
467
468 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
469 - let AddSite set ext_consortium_id - required for the poorman registration pages
470 - drop version constraint on Requires: postgresql-python
471 - don't log system calls nor ReportRunLevel
472
473 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
474 - Fix requires for CentOS.
475
476 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
477 - Require postgresql 8.2 (for array operators && and @>)
478
479 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
480 - Filter now supports the | and & features to match in sequence values
481 - bugfix in the postgresql wrapper for sequence filter values
482 - reviewed GetSlivers to export admin keys more efficiently
483 - fix checking roles in UpdateSliceTag
484
485 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
486 - - Some typos in the documentation were fixed.
487 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
488 - to the tag's min_role_id.
489
490 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
491
492 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
493 - Ongoing work to add upcalls, using new SFA class
494 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
495 - reviewed type-checking for the 3 taggable classes node-interface-slice
496 - cleanup ald dummynet stuff
497 - expose the 'extensions' accessors to the API
498 - tweaked checks in AddSliceTag
499 - GetPersons exposes roles by default
500 - bugfix in ReportRunLevel for non-string levels
501 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
502
503 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
504 - new BindObjectToPeer method for sfa
505 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
506
507 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
508 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
509 - reportrunlevel logs its calls only when run_level changes
510 - pycurl more robust wrt to xmlrpclib.Transport
511
512 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
513 - produce a wsdl interface
514 - bugfix in getbootmedium for nodes with interface tags
515
516 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
517 - bugfix for some rare pattern-based filters
518
519 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
520 - improvements in the 4.2 legacy layer
521
522 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
523 - bugfix required for slice tags set on nodegroups
524
525 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
526 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
527
528 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
529 - more powerful legacy layer with 4.2
530
531 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
532 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
533 - migration script has an option for running interactively
534
535 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
536 - skips already added entries
537
538 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
539 - yet another set of fixes for external dummynet boxes
540
541 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
542 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
543 - and tmp file is cleaned up
544
545 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
546 - restore missing ResolveSlices
547
548 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
549 - new method GetDummyBoxMedium
550
551 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
552 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
553
554 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
555 - support for external dummynet boxes back in 4.3 - first draft
556
557 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
558 - fixes for smooth federation between 4.2 and 4.3
559 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
560
561 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
562 - support for BootCD variants (GetBootMedium ['variant:centos5'])
563 - fix corner case with filters like {'~slice_id':[]}
564 - fix transaction leak that caused the db connections pool to exhaust
565 - properly expose all methods, including Legacy/, and not only Methods/
566
567 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
568 - renumbered as 4.3
569 - nodes have new fields run_level (in addition to boot_state) and verified
570 - tweaked migration from 4.2
571 - tuned rpm dependencies
572 - doc generation more explicit about errors like missing python modules
573 - removed obsolete method GetSlicesMD5
574
575 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
576 - unified all tags
577 - renamed interface settings into interface tags and slice attributes into slice tags
578 - nodes have a node_type
579 - various changes on the way to 4.3
580
581 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
582 - Checkpointing : this version still has interface settings and slice attributes
583
584 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
585 - first iteration with taggable nodes/interfaces/slices
586 - embryo for ilinks
587 - cleaned up boot states
588 - migration script moslty complete
589
590 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
591 - fixed doc build by locating locally installed DTDs at build-time
592
593 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
594 - no more doc packaged outside of myplc-docs - doc/ cleaned up
595 - enhancements in doc on filters 
596 - bootcd-aware GetBootMedium merged from onelab
597
598 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
599 - checkpoint while the new myplc-docs package is underway
600 - bugfix: GetSlivers & conf files
601 - doc: removed target files 
602
603 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
604 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
605 - the non-deleted fields were index, resulting in massivly slow queries.
606
607
608 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
609 - plcsh: better handling of options when running as a shell script
610 - getbootmedium exports compute_key
611 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
612
613 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
614 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
615 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
616
617 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
618 - refresh peer script to use a month-dependent logfile
619 - tracking the starting point for UniPi integration of the dummynet boxes
620
621 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
622 - plcsh adds its own path to sys.path
623 - fix so GetNodes can be called from a Node
624
625 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
626 - Initial build.
627
628 %define module_current_branch 4.3