Setting tag plcapi-5.3-3
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 Requires: SOAPpy
36 Requires: python-simplejson
37 # for the RebootNodeWithPCU method
38 Requires: pcucontrol >= 1.0-6
39 # for OMF integration
40 Requires: pyaspects >= 0.4
41 Requires: python-twisted-words
42 Requires: python-twisted-web
43 # ldap
44 Requires: python-ldap
45 # for memcache
46 Requires: memcached python-memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 # for building the wsdl interface we used to require PyXML
58 # but this has gone with f20 so turning this off for now
59 BuildRequires: php-devel python-simplejson
60 Obsoletes: php-xmlrpc
61 Provides: php-xmlrpc
62
63 # PostgreSQL and SOAPpy are necessary to run the API server, but not
64 # plcsh. Since the only supported method of running the server is via
65 # MyPLC anyway, don't be so stringent about binary requirements, in
66 # case people want to install this package just for plcsh.
67 # Requires: postgresql-server, SOAPpy
68 AutoReqProv: no
69
70 %description
71 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
72 PlanetLab Central (PLC) database. The API may be accessed directly via
73 the Python shell program plcsh, through a toy standalone server, or
74 through Apache mod_python.
75
76 %prep
77 %setup -q
78
79 %build
80 # python-pycurl and python-psycopg2 avail. from fedora 5
81 # we used to ship our own version of psycopg2 and pycurl, for fedora4
82 # starting with 4.3, support for these two modules is taken out
83
84 # Build __init__.py metafiles and PHP API. 
85 %{__make} %{?_smp_mflags}
86 %{__make} -C wsdl
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
91
92 # Install shell symlink
93 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
94 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
95
96 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
97 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
98 ; Enable xmlrpc extension module
99 extension=xmlrpc.so
100 EOF
101
102 # Install initscripts
103 echo "* Installing initscripts"
104 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
105 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
106
107 # Install db-config.d files
108 echo "* Installing db-config.d files"
109 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
111 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
112
113 # Install wsdl
114 echo "* Installing wsdl"
115 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
116
117 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
118 ## Install omf_slicemgr.py
119 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
120 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
121 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
122
123 # Install ratelimit log
124 mkdir -p $RPM_BUILD_ROOT/var/log
125 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
126 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %define php_extension_dir %(php-config --extension-dir)
132
133 %files
134 %defattr(-,root,root,-)
135 %dir %{_datadir}/plc_api
136 #%dir /var/log/omf/
137 %{_datadir}/plc_api/*
138 %{_bindir}/plcsh
139 %{php_extension_dir}/xmlrpc.so
140 %{_sysconfdir}/php.d/xmlrpc.ini
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 #/usr/bin/omf_slicemgr.py*
146 #/usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plc_api_ratelimit.log
148
149
150 %changelog
151 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
152 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
153
154 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
155 - don't use PyXML that is deprecated in f20, use lxml instead
156 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
157
158 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
159 - create accessor 'hrn' for site as well
160 - create accessors 'sfa_created' for site/slice/person
161 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
162 - UpdatePerson() updates Person HRN according to updated email.
163 - UpdateSite() updates Site HRN according to updated login_base.
164 - Fix AddPersonToSite().
165 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
166 - RefreshPeer() manages Site*Person and Person*Role relationships.
167
168 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
169 - provide a slicename_to_hrn function
170
171 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
172 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
173
174 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
175 - fix for wsgi-based deployments, each thread has its own api()
176
177 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
178 - also cleanup omf-slicemgr initscript
179
180 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
181 - tear down omf-related aspects as this is no longer needed with omfv6
182
183 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
184 - also expose 'expires' in ResolveSlices
185
186 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
187 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
188
189 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
190 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
191
192 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
193 - use SFA code for computing hrn's when available
194
195 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
196 - new slice tag 'interface' for configuring a virtual interface
197 - new builtin 030-interface_tags
198 - new node accessor and tag 'virt' for mixing lxc & vs nodes
199 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
200 - moved ModPypthon and plc.wsgi in the apache/ subdir
201 - renamed PLCAPI.spec into plcapi.spec
202 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
203 - support for php-5.4
204
205 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
206 - implement PLC_VSYS_DEFAULTS in AddSlice
207
208 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
209 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
210 - AddPerson and UpdatePerson are now tag-aware
211 - as a side-effect AddPerson is more picky and rejects invalid fields
212 - which results in a requirement to use sfa-2.1-22 with this tag
213 - marginal improvement on the xml doc on tags
214
215 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
216 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
217 - reset_xmpp_pubsub_nodes now hos options and usage
218 - new Accessors for vicci
219
220 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
221 - fixed imports for tags management with sites and persons
222 - add predefined 'cpu_freezable' tag
223
224 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
225 - tweaks in interface initialization
226 - has 'vsys_vnet' as a predefined tagtype
227 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
228 - bugfix: GetSlivers & nodegroups
229 - bugfix: in jabber groups management
230
231 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
232 - fix gpg-authentication for Persons (thanks Jordan)
233 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
234 - ip address/network check: v4 or v6
235 - customized DB Message survive upgrade
236 - make sync works in lxc-hosted tests
237 - no svn keywords anymore
238
239 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
240 - fix sorting for methods list in docs
241 - untested but needed tweak for postgres startup in f16
242
243 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
244 - tweaks in postgresql setup - in line with sfa
245
246 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
247 - slight tweaks in Persons.py
248
249 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
250 - GetSession has support for more than one day sessions
251 - reset_xmpp_pubsub_nodes is much more efficient
252 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
253 - bugfix - deleting a person in the middle of the signup process
254
255 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
256 - ratelimit aspects
257 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
258 - requires Django for cache_utils
259 - attempt to expose 'pldistro' to sfa
260 - last_time_spent_online, last_time_spent_offline: new fields in Node
261 - new slice tags 'isolate_loopback' and 'cpu_cores'
262 - refresh-peer federation logs dump exceptions
263 - modpython logs have a timestamp
264 - more verbose/accurate php error reporting
265 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
266 - AddNode, UpdateNode: manage tags directly rather than through another method
267 - BootUpdateNode: only update once
268 - GetPersons: techs can access the list of persons on their site
269 - GetSlices and GetSliceTags: techs can see slices on their nodes
270 - GetSlivers: isrootonsite tag; cacheable
271
272 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
273 - rename initscript_body into initscript_code
274
275 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
276 - new initscript_body tag
277
278 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
279 - working draft for GetSliceSshKeys
280
281 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
282 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
283 - (this is for people who cancel their download)
284
285 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
286 - fix db-config sequence : accessors step now merged in, and occurs at the right time
287 - db-config also more robust
288 - no more explicit 'accessors' step in plc.d
289
290 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
291 - session auth: do *not* delete session when node runs a method that does not have 'node' role
292 - session auth: remove support for bootonce in old boot CDs
293 - give a reason when caller_may_write_slice_tag fails
294 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
295
296 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
297 - SetSliceVref needed the node role
298 - protect GetSliceFamily
299 - Fix bugs in tag authorizations
300
301 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
302 - altered checking of optional fields in Interfaces
303 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
304 - has pyxml and python-simplejson as new deps
305
306 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
307 - tweak doc extraction for fedora14
308
309 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
310 - builtin accessors for the myslice page
311 - Get{Node,Interface}Tags allowed to techs
312 - tweak in ratelimitaspect.py
313
314 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
315 - add admin role to accessor-related tags (arch, {fc,pl}distro)
316
317 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
318 - bugfix in {Update,Delete}PersonTag
319 - updated xml doc for filters, accessors and tagtypes
320 - more explicit msg in case of missing roles
321 - improvements in ratelimitaspects.py
322
323 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
324 - fix the roles for ssh_key and hmac tags
325
326 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
327 - tag permissions system based on roles and not min_role_ids
328 - accessors simplified accordingly (no more min_role_id)
329 - new methods AddRoleToTagType and DeleteRoleFromTagType
330 - accessor-related tagtypes are created sooner, and enforced
331 - cleaned up redundancy between db-config.d and accessors
332
333 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
334 - fix RefreshPeer that was not working in 5.0-17
335
336 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
337 - RefreshPeer is able to cope with 2 peers running different releases of the api
338 - DeletePerson can be used on duplicates
339 - first appearance of ModPythonJson.py
340
341 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
342 - set accessors return the new value
343 - tweaks in the pubsub groups management
344
345 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
346 - convert hostnames to lower case and use ILIKE instead of LIKE
347
348 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
349 - use hrn in pubsub groups
350
351 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
352 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
353 - OMF fixes
354
355 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
356 - automatically set vsys tag for omf controlled slices
357
358 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
359 - addition of the 'ssh_key' slice tag
360 - first draft of the LDAP interface
361
362 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
363 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
364 - and readable through GetLeaseGranularity
365 - GetSlivers to expose reservation_policy and lease_granularity
366 - GetBootMedium fixed for reservable nodes
367 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
368 - new Apache mod_wsgi python interface
369
370 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
371 - the leases system
372
373 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
374 - previous tag had gone wrong
375
376 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
377 - fix pubsub hostname
378
379 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
380 - tweaks for the omf support (xmpp groups and RC-controlled slices)
381 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
382 - GetNodeFlavour exposes fcdistro
383
384 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
385 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
386
387 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
388 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
389 - pyaspect hooks allow to  maintain the namespace xmpp groups
390 - new omf_slicemgr is a proxy to xmpp, used by these hooks
391 - nodes have their hrn exposed in the 'hrn' tag
392 - node hrn exposed in GetSlivers, as well as the overall xmpp config
393 - system slice 'drl' gets created by db-config
394 - daniel's changes to Filter for supporting wildcards in lists
395 - AddSliceTag consistency check tweaked
396
397 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
398 - major cleanup
399 - get rid of all 4.2-related legacy code
400 - reset the migrations code, planetlab5.sql somes with (5,100)
401 - uses hashlib module when available
402
403 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
404 - first working version of 5.0:
405 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
406 - nodefamily is 3-fold with pldistro-fcdistro-arch
407 - site and person tags
408 - new methods GetSliceFamily and GetNodeFlavour
409 - deprecated the dummynet stuff that were for the external dummyboxes
410 - tags definition : more consistency between db-config scripts and accessors
411 - (get accessor to create the tag type too if absent)
412 - logging an event for AddSliceToNodes
413
414 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
415 - support for fedora 12
416 - fix subtle bug in filtering with ] and quotes
417
418 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
419 - * patch for php-5.3 (the one in f12)
420 - * validate email addresses with regex
421 - * add PersonTags and SiteTags
422 - * add additional accessors for node tags (kvariant, serial, ..)
423
424 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
425 - Redacting password, session, and authstring values from the event log.
426
427 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
428 - let AddSite set ext_consortium_id - required for the poorman registration pages
429 - drop version constraint on Requires: postgresql-python
430 - don't log system calls nor ReportRunLevel
431
432 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
433 - Fix requires for CentOS.
434
435 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
436 - Require postgresql 8.2 (for array operators && and @>)
437
438 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
439 - Filter now supports the | and & features to match in sequence values
440 - bugfix in the postgresql wrapper for sequence filter values
441 - reviewed GetSlivers to export admin keys more efficiently
442 - fix checking roles in UpdateSliceTag
443
444 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
445 - - Some typos in the documentation were fixed.
446 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
447 - to the tag's min_role_id.
448
449 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
450
451 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
452 - Ongoing work to add upcalls, using new SFA class
453 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
454 - reviewed type-checking for the 3 taggable classes node-interface-slice
455 - cleanup ald dummynet stuff
456 - expose the 'extensions' accessors to the API
457 - tweaked checks in AddSliceTag
458 - GetPersons exposes roles by default
459 - bugfix in ReportRunLevel for non-string levels
460 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
461
462 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
463 - new BindObjectToPeer method for sfa
464 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
465
466 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
467 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
468 - reportrunlevel logs its calls only when run_level changes
469 - pycurl more robust wrt to xmlrpclib.Transport
470
471 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
472 - produce a wsdl interface
473 - bugfix in getbootmedium for nodes with interface tags
474
475 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
476 - bugfix for some rare pattern-based filters
477
478 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
479 - improvements in the 4.2 legacy layer
480
481 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
482 - bugfix required for slice tags set on nodegroups
483
484 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
485 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
486
487 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
488 - more powerful legacy layer with 4.2
489
490 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
491 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
492 - migration script has an option for running interactively
493
494 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
495 - skips already added entries
496
497 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
498 - yet another set of fixes for external dummynet boxes
499
500 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
501 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
502 - and tmp file is cleaned up
503
504 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
505 - restore missing ResolveSlices
506
507 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
508 - new method GetDummyBoxMedium
509
510 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
511 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
512
513 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
514 - support for external dummynet boxes back in 4.3 - first draft
515
516 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
517 - fixes for smooth federation between 4.2 and 4.3
518 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
519
520 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
521 - support for BootCD variants (GetBootMedium ['variant:centos5'])
522 - fix corner case with filters like {'~slice_id':[]}
523 - fix transaction leak that caused the db connections pool to exhaust
524 - properly expose all methods, including Legacy/, and not only Methods/
525
526 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
527 - renumbered as 4.3
528 - nodes have new fields run_level (in addition to boot_state) and verified
529 - tweaked migration from 4.2
530 - tuned rpm dependencies
531 - doc generation more explicit about errors like missing python modules
532 - removed obsolete method GetSlicesMD5
533
534 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
535 - unified all tags
536 - renamed interface settings into interface tags and slice attributes into slice tags
537 - nodes have a node_type
538 - various changes on the way to 4.3
539
540 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
541 - Checkpointing : this version still has interface settings and slice attributes
542
543 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
544 - first iteration with taggable nodes/interfaces/slices
545 - embryo for ilinks
546 - cleaned up boot states
547 - migration script moslty complete
548
549 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
550 - fixed doc build by locating locally installed DTDs at build-time
551
552 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
553 - no more doc packaged outside of myplc-docs - doc/ cleaned up
554 - enhancements in doc on filters 
555 - bootcd-aware GetBootMedium merged from onelab
556
557 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
558 - checkpoint while the new myplc-docs package is underway
559 - bugfix: GetSlivers & conf files
560 - doc: removed target files 
561
562 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
563 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
564 - the non-deleted fields were index, resulting in massivly slow queries.
565
566
567 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
568 - plcsh: better handling of options when running as a shell script
569 - getbootmedium exports compute_key
570 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
571
572 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
573 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
574 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
575
576 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
577 - refresh peer script to use a month-dependent logfile
578 - tracking the starting point for UniPi integration of the dummynet boxes
579
580 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
581 - plcsh adds its own path to sys.path
582 - fix so GetNodes can be called from a Node
583
584 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
585 - Initial build.
586
587 %define module_current_branch 4.3