Setting tag plcapi-5.2-3
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 # Install ratelimit log
121 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143 /var/log/plc_api_ratelimit.log
144
145
146 %changelog
147 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
148 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
149
150 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
151 - use SFA code for computing hrn's when available
152
153 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
154 - new slice tag 'interface' for configuring a virtual interface
155 - new builtin 030-interface_tags
156 - new node accessor and tag 'virt' for mixing lxc & vs nodes
157 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
158 - moved ModPypthon and plc.wsgi in the apache/ subdir
159 - renamed PLCAPI.spec into plcapi.spec
160 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
161 - support for php-5.4
162
163 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
164 - implement PLC_VSYS_DEFAULTS in AddSlice
165
166 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
167 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
168 - AddPerson and UpdatePerson are now tag-aware
169 - as a side-effect AddPerson is more picky and rejects invalid fields
170 - which results in a requirement to use sfa-2.1-22 with this tag
171 - marginal improvement on the xml doc on tags
172
173 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
174 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
175 - reset_xmpp_pubsub_nodes now hos options and usage
176 - new Accessors for vicci
177
178 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
179 - fixed imports for tags management with sites and persons
180 - add predefined 'cpu_freezable' tag
181
182 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
183 - tweaks in interface initialization
184 - has 'vsys_vnet' as a predefined tagtype
185 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
186 - bugfix: GetSlivers & nodegroups
187 - bugfix: in jabber groups management
188
189 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
190 - fix gpg-authentication for Persons (thanks Jordan)
191 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
192 - ip address/network check: v4 or v6
193 - customized DB Message survive upgrade
194 - make sync works in lxc-hosted tests
195 - no svn keywords anymore
196
197 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
198 - fix sorting for methods list in docs
199 - untested but needed tweak for postgres startup in f16
200
201 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
202 - tweaks in postgresql setup - in line with sfa
203
204 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
205 - slight tweaks in Persons.py
206
207 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
208 - GetSession has support for more than one day sessions
209 - reset_xmpp_pubsub_nodes is much more efficient
210 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
211 - bugfix - deleting a person in the middle of the signup process
212
213 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
214 - ratelimit aspects
215 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
216 - requires Django for cache_utils
217 - attempt to expose 'pldistro' to sfa
218 - last_time_spent_online, last_time_spent_offline: new fields in Node
219 - new slice tags 'isolate_loopback' and 'cpu_cores'
220 - refresh-peer federation logs dump exceptions
221 - modpython logs have a timestamp
222 - more verbose/accurate php error reporting
223 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
224 - AddNode, UpdateNode: manage tags directly rather than through another method
225 - BootUpdateNode: only update once
226 - GetPersons: techs can access the list of persons on their site
227 - GetSlices and GetSliceTags: techs can see slices on their nodes
228 - GetSlivers: isrootonsite tag; cacheable
229
230 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
231 - rename initscript_body into initscript_code
232
233 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
234 - new initscript_body tag
235
236 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
237 - working draft for GetSliceSshKeys
238
239 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
240 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
241 - (this is for people who cancel their download)
242
243 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
244 - fix db-config sequence : accessors step now merged in, and occurs at the right time
245 - db-config also more robust
246 - no more explicit 'accessors' step in plc.d
247
248 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
249 - session auth: do *not* delete session when node runs a method that does not have 'node' role
250 - session auth: remove support for bootonce in old boot CDs
251 - give a reason when caller_may_write_slice_tag fails
252 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
253
254 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
255 - SetSliceVref needed the node role
256 - protect GetSliceFamily
257 - Fix bugs in tag authorizations
258
259 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
260 - altered checking of optional fields in Interfaces
261 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
262 - has pyxml and python-simplejson as new deps
263
264 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
265 - tweak doc extraction for fedora14
266
267 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
268 - builtin accessors for the myslice page
269 - Get{Node,Interface}Tags allowed to techs
270 - tweak in ratelimitaspect.py
271
272 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
273 - add admin role to accessor-related tags (arch, {fc,pl}distro)
274
275 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
276 - bugfix in {Update,Delete}PersonTag
277 - updated xml doc for filters, accessors and tagtypes
278 - more explicit msg in case of missing roles
279 - improvements in ratelimitaspects.py
280
281 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
282 - fix the roles for ssh_key and hmac tags
283
284 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
285 - tag permissions system based on roles and not min_role_ids
286 - accessors simplified accordingly (no more min_role_id)
287 - new methods AddRoleToTagType and DeleteRoleFromTagType
288 - accessor-related tagtypes are created sooner, and enforced
289 - cleaned up redundancy between db-config.d and accessors
290
291 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
292 - fix RefreshPeer that was not working in 5.0-17
293
294 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
295 - RefreshPeer is able to cope with 2 peers running different releases of the api
296 - DeletePerson can be used on duplicates
297 - first appearance of ModPythonJson.py
298
299 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
300 - set accessors return the new value
301 - tweaks in the pubsub groups management
302
303 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
304 - convert hostnames to lower case and use ILIKE instead of LIKE
305
306 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
307 - use hrn in pubsub groups
308
309 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
310 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
311 - - OMF fixes
312
313 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
314 - automatically set vsys tag for omf controlled slices
315
316 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
317 - addition of the 'ssh_key' slice tag
318 - first draft of the LDAP interface
319
320 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
321 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
322 - and readable through GetLeaseGranularity
323 - GetSlivers to expose reservation_policy and lease_granularity
324 - GetBootMedium fixed for reservable nodes
325 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
326 - new Apache mod_wsgi python interface
327
328 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
329 - the leases system
330
331 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
332 - previous tag had gone wrong
333
334 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
335 - fix pubsub hostname
336
337 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
338 - tweaks for the omf support (xmpp groups and RC-controlled slices)
339 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
340 - GetNodeFlavour exposes fcdistro
341
342 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
343 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
344
345 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
346 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
347 - pyaspect hooks allow to  maintain the namespace xmpp groups
348 - new omf_slicemgr is a proxy to xmpp, used by these hooks
349 - nodes have their hrn exposed in the 'hrn' tag
350 - node hrn exposed in GetSlivers, as well as the overall xmpp config
351 - system slice 'drl' gets created by db-config
352 - daniel's changes to Filter for supporting wildcards in lists
353 - AddSliceTag consistency check tweaked
354
355 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
356 - major cleanup
357 - get rid of all 4.2-related legacy code
358 - reset the migrations code, planetlab5.sql somes with (5,100)
359 - uses hashlib module when available
360
361 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
362 - first working version of 5.0:
363 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
364 - nodefamily is 3-fold with pldistro-fcdistro-arch
365 - site and person tags
366 - new methods GetSliceFamily and GetNodeFlavour
367 - deprecated the dummynet stuff that were for the external dummyboxes
368 - tags definition : more consistency between db-config scripts and accessors
369 - (get accessor to create the tag type too if absent)
370 - logging an event for AddSliceToNodes
371
372 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
373 - support for fedora 12
374 - fix subtle bug in filtering with ] and quotes
375
376 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
377 - * patch for php-5.3 (the one in f12)
378 - * validate email addresses with regex
379 - * add PersonTags and SiteTags
380 - * add additional accessors for node tags (kvariant, serial, ..)
381
382 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
383 - Redacting password, session, and authstring values from the event log.
384
385 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
386 - let AddSite set ext_consortium_id - required for the poorman registration pages
387 - drop version constraint on Requires: postgresql-python
388 - don't log system calls nor ReportRunLevel
389
390 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
391 - Fix requires for CentOS.
392
393 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
394 - Require postgresql 8.2 (for array operators && and @>)
395
396 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
397 - Filter now supports the | and & features to match in sequence values
398 - bugfix in the postgresql wrapper for sequence filter values
399 - reviewed GetSlivers to export admin keys more efficiently
400 - fix checking roles in UpdateSliceTag
401
402 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
403 - - Some typos in the documentation were fixed.
404 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
405 - to the tag's min_role_id.
406
407 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
408
409 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
410 - Ongoing work to add upcalls, using new SFA class
411 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
412 - reviewed type-checking for the 3 taggable classes node-interface-slice
413 - cleanup ald dummynet stuff
414 - expose the 'extensions' accessors to the API
415 - tweaked checks in AddSliceTag
416 - GetPersons exposes roles by default
417 - bugfix in ReportRunLevel for non-string levels
418 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
419
420 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
421 - new BindObjectToPeer method for sfa
422 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
423
424 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
425 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
426 - reportrunlevel logs its calls only when run_level changes
427 - pycurl more robust wrt to xmlrpclib.Transport
428
429 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
430 - produce a wsdl interface
431 - bugfix in getbootmedium for nodes with interface tags
432
433 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
434 - bugfix for some rare pattern-based filters
435
436 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
437 - improvements in the 4.2 legacy layer
438
439 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
440 - bugfix required for slice tags set on nodegroups
441
442 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
443 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
444
445 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
446 - more powerful legacy layer with 4.2
447
448 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
449 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
450 - migration script has an option for running interactively
451
452 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
453 - skips already added entries
454
455 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
456 - yet another set of fixes for external dummynet boxes
457
458 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
459 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
460 - and tmp file is cleaned up
461
462 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
463 - restore missing ResolveSlices
464
465 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
466 - new method GetDummyBoxMedium
467
468 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
469 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
470
471 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
472 - support for external dummynet boxes back in 4.3 - first draft
473
474 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
475 - fixes for smooth federation between 4.2 and 4.3
476 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
477
478 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
479 - support for BootCD variants (GetBootMedium ['variant:centos5'])
480 - fix corner case with filters like {'~slice_id':[]}
481 - fix transaction leak that caused the db connections pool to exhaust
482 - properly expose all methods, including Legacy/, and not only Methods/
483
484 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
485 - renumbered as 4.3
486 - nodes have new fields run_level (in addition to boot_state) and verified
487 - tweaked migration from 4.2
488 - tuned rpm dependencies
489 - doc generation more explicit about errors like missing python modules
490 - removed obsolete method GetSlicesMD5
491
492 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
493 - unified all tags
494 - renamed interface settings into interface tags and slice attributes into slice tags
495 - nodes have a node_type
496 - various changes on the way to 4.3
497
498 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
499 - Checkpointing : this version still has interface settings and slice attributes
500
501 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
502 - first iteration with taggable nodes/interfaces/slices
503 - embryo for ilinks
504 - cleaned up boot states
505 - migration script moslty complete
506
507 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
508 - fixed doc build by locating locally installed DTDs at build-time
509
510 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
511 - no more doc packaged outside of myplc-docs - doc/ cleaned up
512 - enhancements in doc on filters 
513 - bootcd-aware GetBootMedium merged from onelab
514
515 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
516 - checkpoint while the new myplc-docs package is underway
517 - bugfix: GetSlivers & conf files
518 - doc: removed target files 
519
520 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
521 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
522 - the non-deleted fields were index, resulting in massivly slow queries.
523
524
525 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
526 - plcsh: better handling of options when running as a shell script
527 - getbootmedium exports compute_key
528 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
529
530 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
531 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
532 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
533
534 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
535 - refresh peer script to use a month-dependent logfile
536 - tracking the starting point for UniPi integration of the dummynet boxes
537
538 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
539 - plcsh adds its own path to sys.path
540 - fix so GetNodes can be called from a Node
541
542 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
543 - Initial build.
544
545 %define module_current_branch 4.3