Setting tag plcapi-5.2-4
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 # Install ratelimit log
121 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143 /var/log/plc_api_ratelimit.log
144
145
146 %changelog
147 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
148 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
149
150 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
151 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
152
153 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
154 - use SFA code for computing hrn's when available
155
156 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
157 - new slice tag 'interface' for configuring a virtual interface
158 - new builtin 030-interface_tags
159 - new node accessor and tag 'virt' for mixing lxc & vs nodes
160 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
161 - moved ModPypthon and plc.wsgi in the apache/ subdir
162 - renamed PLCAPI.spec into plcapi.spec
163 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
164 - support for php-5.4
165
166 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
167 - implement PLC_VSYS_DEFAULTS in AddSlice
168
169 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
170 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
171 - AddPerson and UpdatePerson are now tag-aware
172 - as a side-effect AddPerson is more picky and rejects invalid fields
173 - which results in a requirement to use sfa-2.1-22 with this tag
174 - marginal improvement on the xml doc on tags
175
176 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
177 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
178 - reset_xmpp_pubsub_nodes now hos options and usage
179 - new Accessors for vicci
180
181 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
182 - fixed imports for tags management with sites and persons
183 - add predefined 'cpu_freezable' tag
184
185 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
186 - tweaks in interface initialization
187 - has 'vsys_vnet' as a predefined tagtype
188 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
189 - bugfix: GetSlivers & nodegroups
190 - bugfix: in jabber groups management
191
192 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
193 - fix gpg-authentication for Persons (thanks Jordan)
194 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
195 - ip address/network check: v4 or v6
196 - customized DB Message survive upgrade
197 - make sync works in lxc-hosted tests
198 - no svn keywords anymore
199
200 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
201 - fix sorting for methods list in docs
202 - untested but needed tweak for postgres startup in f16
203
204 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
205 - tweaks in postgresql setup - in line with sfa
206
207 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
208 - slight tweaks in Persons.py
209
210 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
211 - GetSession has support for more than one day sessions
212 - reset_xmpp_pubsub_nodes is much more efficient
213 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
214 - bugfix - deleting a person in the middle of the signup process
215
216 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
217 - ratelimit aspects
218 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
219 - requires Django for cache_utils
220 - attempt to expose 'pldistro' to sfa
221 - last_time_spent_online, last_time_spent_offline: new fields in Node
222 - new slice tags 'isolate_loopback' and 'cpu_cores'
223 - refresh-peer federation logs dump exceptions
224 - modpython logs have a timestamp
225 - more verbose/accurate php error reporting
226 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
227 - AddNode, UpdateNode: manage tags directly rather than through another method
228 - BootUpdateNode: only update once
229 - GetPersons: techs can access the list of persons on their site
230 - GetSlices and GetSliceTags: techs can see slices on their nodes
231 - GetSlivers: isrootonsite tag; cacheable
232
233 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
234 - rename initscript_body into initscript_code
235
236 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
237 - new initscript_body tag
238
239 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
240 - working draft for GetSliceSshKeys
241
242 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
243 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
244 - (this is for people who cancel their download)
245
246 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
247 - fix db-config sequence : accessors step now merged in, and occurs at the right time
248 - db-config also more robust
249 - no more explicit 'accessors' step in plc.d
250
251 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
252 - session auth: do *not* delete session when node runs a method that does not have 'node' role
253 - session auth: remove support for bootonce in old boot CDs
254 - give a reason when caller_may_write_slice_tag fails
255 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
256
257 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
258 - SetSliceVref needed the node role
259 - protect GetSliceFamily
260 - Fix bugs in tag authorizations
261
262 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
263 - altered checking of optional fields in Interfaces
264 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
265 - has pyxml and python-simplejson as new deps
266
267 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
268 - tweak doc extraction for fedora14
269
270 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
271 - builtin accessors for the myslice page
272 - Get{Node,Interface}Tags allowed to techs
273 - tweak in ratelimitaspect.py
274
275 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
276 - add admin role to accessor-related tags (arch, {fc,pl}distro)
277
278 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
279 - bugfix in {Update,Delete}PersonTag
280 - updated xml doc for filters, accessors and tagtypes
281 - more explicit msg in case of missing roles
282 - improvements in ratelimitaspects.py
283
284 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
285 - fix the roles for ssh_key and hmac tags
286
287 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
288 - tag permissions system based on roles and not min_role_ids
289 - accessors simplified accordingly (no more min_role_id)
290 - new methods AddRoleToTagType and DeleteRoleFromTagType
291 - accessor-related tagtypes are created sooner, and enforced
292 - cleaned up redundancy between db-config.d and accessors
293
294 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
295 - fix RefreshPeer that was not working in 5.0-17
296
297 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
298 - RefreshPeer is able to cope with 2 peers running different releases of the api
299 - DeletePerson can be used on duplicates
300 - first appearance of ModPythonJson.py
301
302 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
303 - set accessors return the new value
304 - tweaks in the pubsub groups management
305
306 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
307 - convert hostnames to lower case and use ILIKE instead of LIKE
308
309 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
310 - use hrn in pubsub groups
311
312 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
313 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
314 - - OMF fixes
315
316 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
317 - automatically set vsys tag for omf controlled slices
318
319 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
320 - addition of the 'ssh_key' slice tag
321 - first draft of the LDAP interface
322
323 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
324 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
325 - and readable through GetLeaseGranularity
326 - GetSlivers to expose reservation_policy and lease_granularity
327 - GetBootMedium fixed for reservable nodes
328 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
329 - new Apache mod_wsgi python interface
330
331 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
332 - the leases system
333
334 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
335 - previous tag had gone wrong
336
337 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
338 - fix pubsub hostname
339
340 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
341 - tweaks for the omf support (xmpp groups and RC-controlled slices)
342 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
343 - GetNodeFlavour exposes fcdistro
344
345 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
346 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
347
348 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
349 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
350 - pyaspect hooks allow to  maintain the namespace xmpp groups
351 - new omf_slicemgr is a proxy to xmpp, used by these hooks
352 - nodes have their hrn exposed in the 'hrn' tag
353 - node hrn exposed in GetSlivers, as well as the overall xmpp config
354 - system slice 'drl' gets created by db-config
355 - daniel's changes to Filter for supporting wildcards in lists
356 - AddSliceTag consistency check tweaked
357
358 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
359 - major cleanup
360 - get rid of all 4.2-related legacy code
361 - reset the migrations code, planetlab5.sql somes with (5,100)
362 - uses hashlib module when available
363
364 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
365 - first working version of 5.0:
366 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
367 - nodefamily is 3-fold with pldistro-fcdistro-arch
368 - site and person tags
369 - new methods GetSliceFamily and GetNodeFlavour
370 - deprecated the dummynet stuff that were for the external dummyboxes
371 - tags definition : more consistency between db-config scripts and accessors
372 - (get accessor to create the tag type too if absent)
373 - logging an event for AddSliceToNodes
374
375 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
376 - support for fedora 12
377 - fix subtle bug in filtering with ] and quotes
378
379 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
380 - * patch for php-5.3 (the one in f12)
381 - * validate email addresses with regex
382 - * add PersonTags and SiteTags
383 - * add additional accessors for node tags (kvariant, serial, ..)
384
385 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
386 - Redacting password, session, and authstring values from the event log.
387
388 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
389 - let AddSite set ext_consortium_id - required for the poorman registration pages
390 - drop version constraint on Requires: postgresql-python
391 - don't log system calls nor ReportRunLevel
392
393 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
394 - Fix requires for CentOS.
395
396 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
397 - Require postgresql 8.2 (for array operators && and @>)
398
399 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
400 - Filter now supports the | and & features to match in sequence values
401 - bugfix in the postgresql wrapper for sequence filter values
402 - reviewed GetSlivers to export admin keys more efficiently
403 - fix checking roles in UpdateSliceTag
404
405 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
406 - - Some typos in the documentation were fixed.
407 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
408 - to the tag's min_role_id.
409
410 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
411
412 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
413 - Ongoing work to add upcalls, using new SFA class
414 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
415 - reviewed type-checking for the 3 taggable classes node-interface-slice
416 - cleanup ald dummynet stuff
417 - expose the 'extensions' accessors to the API
418 - tweaked checks in AddSliceTag
419 - GetPersons exposes roles by default
420 - bugfix in ReportRunLevel for non-string levels
421 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
422
423 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
424 - new BindObjectToPeer method for sfa
425 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
426
427 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
428 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
429 - reportrunlevel logs its calls only when run_level changes
430 - pycurl more robust wrt to xmlrpclib.Transport
431
432 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
433 - produce a wsdl interface
434 - bugfix in getbootmedium for nodes with interface tags
435
436 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
437 - bugfix for some rare pattern-based filters
438
439 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
440 - improvements in the 4.2 legacy layer
441
442 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
443 - bugfix required for slice tags set on nodegroups
444
445 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
446 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
447
448 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
449 - more powerful legacy layer with 4.2
450
451 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
452 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
453 - migration script has an option for running interactively
454
455 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
456 - skips already added entries
457
458 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
459 - yet another set of fixes for external dummynet boxes
460
461 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
462 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
463 - and tmp file is cleaned up
464
465 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
466 - restore missing ResolveSlices
467
468 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
469 - new method GetDummyBoxMedium
470
471 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
472 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
473
474 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
475 - support for external dummynet boxes back in 4.3 - first draft
476
477 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
478 - fixes for smooth federation between 4.2 and 4.3
479 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
480
481 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
482 - support for BootCD variants (GetBootMedium ['variant:centos5'])
483 - fix corner case with filters like {'~slice_id':[]}
484 - fix transaction leak that caused the db connections pool to exhaust
485 - properly expose all methods, including Legacy/, and not only Methods/
486
487 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
488 - renumbered as 4.3
489 - nodes have new fields run_level (in addition to boot_state) and verified
490 - tweaked migration from 4.2
491 - tuned rpm dependencies
492 - doc generation more explicit about errors like missing python modules
493 - removed obsolete method GetSlicesMD5
494
495 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
496 - unified all tags
497 - renamed interface settings into interface tags and slice attributes into slice tags
498 - nodes have a node_type
499 - various changes on the way to 4.3
500
501 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
502 - Checkpointing : this version still has interface settings and slice attributes
503
504 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
505 - first iteration with taggable nodes/interfaces/slices
506 - embryo for ilinks
507 - cleaned up boot states
508 - migration script moslty complete
509
510 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
511 - fixed doc build by locating locally installed DTDs at build-time
512
513 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
514 - no more doc packaged outside of myplc-docs - doc/ cleaned up
515 - enhancements in doc on filters 
516 - bootcd-aware GetBootMedium merged from onelab
517
518 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
519 - checkpoint while the new myplc-docs package is underway
520 - bugfix: GetSlivers & conf files
521 - doc: removed target files 
522
523 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
524 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
525 - the non-deleted fields were index, resulting in massivly slow queries.
526
527
528 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
529 - plcsh: better handling of options when running as a shell script
530 - getbootmedium exports compute_key
531 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
532
533 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
534 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
535 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
536
537 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
538 - refresh peer script to use a month-dependent logfile
539 - tracking the starting point for UniPi integration of the dummynet boxes
540
541 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
542 - plcsh adds its own path to sys.path
543 - fix so GetNodes can be called from a Node
544
545 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
546 - Initial build.
547
548 %define module_current_branch 4.3