provide PLCAPI
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.1
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 # Install ratelimit log
121 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143 /var/log/plc_api_ratelimit.log
144
145
146 %changelog
147 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
148 - implement PLC_VSYS_DEFAULTS in AddSlice
149
150 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
151 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
152 - AddPerson and UpdatePerson are now tag-aware
153 - as a side-effect AddPerson is more picky and rejects invalid fields
154 - which results in a requirement to use sfa-2.1-22 with this tag
155 - marginal improvement on the xml doc on tags
156
157 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
158 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
159 - reset_xmpp_pubsub_nodes now hos options and usage
160 - new Accessors for vicci
161
162 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
163 - fixed imports for tags management with sites and persons
164 - add predefined 'cpu_freezable' tag
165
166 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
167 - tweaks in interface initialization
168 - has 'vsys_vnet' as a predefined tagtype
169 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
170 - bugfix: GetSlivers & nodegroups
171 - bugfix: in jabber groups management
172
173 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
174 - fix gpg-authentication for Persons (thanks Jordan)
175 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
176 - ip address/network check: v4 or v6
177 - customized DB Message survive upgrade
178 - make sync works in lxc-hosted tests
179 - no svn keywords anymore
180
181 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
182 - fix sorting for methods list in docs
183 - untested but needed tweak for postgres startup in f16
184
185 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
186 - tweaks in postgresql setup - in line with sfa
187
188 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
189 - slight tweaks in Persons.py
190
191 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
192 - GetSession has support for more than one day sessions
193 - reset_xmpp_pubsub_nodes is much more efficient
194 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
195 - bugfix - deleting a person in the middle of the signup process
196
197 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
198 - ratelimit aspects
199 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
200 - requires Django for cache_utils
201 - attempt to expose 'pldistro' to sfa
202 - last_time_spent_online, last_time_spent_offline: new fields in Node
203 - new slice tags 'isolate_loopback' and 'cpu_cores'
204 - refresh-peer federation logs dump exceptions
205 - modpython logs have a timestamp
206 - more verbose/accurate php error reporting
207 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
208 - AddNode, UpdateNode: manage tags directly rather than through another method
209 - BootUpdateNode: only update once
210 - GetPersons: techs can access the list of persons on their site
211 - GetSlices and GetSliceTags: techs can see slices on their nodes
212 - GetSlivers: isrootonsite tag; cacheable
213
214 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
215 - rename initscript_body into initscript_code
216
217 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
218 - new initscript_body tag
219
220 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
221 - working draft for GetSliceSshKeys
222
223 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
224 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
225 - (this is for people who cancel their download)
226
227 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
228 - fix db-config sequence : accessors step now merged in, and occurs at the right time
229 - db-config also more robust
230 - no more explicit 'accessors' step in plc.d
231
232 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
233 - session auth: do *not* delete session when node runs a method that does not have 'node' role
234 - session auth: remove support for bootonce in old boot CDs
235 - give a reason when caller_may_write_slice_tag fails
236 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
237
238 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
239 - SetSliceVref needed the node role
240 - protect GetSliceFamily
241 - Fix bugs in tag authorizations
242
243 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
244 - altered checking of optional fields in Interfaces
245 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
246 - has pyxml and python-simplejson as new deps
247
248 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
249 - tweak doc extraction for fedora14
250
251 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
252 - builtin accessors for the myslice page
253 - Get{Node,Interface}Tags allowed to techs
254 - tweak in ratelimitaspect.py
255
256 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
257 - add admin role to accessor-related tags (arch, {fc,pl}distro)
258
259 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
260 - bugfix in {Update,Delete}PersonTag
261 - updated xml doc for filters, accessors and tagtypes
262 - more explicit msg in case of missing roles
263 - improvements in ratelimitaspects.py
264
265 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
266 - fix the roles for ssh_key and hmac tags
267
268 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
269 - tag permissions system based on roles and not min_role_ids
270 - accessors simplified accordingly (no more min_role_id)
271 - new methods AddRoleToTagType and DeleteRoleFromTagType
272 - accessor-related tagtypes are created sooner, and enforced
273 - cleaned up redundancy between db-config.d and accessors
274
275 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
276 - fix RefreshPeer that was not working in 5.0-17
277
278 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
279 - RefreshPeer is able to cope with 2 peers running different releases of the api
280 - DeletePerson can be used on duplicates
281 - first appearance of ModPythonJson.py
282
283 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
284 - set accessors return the new value
285 - tweaks in the pubsub groups management
286
287 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
288 - convert hostnames to lower case and use ILIKE instead of LIKE
289
290 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
291 - use hrn in pubsub groups
292
293 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
294 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
295 - - OMF fixes
296
297 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
298 - automatically set vsys tag for omf controlled slices
299
300 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
301 - addition of the 'ssh_key' slice tag
302 - first draft of the LDAP interface
303
304 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
305 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
306 - and readable through GetLeaseGranularity
307 - GetSlivers to expose reservation_policy and lease_granularity
308 - GetBootMedium fixed for reservable nodes
309 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
310 - new Apache mod_wsgi python interface
311
312 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
313 - the leases system
314
315 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
316 - previous tag had gone wrong
317
318 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
319 - fix pubsub hostname
320
321 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
322 - tweaks for the omf support (xmpp groups and RC-controlled slices)
323 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
324 - GetNodeFlavour exposes fcdistro
325
326 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
327 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
328
329 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
330 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
331 - pyaspect hooks allow to  maintain the namespace xmpp groups
332 - new omf_slicemgr is a proxy to xmpp, used by these hooks
333 - nodes have their hrn exposed in the 'hrn' tag
334 - node hrn exposed in GetSlivers, as well as the overall xmpp config
335 - system slice 'drl' gets created by db-config
336 - daniel's changes to Filter for supporting wildcards in lists
337 - AddSliceTag consistency check tweaked
338
339 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
340 - major cleanup
341 - get rid of all 4.2-related legacy code
342 - reset the migrations code, planetlab5.sql somes with (5,100)
343 - uses hashlib module when available
344
345 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
346 - first working version of 5.0:
347 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
348 - nodefamily is 3-fold with pldistro-fcdistro-arch
349 - site and person tags
350 - new methods GetSliceFamily and GetNodeFlavour
351 - deprecated the dummynet stuff that were for the external dummyboxes
352 - tags definition : more consistency between db-config scripts and accessors
353 - (get accessor to create the tag type too if absent)
354 - logging an event for AddSliceToNodes
355
356 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
357 - support for fedora 12
358 - fix subtle bug in filtering with ] and quotes
359
360 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
361 - * patch for php-5.3 (the one in f12)
362 - * validate email addresses with regex
363 - * add PersonTags and SiteTags
364 - * add additional accessors for node tags (kvariant, serial, ..)
365
366 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
367 - Redacting password, session, and authstring values from the event log.
368
369 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
370 - let AddSite set ext_consortium_id - required for the poorman registration pages
371 - drop version constraint on Requires: postgresql-python
372 - don't log system calls nor ReportRunLevel
373
374 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
375 - Fix requires for CentOS.
376
377 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
378 - Require postgresql 8.2 (for array operators && and @>)
379
380 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
381 - Filter now supports the | and & features to match in sequence values
382 - bugfix in the postgresql wrapper for sequence filter values
383 - reviewed GetSlivers to export admin keys more efficiently
384 - fix checking roles in UpdateSliceTag
385
386 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
387 - - Some typos in the documentation were fixed.
388 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
389 - to the tag's min_role_id.
390
391 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
392
393 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
394 - Ongoing work to add upcalls, using new SFA class
395 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
396 - reviewed type-checking for the 3 taggable classes node-interface-slice
397 - cleanup ald dummynet stuff
398 - expose the 'extensions' accessors to the API
399 - tweaked checks in AddSliceTag
400 - GetPersons exposes roles by default
401 - bugfix in ReportRunLevel for non-string levels
402 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
403
404 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
405 - new BindObjectToPeer method for sfa
406 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
407
408 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
409 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
410 - reportrunlevel logs its calls only when run_level changes
411 - pycurl more robust wrt to xmlrpclib.Transport
412
413 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
414 - produce a wsdl interface
415 - bugfix in getbootmedium for nodes with interface tags
416
417 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
418 - bugfix for some rare pattern-based filters
419
420 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
421 - improvements in the 4.2 legacy layer
422
423 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
424 - bugfix required for slice tags set on nodegroups
425
426 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
427 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
428
429 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
430 - more powerful legacy layer with 4.2
431
432 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
433 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
434 - migration script has an option for running interactively
435
436 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
437 - skips already added entries
438
439 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
440 - yet another set of fixes for external dummynet boxes
441
442 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
443 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
444 - and tmp file is cleaned up
445
446 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
447 - restore missing ResolveSlices
448
449 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
450 - new method GetDummyBoxMedium
451
452 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
453 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
454
455 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
456 - support for external dummynet boxes back in 4.3 - first draft
457
458 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
459 - fixes for smooth federation between 4.2 and 4.3
460 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
461
462 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
463 - support for BootCD variants (GetBootMedium ['variant:centos5'])
464 - fix corner case with filters like {'~slice_id':[]}
465 - fix transaction leak that caused the db connections pool to exhaust
466 - properly expose all methods, including Legacy/, and not only Methods/
467
468 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
469 - renumbered as 4.3
470 - nodes have new fields run_level (in addition to boot_state) and verified
471 - tweaked migration from 4.2
472 - tuned rpm dependencies
473 - doc generation more explicit about errors like missing python modules
474 - removed obsolete method GetSlicesMD5
475
476 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
477 - unified all tags
478 - renamed interface settings into interface tags and slice attributes into slice tags
479 - nodes have a node_type
480 - various changes on the way to 4.3
481
482 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
483 - Checkpointing : this version still has interface settings and slice attributes
484
485 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
486 - first iteration with taggable nodes/interfaces/slices
487 - embryo for ilinks
488 - cleaned up boot states
489 - migration script moslty complete
490
491 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
492 - fixed doc build by locating locally installed DTDs at build-time
493
494 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
495 - no more doc packaged outside of myplc-docs - doc/ cleaned up
496 - enhancements in doc on filters 
497 - bootcd-aware GetBootMedium merged from onelab
498
499 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
500 - checkpoint while the new myplc-docs package is underway
501 - bugfix: GetSlivers & conf files
502 - doc: removed target files 
503
504 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
505 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
506 - the non-deleted fields were index, resulting in massivly slow queries.
507
508
509 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
510 - plcsh: better handling of options when running as a shell script
511 - getbootmedium exports compute_key
512 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
513
514 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
515 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
516 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
517
518 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
519 - refresh peer script to use a month-dependent logfile
520 - tracking the starting point for UniPi integration of the dummynet boxes
521
522 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
523 - plcsh adds its own path to sys.path
524 - fix so GetNodes can be called from a Node
525
526 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
527 - Initial build.
528
529 %define module_current_branch 4.3