Setting tag plcapi-5.2-5
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 # Install ratelimit log
121 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143 /var/log/plc_api_ratelimit.log
144
145
146 %changelog
147 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
148 - also expose 'expires' in ResolveSlices
149
150 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
151 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
152
153 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
154 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
155
156 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
157 - use SFA code for computing hrn's when available
158
159 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
160 - new slice tag 'interface' for configuring a virtual interface
161 - new builtin 030-interface_tags
162 - new node accessor and tag 'virt' for mixing lxc & vs nodes
163 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
164 - moved ModPypthon and plc.wsgi in the apache/ subdir
165 - renamed PLCAPI.spec into plcapi.spec
166 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
167 - support for php-5.4
168
169 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
170 - implement PLC_VSYS_DEFAULTS in AddSlice
171
172 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
173 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
174 - AddPerson and UpdatePerson are now tag-aware
175 - as a side-effect AddPerson is more picky and rejects invalid fields
176 - which results in a requirement to use sfa-2.1-22 with this tag
177 - marginal improvement on the xml doc on tags
178
179 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
180 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
181 - reset_xmpp_pubsub_nodes now hos options and usage
182 - new Accessors for vicci
183
184 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
185 - fixed imports for tags management with sites and persons
186 - add predefined 'cpu_freezable' tag
187
188 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
189 - tweaks in interface initialization
190 - has 'vsys_vnet' as a predefined tagtype
191 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
192 - bugfix: GetSlivers & nodegroups
193 - bugfix: in jabber groups management
194
195 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
196 - fix gpg-authentication for Persons (thanks Jordan)
197 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
198 - ip address/network check: v4 or v6
199 - customized DB Message survive upgrade
200 - make sync works in lxc-hosted tests
201 - no svn keywords anymore
202
203 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
204 - fix sorting for methods list in docs
205 - untested but needed tweak for postgres startup in f16
206
207 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
208 - tweaks in postgresql setup - in line with sfa
209
210 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
211 - slight tweaks in Persons.py
212
213 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
214 - GetSession has support for more than one day sessions
215 - reset_xmpp_pubsub_nodes is much more efficient
216 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
217 - bugfix - deleting a person in the middle of the signup process
218
219 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
220 - ratelimit aspects
221 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
222 - requires Django for cache_utils
223 - attempt to expose 'pldistro' to sfa
224 - last_time_spent_online, last_time_spent_offline: new fields in Node
225 - new slice tags 'isolate_loopback' and 'cpu_cores'
226 - refresh-peer federation logs dump exceptions
227 - modpython logs have a timestamp
228 - more verbose/accurate php error reporting
229 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
230 - AddNode, UpdateNode: manage tags directly rather than through another method
231 - BootUpdateNode: only update once
232 - GetPersons: techs can access the list of persons on their site
233 - GetSlices and GetSliceTags: techs can see slices on their nodes
234 - GetSlivers: isrootonsite tag; cacheable
235
236 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
237 - rename initscript_body into initscript_code
238
239 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
240 - new initscript_body tag
241
242 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
243 - working draft for GetSliceSshKeys
244
245 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
246 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
247 - (this is for people who cancel their download)
248
249 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
250 - fix db-config sequence : accessors step now merged in, and occurs at the right time
251 - db-config also more robust
252 - no more explicit 'accessors' step in plc.d
253
254 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
255 - session auth: do *not* delete session when node runs a method that does not have 'node' role
256 - session auth: remove support for bootonce in old boot CDs
257 - give a reason when caller_may_write_slice_tag fails
258 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
259
260 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
261 - SetSliceVref needed the node role
262 - protect GetSliceFamily
263 - Fix bugs in tag authorizations
264
265 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
266 - altered checking of optional fields in Interfaces
267 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
268 - has pyxml and python-simplejson as new deps
269
270 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
271 - tweak doc extraction for fedora14
272
273 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
274 - builtin accessors for the myslice page
275 - Get{Node,Interface}Tags allowed to techs
276 - tweak in ratelimitaspect.py
277
278 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
279 - add admin role to accessor-related tags (arch, {fc,pl}distro)
280
281 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
282 - bugfix in {Update,Delete}PersonTag
283 - updated xml doc for filters, accessors and tagtypes
284 - more explicit msg in case of missing roles
285 - improvements in ratelimitaspects.py
286
287 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
288 - fix the roles for ssh_key and hmac tags
289
290 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
291 - tag permissions system based on roles and not min_role_ids
292 - accessors simplified accordingly (no more min_role_id)
293 - new methods AddRoleToTagType and DeleteRoleFromTagType
294 - accessor-related tagtypes are created sooner, and enforced
295 - cleaned up redundancy between db-config.d and accessors
296
297 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
298 - fix RefreshPeer that was not working in 5.0-17
299
300 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
301 - RefreshPeer is able to cope with 2 peers running different releases of the api
302 - DeletePerson can be used on duplicates
303 - first appearance of ModPythonJson.py
304
305 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
306 - set accessors return the new value
307 - tweaks in the pubsub groups management
308
309 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
310 - convert hostnames to lower case and use ILIKE instead of LIKE
311
312 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
313 - use hrn in pubsub groups
314
315 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
316 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
317 - - OMF fixes
318
319 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
320 - automatically set vsys tag for omf controlled slices
321
322 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
323 - addition of the 'ssh_key' slice tag
324 - first draft of the LDAP interface
325
326 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
327 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
328 - and readable through GetLeaseGranularity
329 - GetSlivers to expose reservation_policy and lease_granularity
330 - GetBootMedium fixed for reservable nodes
331 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
332 - new Apache mod_wsgi python interface
333
334 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
335 - the leases system
336
337 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
338 - previous tag had gone wrong
339
340 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
341 - fix pubsub hostname
342
343 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
344 - tweaks for the omf support (xmpp groups and RC-controlled slices)
345 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
346 - GetNodeFlavour exposes fcdistro
347
348 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
349 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
350
351 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
352 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
353 - pyaspect hooks allow to  maintain the namespace xmpp groups
354 - new omf_slicemgr is a proxy to xmpp, used by these hooks
355 - nodes have their hrn exposed in the 'hrn' tag
356 - node hrn exposed in GetSlivers, as well as the overall xmpp config
357 - system slice 'drl' gets created by db-config
358 - daniel's changes to Filter for supporting wildcards in lists
359 - AddSliceTag consistency check tweaked
360
361 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
362 - major cleanup
363 - get rid of all 4.2-related legacy code
364 - reset the migrations code, planetlab5.sql somes with (5,100)
365 - uses hashlib module when available
366
367 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
368 - first working version of 5.0:
369 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
370 - nodefamily is 3-fold with pldistro-fcdistro-arch
371 - site and person tags
372 - new methods GetSliceFamily and GetNodeFlavour
373 - deprecated the dummynet stuff that were for the external dummyboxes
374 - tags definition : more consistency between db-config scripts and accessors
375 - (get accessor to create the tag type too if absent)
376 - logging an event for AddSliceToNodes
377
378 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
379 - support for fedora 12
380 - fix subtle bug in filtering with ] and quotes
381
382 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
383 - * patch for php-5.3 (the one in f12)
384 - * validate email addresses with regex
385 - * add PersonTags and SiteTags
386 - * add additional accessors for node tags (kvariant, serial, ..)
387
388 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
389 - Redacting password, session, and authstring values from the event log.
390
391 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
392 - let AddSite set ext_consortium_id - required for the poorman registration pages
393 - drop version constraint on Requires: postgresql-python
394 - don't log system calls nor ReportRunLevel
395
396 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
397 - Fix requires for CentOS.
398
399 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
400 - Require postgresql 8.2 (for array operators && and @>)
401
402 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
403 - Filter now supports the | and & features to match in sequence values
404 - bugfix in the postgresql wrapper for sequence filter values
405 - reviewed GetSlivers to export admin keys more efficiently
406 - fix checking roles in UpdateSliceTag
407
408 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
409 - - Some typos in the documentation were fixed.
410 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
411 - to the tag's min_role_id.
412
413 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
414
415 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
416 - Ongoing work to add upcalls, using new SFA class
417 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
418 - reviewed type-checking for the 3 taggable classes node-interface-slice
419 - cleanup ald dummynet stuff
420 - expose the 'extensions' accessors to the API
421 - tweaked checks in AddSliceTag
422 - GetPersons exposes roles by default
423 - bugfix in ReportRunLevel for non-string levels
424 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
425
426 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
427 - new BindObjectToPeer method for sfa
428 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
429
430 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
431 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
432 - reportrunlevel logs its calls only when run_level changes
433 - pycurl more robust wrt to xmlrpclib.Transport
434
435 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
436 - produce a wsdl interface
437 - bugfix in getbootmedium for nodes with interface tags
438
439 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
440 - bugfix for some rare pattern-based filters
441
442 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
443 - improvements in the 4.2 legacy layer
444
445 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
446 - bugfix required for slice tags set on nodegroups
447
448 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
449 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
450
451 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
452 - more powerful legacy layer with 4.2
453
454 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
455 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
456 - migration script has an option for running interactively
457
458 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
459 - skips already added entries
460
461 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
462 - yet another set of fixes for external dummynet boxes
463
464 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
465 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
466 - and tmp file is cleaned up
467
468 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
469 - restore missing ResolveSlices
470
471 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
472 - new method GetDummyBoxMedium
473
474 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
475 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
476
477 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
478 - support for external dummynet boxes back in 4.3 - first draft
479
480 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
481 - fixes for smooth federation between 4.2 and 4.3
482 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
483
484 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
485 - support for BootCD variants (GetBootMedium ['variant:centos5'])
486 - fix corner case with filters like {'~slice_id':[]}
487 - fix transaction leak that caused the db connections pool to exhaust
488 - properly expose all methods, including Legacy/, and not only Methods/
489
490 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
491 - renumbered as 4.3
492 - nodes have new fields run_level (in addition to boot_state) and verified
493 - tweaked migration from 4.2
494 - tuned rpm dependencies
495 - doc generation more explicit about errors like missing python modules
496 - removed obsolete method GetSlicesMD5
497
498 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
499 - unified all tags
500 - renamed interface settings into interface tags and slice attributes into slice tags
501 - nodes have a node_type
502 - various changes on the way to 4.3
503
504 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
505 - Checkpointing : this version still has interface settings and slice attributes
506
507 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
508 - first iteration with taggable nodes/interfaces/slices
509 - embryo for ilinks
510 - cleaned up boot states
511 - migration script moslty complete
512
513 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
514 - fixed doc build by locating locally installed DTDs at build-time
515
516 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
517 - no more doc packaged outside of myplc-docs - doc/ cleaned up
518 - enhancements in doc on filters 
519 - bootcd-aware GetBootMedium merged from onelab
520
521 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
522 - checkpoint while the new myplc-docs package is underway
523 - bugfix: GetSlivers & conf files
524 - doc: removed target files 
525
526 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
527 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
528 - the non-deleted fields were index, resulting in massivly slow queries.
529
530
531 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
532 - plcsh: better handling of options when running as a shell script
533 - getbootmedium exports compute_key
534 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
535
536 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
537 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
538 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
539
540 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
541 - refresh peer script to use a month-dependent logfile
542 - tracking the starting point for UniPi integration of the dummynet boxes
543
544 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
545 - plcsh adds its own path to sys.path
546 - fix so GetNodes can be called from a Node
547
548 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
549 - Initial build.
550
551 %define module_current_branch 4.3