bump version number to 5.3
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 mkdir -p $RPM_BUILD_ROOT/var/log
123 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %define php_extension_dir %(php-config --extension-dir)
130
131 %files
132 %defattr(-,root,root,-)
133 %dir %{_datadir}/plc_api
134 #%dir /var/log/omf/
135 %{_datadir}/plc_api/*
136 %{_bindir}/plcsh
137 %{php_extension_dir}/xmlrpc.so
138 %{_sysconfdir}/php.d/xmlrpc.ini
139 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
140 /etc/plc.d
141 /etc/planetlab/db-config.d
142 /var/www/html/wsdl/plcapi.wsdl
143 #/usr/bin/omf_slicemgr.py*
144 #/usr/bin/reset_xmpp_pubsub_nodes.py*
145 /var/log/plc_api_ratelimit.log
146
147
148 %changelog
149 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
150 - provide a slicename_to_hrn function
151
152 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
153 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
154
155 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
156 - fix for wsgi-based deployments, each thread has its own api()
157
158 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
159 - also cleanup omf-slicemgr initscript
160
161 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
162 - tear down omf-related aspects as this is no longer needed with omfv6
163
164 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
165 - also expose 'expires' in ResolveSlices
166
167 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
168 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
169
170 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
171 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
172
173 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
174 - use SFA code for computing hrn's when available
175
176 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
177 - new slice tag 'interface' for configuring a virtual interface
178 - new builtin 030-interface_tags
179 - new node accessor and tag 'virt' for mixing lxc & vs nodes
180 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
181 - moved ModPypthon and plc.wsgi in the apache/ subdir
182 - renamed PLCAPI.spec into plcapi.spec
183 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
184 - support for php-5.4
185
186 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
187 - implement PLC_VSYS_DEFAULTS in AddSlice
188
189 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
190 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
191 - AddPerson and UpdatePerson are now tag-aware
192 - as a side-effect AddPerson is more picky and rejects invalid fields
193 - which results in a requirement to use sfa-2.1-22 with this tag
194 - marginal improvement on the xml doc on tags
195
196 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
197 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
198 - reset_xmpp_pubsub_nodes now hos options and usage
199 - new Accessors for vicci
200
201 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
202 - fixed imports for tags management with sites and persons
203 - add predefined 'cpu_freezable' tag
204
205 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
206 - tweaks in interface initialization
207 - has 'vsys_vnet' as a predefined tagtype
208 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
209 - bugfix: GetSlivers & nodegroups
210 - bugfix: in jabber groups management
211
212 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
213 - fix gpg-authentication for Persons (thanks Jordan)
214 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
215 - ip address/network check: v4 or v6
216 - customized DB Message survive upgrade
217 - make sync works in lxc-hosted tests
218 - no svn keywords anymore
219
220 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
221 - fix sorting for methods list in docs
222 - untested but needed tweak for postgres startup in f16
223
224 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
225 - tweaks in postgresql setup - in line with sfa
226
227 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
228 - slight tweaks in Persons.py
229
230 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
231 - GetSession has support for more than one day sessions
232 - reset_xmpp_pubsub_nodes is much more efficient
233 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
234 - bugfix - deleting a person in the middle of the signup process
235
236 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
237 - ratelimit aspects
238 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
239 - requires Django for cache_utils
240 - attempt to expose 'pldistro' to sfa
241 - last_time_spent_online, last_time_spent_offline: new fields in Node
242 - new slice tags 'isolate_loopback' and 'cpu_cores'
243 - refresh-peer federation logs dump exceptions
244 - modpython logs have a timestamp
245 - more verbose/accurate php error reporting
246 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
247 - AddNode, UpdateNode: manage tags directly rather than through another method
248 - BootUpdateNode: only update once
249 - GetPersons: techs can access the list of persons on their site
250 - GetSlices and GetSliceTags: techs can see slices on their nodes
251 - GetSlivers: isrootonsite tag; cacheable
252
253 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
254 - rename initscript_body into initscript_code
255
256 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
257 - new initscript_body tag
258
259 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
260 - working draft for GetSliceSshKeys
261
262 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
263 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
264 - (this is for people who cancel their download)
265
266 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
267 - fix db-config sequence : accessors step now merged in, and occurs at the right time
268 - db-config also more robust
269 - no more explicit 'accessors' step in plc.d
270
271 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
272 - session auth: do *not* delete session when node runs a method that does not have 'node' role
273 - session auth: remove support for bootonce in old boot CDs
274 - give a reason when caller_may_write_slice_tag fails
275 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
276
277 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
278 - SetSliceVref needed the node role
279 - protect GetSliceFamily
280 - Fix bugs in tag authorizations
281
282 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
283 - altered checking of optional fields in Interfaces
284 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
285 - has pyxml and python-simplejson as new deps
286
287 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
288 - tweak doc extraction for fedora14
289
290 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
291 - builtin accessors for the myslice page
292 - Get{Node,Interface}Tags allowed to techs
293 - tweak in ratelimitaspect.py
294
295 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
296 - add admin role to accessor-related tags (arch, {fc,pl}distro)
297
298 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
299 - bugfix in {Update,Delete}PersonTag
300 - updated xml doc for filters, accessors and tagtypes
301 - more explicit msg in case of missing roles
302 - improvements in ratelimitaspects.py
303
304 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
305 - fix the roles for ssh_key and hmac tags
306
307 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
308 - tag permissions system based on roles and not min_role_ids
309 - accessors simplified accordingly (no more min_role_id)
310 - new methods AddRoleToTagType and DeleteRoleFromTagType
311 - accessor-related tagtypes are created sooner, and enforced
312 - cleaned up redundancy between db-config.d and accessors
313
314 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
315 - fix RefreshPeer that was not working in 5.0-17
316
317 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
318 - RefreshPeer is able to cope with 2 peers running different releases of the api
319 - DeletePerson can be used on duplicates
320 - first appearance of ModPythonJson.py
321
322 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
323 - set accessors return the new value
324 - tweaks in the pubsub groups management
325
326 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
327 - convert hostnames to lower case and use ILIKE instead of LIKE
328
329 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
330 - use hrn in pubsub groups
331
332 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
333 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
334 - OMF fixes
335
336 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
337 - automatically set vsys tag for omf controlled slices
338
339 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
340 - addition of the 'ssh_key' slice tag
341 - first draft of the LDAP interface
342
343 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
344 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
345 - and readable through GetLeaseGranularity
346 - GetSlivers to expose reservation_policy and lease_granularity
347 - GetBootMedium fixed for reservable nodes
348 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
349 - new Apache mod_wsgi python interface
350
351 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
352 - the leases system
353
354 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
355 - previous tag had gone wrong
356
357 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
358 - fix pubsub hostname
359
360 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
361 - tweaks for the omf support (xmpp groups and RC-controlled slices)
362 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
363 - GetNodeFlavour exposes fcdistro
364
365 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
366 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
367
368 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
369 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
370 - pyaspect hooks allow to  maintain the namespace xmpp groups
371 - new omf_slicemgr is a proxy to xmpp, used by these hooks
372 - nodes have their hrn exposed in the 'hrn' tag
373 - node hrn exposed in GetSlivers, as well as the overall xmpp config
374 - system slice 'drl' gets created by db-config
375 - daniel's changes to Filter for supporting wildcards in lists
376 - AddSliceTag consistency check tweaked
377
378 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
379 - major cleanup
380 - get rid of all 4.2-related legacy code
381 - reset the migrations code, planetlab5.sql somes with (5,100)
382 - uses hashlib module when available
383
384 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
385 - first working version of 5.0:
386 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
387 - nodefamily is 3-fold with pldistro-fcdistro-arch
388 - site and person tags
389 - new methods GetSliceFamily and GetNodeFlavour
390 - deprecated the dummynet stuff that were for the external dummyboxes
391 - tags definition : more consistency between db-config scripts and accessors
392 - (get accessor to create the tag type too if absent)
393 - logging an event for AddSliceToNodes
394
395 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
396 - support for fedora 12
397 - fix subtle bug in filtering with ] and quotes
398
399 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
400 - * patch for php-5.3 (the one in f12)
401 - * validate email addresses with regex
402 - * add PersonTags and SiteTags
403 - * add additional accessors for node tags (kvariant, serial, ..)
404
405 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
406 - Redacting password, session, and authstring values from the event log.
407
408 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
409 - let AddSite set ext_consortium_id - required for the poorman registration pages
410 - drop version constraint on Requires: postgresql-python
411 - don't log system calls nor ReportRunLevel
412
413 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
414 - Fix requires for CentOS.
415
416 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
417 - Require postgresql 8.2 (for array operators && and @>)
418
419 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
420 - Filter now supports the | and & features to match in sequence values
421 - bugfix in the postgresql wrapper for sequence filter values
422 - reviewed GetSlivers to export admin keys more efficiently
423 - fix checking roles in UpdateSliceTag
424
425 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
426 - - Some typos in the documentation were fixed.
427 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
428 - to the tag's min_role_id.
429
430 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
431
432 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
433 - Ongoing work to add upcalls, using new SFA class
434 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
435 - reviewed type-checking for the 3 taggable classes node-interface-slice
436 - cleanup ald dummynet stuff
437 - expose the 'extensions' accessors to the API
438 - tweaked checks in AddSliceTag
439 - GetPersons exposes roles by default
440 - bugfix in ReportRunLevel for non-string levels
441 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
442
443 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
444 - new BindObjectToPeer method for sfa
445 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
446
447 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
448 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
449 - reportrunlevel logs its calls only when run_level changes
450 - pycurl more robust wrt to xmlrpclib.Transport
451
452 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
453 - produce a wsdl interface
454 - bugfix in getbootmedium for nodes with interface tags
455
456 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
457 - bugfix for some rare pattern-based filters
458
459 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
460 - improvements in the 4.2 legacy layer
461
462 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
463 - bugfix required for slice tags set on nodegroups
464
465 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
466 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
467
468 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
469 - more powerful legacy layer with 4.2
470
471 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
472 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
473 - migration script has an option for running interactively
474
475 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
476 - skips already added entries
477
478 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
479 - yet another set of fixes for external dummynet boxes
480
481 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
482 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
483 - and tmp file is cleaned up
484
485 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
486 - restore missing ResolveSlices
487
488 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
489 - new method GetDummyBoxMedium
490
491 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
492 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
493
494 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
495 - support for external dummynet boxes back in 4.3 - first draft
496
497 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
498 - fixes for smooth federation between 4.2 and 4.3
499 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
500
501 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
502 - support for BootCD variants (GetBootMedium ['variant:centos5'])
503 - fix corner case with filters like {'~slice_id':[]}
504 - fix transaction leak that caused the db connections pool to exhaust
505 - properly expose all methods, including Legacy/, and not only Methods/
506
507 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
508 - renumbered as 4.3
509 - nodes have new fields run_level (in addition to boot_state) and verified
510 - tweaked migration from 4.2
511 - tuned rpm dependencies
512 - doc generation more explicit about errors like missing python modules
513 - removed obsolete method GetSlicesMD5
514
515 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
516 - unified all tags
517 - renamed interface settings into interface tags and slice attributes into slice tags
518 - nodes have a node_type
519 - various changes on the way to 4.3
520
521 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
522 - Checkpointing : this version still has interface settings and slice attributes
523
524 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
525 - first iteration with taggable nodes/interfaces/slices
526 - embryo for ilinks
527 - cleaned up boot states
528 - migration script moslty complete
529
530 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
531 - fixed doc build by locating locally installed DTDs at build-time
532
533 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
534 - no more doc packaged outside of myplc-docs - doc/ cleaned up
535 - enhancements in doc on filters 
536 - bootcd-aware GetBootMedium merged from onelab
537
538 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
539 - checkpoint while the new myplc-docs package is underway
540 - bugfix: GetSlivers & conf files
541 - doc: removed target files 
542
543 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
544 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
545 - the non-deleted fields were index, resulting in massivly slow queries.
546
547
548 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
549 - plcsh: better handling of options when running as a shell script
550 - getbootmedium exports compute_key
551 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
552
553 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
554 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
555 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
556
557 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
558 - refresh peer script to use a month-dependent logfile
559 - tracking the starting point for UniPi integration of the dummynet boxes
560
561 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
562 - plcsh adds its own path to sys.path
563 - fix so GetNodes can be called from a Node
564
565 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
566 - Initial build.
567
568 %define module_current_branch 4.3