Setting tag plcapi-5.3-1
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 mkdir -p $RPM_BUILD_ROOT/var/log
123 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %define php_extension_dir %(php-config --extension-dir)
130
131 %files
132 %defattr(-,root,root,-)
133 %dir %{_datadir}/plc_api
134 #%dir /var/log/omf/
135 %{_datadir}/plc_api/*
136 %{_bindir}/plcsh
137 %{php_extension_dir}/xmlrpc.so
138 %{_sysconfdir}/php.d/xmlrpc.ini
139 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
140 /etc/plc.d
141 /etc/planetlab/db-config.d
142 /var/www/html/wsdl/plcapi.wsdl
143 #/usr/bin/omf_slicemgr.py*
144 #/usr/bin/reset_xmpp_pubsub_nodes.py*
145 /var/log/plc_api_ratelimit.log
146
147
148 %changelog
149 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
150 - create accessor 'hrn' for site as well
151 - create accessors 'sfa_created' for site/slice/person
152 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
153 - UpdatePerson() updates Person HRN according to updated email.
154 - UpdateSite() updates Site HRN according to updated login_base.
155 - Fix AddPersonToSite().
156 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
157 - RefreshPeer() manages Site*Person and Person*Role relationships.
158
159 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
160 - provide a slicename_to_hrn function
161
162 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
163 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
164
165 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
166 - fix for wsgi-based deployments, each thread has its own api()
167
168 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
169 - also cleanup omf-slicemgr initscript
170
171 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
172 - tear down omf-related aspects as this is no longer needed with omfv6
173
174 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
175 - also expose 'expires' in ResolveSlices
176
177 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
178 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
179
180 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
181 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
182
183 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
184 - use SFA code for computing hrn's when available
185
186 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
187 - new slice tag 'interface' for configuring a virtual interface
188 - new builtin 030-interface_tags
189 - new node accessor and tag 'virt' for mixing lxc & vs nodes
190 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
191 - moved ModPypthon and plc.wsgi in the apache/ subdir
192 - renamed PLCAPI.spec into plcapi.spec
193 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
194 - support for php-5.4
195
196 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
197 - implement PLC_VSYS_DEFAULTS in AddSlice
198
199 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
200 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
201 - AddPerson and UpdatePerson are now tag-aware
202 - as a side-effect AddPerson is more picky and rejects invalid fields
203 - which results in a requirement to use sfa-2.1-22 with this tag
204 - marginal improvement on the xml doc on tags
205
206 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
207 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
208 - reset_xmpp_pubsub_nodes now hos options and usage
209 - new Accessors for vicci
210
211 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
212 - fixed imports for tags management with sites and persons
213 - add predefined 'cpu_freezable' tag
214
215 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
216 - tweaks in interface initialization
217 - has 'vsys_vnet' as a predefined tagtype
218 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
219 - bugfix: GetSlivers & nodegroups
220 - bugfix: in jabber groups management
221
222 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
223 - fix gpg-authentication for Persons (thanks Jordan)
224 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
225 - ip address/network check: v4 or v6
226 - customized DB Message survive upgrade
227 - make sync works in lxc-hosted tests
228 - no svn keywords anymore
229
230 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
231 - fix sorting for methods list in docs
232 - untested but needed tweak for postgres startup in f16
233
234 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
235 - tweaks in postgresql setup - in line with sfa
236
237 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
238 - slight tweaks in Persons.py
239
240 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
241 - GetSession has support for more than one day sessions
242 - reset_xmpp_pubsub_nodes is much more efficient
243 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
244 - bugfix - deleting a person in the middle of the signup process
245
246 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
247 - ratelimit aspects
248 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
249 - requires Django for cache_utils
250 - attempt to expose 'pldistro' to sfa
251 - last_time_spent_online, last_time_spent_offline: new fields in Node
252 - new slice tags 'isolate_loopback' and 'cpu_cores'
253 - refresh-peer federation logs dump exceptions
254 - modpython logs have a timestamp
255 - more verbose/accurate php error reporting
256 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
257 - AddNode, UpdateNode: manage tags directly rather than through another method
258 - BootUpdateNode: only update once
259 - GetPersons: techs can access the list of persons on their site
260 - GetSlices and GetSliceTags: techs can see slices on their nodes
261 - GetSlivers: isrootonsite tag; cacheable
262
263 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
264 - rename initscript_body into initscript_code
265
266 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
267 - new initscript_body tag
268
269 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
270 - working draft for GetSliceSshKeys
271
272 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
273 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
274 - (this is for people who cancel their download)
275
276 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
277 - fix db-config sequence : accessors step now merged in, and occurs at the right time
278 - db-config also more robust
279 - no more explicit 'accessors' step in plc.d
280
281 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
282 - session auth: do *not* delete session when node runs a method that does not have 'node' role
283 - session auth: remove support for bootonce in old boot CDs
284 - give a reason when caller_may_write_slice_tag fails
285 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
286
287 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
288 - SetSliceVref needed the node role
289 - protect GetSliceFamily
290 - Fix bugs in tag authorizations
291
292 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
293 - altered checking of optional fields in Interfaces
294 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
295 - has pyxml and python-simplejson as new deps
296
297 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
298 - tweak doc extraction for fedora14
299
300 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
301 - builtin accessors for the myslice page
302 - Get{Node,Interface}Tags allowed to techs
303 - tweak in ratelimitaspect.py
304
305 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
306 - add admin role to accessor-related tags (arch, {fc,pl}distro)
307
308 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
309 - bugfix in {Update,Delete}PersonTag
310 - updated xml doc for filters, accessors and tagtypes
311 - more explicit msg in case of missing roles
312 - improvements in ratelimitaspects.py
313
314 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
315 - fix the roles for ssh_key and hmac tags
316
317 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
318 - tag permissions system based on roles and not min_role_ids
319 - accessors simplified accordingly (no more min_role_id)
320 - new methods AddRoleToTagType and DeleteRoleFromTagType
321 - accessor-related tagtypes are created sooner, and enforced
322 - cleaned up redundancy between db-config.d and accessors
323
324 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
325 - fix RefreshPeer that was not working in 5.0-17
326
327 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
328 - RefreshPeer is able to cope with 2 peers running different releases of the api
329 - DeletePerson can be used on duplicates
330 - first appearance of ModPythonJson.py
331
332 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
333 - set accessors return the new value
334 - tweaks in the pubsub groups management
335
336 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
337 - convert hostnames to lower case and use ILIKE instead of LIKE
338
339 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
340 - use hrn in pubsub groups
341
342 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
343 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
344 - OMF fixes
345
346 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
347 - automatically set vsys tag for omf controlled slices
348
349 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
350 - addition of the 'ssh_key' slice tag
351 - first draft of the LDAP interface
352
353 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
354 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
355 - and readable through GetLeaseGranularity
356 - GetSlivers to expose reservation_policy and lease_granularity
357 - GetBootMedium fixed for reservable nodes
358 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
359 - new Apache mod_wsgi python interface
360
361 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
362 - the leases system
363
364 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
365 - previous tag had gone wrong
366
367 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
368 - fix pubsub hostname
369
370 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
371 - tweaks for the omf support (xmpp groups and RC-controlled slices)
372 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
373 - GetNodeFlavour exposes fcdistro
374
375 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
376 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
377
378 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
379 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
380 - pyaspect hooks allow to  maintain the namespace xmpp groups
381 - new omf_slicemgr is a proxy to xmpp, used by these hooks
382 - nodes have their hrn exposed in the 'hrn' tag
383 - node hrn exposed in GetSlivers, as well as the overall xmpp config
384 - system slice 'drl' gets created by db-config
385 - daniel's changes to Filter for supporting wildcards in lists
386 - AddSliceTag consistency check tweaked
387
388 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
389 - major cleanup
390 - get rid of all 4.2-related legacy code
391 - reset the migrations code, planetlab5.sql somes with (5,100)
392 - uses hashlib module when available
393
394 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
395 - first working version of 5.0:
396 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
397 - nodefamily is 3-fold with pldistro-fcdistro-arch
398 - site and person tags
399 - new methods GetSliceFamily and GetNodeFlavour
400 - deprecated the dummynet stuff that were for the external dummyboxes
401 - tags definition : more consistency between db-config scripts and accessors
402 - (get accessor to create the tag type too if absent)
403 - logging an event for AddSliceToNodes
404
405 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
406 - support for fedora 12
407 - fix subtle bug in filtering with ] and quotes
408
409 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
410 - * patch for php-5.3 (the one in f12)
411 - * validate email addresses with regex
412 - * add PersonTags and SiteTags
413 - * add additional accessors for node tags (kvariant, serial, ..)
414
415 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
416 - Redacting password, session, and authstring values from the event log.
417
418 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
419 - let AddSite set ext_consortium_id - required for the poorman registration pages
420 - drop version constraint on Requires: postgresql-python
421 - don't log system calls nor ReportRunLevel
422
423 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
424 - Fix requires for CentOS.
425
426 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
427 - Require postgresql 8.2 (for array operators && and @>)
428
429 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
430 - Filter now supports the | and & features to match in sequence values
431 - bugfix in the postgresql wrapper for sequence filter values
432 - reviewed GetSlivers to export admin keys more efficiently
433 - fix checking roles in UpdateSliceTag
434
435 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
436 - - Some typos in the documentation were fixed.
437 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
438 - to the tag's min_role_id.
439
440 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
441
442 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
443 - Ongoing work to add upcalls, using new SFA class
444 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
445 - reviewed type-checking for the 3 taggable classes node-interface-slice
446 - cleanup ald dummynet stuff
447 - expose the 'extensions' accessors to the API
448 - tweaked checks in AddSliceTag
449 - GetPersons exposes roles by default
450 - bugfix in ReportRunLevel for non-string levels
451 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
452
453 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
454 - new BindObjectToPeer method for sfa
455 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
456
457 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
458 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
459 - reportrunlevel logs its calls only when run_level changes
460 - pycurl more robust wrt to xmlrpclib.Transport
461
462 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
463 - produce a wsdl interface
464 - bugfix in getbootmedium for nodes with interface tags
465
466 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
467 - bugfix for some rare pattern-based filters
468
469 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
470 - improvements in the 4.2 legacy layer
471
472 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
473 - bugfix required for slice tags set on nodegroups
474
475 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
476 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
477
478 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
479 - more powerful legacy layer with 4.2
480
481 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
482 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
483 - migration script has an option for running interactively
484
485 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
486 - skips already added entries
487
488 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
489 - yet another set of fixes for external dummynet boxes
490
491 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
492 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
493 - and tmp file is cleaned up
494
495 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
496 - restore missing ResolveSlices
497
498 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
499 - new method GetDummyBoxMedium
500
501 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
502 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
503
504 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
505 - support for external dummynet boxes back in 4.3 - first draft
506
507 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
508 - fixes for smooth federation between 4.2 and 4.3
509 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
510
511 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
512 - support for BootCD variants (GetBootMedium ['variant:centos5'])
513 - fix corner case with filters like {'~slice_id':[]}
514 - fix transaction leak that caused the db connections pool to exhaust
515 - properly expose all methods, including Legacy/, and not only Methods/
516
517 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
518 - renumbered as 4.3
519 - nodes have new fields run_level (in addition to boot_state) and verified
520 - tweaked migration from 4.2
521 - tuned rpm dependencies
522 - doc generation more explicit about errors like missing python modules
523 - removed obsolete method GetSlicesMD5
524
525 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
526 - unified all tags
527 - renamed interface settings into interface tags and slice attributes into slice tags
528 - nodes have a node_type
529 - various changes on the way to 4.3
530
531 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
532 - Checkpointing : this version still has interface settings and slice attributes
533
534 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
535 - first iteration with taggable nodes/interfaces/slices
536 - embryo for ilinks
537 - cleaned up boot states
538 - migration script moslty complete
539
540 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
541 - fixed doc build by locating locally installed DTDs at build-time
542
543 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
544 - no more doc packaged outside of myplc-docs - doc/ cleaned up
545 - enhancements in doc on filters 
546 - bootcd-aware GetBootMedium merged from onelab
547
548 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
549 - checkpoint while the new myplc-docs package is underway
550 - bugfix: GetSlivers & conf files
551 - doc: removed target files 
552
553 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
554 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
555 - the non-deleted fields were index, resulting in massivly slow queries.
556
557
558 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
559 - plcsh: better handling of options when running as a shell script
560 - getbootmedium exports compute_key
561 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
562
563 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
564 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
565 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
566
567 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
568 - refresh peer script to use a month-dependent logfile
569 - tracking the starting point for UniPi integration of the dummynet boxes
570
571 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
572 - plcsh adds its own path to sys.path
573 - fix so GetNodes can be called from a Node
574
575 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
576 - Initial build.
577
578 %define module_current_branch 4.3