svn:keywords
[plewww.git] / PLCWWW.spec
1 #
2 # $Id$
3 #
4 %define name PLCWWW
5 %define version PLE.5.0
6 %define taglevel 0
7
8 # no need to mention pldistro as this module differs in both distros
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) Web Pages
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: OneLab
23 Packager: OneLab <support@one-lab.org>
24 Distribution: PlanetLab %{version}
25 URL: http://svn.one-lab.org/svn/new_plc_www/
26
27 # We use set everywhere
28 #Requires: httpd >= 2.0
29 Requires: php >= 5.0
30 Requires: postgresql >= 8.0
31 Requires: PLCAPI >= 5.0
32
33 # on centos5, when rebuilding the full monty, we get:
34 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
35 # and the perl-GD rpm is nowhere to be found
36 AutoReqProv: no
37
38 %description
39 The PLCWWW package is made of the web pages that run on top of the 
40 PLCAPI component to provide the Web Interface to MyPLC users.
41
42 %prep
43 %setup -q
44
45 %build
46 echo "There is no build stage for this component"
47 echo "All files just need to be installed as is from the codebase"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 #
53 # plcwww
54 #
55
56 echo "* PLEWWW: Installing web pages"
57 mkdir -p $RPM_BUILD_ROOT/var/www/html
58 # let's be conservative and exclude codebase files, though there should not be any
59 rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
60
61 echo "* PLEWWW: Installing config for httpd"
62 install -D -m 644 planetlab.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/planetlab.conf
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(-,root,root,-)
69 /var/www/html
70 /etc/httpd/conf.d/planetlab.conf
71
72 %changelog
73 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
74 - everyone is welcome to add nodes
75
76 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
77 - node-specific bootcd images to include arch in their name
78
79 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
80 - remove explicit dep to bootcd as the rpm name has changed
81
82 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
83 - noarch
84
85 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
86 - should fix yum.conf on nodes after install
87
88 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
89 - uses different path for getbootmedium results - should be safer
90
91 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
92 - comon icon replaced with the one from the comon website
93
94 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
95 - displays rpms in the about page
96
97 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
98 - safer, reference-less, way to implement layout mechnism - see
99 - settings.php for details
100 - setting types properly displayed according to user's role
101 - setting deletion : fixed (was still using code from slice attribute)
102 - more comon buttons : in the nodes and peers index pages
103 - comon_button knows about peer_id
104
105 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
106 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
107
108 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
109 - Initial build.