Setting tag plewww-5.2-2
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 2
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: plcapi >= 5.2
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
129 - node page and person page show hrn in details
130
131 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
132 - late fix of registration for plcapi-5.1-6
133
134 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
135 - add extra code to prevent confidentiality leaks
136 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
137 - return_url for add-person and remove-person
138 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
139
140 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
141 - add tags section on site and person pages
142
143 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
144 - slightly tweak profiling points in slice.php
145
146 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
147 - ships with new default images for PLC/PLE from planet-lab.eu
148
149 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
150 - no change, just make sync for lxc-hosted tests
151
152 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
153 - refactoring for tophat/columns
154 - should take care of the irritating warning message about columns
155
156 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
157 - do not display the 'node' role when confusing
158
159 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
160 - support for setting nodes as reservable
161 - rely more on previous state when deciding to open or not toggles in a view
162 - remove statements for setting maximum memory usage, that sometimes
163
164 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
165 - node page can edit interfaces even when no interface
166
167 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
168 - uses a 2-week (!) session
169
170 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
171 - minor/cosmetic fixes in the leases area
172
173 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
174 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
175 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
176 - has a feature to 'test' pcu connection
177 - only admins can add users to different sites.
178 - remove dep. to outdated _gen_planetflow.php
179 - rephrased (disabled, or pending registration)
180 - + various fixes
181
182 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
183 - fix display glitch exposed with dimes initscript
184
185 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
186 - rename initscript_body into initscript_code
187
188 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
189 - bugfix for the reservation interface
190
191 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
192 - reservation page uses ajax - no need to reload after submit
193 - reservation dialogs for offset in the future & # slots
194 - fix the timezone in reservations (actually use php.ini)
195 - reservation visible (and hardwired) in nodes view
196 - have pulled prototype 1.7 but not in used yet
197
198 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
199 - set both 'omf_control' and 'vref' for omf-friendly slices
200
201 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
202 - display tags in alphabetic order in node view, tags section, the drop down menu
203
204 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
205 - on-the-fly retrieval of data at comon & tophat (unused so far)
206 - use accessors to store person's preference of columns
207 - fix in toggle.js for the '?' button, node table layout tab
208 - sort actions logging improved
209
210 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
211 - keep people from disabling or deleting themselves
212 - cannot become a disabled person
213 - outline people without a role
214
215 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
216 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
217
218 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
219 - tagging plewww for a new deployment
220
221 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
222 - add a 'report a problem' link for the RebootNode button
223 - new exp page nodes2.php with consistent selectable-columns layout as myslice
224 - tweaks in the exp. myslice (slices.php)
225
226 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
227 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
228 - my_slice with adjustable set of columns in slices/slice2.php
229 - fix for the 'site registration' page
230
231 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
232 - show message about leases - leases tab first in nodes section
233 - fix how reservable nodes show up
234
235 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
236 - cosmetic, rendering of textareas was like password fields
237
238 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
239 - bugfix in slice page, had wrong (null) expiration date
240 - upgraded to raphael-1.5.2, don't minimize this lib
241 - nicer layout for password fields as well
242 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
243 - marginally optimized slice page (2 GetNodes call down)
244 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
245 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
246 - reservations can cope with a bit more slots - will need scrolling someday
247 - omf text has hyperlinks to the tools
248
249 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
250 - reservation section now effective
251 - can set omf_control at slice-creation time
252 - can set node as reservable at node-creation time
253 - nicer text input fields + various tweaks
254
255 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
256 - show nodegroups form to add new groups
257
258 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
259 - just tagging plewww again to test module-tag on git
260
261 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
262 - encode strings properly in forms.
263
264 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
265 - Use readfile() function to reduce the memory footprint
266
267 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
268 - removed all deprecated functions for PHP-5.3 on fedora 12
269
270 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
271 - * exclude DNS from subnet checking
272 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
273 - * allow longer abbreviated names
274 - * don't let empty strings kill the server (postgresql and apache)
275
276 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
277 - disable drupal user registration (hard: patching the user module)
278
279 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
280 - * show error messages for update interface
281 - * 'Add Node' is admin only
282 - * add site selector for 'Add Node'
283
284 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
285 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
286 - this affects the settings of ifname and alias that were formerly set unconditionally
287 - review the interface-checking javascript code
288 - changed the interface to plekitform, method is now optional and part of an options hash
289
290 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
291 - can't use php objects for showing node status, this is too slow
292 - fix interface add page
293
294 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
295 - consistency in the way nodes status is displayed in the node and slice areas
296 - extra tags columns show up on the nodes page as well, tweaked in the process
297 - roles management in person page fixed
298
299 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
300 - displaying node tags in the nodes page as well
301 - table headers now can have a 'title' that shows up when hovering on the column header
302
303 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
304 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
305
306 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
307 - extensible set of columns in the nodes area of the (my)slice page
308 - nodegroups can be added/deleted/updated
309 - tags management improved marginally
310
311 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
312 - fix pending sites page - was getting fooled by ext_consortium_id=None
313
314 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
315 - resetting tag as something went wrong when setting 31
316
317 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
318 - nicer look for slice creation, (public) sites
319 - users show with all their sites in the persons page
320
321 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
322 - reviewed registration pages for persons and sites
323
324 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
325 - increase memory limit in the nodes page
326
327 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
328 - fixes one typo
329
330 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
331 - minor/cosmetic
332
333 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
334 - Add default Interface tags to extra interfaces.
335 - Add clearer 'Add New PCU' link on node page.
336 - Disable user registration for tech and PI roles.
337
338 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
339 - new 'controller' instantiation state available in add slice page
340
341 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
342 - exclude datepicler.js from jsmin
343 - table sort function for Last Contact columns
344 - drop options for generic boot images
345
346 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
347 - displays editable mac address for interfaces
348 - properly sorts bandwidths
349 - new 'controller' slice instantiation method
350 - bugfix, division by zero when displaying a just-changed node
351
352 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
353 - bugfix with linetabs
354
355 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
356 - fix add interface from the node page
357
358 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
359 - only add users that are enabled and not yet a member of the slice
360 - fix to plc_peers
361 - my sites, my nodes, my persons improvements for users with multiple sites
362 - adds a script to minimize the java script files.
363
364 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
365 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
366
367 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
368 - first draft for pcu-handling features
369 - lighter contrat for PLE/PLC toggles
370 - as many 'my site'-like  links as the user has sites
371
372 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
373 - fix for whitelisted nodes
374 - now links to the node register wizard
375 - can enable sites
376 - various other minor fixes, like broken planetlab.module for techs, and login link
377
378 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
379 - plekittable knows how to turn off sort-on-load, and the admin users pages do
380 - + various cosmetic fixes
381
382 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
383 - a few minor improvements pushed on PLE
384
385 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
386 - fix for sites that were displayed as not public
387 - improvements to the python interface to sortable tables for monitor
388
389 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
390 - various improvements
391
392 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
393 - sliver page now correctly shows sliver tags
394 - support for download-node-usb-partition and various other improvements
395
396 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
397 - a few tweaks and typos fixed on PLE
398
399 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
400 - slice_add & node_download dialogs use plekit
401 - slice_add can add people in the slice
402 - various improvements after rollout on PLE
403
404 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
405 - cosmetic fixes to be in 4.3-rc2
406 - also a first (unpackaged) draft of the plekit table in python
407
408 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
409 - search in tables more robust
410
411 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
412 - performance improvements
413
414 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
415 - detect expired session and redirect to the login page
416
417 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
418 - improve browser health - was using too many cycles
419
420 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
421 - more consistency between views, and cosmetic changes
422
423 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
424 - area for managing slice tags
425
426 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
427 - first checkpoint tag for PLEWWW
428 - mostly functionally complete, probably a lot of tweaks still needed
429
430 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
431 - everyone is welcome to add nodes
432
433 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
434 - node-specific bootcd images to include arch in their name
435
436 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
437 - remove explicit dep to bootcd as the rpm name has changed
438
439 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
440 - noarch
441
442 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
443 - should fix yum.conf on nodes after install
444
445 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
446 - uses different path for getbootmedium results - should be safer
447
448 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
449 - comon icon replaced with the one from the comon website
450
451 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
452 - displays rpms in the about page
453
454 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
455 - safer, reference-less, way to implement layout mechnism - see
456 - settings.php for details
457 - setting types properly displayed according to user's role
458 - setting deletion : fixed (was still using code from slice attribute)
459 - more comon buttons : in the nodes and peers index pages
460 - comon_button knows about peer_id
461
462 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
463 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
464
465 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
466 - Initial build.