Setting tag plewww-4.3-74
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 74
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
129 - add tags section on site and person pages
130
131 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
132 - slightly tweak profiling points in slice.php
133
134 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
135 - ships with new default images for PLC/PLE from planet-lab.eu
136
137 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
138 - no change, just make sync for lxc-hosted tests
139
140 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
141 - refactoring for tophat/columns
142 - should take care of the irritating warning message about columns
143
144 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
145 - do not display the 'node' role when confusing
146
147 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
148 - support for setting nodes as reservable
149 - rely more on previous state when deciding to open or not toggles in a view
150 - remove statements for setting maximum memory usage, that sometimes
151
152 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
153 - node page can edit interfaces even when no interface
154
155 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
156 - uses a 2-week (!) session
157
158 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
159 - minor/cosmetic fixes in the leases area
160
161 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
162 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
163 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
164 - has a feature to 'test' pcu connection
165 - only admins can add users to different sites.
166 - remove dep. to outdated _gen_planetflow.php
167 - rephrased (disabled, or pending registration)
168 - + various fixes
169
170 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
171 - fix display glitch exposed with dimes initscript
172
173 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
174 - rename initscript_body into initscript_code
175
176 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
177 - bugfix for the reservation interface
178
179 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
180 - reservation page uses ajax - no need to reload after submit
181 - reservation dialogs for offset in the future & # slots
182 - fix the timezone in reservations (actually use php.ini)
183 - reservation visible (and hardwired) in nodes view
184 - have pulled prototype 1.7 but not in used yet
185
186 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
187 - set both 'omf_control' and 'vref' for omf-friendly slices
188
189 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
190 - display tags in alphabetic order in node view, tags section, the drop down menu
191
192 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
193 - on-the-fly retrieval of data at comon & tophat (unused so far)
194 - use accessors to store person's preference of columns
195 - fix in toggle.js for the '?' button, node table layout tab
196 - sort actions logging improved
197
198 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
199 - keep people from disabling or deleting themselves
200 - cannot become a disabled person
201 - outline people without a role
202
203 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
204 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
205
206 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
207 - tagging plewww for a new deployment
208
209 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
210 - add a 'report a problem' link for the RebootNode button
211 - new exp page nodes2.php with consistent selectable-columns layout as myslice
212 - tweaks in the exp. myslice (slices.php)
213
214 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
215 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
216 - my_slice with adjustable set of columns in slices/slice2.php
217 - fix for the 'site registration' page
218
219 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
220 - show message about leases - leases tab first in nodes section
221 - fix how reservable nodes show up
222
223 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
224 - cosmetic, rendering of textareas was like password fields
225
226 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
227 - bugfix in slice page, had wrong (null) expiration date
228 - upgraded to raphael-1.5.2, don't minimize this lib
229 - nicer layout for password fields as well
230 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
231 - marginally optimized slice page (2 GetNodes call down)
232 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
233 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
234 - reservations can cope with a bit more slots - will need scrolling someday
235 - omf text has hyperlinks to the tools
236
237 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
238 - reservation section now effective
239 - can set omf_control at slice-creation time
240 - can set node as reservable at node-creation time
241 - nicer text input fields + various tweaks
242
243 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
244 - show nodegroups form to add new groups
245
246 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
247 - just tagging plewww again to test module-tag on git
248
249 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
250 - encode strings properly in forms.
251
252 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
253 - Use readfile() function to reduce the memory footprint
254
255 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
256 - removed all deprecated functions for PHP-5.3 on fedora 12
257
258 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
259 - * exclude DNS from subnet checking
260 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
261 - * allow longer abbreviated names
262 - * don't let empty strings kill the server (postgresql and apache)
263
264 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
265 - disable drupal user registration (hard: patching the user module)
266
267 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
268 - * show error messages for update interface
269 - * 'Add Node' is admin only
270 - * add site selector for 'Add Node'
271
272 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
273 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
274 - this affects the settings of ifname and alias that were formerly set unconditionally
275 - review the interface-checking javascript code
276 - changed the interface to plekitform, method is now optional and part of an options hash
277
278 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
279 - can't use php objects for showing node status, this is too slow
280 - fix interface add page
281
282 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
283 - consistency in the way nodes status is displayed in the node and slice areas
284 - extra tags columns show up on the nodes page as well, tweaked in the process
285 - roles management in person page fixed
286
287 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
288 - displaying node tags in the nodes page as well
289 - table headers now can have a 'title' that shows up when hovering on the column header
290
291 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
292 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
293
294 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
295 - extensible set of columns in the nodes area of the (my)slice page
296 - nodegroups can be added/deleted/updated
297 - tags management improved marginally
298
299 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
300 - fix pending sites page - was getting fooled by ext_consortium_id=None
301
302 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
303 - resetting tag as something went wrong when setting 31
304
305 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
306 - nicer look for slice creation, (public) sites
307 - users show with all their sites in the persons page
308
309 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
310 - reviewed registration pages for persons and sites
311
312 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
313 - increase memory limit in the nodes page
314
315 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
316 - fixes one typo
317
318 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
319 - minor/cosmetic
320
321 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
322 - Add default Interface tags to extra interfaces.
323 - Add clearer 'Add New PCU' link on node page.
324 - Disable user registration for tech and PI roles.
325
326 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
327 - new 'controller' instantiation state available in add slice page
328
329 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
330 - exclude datepicler.js from jsmin
331 - table sort function for Last Contact columns
332 - drop options for generic boot images
333
334 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
335 - displays editable mac address for interfaces
336 - properly sorts bandwidths
337 - new 'controller' slice instantiation method
338 - bugfix, division by zero when displaying a just-changed node
339
340 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
341 - bugfix with linetabs
342
343 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
344 - fix add interface from the node page
345
346 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
347 - only add users that are enabled and not yet a member of the slice
348 - fix to plc_peers
349 - my sites, my nodes, my persons improvements for users with multiple sites
350 - adds a script to minimize the java script files.
351
352 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
353 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
354
355 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
356 - first draft for pcu-handling features
357 - lighter contrat for PLE/PLC toggles
358 - as many 'my site'-like  links as the user has sites
359
360 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
361 - fix for whitelisted nodes
362 - now links to the node register wizard
363 - can enable sites
364 - various other minor fixes, like broken planetlab.module for techs, and login link
365
366 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
367 - plekittable knows how to turn off sort-on-load, and the admin users pages do
368 - + various cosmetic fixes
369
370 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
371 - a few minor improvements pushed on PLE
372
373 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
374 - fix for sites that were displayed as not public
375 - improvements to the python interface to sortable tables for monitor
376
377 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
378 - various improvements
379
380 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
381 - sliver page now correctly shows sliver tags
382 - support for download-node-usb-partition and various other improvements
383
384 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
385 - a few tweaks and typos fixed on PLE
386
387 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
388 - slice_add & node_download dialogs use plekit
389 - slice_add can add people in the slice
390 - various improvements after rollout on PLE
391
392 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
393 - cosmetic fixes to be in 4.3-rc2
394 - also a first (unpackaged) draft of the plekit table in python
395
396 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
397 - search in tables more robust
398
399 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
400 - performance improvements
401
402 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
403 - detect expired session and redirect to the login page
404
405 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
406 - improve browser health - was using too many cycles
407
408 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
409 - more consistency between views, and cosmetic changes
410
411 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
412 - area for managing slice tags
413
414 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
415 - first checkpoint tag for PLEWWW
416 - mostly functionally complete, probably a lot of tweaks still needed
417
418 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
419 - everyone is welcome to add nodes
420
421 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
422 - node-specific bootcd images to include arch in their name
423
424 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
425 - remove explicit dep to bootcd as the rpm name has changed
426
427 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
428 - noarch
429
430 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
431 - should fix yum.conf on nodes after install
432
433 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
434 - uses different path for getbootmedium results - should be safer
435
436 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
437 - comon icon replaced with the one from the comon website
438
439 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
440 - displays rpms in the about page
441
442 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
443 - safer, reference-less, way to implement layout mechnism - see
444 - settings.php for details
445 - setting types properly displayed according to user's role
446 - setting deletion : fixed (was still using code from slice attribute)
447 - more comon buttons : in the nodes and peers index pages
448 - comon_button knows about peer_id
449
450 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
451 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
452
453 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
454 - Initial build.