bugfix: the slice page was broken when nobody is in slice
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 9
5
6 # no need to mention pldistro as this module differs in both distros
7 %define release %{taglevel}%{?date:.%{date}}
8
9 Summary: PlanetLab Europe (PLC) Web Pages
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: Applications/Systems
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17 BuildArch: noarch
18 BuildRequires: python
19
20 Vendor: OneLab
21 Packager: OneLab <support@one-lab.org>
22 Distribution: PlanetLab %{version}
23 URL: %{SCMURL}
24
25 # We use set everywhere
26 #Requires: httpd >= 2.0
27 Requires: php >= 5.0
28 Requires: postgresql >= 8.0
29 Requires: plcapi >= 5.2
30 Requires: drupal = 4.7
31 Requires: plewww-plekit
32
33 # this is what MyPLC requires
34 Provides: PLCWWW
35
36 # on centos5, when rebuilding the full monty, we get:
37 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
38 # and the perl-GD rpm is nowhere to be found
39 AutoReqProv: no
40
41 %package plekit
42 Summary: Utilities used by the plewww pages
43 Group: Applications/Systems
44
45 %description
46 The plewww package is made of the web pages that run on top of the 
47 PLCAPI component to provide the Web Interface to MyPLC users.
48
49 %description plekit
50 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
51
52 %prep
53 %setup -q
54
55 %build
56 echo "Compressing javascript files"
57 make compress
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 #
63 # plewww
64 # xxx : uninstall should undo this
65 #
66
67 echo "* PLEWWW: Installing web pages"
68 mkdir -p $RPM_BUILD_ROOT/var/www/html
69 # exclude codebase just in case
70 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
71
72 echo "* PLEWWW: Installing conf files for httpd"
73 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
74 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
75
76 %post
77 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
78 drupal_settings_dir=/var/www/html/sites/default
79 if [ ! -d $drupal_settings_dir ] ; then
80     echo "Could not find directory $drupal_settings_dir"
81     echo "This suggests that you do not have a planetlab-custom drupal installed"
82     exit 1
83 fi
84 pushd $drupal_settings_dir
85 # tune $db_url
86 if [ ! -f settings.php.drupal ] ; then
87     cp settings.php settings.php.drupal
88     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
89         settings.php.drupal > settings.php
90 fi
91 popd
92 # append our own database creation hacks to the drupal database schema
93 pushd /var/www/html/database
94 if [ ! -f database.pgsql.drupal ] ; then
95     cp database.pgsql database.pgsql.drupal
96     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
97 fi
98 popd
99 # hack the welcome page for MyPLC
100 pushd /var/www/html/modules
101 for module in user node; do
102     # backup only once
103     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
104     # always update so a change in our file can make through
105     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
106 done
107 popd
108 # create myslice.log and change its ownership
109 touch /var/log/myslice.log
110 chown apache:apache /var/log/myslice.log
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(-,root,root,-)
117 /var/www/html/modules
118 /var/www/html/planetlab
119 /var/www/html/googlemap
120 /var/www/html/drupal-hacks
121 /etc/httpd/conf.d
122
123 %files plekit
124 /var/www/html/plekit
125
126 %changelog
127 * Wed May 16 2018 Thierry <Parmentelat> - plewww-5.2-9
128 - not too clean patches for r2lab:
129 - * search for a file named /etc/planetlab/php/person-registration.txt
130 - that can override the text message for individuals registration
131 - * do not list sites that have the disabled_registration tag set
132 - when listing them for individuals registration
133 - remove omf-friendly checkbox in slice-creation dialog
134 - comment out {Min,Max}SpareServers settings in httpd config
135
136 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-8
137 - a few niceties, thanks to Ciro
138
139 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-7
140 - remove utf8_deode as per Thomas's suggestion
141
142 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-6
143 - Offer the option to set a node in 'upgrade' mode - like reinstall but leaving slices intact
144
145 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-5
146 - tweaks in node_downloads.php about memory size and compression scheme
147
148 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-4
149 - googlemap widget: support for gmap api v3 + various cosmetic tweaks
150 - can display site names with odd characters
151
152 * Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
153 - typo in help message about initscripts
154
155 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
156 - node page and person page show hrn in details
157
158 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
159 - late fix of registration for plcapi-5.1-6
160
161 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
162 - add extra code to prevent confidentiality leaks
163 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
164 - return_url for add-person and remove-person
165 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
166
167 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
168 - add tags section on site and person pages
169
170 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
171 - slightly tweak profiling points in slice.php
172
173 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
174 - ships with new default images for PLC/PLE from planet-lab.eu
175
176 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
177 - no change, just make sync for lxc-hosted tests
178
179 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
180 - refactoring for tophat/columns
181 - should take care of the irritating warning message about columns
182
183 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
184 - do not display the 'node' role when confusing
185
186 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
187 - support for setting nodes as reservable
188 - rely more on previous state when deciding to open or not toggles in a view
189 - remove statements for setting maximum memory usage, that sometimes
190
191 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
192 - node page can edit interfaces even when no interface
193
194 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
195 - uses a 2-week (!) session
196
197 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
198 - minor/cosmetic fixes in the leases area
199
200 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
201 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
202 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
203 - has a feature to 'test' pcu connection
204 - only admins can add users to different sites.
205 - remove dep. to outdated _gen_planetflow.php
206 - rephrased (disabled, or pending registration)
207 - + various fixes
208
209 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
210 - fix display glitch exposed with dimes initscript
211
212 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
213 - rename initscript_body into initscript_code
214
215 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
216 - bugfix for the reservation interface
217
218 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
219 - reservation page uses ajax - no need to reload after submit
220 - reservation dialogs for offset in the future & # slots
221 - fix the timezone in reservations (actually use php.ini)
222 - reservation visible (and hardwired) in nodes view
223 - have pulled prototype 1.7 but not in used yet
224
225 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
226 - set both 'omf_control' and 'vref' for omf-friendly slices
227
228 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
229 - display tags in alphabetic order in node view, tags section, the drop down menu
230
231 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
232 - on-the-fly retrieval of data at comon & tophat (unused so far)
233 - use accessors to store person's preference of columns
234 - fix in toggle.js for the '?' button, node table layout tab
235 - sort actions logging improved
236
237 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
238 - keep people from disabling or deleting themselves
239 - cannot become a disabled person
240 - outline people without a role
241
242 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
243 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
244
245 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
246 - tagging plewww for a new deployment
247
248 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
249 - add a 'report a problem' link for the RebootNode button
250 - new exp page nodes2.php with consistent selectable-columns layout as myslice
251 - tweaks in the exp. myslice (slices.php)
252
253 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
254 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
255 - my_slice with adjustable set of columns in slices/slice2.php
256 - fix for the 'site registration' page
257
258 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
259 - show message about leases - leases tab first in nodes section
260 - fix how reservable nodes show up
261
262 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
263 - cosmetic, rendering of textareas was like password fields
264
265 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
266 - bugfix in slice page, had wrong (null) expiration date
267 - upgraded to raphael-1.5.2, don't minimize this lib
268 - nicer layout for password fields as well
269 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
270 - marginally optimized slice page (2 GetNodes call down)
271 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
272 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
273 - reservations can cope with a bit more slots - will need scrolling someday
274 - omf text has hyperlinks to the tools
275
276 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
277 - reservation section now effective
278 - can set omf_control at slice-creation time
279 - can set node as reservable at node-creation time
280 - nicer text input fields + various tweaks
281
282 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
283 - show nodegroups form to add new groups
284
285 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
286 - just tagging plewww again to test module-tag on git
287
288 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
289 - encode strings properly in forms.
290
291 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
292 - Use readfile() function to reduce the memory footprint
293
294 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
295 - removed all deprecated functions for PHP-5.3 on fedora 12
296
297 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
298 - * exclude DNS from subnet checking
299 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
300 - * allow longer abbreviated names
301 - * don't let empty strings kill the server (postgresql and apache)
302
303 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
304 - disable drupal user registration (hard: patching the user module)
305
306 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
307 - * show error messages for update interface
308 - * 'Add Node' is admin only
309 - * add site selector for 'Add Node'
310
311 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
312 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
313 - this affects the settings of ifname and alias that were formerly set unconditionally
314 - review the interface-checking javascript code
315 - changed the interface to plekitform, method is now optional and part of an options hash
316
317 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
318 - can't use php objects for showing node status, this is too slow
319 - fix interface add page
320
321 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
322 - consistency in the way nodes status is displayed in the node and slice areas
323 - extra tags columns show up on the nodes page as well, tweaked in the process
324 - roles management in person page fixed
325
326 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
327 - displaying node tags in the nodes page as well
328 - table headers now can have a 'title' that shows up when hovering on the column header
329
330 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
331 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
332
333 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
334 - extensible set of columns in the nodes area of the (my)slice page
335 - nodegroups can be added/deleted/updated
336 - tags management improved marginally
337
338 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
339 - fix pending sites page - was getting fooled by ext_consortium_id=None
340
341 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
342 - resetting tag as something went wrong when setting 31
343
344 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
345 - nicer look for slice creation, (public) sites
346 - users show with all their sites in the persons page
347
348 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
349 - reviewed registration pages for persons and sites
350
351 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
352 - increase memory limit in the nodes page
353
354 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
355 - fixes one typo
356
357 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
358 - minor/cosmetic
359
360 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
361 - Add default Interface tags to extra interfaces.
362 - Add clearer 'Add New PCU' link on node page.
363 - Disable user registration for tech and PI roles.
364
365 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
366 - new 'controller' instantiation state available in add slice page
367
368 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
369 - exclude datepicler.js from jsmin
370 - table sort function for Last Contact columns
371 - drop options for generic boot images
372
373 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
374 - displays editable mac address for interfaces
375 - properly sorts bandwidths
376 - new 'controller' slice instantiation method
377 - bugfix, division by zero when displaying a just-changed node
378
379 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
380 - bugfix with linetabs
381
382 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
383 - fix add interface from the node page
384
385 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
386 - only add users that are enabled and not yet a member of the slice
387 - fix to plc_peers
388 - my sites, my nodes, my persons improvements for users with multiple sites
389 - adds a script to minimize the java script files.
390
391 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
392 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
393
394 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
395 - first draft for pcu-handling features
396 - lighter contrat for PLE/PLC toggles
397 - as many 'my site'-like  links as the user has sites
398
399 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
400 - fix for whitelisted nodes
401 - now links to the node register wizard
402 - can enable sites
403 - various other minor fixes, like broken planetlab.module for techs, and login link
404
405 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
406 - plekittable knows how to turn off sort-on-load, and the admin users pages do
407 - + various cosmetic fixes
408
409 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
410 - a few minor improvements pushed on PLE
411
412 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
413 - fix for sites that were displayed as not public
414 - improvements to the python interface to sortable tables for monitor
415
416 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
417 - various improvements
418
419 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
420 - sliver page now correctly shows sliver tags
421 - support for download-node-usb-partition and various other improvements
422
423 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
424 - a few tweaks and typos fixed on PLE
425
426 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
427 - slice_add & node_download dialogs use plekit
428 - slice_add can add people in the slice
429 - various improvements after rollout on PLE
430
431 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
432 - cosmetic fixes to be in 4.3-rc2
433 - also a first (unpackaged) draft of the plekit table in python
434
435 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
436 - search in tables more robust
437
438 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
439 - performance improvements
440
441 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
442 - detect expired session and redirect to the login page
443
444 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
445 - improve browser health - was using too many cycles
446
447 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
448 - more consistency between views, and cosmetic changes
449
450 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
451 - area for managing slice tags
452
453 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
454 - first checkpoint tag for PLEWWW
455 - mostly functionally complete, probably a lot of tweaks still needed
456
457 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
458 - everyone is welcome to add nodes
459
460 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
461 - node-specific bootcd images to include arch in their name
462
463 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
464 - remove explicit dep to bootcd as the rpm name has changed
465
466 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
467 - noarch
468
469 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
470 - should fix yum.conf on nodes after install
471
472 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
473 - uses different path for getbootmedium results - should be safer
474
475 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
476 - comon icon replaced with the one from the comon website
477
478 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
479 - displays rpms in the about page
480
481 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
482 - safer, reference-less, way to implement layout mechnism - see
483 - settings.php for details
484 - setting types properly displayed according to user's role
485 - setting deletion : fixed (was still using code from slice attribute)
486 - more comon buttons : in the nodes and peers index pages
487 - comon_button knows about peer_id
488
489 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
490 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
491
492 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
493 - Initial build.