Setting tag plewww-4.3-69
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 69
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
129 - do not display the 'node' role when confusing
130
131 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
132 - support for setting nodes as reservable
133 - rely more on previous state when deciding to open or not toggles in a view
134 - remove statements for setting maximum memory usage, that sometimes
135
136 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
137 - node page can edit interfaces even when no interface
138
139 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
140 - uses a 2-week (!) session
141
142 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
143 - minor/cosmetic fixes in the leases area
144
145 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
146 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
147 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
148 - has a feature to 'test' pcu connection
149 - only admins can add users to different sites.
150 - remove dep. to outdated _gen_planetflow.php
151 - rephrased (disabled, or pending registration)
152 - + various fixes
153
154 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
155 - fix display glitch exposed with dimes initscript
156
157 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
158 - rename initscript_body into initscript_code
159
160 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
161 - bugfix for the reservation interface
162
163 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
164 - reservation page uses ajax - no need to reload after submit
165 - reservation dialogs for offset in the future & # slots
166 - fix the timezone in reservations (actually use php.ini)
167 - reservation visible (and hardwired) in nodes view
168 - have pulled prototype 1.7 but not in used yet
169
170 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
171 - set both 'omf_control' and 'vref' for omf-friendly slices
172
173 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
174 - display tags in alphabetic order in node view, tags section, the drop down menu
175
176 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
177 - on-the-fly retrieval of data at comon & tophat (unused so far)
178 - use accessors to store person's preference of columns
179 - fix in toggle.js for the '?' button, node table layout tab
180 - sort actions logging improved
181
182 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
183 - keep people from disabling or deleting themselves
184 - cannot become a disabled person
185 - outline people without a role
186
187 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
188 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
189
190 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
191 - tagging plewww for a new deployment
192
193 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
194 - add a 'report a problem' link for the RebootNode button
195 - new exp page nodes2.php with consistent selectable-columns layout as myslice
196 - tweaks in the exp. myslice (slices.php)
197
198 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
199 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
200 - my_slice with adjustable set of columns in slices/slice2.php
201 - fix for the 'site registration' page
202
203 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
204 - show message about leases - leases tab first in nodes section
205 - fix how reservable nodes show up
206
207 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
208 - cosmetic, rendering of textareas was like password fields
209
210 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
211 - bugfix in slice page, had wrong (null) expiration date
212 - upgraded to raphael-1.5.2, don't minimize this lib
213 - nicer layout for password fields as well
214 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
215 - marginally optimized slice page (2 GetNodes call down)
216 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
217 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
218 - reservations can cope with a bit more slots - will need scrolling someday
219 - omf text has hyperlinks to the tools
220
221 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
222 - reservation section now effective
223 - can set omf_control at slice-creation time
224 - can set node as reservable at node-creation time
225 - nicer text input fields + various tweaks
226
227 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
228 - show nodegroups form to add new groups
229
230 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
231 - just tagging plewww again to test module-tag on git
232
233 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
234 - encode strings properly in forms.
235
236 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
237 - Use readfile() function to reduce the memory footprint
238
239 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
240 - removed all deprecated functions for PHP-5.3 on fedora 12
241
242 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
243 - * exclude DNS from subnet checking
244 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
245 - * allow longer abbreviated names
246 - * don't let empty strings kill the server (postgresql and apache)
247
248 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
249 - disable drupal user registration (hard: patching the user module)
250
251 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
252 - * show error messages for update interface
253 - * 'Add Node' is admin only
254 - * add site selector for 'Add Node'
255
256 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
257 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
258 - this affects the settings of ifname and alias that were formerly set unconditionally
259 - review the interface-checking javascript code
260 - changed the interface to plekitform, method is now optional and part of an options hash
261
262 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
263 - can't use php objects for showing node status, this is too slow
264 - fix interface add page
265
266 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
267 - consistency in the way nodes status is displayed in the node and slice areas
268 - extra tags columns show up on the nodes page as well, tweaked in the process
269 - roles management in person page fixed
270
271 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
272 - displaying node tags in the nodes page as well
273 - table headers now can have a 'title' that shows up when hovering on the column header
274
275 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
276 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
277
278 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
279 - extensible set of columns in the nodes area of the (my)slice page
280 - nodegroups can be added/deleted/updated
281 - tags management improved marginally
282
283 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
284 - fix pending sites page - was getting fooled by ext_consortium_id=None
285
286 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
287 - resetting tag as something went wrong when setting 31
288
289 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
290 - nicer look for slice creation, (public) sites
291 - users show with all their sites in the persons page
292
293 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
294 - reviewed registration pages for persons and sites
295
296 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
297 - increase memory limit in the nodes page
298
299 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
300 - fixes one typo
301
302 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
303 - minor/cosmetic
304
305 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
306 - Add default Interface tags to extra interfaces.
307 - Add clearer 'Add New PCU' link on node page.
308 - Disable user registration for tech and PI roles.
309
310 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
311 - new 'controller' instantiation state available in add slice page
312
313 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
314 - exclude datepicler.js from jsmin
315 - table sort function for Last Contact columns
316 - drop options for generic boot images
317
318 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
319 - displays editable mac address for interfaces
320 - properly sorts bandwidths
321 - new 'controller' slice instantiation method
322 - bugfix, division by zero when displaying a just-changed node
323
324 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
325 - bugfix with linetabs
326
327 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
328 - fix add interface from the node page
329
330 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
331 - only add users that are enabled and not yet a member of the slice
332 - fix to plc_peers
333 - my sites, my nodes, my persons improvements for users with multiple sites
334 - adds a script to minimize the java script files.
335
336 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
337 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
338
339 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
340 - first draft for pcu-handling features
341 - lighter contrat for PLE/PLC toggles
342 - as many 'my site'-like  links as the user has sites
343
344 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
345 - fix for whitelisted nodes
346 - now links to the node register wizard
347 - can enable sites
348 - various other minor fixes, like broken planetlab.module for techs, and login link
349
350 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
351 - plekittable knows how to turn off sort-on-load, and the admin users pages do
352 - + various cosmetic fixes
353
354 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
355 - a few minor improvements pushed on PLE
356
357 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
358 - fix for sites that were displayed as not public
359 - improvements to the python interface to sortable tables for monitor
360
361 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
362 - various improvements
363
364 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
365 - sliver page now correctly shows sliver tags
366 - support for download-node-usb-partition and various other improvements
367
368 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
369 - a few tweaks and typos fixed on PLE
370
371 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
372 - slice_add & node_download dialogs use plekit
373 - slice_add can add people in the slice
374 - various improvements after rollout on PLE
375
376 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
377 - cosmetic fixes to be in 4.3-rc2
378 - also a first (unpackaged) draft of the plekit table in python
379
380 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
381 - search in tables more robust
382
383 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
384 - performance improvements
385
386 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
387 - detect expired session and redirect to the login page
388
389 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
390 - improve browser health - was using too many cycles
391
392 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
393 - more consistency between views, and cosmetic changes
394
395 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
396 - area for managing slice tags
397
398 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
399 - first checkpoint tag for PLEWWW
400 - mostly functionally complete, probably a lot of tweaks still needed
401
402 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
403 - everyone is welcome to add nodes
404
405 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
406 - node-specific bootcd images to include arch in their name
407
408 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
409 - remove explicit dep to bootcd as the rpm name has changed
410
411 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
412 - noarch
413
414 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
415 - should fix yum.conf on nodes after install
416
417 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
418 - uses different path for getbootmedium results - should be safer
419
420 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
421 - comon icon replaced with the one from the comon website
422
423 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
424 - displays rpms in the about page
425
426 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
427 - safer, reference-less, way to implement layout mechnism - see
428 - settings.php for details
429 - setting types properly displayed according to user's role
430 - setting deletion : fixed (was still using code from slice attribute)
431 - more comon buttons : in the nodes and peers index pages
432 - comon_button knows about peer_id
433
434 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
435 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
436
437 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
438 - Initial build.