Setting tag plewww-4.3-45
[plewww.git] / plewww.spec
1 #
2 # $Id$
3 #
4
5 # what the myplc rpm requires
6 %define name plewww
7 %define version 4.3
8 %define taglevel 45
9
10 # no need to mention pldistro as this module differs in both distros
11 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %define release %{taglevel}%{?date:.%{date}}
13
14 Summary: PlanetLab Europe (PLC) Web Pages
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: Applications/Systems
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 BuildArch: noarch
23 BuildRequires: python
24
25 Vendor: OneLab
26 Packager: OneLab <support@one-lab.org>
27 Distribution: PlanetLab %{version}
28 URL: http://svn.one-lab.org/svn/new_plc_www/
29
30 # We use set everywhere
31 #Requires: httpd >= 2.0
32 Requires: php >= 5.0
33 Requires: postgresql >= 8.0
34 Requires: PLCAPI >= 4.3
35 Requires: drupal = 4.7
36 Requires: plewww-plekit
37
38 # this is what MyPLC requires
39 Provides: PLCWWW
40
41 # on centos5, when rebuilding the full monty, we get:
42 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
43 # and the perl-GD rpm is nowhere to be found
44 AutoReqProv: no
45
46 %package plekit
47 Summary: Utilities used by the plewww pages
48 Group: Applications/Systems
49
50 %description
51 The plewww package is made of the web pages that run on top of the 
52 PLCAPI component to provide the Web Interface to MyPLC users.
53
54 %description plekit
55 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
56
57 %prep
58 %setup -q
59
60 %build
61 echo "Compressing javascript files"
62 make compress
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 #
68 # plewww
69 # xxx : uninstall should undo this
70 #
71
72 echo "* PLEWWW: Installing web pages"
73 mkdir -p $RPM_BUILD_ROOT/var/www/html
74 # exclude codebase just in case
75 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
76
77 echo "* PLEWWW: Installing conf files for httpd"
78 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
79 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
80
81 %post
82 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
83 drupal_settings_dir=/var/www/html/sites/default
84 if [ ! -d $drupal_settings_dir ] ; then
85     echo "Could not find directory $drupal_settings_dir"
86     echo "This suggests that you do not have a planetlab-custom drupal installed"
87     exit 1
88 fi
89 pushd $drupal_settings_dir
90 # tune $db_url
91 if [ ! -f settings.php.drupal ] ; then
92     cp settings.php settings.php.drupal
93     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
94         settings.php.drupal > settings.php
95 fi
96 popd
97 # append our own database creation hacks to the drupal database schema
98 pushd /var/www/html/database
99 if [ ! -f database.pgsql.drupal ] ; then
100     cp database.pgsql database.pgsql.drupal
101     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
102 fi
103 popd
104 # hack the welcome page for MyPLC
105 pushd /var/www/html/modules
106 for module in user node; do
107     # backup only once
108     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
109     # always update so a change in our file can make through
110     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
111 done
112 popd
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(-,root,root,-)
119 /var/www/html/modules
120 /var/www/html/planetlab
121 /var/www/html/googlemap
122 /var/www/html/drupal-hacks
123 /etc/httpd/conf.d
124
125 %files plekit
126 /var/www/html/plekit
127
128 %changelog
129 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-45
130 - encode strings properly in forms.
131 - (also testing git module tagging)
132
133 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
134 - Use readfile() function to reduce the memory footprint
135
136 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
137 - removed all deprecated functions for PHP-5.3 on fedora 12
138
139 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
140 - * exclude DNS from subnet checking
141 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
142 - * allow longer abbreviated names
143 - * don't let empty strings kill the server (postgresql and apache)
144
145 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
146 - disable drupal user registration (hard: patching the user module)
147
148 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
149 - * show error messages for update interface
150 - * 'Add Node' is admin only
151 - * add site selector for 'Add Node'
152
153 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
154 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
155 - this affects the settings of ifname and alias that were formerly set unconditionally
156 - review the interface-checking javascript code
157 - changed the interface to plekitform, method is now optional and part of an options hash
158
159 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
160 - can't use php objects for showing node status, this is too slow
161 - fix interface add page
162
163 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
164 - consistency in the way nodes status is displayed in the node and slice areas
165 - extra tags columns show up on the nodes page as well, tweaked in the process
166 - roles management in person page fixed
167
168 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
169 - displaying node tags in the nodes page as well
170 - table headers now can have a 'title' that shows up when hovering on the column header
171
172 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
173 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
174
175 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
176 - extensible set of columns in the nodes area of the (my)slice page
177 - nodegroups can be added/deleted/updated
178 - tags management improved marginally
179
180 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
181 - fix pending sites page - was getting fooled by ext_consortium_id=None
182
183 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
184 - resetting tag as something went wrong when setting 31
185
186 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
187 - nicer look for slice creation, (public) sites
188 - users show with all their sites in the persons page
189
190 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
191 - reviewed registration pages for persons and sites
192
193 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
194 - increase memory limit in the nodes page
195
196 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
197 - fixes one typo
198
199 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
200 - minor/cosmetic
201
202 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
203 - Add default Interface tags to extra interfaces.
204 - Add clearer 'Add New PCU' link on node page.
205 - Disable user registration for tech and PI roles.
206
207 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
208 - new 'controller' instantiation state available in add slice page
209
210 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
211 - exclude datepicler.js from jsmin
212 - table sort function for Last Contact columns
213 - drop options for generic boot images
214
215 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
216 - displays editable mac address for interfaces
217 - properly sorts bandwidths
218 - new 'controller' slice instantiation method
219 - bugfix, division by zero when displaying a just-changed node
220
221 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
222 - bugfix with linetabs
223
224 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
225 - fix add interface from the node page
226
227 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
228 - only add users that are enabled and not yet a member of the slice
229 - fix to plc_peers
230 - my sites, my nodes, my persons improvements for users with multiple sites
231 - adds a script to minimize the java script files.
232
233 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
234 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
235
236 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
237 - first draft for pcu-handling features
238 - lighter contrat for PLE/PLC toggles
239 - as many 'my site'-like  links as the user has sites
240
241 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
242 - fix for whitelisted nodes
243 - now links to the node register wizard
244 - can enable sites
245 - various other minor fixes, like broken planetlab.module for techs, and login link
246
247 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
248 - plekittable knows how to turn off sort-on-load, and the admin users pages do
249 - + various cosmetic fixes
250
251 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
252 - a few minor improvements pushed on PLE
253
254 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
255 - fix for sites that were displayed as not public
256 - improvements to the python interface to sortable tables for monitor
257
258 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
259 - various improvements
260
261 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
262 - sliver page now correctly shows sliver tags
263 - support for download-node-usb-partition and various other improvements
264
265 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
266 - a few tweaks and typos fixed on PLE
267
268 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
269 - slice_add & node_download dialogs use plekit
270 - slice_add can add people in the slice
271 - various improvements after rollout on PLE
272
273 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
274 - cosmetic fixes to be in 4.3-rc2
275 - also a first (unpackaged) draft of the plekit table in python
276
277 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
278 - search in tables more robust
279
280 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
281 - performance improvements
282
283 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
284 - detect expired session and redirect to the login page
285
286 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
287 - improve browser health - was using too many cycles
288
289 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
290 - more consistency between views, and cosmetic changes
291
292 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
293 - area for managing slice tags
294
295 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
296 - first checkpoint tag for PLEWWW
297 - mostly functionally complete, probably a lot of tweaks still needed
298
299 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
300 - everyone is welcome to add nodes
301
302 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
303 - node-specific bootcd images to include arch in their name
304
305 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
306 - remove explicit dep to bootcd as the rpm name has changed
307
308 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
309 - noarch
310
311 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
312 - should fix yum.conf on nodes after install
313
314 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
315 - uses different path for getbootmedium results - should be safer
316
317 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
318 - comon icon replaced with the one from the comon website
319
320 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
321 - displays rpms in the about page
322
323 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
324 - safer, reference-less, way to implement layout mechnism - see
325 - settings.php for details
326 - setting types properly displayed according to user's role
327 - setting deletion : fixed (was still using code from slice attribute)
328 - more comon buttons : in the nodes and peers index pages
329 - comon_button knows about peer_id
330
331 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
332 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
333
334 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
335 - Initial build.