adding ed in the mix so we can patch drupal session code
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 9
5
6 # no need to mention pldistro as this module differs in both distros
7 %define release %{taglevel}%{?date:.%{date}}
8
9 Summary: PlanetLab Europe (PLC) Web Pages
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: Applications/Systems
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17 BuildArch: noarch
18 BuildRequires: python
19 # for patching drupal session code
20 BuildRequires: ed
21
22 Vendor: OneLab
23 Packager: OneLab <support@one-lab.org>
24 Distribution: PlanetLab %{version}
25 URL: %{SCMURL}
26
27 # We use set everywhere
28 #Requires: httpd >= 2.0
29 Requires: php >= 5.0
30 Requires: postgresql >= 8.0
31 Requires: plcapi >= 5.2
32 Requires: drupal = 4.7
33 Requires: plewww-plekit
34
35 # this is what MyPLC requires
36 Provides: PLCWWW
37
38 # on centos5, when rebuilding the full monty, we get:
39 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
40 # and the perl-GD rpm is nowhere to be found
41 AutoReqProv: no
42
43 %package plekit
44 Summary: Utilities used by the plewww pages
45 Group: Applications/Systems
46
47 %description
48 The plewww package is made of the web pages that run on top of the 
49 PLCAPI component to provide the Web Interface to MyPLC users.
50
51 %description plekit
52 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
53
54 %prep
55 %setup -q
56
57 %build
58 echo "Compressing javascript files"
59 make compress
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 #
65 # plewww
66 # xxx : uninstall should undo this
67 #
68
69 echo "* PLEWWW: Installing web pages"
70 mkdir -p $RPM_BUILD_ROOT/var/www/html
71 # exclude codebase just in case
72 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
73
74 echo "* PLEWWW: Installing conf files for httpd"
75 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
76 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
77
78 %post
79 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
80 drupal_settings_dir=/var/www/html/sites/default
81 if [ ! -d $drupal_settings_dir ] ; then
82     echo "Could not find directory $drupal_settings_dir"
83     echo "This suggests that you do not have a planetlab-custom drupal installed"
84     exit 1
85 fi
86 pushd $drupal_settings_dir
87 # tune $db_url
88 if [ ! -f settings.php.drupal ] ; then
89     cp settings.php settings.php.drupal
90     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
91         settings.php.drupal > settings.php
92 fi
93 popd
94 # append our own database creation hacks to the drupal database schema
95 pushd /var/www/html/database
96 if [ ! -f database.pgsql.drupal ] ; then
97     cp database.pgsql database.pgsql.drupal
98     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
99 fi
100 popd
101 # hack the welcome page for MyPLC
102 pushd /var/www/html/modules
103 for module in user node; do
104     # backup only once
105     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
106     # always update so a change in our file can make through
107     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
108 done
109 popd
110 # hack drupal's session handler for php8
111 pushd /var/www/html/includes
112 bash /var/www/html/drupal-hacks/patch-session-inc.sh
113 popd
114 # create myslice.log and change its ownership
115 mkdir -p /var/log/myslice
116 touch /var/log/myslice/myslice.log
117 chown apache:apache /var/log/myslice/myslice.log
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(-,root,root,-)
124 /var/www/html/modules
125 /var/www/html/planetlab
126 /var/www/html/googlemap
127 /var/www/html/drupal-hacks
128 /etc/httpd/conf.d
129
130 %files plekit
131 /var/www/html/plekit
132
133 %changelog
134 * Wed May 16 2018 Thierry <Parmentelat> - plewww-5.2-9
135 - not too clean patches for r2lab:
136 - * search for a file named /etc/planetlab/php/person-registration.txt
137 - that can override the text message for individuals registration
138 - * do not list sites that have the disabled_registration tag set
139 - when listing them for individuals registration
140 - remove omf-friendly checkbox in slice-creation dialog
141 - comment out {Min,Max}SpareServers settings in httpd config
142
143 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-8
144 - a few niceties, thanks to Ciro
145
146 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-7
147 - remove utf8_deode as per Thomas's suggestion
148
149 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-6
150 - Offer the option to set a node in 'upgrade' mode - like reinstall but leaving slices intact
151
152 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-5
153 - tweaks in node_downloads.php about memory size and compression scheme
154
155 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-4
156 - googlemap widget: support for gmap api v3 + various cosmetic tweaks
157 - can display site names with odd characters
158
159 * Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
160 - typo in help message about initscripts
161
162 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
163 - node page and person page show hrn in details
164
165 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
166 - late fix of registration for plcapi-5.1-6
167
168 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
169 - add extra code to prevent confidentiality leaks
170 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
171 - return_url for add-person and remove-person
172 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
173
174 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
175 - add tags section on site and person pages
176
177 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
178 - slightly tweak profiling points in slice.php
179
180 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
181 - ships with new default images for PLC/PLE from planet-lab.eu
182
183 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
184 - no change, just make sync for lxc-hosted tests
185
186 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
187 - refactoring for tophat/columns
188 - should take care of the irritating warning message about columns
189
190 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
191 - do not display the 'node' role when confusing
192
193 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
194 - support for setting nodes as reservable
195 - rely more on previous state when deciding to open or not toggles in a view
196 - remove statements for setting maximum memory usage, that sometimes
197
198 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
199 - node page can edit interfaces even when no interface
200
201 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
202 - uses a 2-week (!) session
203
204 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
205 - minor/cosmetic fixes in the leases area
206
207 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
208 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
209 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
210 - has a feature to 'test' pcu connection
211 - only admins can add users to different sites.
212 - remove dep. to outdated _gen_planetflow.php
213 - rephrased (disabled, or pending registration)
214 - + various fixes
215
216 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
217 - fix display glitch exposed with dimes initscript
218
219 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
220 - rename initscript_body into initscript_code
221
222 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
223 - bugfix for the reservation interface
224
225 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
226 - reservation page uses ajax - no need to reload after submit
227 - reservation dialogs for offset in the future & # slots
228 - fix the timezone in reservations (actually use php.ini)
229 - reservation visible (and hardwired) in nodes view
230 - have pulled prototype 1.7 but not in used yet
231
232 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
233 - set both 'omf_control' and 'vref' for omf-friendly slices
234
235 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
236 - display tags in alphabetic order in node view, tags section, the drop down menu
237
238 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
239 - on-the-fly retrieval of data at comon & tophat (unused so far)
240 - use accessors to store person's preference of columns
241 - fix in toggle.js for the '?' button, node table layout tab
242 - sort actions logging improved
243
244 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
245 - keep people from disabling or deleting themselves
246 - cannot become a disabled person
247 - outline people without a role
248
249 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
250 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
251
252 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
253 - tagging plewww for a new deployment
254
255 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
256 - add a 'report a problem' link for the RebootNode button
257 - new exp page nodes2.php with consistent selectable-columns layout as myslice
258 - tweaks in the exp. myslice (slices.php)
259
260 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
261 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
262 - my_slice with adjustable set of columns in slices/slice2.php
263 - fix for the 'site registration' page
264
265 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
266 - show message about leases - leases tab first in nodes section
267 - fix how reservable nodes show up
268
269 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
270 - cosmetic, rendering of textareas was like password fields
271
272 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
273 - bugfix in slice page, had wrong (null) expiration date
274 - upgraded to raphael-1.5.2, don't minimize this lib
275 - nicer layout for password fields as well
276 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
277 - marginally optimized slice page (2 GetNodes call down)
278 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
279 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
280 - reservations can cope with a bit more slots - will need scrolling someday
281 - omf text has hyperlinks to the tools
282
283 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
284 - reservation section now effective
285 - can set omf_control at slice-creation time
286 - can set node as reservable at node-creation time
287 - nicer text input fields + various tweaks
288
289 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
290 - show nodegroups form to add new groups
291
292 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
293 - just tagging plewww again to test module-tag on git
294
295 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
296 - encode strings properly in forms.
297
298 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
299 - Use readfile() function to reduce the memory footprint
300
301 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
302 - removed all deprecated functions for PHP-5.3 on fedora 12
303
304 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
305 - * exclude DNS from subnet checking
306 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
307 - * allow longer abbreviated names
308 - * don't let empty strings kill the server (postgresql and apache)
309
310 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
311 - disable drupal user registration (hard: patching the user module)
312
313 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
314 - * show error messages for update interface
315 - * 'Add Node' is admin only
316 - * add site selector for 'Add Node'
317
318 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
319 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
320 - this affects the settings of ifname and alias that were formerly set unconditionally
321 - review the interface-checking javascript code
322 - changed the interface to plekitform, method is now optional and part of an options hash
323
324 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
325 - can't use php objects for showing node status, this is too slow
326 - fix interface add page
327
328 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
329 - consistency in the way nodes status is displayed in the node and slice areas
330 - extra tags columns show up on the nodes page as well, tweaked in the process
331 - roles management in person page fixed
332
333 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
334 - displaying node tags in the nodes page as well
335 - table headers now can have a 'title' that shows up when hovering on the column header
336
337 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
338 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
339
340 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
341 - extensible set of columns in the nodes area of the (my)slice page
342 - nodegroups can be added/deleted/updated
343 - tags management improved marginally
344
345 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
346 - fix pending sites page - was getting fooled by ext_consortium_id=None
347
348 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
349 - resetting tag as something went wrong when setting 31
350
351 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
352 - nicer look for slice creation, (public) sites
353 - users show with all their sites in the persons page
354
355 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
356 - reviewed registration pages for persons and sites
357
358 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
359 - increase memory limit in the nodes page
360
361 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
362 - fixes one typo
363
364 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
365 - minor/cosmetic
366
367 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
368 - Add default Interface tags to extra interfaces.
369 - Add clearer 'Add New PCU' link on node page.
370 - Disable user registration for tech and PI roles.
371
372 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
373 - new 'controller' instantiation state available in add slice page
374
375 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
376 - exclude datepicler.js from jsmin
377 - table sort function for Last Contact columns
378 - drop options for generic boot images
379
380 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
381 - displays editable mac address for interfaces
382 - properly sorts bandwidths
383 - new 'controller' slice instantiation method
384 - bugfix, division by zero when displaying a just-changed node
385
386 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
387 - bugfix with linetabs
388
389 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
390 - fix add interface from the node page
391
392 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
393 - only add users that are enabled and not yet a member of the slice
394 - fix to plc_peers
395 - my sites, my nodes, my persons improvements for users with multiple sites
396 - adds a script to minimize the java script files.
397
398 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
399 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
400
401 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
402 - first draft for pcu-handling features
403 - lighter contrat for PLE/PLC toggles
404 - as many 'my site'-like  links as the user has sites
405
406 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
407 - fix for whitelisted nodes
408 - now links to the node register wizard
409 - can enable sites
410 - various other minor fixes, like broken planetlab.module for techs, and login link
411
412 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
413 - plekittable knows how to turn off sort-on-load, and the admin users pages do
414 - + various cosmetic fixes
415
416 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
417 - a few minor improvements pushed on PLE
418
419 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
420 - fix for sites that were displayed as not public
421 - improvements to the python interface to sortable tables for monitor
422
423 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
424 - various improvements
425
426 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
427 - sliver page now correctly shows sliver tags
428 - support for download-node-usb-partition and various other improvements
429
430 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
431 - a few tweaks and typos fixed on PLE
432
433 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
434 - slice_add & node_download dialogs use plekit
435 - slice_add can add people in the slice
436 - various improvements after rollout on PLE
437
438 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
439 - cosmetic fixes to be in 4.3-rc2
440 - also a first (unpackaged) draft of the plekit table in python
441
442 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
443 - search in tables more robust
444
445 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
446 - performance improvements
447
448 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
449 - detect expired session and redirect to the login page
450
451 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
452 - improve browser health - was using too many cycles
453
454 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
455 - more consistency between views, and cosmetic changes
456
457 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
458 - area for managing slice tags
459
460 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
461 - first checkpoint tag for PLEWWW
462 - mostly functionally complete, probably a lot of tweaks still needed
463
464 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
465 - everyone is welcome to add nodes
466
467 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
468 - node-specific bootcd images to include arch in their name
469
470 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
471 - remove explicit dep to bootcd as the rpm name has changed
472
473 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
474 - noarch
475
476 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
477 - should fix yum.conf on nodes after install
478
479 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
480 - uses different path for getbootmedium results - should be safer
481
482 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
483 - comon icon replaced with the one from the comon website
484
485 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
486 - displays rpms in the about page
487
488 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
489 - safer, reference-less, way to implement layout mechnism - see
490 - settings.php for details
491 - setting types properly displayed according to user's role
492 - setting deletion : fixed (was still using code from slice attribute)
493 - more comon buttons : in the nodes and peers index pages
494 - comon_button knows about peer_id
495
496 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
497 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
498
499 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
500 - Initial build.