Setting tag plewww-4.3-54
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 54
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(-,root,root,-)
115 /var/www/html/modules
116 /var/www/html/planetlab
117 /var/www/html/googlemap
118 /var/www/html/drupal-hacks
119 /etc/httpd/conf.d
120
121 %files plekit
122 /var/www/html/plekit
123
124 %changelog
125 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
126 - tagging plewww for a new deployment
127
128 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
129 - add a 'report a problem' link for the RebootNode button
130 - new exp page nodes2.php with consistent selectable-columns layout as myslice
131 - tweaks in the exp. myslice (slices.php)
132
133 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
134 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
135 - my_slice with adjustable set of columns in slices/slice2.php
136 - fix for the 'site registration' page
137
138 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
139 - show message about leases - leases tab first in nodes section
140 - fix how reservable nodes show up
141
142 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
143 - cosmetic, rendering of textareas was like password fields
144
145 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
146 - bugfix in slice page, had wrong (null) expiration date
147 - upgraded to raphael-1.5.2, don't minimize this lib
148 - nicer layout for password fields as well
149 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
150 - marginally optimized slice page (2 GetNodes call down)
151 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
152 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
153 - reservations can cope with a bit more slots - will need scrolling someday
154 - omf text has hyperlinks to the tools
155
156 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
157 - reservation section now effective
158 - can set omf_control at slice-creation time
159 - can set node as reservable at node-creation time
160 - nicer text input fields + various tweaks
161
162 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
163 - show nodegroups form to add new groups
164
165 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
166 - just tagging plewww again to test module-tag on git
167
168 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
169 - encode strings properly in forms.
170
171 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
172 - Use readfile() function to reduce the memory footprint
173
174 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
175 - removed all deprecated functions for PHP-5.3 on fedora 12
176
177 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
178 - * exclude DNS from subnet checking
179 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
180 - * allow longer abbreviated names
181 - * don't let empty strings kill the server (postgresql and apache)
182
183 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
184 - disable drupal user registration (hard: patching the user module)
185
186 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
187 - * show error messages for update interface
188 - * 'Add Node' is admin only
189 - * add site selector for 'Add Node'
190
191 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
192 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
193 - this affects the settings of ifname and alias that were formerly set unconditionally
194 - review the interface-checking javascript code
195 - changed the interface to plekitform, method is now optional and part of an options hash
196
197 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
198 - can't use php objects for showing node status, this is too slow
199 - fix interface add page
200
201 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
202 - consistency in the way nodes status is displayed in the node and slice areas
203 - extra tags columns show up on the nodes page as well, tweaked in the process
204 - roles management in person page fixed
205
206 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
207 - displaying node tags in the nodes page as well
208 - table headers now can have a 'title' that shows up when hovering on the column header
209
210 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
211 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
212
213 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
214 - extensible set of columns in the nodes area of the (my)slice page
215 - nodegroups can be added/deleted/updated
216 - tags management improved marginally
217
218 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
219 - fix pending sites page - was getting fooled by ext_consortium_id=None
220
221 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
222 - resetting tag as something went wrong when setting 31
223
224 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
225 - nicer look for slice creation, (public) sites
226 - users show with all their sites in the persons page
227
228 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
229 - reviewed registration pages for persons and sites
230
231 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
232 - increase memory limit in the nodes page
233
234 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
235 - fixes one typo
236
237 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
238 - minor/cosmetic
239
240 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
241 - Add default Interface tags to extra interfaces.
242 - Add clearer 'Add New PCU' link on node page.
243 - Disable user registration for tech and PI roles.
244
245 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
246 - new 'controller' instantiation state available in add slice page
247
248 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
249 - exclude datepicler.js from jsmin
250 - table sort function for Last Contact columns
251 - drop options for generic boot images
252
253 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
254 - displays editable mac address for interfaces
255 - properly sorts bandwidths
256 - new 'controller' slice instantiation method
257 - bugfix, division by zero when displaying a just-changed node
258
259 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
260 - bugfix with linetabs
261
262 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
263 - fix add interface from the node page
264
265 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
266 - only add users that are enabled and not yet a member of the slice
267 - fix to plc_peers
268 - my sites, my nodes, my persons improvements for users with multiple sites
269 - adds a script to minimize the java script files.
270
271 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
272 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
273
274 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
275 - first draft for pcu-handling features
276 - lighter contrat for PLE/PLC toggles
277 - as many 'my site'-like  links as the user has sites
278
279 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
280 - fix for whitelisted nodes
281 - now links to the node register wizard
282 - can enable sites
283 - various other minor fixes, like broken planetlab.module for techs, and login link
284
285 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
286 - plekittable knows how to turn off sort-on-load, and the admin users pages do
287 - + various cosmetic fixes
288
289 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
290 - a few minor improvements pushed on PLE
291
292 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
293 - fix for sites that were displayed as not public
294 - improvements to the python interface to sortable tables for monitor
295
296 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
297 - various improvements
298
299 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
300 - sliver page now correctly shows sliver tags
301 - support for download-node-usb-partition and various other improvements
302
303 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
304 - a few tweaks and typos fixed on PLE
305
306 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
307 - slice_add & node_download dialogs use plekit
308 - slice_add can add people in the slice
309 - various improvements after rollout on PLE
310
311 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
312 - cosmetic fixes to be in 4.3-rc2
313 - also a first (unpackaged) draft of the plekit table in python
314
315 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
316 - search in tables more robust
317
318 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
319 - performance improvements
320
321 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
322 - detect expired session and redirect to the login page
323
324 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
325 - improve browser health - was using too many cycles
326
327 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
328 - more consistency between views, and cosmetic changes
329
330 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
331 - area for managing slice tags
332
333 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
334 - first checkpoint tag for PLEWWW
335 - mostly functionally complete, probably a lot of tweaks still needed
336
337 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
338 - everyone is welcome to add nodes
339
340 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
341 - node-specific bootcd images to include arch in their name
342
343 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
344 - remove explicit dep to bootcd as the rpm name has changed
345
346 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
347 - noarch
348
349 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
350 - should fix yum.conf on nodes after install
351
352 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
353 - uses different path for getbootmedium results - should be safer
354
355 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
356 - comon icon replaced with the one from the comon website
357
358 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
359 - displays rpms in the about page
360
361 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
362 - safer, reference-less, way to implement layout mechnism - see
363 - settings.php for details
364 - setting types properly displayed according to user's role
365 - setting deletion : fixed (was still using code from slice attribute)
366 - more comon buttons : in the nodes and peers index pages
367 - comon_button knows about peer_id
368
369 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
370 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
371
372 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
373 - Initial build.