PLCAPI is now plcapi
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 0
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: plcapi >= 5.2
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
129 - add extra code to prevent confidentiality leaks
130 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
131 - return_url for add-person and remove-person
132 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
133
134 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
135 - add tags section on site and person pages
136
137 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
138 - slightly tweak profiling points in slice.php
139
140 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
141 - ships with new default images for PLC/PLE from planet-lab.eu
142
143 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
144 - no change, just make sync for lxc-hosted tests
145
146 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
147 - refactoring for tophat/columns
148 - should take care of the irritating warning message about columns
149
150 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
151 - do not display the 'node' role when confusing
152
153 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
154 - support for setting nodes as reservable
155 - rely more on previous state when deciding to open or not toggles in a view
156 - remove statements for setting maximum memory usage, that sometimes
157
158 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
159 - node page can edit interfaces even when no interface
160
161 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
162 - uses a 2-week (!) session
163
164 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
165 - minor/cosmetic fixes in the leases area
166
167 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
168 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
169 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
170 - has a feature to 'test' pcu connection
171 - only admins can add users to different sites.
172 - remove dep. to outdated _gen_planetflow.php
173 - rephrased (disabled, or pending registration)
174 - + various fixes
175
176 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
177 - fix display glitch exposed with dimes initscript
178
179 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
180 - rename initscript_body into initscript_code
181
182 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
183 - bugfix for the reservation interface
184
185 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
186 - reservation page uses ajax - no need to reload after submit
187 - reservation dialogs for offset in the future & # slots
188 - fix the timezone in reservations (actually use php.ini)
189 - reservation visible (and hardwired) in nodes view
190 - have pulled prototype 1.7 but not in used yet
191
192 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
193 - set both 'omf_control' and 'vref' for omf-friendly slices
194
195 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
196 - display tags in alphabetic order in node view, tags section, the drop down menu
197
198 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
199 - on-the-fly retrieval of data at comon & tophat (unused so far)
200 - use accessors to store person's preference of columns
201 - fix in toggle.js for the '?' button, node table layout tab
202 - sort actions logging improved
203
204 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
205 - keep people from disabling or deleting themselves
206 - cannot become a disabled person
207 - outline people without a role
208
209 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
210 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
211
212 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
213 - tagging plewww for a new deployment
214
215 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
216 - add a 'report a problem' link for the RebootNode button
217 - new exp page nodes2.php with consistent selectable-columns layout as myslice
218 - tweaks in the exp. myslice (slices.php)
219
220 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
221 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
222 - my_slice with adjustable set of columns in slices/slice2.php
223 - fix for the 'site registration' page
224
225 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
226 - show message about leases - leases tab first in nodes section
227 - fix how reservable nodes show up
228
229 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
230 - cosmetic, rendering of textareas was like password fields
231
232 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
233 - bugfix in slice page, had wrong (null) expiration date
234 - upgraded to raphael-1.5.2, don't minimize this lib
235 - nicer layout for password fields as well
236 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
237 - marginally optimized slice page (2 GetNodes call down)
238 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
239 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
240 - reservations can cope with a bit more slots - will need scrolling someday
241 - omf text has hyperlinks to the tools
242
243 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
244 - reservation section now effective
245 - can set omf_control at slice-creation time
246 - can set node as reservable at node-creation time
247 - nicer text input fields + various tweaks
248
249 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
250 - show nodegroups form to add new groups
251
252 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
253 - just tagging plewww again to test module-tag on git
254
255 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
256 - encode strings properly in forms.
257
258 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
259 - Use readfile() function to reduce the memory footprint
260
261 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
262 - removed all deprecated functions for PHP-5.3 on fedora 12
263
264 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
265 - * exclude DNS from subnet checking
266 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
267 - * allow longer abbreviated names
268 - * don't let empty strings kill the server (postgresql and apache)
269
270 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
271 - disable drupal user registration (hard: patching the user module)
272
273 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
274 - * show error messages for update interface
275 - * 'Add Node' is admin only
276 - * add site selector for 'Add Node'
277
278 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
279 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
280 - this affects the settings of ifname and alias that were formerly set unconditionally
281 - review the interface-checking javascript code
282 - changed the interface to plekitform, method is now optional and part of an options hash
283
284 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
285 - can't use php objects for showing node status, this is too slow
286 - fix interface add page
287
288 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
289 - consistency in the way nodes status is displayed in the node and slice areas
290 - extra tags columns show up on the nodes page as well, tweaked in the process
291 - roles management in person page fixed
292
293 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
294 - displaying node tags in the nodes page as well
295 - table headers now can have a 'title' that shows up when hovering on the column header
296
297 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
298 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
299
300 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
301 - extensible set of columns in the nodes area of the (my)slice page
302 - nodegroups can be added/deleted/updated
303 - tags management improved marginally
304
305 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
306 - fix pending sites page - was getting fooled by ext_consortium_id=None
307
308 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
309 - resetting tag as something went wrong when setting 31
310
311 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
312 - nicer look for slice creation, (public) sites
313 - users show with all their sites in the persons page
314
315 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
316 - reviewed registration pages for persons and sites
317
318 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
319 - increase memory limit in the nodes page
320
321 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
322 - fixes one typo
323
324 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
325 - minor/cosmetic
326
327 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
328 - Add default Interface tags to extra interfaces.
329 - Add clearer 'Add New PCU' link on node page.
330 - Disable user registration for tech and PI roles.
331
332 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
333 - new 'controller' instantiation state available in add slice page
334
335 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
336 - exclude datepicler.js from jsmin
337 - table sort function for Last Contact columns
338 - drop options for generic boot images
339
340 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
341 - displays editable mac address for interfaces
342 - properly sorts bandwidths
343 - new 'controller' slice instantiation method
344 - bugfix, division by zero when displaying a just-changed node
345
346 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
347 - bugfix with linetabs
348
349 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
350 - fix add interface from the node page
351
352 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
353 - only add users that are enabled and not yet a member of the slice
354 - fix to plc_peers
355 - my sites, my nodes, my persons improvements for users with multiple sites
356 - adds a script to minimize the java script files.
357
358 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
359 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
360
361 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
362 - first draft for pcu-handling features
363 - lighter contrat for PLE/PLC toggles
364 - as many 'my site'-like  links as the user has sites
365
366 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
367 - fix for whitelisted nodes
368 - now links to the node register wizard
369 - can enable sites
370 - various other minor fixes, like broken planetlab.module for techs, and login link
371
372 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
373 - plekittable knows how to turn off sort-on-load, and the admin users pages do
374 - + various cosmetic fixes
375
376 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
377 - a few minor improvements pushed on PLE
378
379 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
380 - fix for sites that were displayed as not public
381 - improvements to the python interface to sortable tables for monitor
382
383 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
384 - various improvements
385
386 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
387 - sliver page now correctly shows sliver tags
388 - support for download-node-usb-partition and various other improvements
389
390 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
391 - a few tweaks and typos fixed on PLE
392
393 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
394 - slice_add & node_download dialogs use plekit
395 - slice_add can add people in the slice
396 - various improvements after rollout on PLE
397
398 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
399 - cosmetic fixes to be in 4.3-rc2
400 - also a first (unpackaged) draft of the plekit table in python
401
402 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
403 - search in tables more robust
404
405 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
406 - performance improvements
407
408 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
409 - detect expired session and redirect to the login page
410
411 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
412 - improve browser health - was using too many cycles
413
414 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
415 - more consistency between views, and cosmetic changes
416
417 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
418 - area for managing slice tags
419
420 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
421 - first checkpoint tag for PLEWWW
422 - mostly functionally complete, probably a lot of tweaks still needed
423
424 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
425 - everyone is welcome to add nodes
426
427 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
428 - node-specific bootcd images to include arch in their name
429
430 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
431 - remove explicit dep to bootcd as the rpm name has changed
432
433 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
434 - noarch
435
436 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
437 - should fix yum.conf on nodes after install
438
439 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
440 - uses different path for getbootmedium results - should be safer
441
442 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
443 - comon icon replaced with the one from the comon website
444
445 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
446 - displays rpms in the about page
447
448 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
449 - safer, reference-less, way to implement layout mechnism - see
450 - settings.php for details
451 - setting types properly displayed according to user's role
452 - setting deletion : fixed (was still using code from slice attribute)
453 - more comon buttons : in the nodes and peers index pages
454 - comon_button knows about peer_id
455
456 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
457 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
458
459 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
460 - Initial build.