Setting tag plewww-4.3-59
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 59
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
129 - set both 'omf_control' and 'vref' for omf-friendly slices
130
131 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
132 - display tags in alphabetic order in node view, tags section, the drop down menu
133
134 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
135 - on-the-fly retrieval of data at comon & tophat (unused so far)
136 - use accessors to store person's preference of columns
137 - fix in toggle.js for the '?' button, node table layout tab
138 - sort actions logging improved
139
140 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
141 - keep people from disabling or deleting themselves
142 - cannot become a disabled person
143 - outline people without a role
144
145 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
146 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
147
148 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
149 - tagging plewww for a new deployment
150
151 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
152 - add a 'report a problem' link for the RebootNode button
153 - new exp page nodes2.php with consistent selectable-columns layout as myslice
154 - tweaks in the exp. myslice (slices.php)
155
156 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
157 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
158 - my_slice with adjustable set of columns in slices/slice2.php
159 - fix for the 'site registration' page
160
161 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
162 - show message about leases - leases tab first in nodes section
163 - fix how reservable nodes show up
164
165 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
166 - cosmetic, rendering of textareas was like password fields
167
168 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
169 - bugfix in slice page, had wrong (null) expiration date
170 - upgraded to raphael-1.5.2, don't minimize this lib
171 - nicer layout for password fields as well
172 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
173 - marginally optimized slice page (2 GetNodes call down)
174 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
175 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
176 - reservations can cope with a bit more slots - will need scrolling someday
177 - omf text has hyperlinks to the tools
178
179 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
180 - reservation section now effective
181 - can set omf_control at slice-creation time
182 - can set node as reservable at node-creation time
183 - nicer text input fields + various tweaks
184
185 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
186 - show nodegroups form to add new groups
187
188 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
189 - just tagging plewww again to test module-tag on git
190
191 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
192 - encode strings properly in forms.
193
194 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
195 - Use readfile() function to reduce the memory footprint
196
197 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
198 - removed all deprecated functions for PHP-5.3 on fedora 12
199
200 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
201 - * exclude DNS from subnet checking
202 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
203 - * allow longer abbreviated names
204 - * don't let empty strings kill the server (postgresql and apache)
205
206 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
207 - disable drupal user registration (hard: patching the user module)
208
209 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
210 - * show error messages for update interface
211 - * 'Add Node' is admin only
212 - * add site selector for 'Add Node'
213
214 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
215 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
216 - this affects the settings of ifname and alias that were formerly set unconditionally
217 - review the interface-checking javascript code
218 - changed the interface to plekitform, method is now optional and part of an options hash
219
220 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
221 - can't use php objects for showing node status, this is too slow
222 - fix interface add page
223
224 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
225 - consistency in the way nodes status is displayed in the node and slice areas
226 - extra tags columns show up on the nodes page as well, tweaked in the process
227 - roles management in person page fixed
228
229 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
230 - displaying node tags in the nodes page as well
231 - table headers now can have a 'title' that shows up when hovering on the column header
232
233 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
234 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
235
236 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
237 - extensible set of columns in the nodes area of the (my)slice page
238 - nodegroups can be added/deleted/updated
239 - tags management improved marginally
240
241 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
242 - fix pending sites page - was getting fooled by ext_consortium_id=None
243
244 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
245 - resetting tag as something went wrong when setting 31
246
247 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
248 - nicer look for slice creation, (public) sites
249 - users show with all their sites in the persons page
250
251 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
252 - reviewed registration pages for persons and sites
253
254 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
255 - increase memory limit in the nodes page
256
257 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
258 - fixes one typo
259
260 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
261 - minor/cosmetic
262
263 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
264 - Add default Interface tags to extra interfaces.
265 - Add clearer 'Add New PCU' link on node page.
266 - Disable user registration for tech and PI roles.
267
268 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
269 - new 'controller' instantiation state available in add slice page
270
271 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
272 - exclude datepicler.js from jsmin
273 - table sort function for Last Contact columns
274 - drop options for generic boot images
275
276 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
277 - displays editable mac address for interfaces
278 - properly sorts bandwidths
279 - new 'controller' slice instantiation method
280 - bugfix, division by zero when displaying a just-changed node
281
282 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
283 - bugfix with linetabs
284
285 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
286 - fix add interface from the node page
287
288 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
289 - only add users that are enabled and not yet a member of the slice
290 - fix to plc_peers
291 - my sites, my nodes, my persons improvements for users with multiple sites
292 - adds a script to minimize the java script files.
293
294 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
295 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
296
297 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
298 - first draft for pcu-handling features
299 - lighter contrat for PLE/PLC toggles
300 - as many 'my site'-like  links as the user has sites
301
302 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
303 - fix for whitelisted nodes
304 - now links to the node register wizard
305 - can enable sites
306 - various other minor fixes, like broken planetlab.module for techs, and login link
307
308 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
309 - plekittable knows how to turn off sort-on-load, and the admin users pages do
310 - + various cosmetic fixes
311
312 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
313 - a few minor improvements pushed on PLE
314
315 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
316 - fix for sites that were displayed as not public
317 - improvements to the python interface to sortable tables for monitor
318
319 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
320 - various improvements
321
322 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
323 - sliver page now correctly shows sliver tags
324 - support for download-node-usb-partition and various other improvements
325
326 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
327 - a few tweaks and typos fixed on PLE
328
329 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
330 - slice_add & node_download dialogs use plekit
331 - slice_add can add people in the slice
332 - various improvements after rollout on PLE
333
334 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
335 - cosmetic fixes to be in 4.3-rc2
336 - also a first (unpackaged) draft of the plekit table in python
337
338 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
339 - search in tables more robust
340
341 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
342 - performance improvements
343
344 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
345 - detect expired session and redirect to the login page
346
347 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
348 - improve browser health - was using too many cycles
349
350 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
351 - more consistency between views, and cosmetic changes
352
353 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
354 - area for managing slice tags
355
356 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
357 - first checkpoint tag for PLEWWW
358 - mostly functionally complete, probably a lot of tweaks still needed
359
360 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
361 - everyone is welcome to add nodes
362
363 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
364 - node-specific bootcd images to include arch in their name
365
366 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
367 - remove explicit dep to bootcd as the rpm name has changed
368
369 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
370 - noarch
371
372 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
373 - should fix yum.conf on nodes after install
374
375 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
376 - uses different path for getbootmedium results - should be safer
377
378 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
379 - comon icon replaced with the one from the comon website
380
381 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
382 - displays rpms in the about page
383
384 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
385 - safer, reference-less, way to implement layout mechnism - see
386 - settings.php for details
387 - setting types properly displayed according to user's role
388 - setting deletion : fixed (was still using code from slice attribute)
389 - more comon buttons : in the nodes and peers index pages
390 - comon_button knows about peer_id
391
392 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
393 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
394
395 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
396 - Initial build.