this one was lingering too
[plewww.git] / plewww.spec
1 #
2 # $Id$
3 #
4
5 # what the myplc rpm requires
6 %define name plewww
7 %define version 4.3
8 %define taglevel 40
9
10 # no need to mention pldistro as this module differs in both distros
11 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %define release %{taglevel}%{?date:.%{date}}
13
14 Summary: PlanetLab Europe (PLC) Web Pages
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: Applications/Systems
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 BuildArch: noarch
23 BuildRequires: python
24
25 Vendor: OneLab
26 Packager: OneLab <support@one-lab.org>
27 Distribution: PlanetLab %{version}
28 URL: http://svn.one-lab.org/svn/new_plc_www/
29
30 # We use set everywhere
31 #Requires: httpd >= 2.0
32 Requires: php >= 5.0
33 Requires: postgresql >= 8.0
34 Requires: PLCAPI >= 4.3
35 Requires: drupal = 4.7
36 Requires: plewww-plekit
37
38 # this is what MyPLC requires
39 Provides: PLCWWW
40
41 # on centos5, when rebuilding the full monty, we get:
42 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
43 # and the perl-GD rpm is nowhere to be found
44 AutoReqProv: no
45
46 %package plekit
47 Summary: Utilities used by the plewww pages
48 Group: Applications/Systems
49
50 %description
51 The plewww package is made of the web pages that run on top of the 
52 PLCAPI component to provide the Web Interface to MyPLC users.
53
54 %description plekit
55 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
56
57 %prep
58 %setup -q
59
60 %build
61 echo "Compressing javascript files"
62 make compress
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 #
68 # plewww
69 # xxx : uninstall should undo this
70 #
71
72 echo "* PLEWWW: Installing web pages"
73 mkdir -p $RPM_BUILD_ROOT/var/www/html
74 # exclude codebase just in case
75 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
76
77 echo "* PLEWWW: Installing conf files for httpd"
78 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
79 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
80
81 %post
82 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
83 drupal_settings_dir=/var/www/html/sites/default
84 if [ ! -d $drupal_settings_dir ] ; then
85     echo "Could not find directory $drupal_settings_dir"
86     echo "This suggests that you do not have a planetlab-custom drupal installed"
87     exit 1
88 fi
89 pushd $drupal_settings_dir
90 # tune $db_url
91 if [ ! -f settings.php.drupal ] ; then
92     cp settings.php settings.php.drupal
93     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
94         settings.php.drupal > settings.php
95 fi
96 popd
97 # append our own database creation hacks to the drupal database schema
98 pushd /var/www/html/database
99 if [ ! -f database.pgsql.drupal ] ; then
100     cp database.pgsql database.pgsql.drupal
101     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
102 fi
103 popd
104 # hack the welcome page for MyPLC
105 pushd /var/www/html/modules
106 for module in user node; do
107     # backup only once
108     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
109     # always update so a change in our file can make through
110     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
111 done
112 popd
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(-,root,root,-)
119 /var/www/html/modules
120 /var/www/html/planetlab
121 /var/www/html/googlemap
122 /var/www/html/drupal-hacks
123 /etc/httpd/conf.d
124
125 %files plekit
126 /var/www/html/plekit
127
128 %changelog
129 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
130 - * show error messages for update interface
131 - * 'Add Node' is admin only
132 - * add site selector for 'Add Node'
133
134 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
135 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
136 - this affects the settings of ifname and alias that were formerly set unconditionally
137 - review the interface-checking javascript code
138 - changed the interface to plekitform, method is now optional and part of an options hash
139
140 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
141 - can't use php objects for showing node status, this is too slow
142 - fix interface add page
143
144 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
145 - consistency in the way nodes status is displayed in the node and slice areas
146 - extra tags columns show up on the nodes page as well, tweaked in the process
147 - roles management in person page fixed
148
149 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
150 - displaying node tags in the nodes page as well
151 - table headers now can have a 'title' that shows up when hovering on the column header
152
153 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
154 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
155
156 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
157 - extensible set of columns in the nodes area of the (my)slice page
158 - nodegroups can be added/deleted/updated
159 - tags management improved marginally
160
161 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
162 - fix pending sites page - was getting fooled by ext_consortium_id=None
163
164 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
165 - resetting tag as something went wrong when setting 31
166
167 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
168 - nicer look for slice creation, (public) sites
169 - users show with all their sites in the persons page
170
171 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
172 - reviewed registration pages for persons and sites
173
174 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
175 - increase memory limit in the nodes page
176
177 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
178 - fixes one typo
179
180 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
181 - minor/cosmetic
182
183 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
184 - Add default Interface tags to extra interfaces.
185 - Add clearer 'Add New PCU' link on node page.
186 - Disable user registration for tech and PI roles.
187
188 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
189 - new 'controller' instantiation state available in add slice page
190
191 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
192 - exclude datepicler.js from jsmin
193 - table sort function for Last Contact columns
194 - drop options for generic boot images
195
196 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
197 - displays editable mac address for interfaces
198 - properly sorts bandwidths
199 - new 'controller' slice instantiation method
200 - bugfix, division by zero when displaying a just-changed node
201
202 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
203 - bugfix with linetabs
204
205 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
206 - fix add interface from the node page
207
208 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
209 - only add users that are enabled and not yet a member of the slice
210 - fix to plc_peers
211 - my sites, my nodes, my persons improvements for users with multiple sites
212 - adds a script to minimize the java script files.
213
214 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
215 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
216
217 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
218 - first draft for pcu-handling features
219 - lighter contrat for PLE/PLC toggles
220 - as many 'my site'-like  links as the user has sites
221
222 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
223 - fix for whitelisted nodes
224 - now links to the node register wizard
225 - can enable sites
226 - various other minor fixes, like broken planetlab.module for techs, and login link
227
228 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
229 - plekittable knows how to turn off sort-on-load, and the admin users pages do
230 - + various cosmetic fixes
231
232 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
233 - a few minor improvements pushed on PLE
234
235 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
236 - fix for sites that were displayed as not public
237 - improvements to the python interface to sortable tables for monitor
238
239 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
240 - various improvements
241
242 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
243 - sliver page now correctly shows sliver tags
244 - support for download-node-usb-partition and various other improvements
245
246 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
247 - a few tweaks and typos fixed on PLE
248
249 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
250 - slice_add & node_download dialogs use plekit
251 - slice_add can add people in the slice
252 - various improvements after rollout on PLE
253
254 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
255 - cosmetic fixes to be in 4.3-rc2
256 - also a first (unpackaged) draft of the plekit table in python
257
258 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
259 - search in tables more robust
260
261 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
262 - performance improvements
263
264 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
265 - detect expired session and redirect to the login page
266
267 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
268 - improve browser health - was using too many cycles
269
270 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
271 - more consistency between views, and cosmetic changes
272
273 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
274 - area for managing slice tags
275
276 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
277 - first checkpoint tag for PLEWWW
278 - mostly functionally complete, probably a lot of tweaks still needed
279
280 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
281 - everyone is welcome to add nodes
282
283 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
284 - node-specific bootcd images to include arch in their name
285
286 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
287 - remove explicit dep to bootcd as the rpm name has changed
288
289 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
290 - noarch
291
292 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
293 - should fix yum.conf on nodes after install
294
295 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
296 - uses different path for getbootmedium results - should be safer
297
298 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
299 - comon icon replaced with the one from the comon website
300
301 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
302 - displays rpms in the about page
303
304 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
305 - safer, reference-less, way to implement layout mechnism - see
306 - settings.php for details
307 - setting types properly displayed according to user's role
308 - setting deletion : fixed (was still using code from slice attribute)
309 - more comon buttons : in the nodes and peers index pages
310 - comon_button knows about peer_id
311
312 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
313 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
314
315 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
316 - Initial build.