Setting tag plewww-5.2-7
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 7
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: plcapi >= 5.2
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-7
129 - remove utf8_deode as per Thomas's suggestion
130
131 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-6
132 - Offer the option to set a node in 'upgrade' mode - like reinstall but leaving slices intact
133
134 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-5
135 - tweaks in node_downloads.php about memory size and compression scheme
136
137 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-4
138 - googlemap widget: support for gmap api v3 + various cosmetic tweaks
139 - can display site names with odd characters
140
141 * Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
142 - typo in help message about initscripts
143
144 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
145 - node page and person page show hrn in details
146
147 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
148 - late fix of registration for plcapi-5.1-6
149
150 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
151 - add extra code to prevent confidentiality leaks
152 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
153 - return_url for add-person and remove-person
154 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
155
156 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
157 - add tags section on site and person pages
158
159 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
160 - slightly tweak profiling points in slice.php
161
162 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
163 - ships with new default images for PLC/PLE from planet-lab.eu
164
165 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
166 - no change, just make sync for lxc-hosted tests
167
168 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
169 - refactoring for tophat/columns
170 - should take care of the irritating warning message about columns
171
172 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
173 - do not display the 'node' role when confusing
174
175 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
176 - support for setting nodes as reservable
177 - rely more on previous state when deciding to open or not toggles in a view
178 - remove statements for setting maximum memory usage, that sometimes
179
180 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
181 - node page can edit interfaces even when no interface
182
183 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
184 - uses a 2-week (!) session
185
186 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
187 - minor/cosmetic fixes in the leases area
188
189 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
190 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
191 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
192 - has a feature to 'test' pcu connection
193 - only admins can add users to different sites.
194 - remove dep. to outdated _gen_planetflow.php
195 - rephrased (disabled, or pending registration)
196 - + various fixes
197
198 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
199 - fix display glitch exposed with dimes initscript
200
201 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
202 - rename initscript_body into initscript_code
203
204 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
205 - bugfix for the reservation interface
206
207 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
208 - reservation page uses ajax - no need to reload after submit
209 - reservation dialogs for offset in the future & # slots
210 - fix the timezone in reservations (actually use php.ini)
211 - reservation visible (and hardwired) in nodes view
212 - have pulled prototype 1.7 but not in used yet
213
214 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
215 - set both 'omf_control' and 'vref' for omf-friendly slices
216
217 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
218 - display tags in alphabetic order in node view, tags section, the drop down menu
219
220 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
221 - on-the-fly retrieval of data at comon & tophat (unused so far)
222 - use accessors to store person's preference of columns
223 - fix in toggle.js for the '?' button, node table layout tab
224 - sort actions logging improved
225
226 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
227 - keep people from disabling or deleting themselves
228 - cannot become a disabled person
229 - outline people without a role
230
231 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
232 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
233
234 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
235 - tagging plewww for a new deployment
236
237 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
238 - add a 'report a problem' link for the RebootNode button
239 - new exp page nodes2.php with consistent selectable-columns layout as myslice
240 - tweaks in the exp. myslice (slices.php)
241
242 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
243 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
244 - my_slice with adjustable set of columns in slices/slice2.php
245 - fix for the 'site registration' page
246
247 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
248 - show message about leases - leases tab first in nodes section
249 - fix how reservable nodes show up
250
251 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
252 - cosmetic, rendering of textareas was like password fields
253
254 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
255 - bugfix in slice page, had wrong (null) expiration date
256 - upgraded to raphael-1.5.2, don't minimize this lib
257 - nicer layout for password fields as well
258 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
259 - marginally optimized slice page (2 GetNodes call down)
260 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
261 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
262 - reservations can cope with a bit more slots - will need scrolling someday
263 - omf text has hyperlinks to the tools
264
265 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
266 - reservation section now effective
267 - can set omf_control at slice-creation time
268 - can set node as reservable at node-creation time
269 - nicer text input fields + various tweaks
270
271 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
272 - show nodegroups form to add new groups
273
274 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
275 - just tagging plewww again to test module-tag on git
276
277 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
278 - encode strings properly in forms.
279
280 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
281 - Use readfile() function to reduce the memory footprint
282
283 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
284 - removed all deprecated functions for PHP-5.3 on fedora 12
285
286 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
287 - * exclude DNS from subnet checking
288 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
289 - * allow longer abbreviated names
290 - * don't let empty strings kill the server (postgresql and apache)
291
292 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
293 - disable drupal user registration (hard: patching the user module)
294
295 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
296 - * show error messages for update interface
297 - * 'Add Node' is admin only
298 - * add site selector for 'Add Node'
299
300 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
301 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
302 - this affects the settings of ifname and alias that were formerly set unconditionally
303 - review the interface-checking javascript code
304 - changed the interface to plekitform, method is now optional and part of an options hash
305
306 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
307 - can't use php objects for showing node status, this is too slow
308 - fix interface add page
309
310 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
311 - consistency in the way nodes status is displayed in the node and slice areas
312 - extra tags columns show up on the nodes page as well, tweaked in the process
313 - roles management in person page fixed
314
315 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
316 - displaying node tags in the nodes page as well
317 - table headers now can have a 'title' that shows up when hovering on the column header
318
319 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
320 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
321
322 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
323 - extensible set of columns in the nodes area of the (my)slice page
324 - nodegroups can be added/deleted/updated
325 - tags management improved marginally
326
327 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
328 - fix pending sites page - was getting fooled by ext_consortium_id=None
329
330 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
331 - resetting tag as something went wrong when setting 31
332
333 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
334 - nicer look for slice creation, (public) sites
335 - users show with all their sites in the persons page
336
337 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
338 - reviewed registration pages for persons and sites
339
340 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
341 - increase memory limit in the nodes page
342
343 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
344 - fixes one typo
345
346 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
347 - minor/cosmetic
348
349 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
350 - Add default Interface tags to extra interfaces.
351 - Add clearer 'Add New PCU' link on node page.
352 - Disable user registration for tech and PI roles.
353
354 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
355 - new 'controller' instantiation state available in add slice page
356
357 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
358 - exclude datepicler.js from jsmin
359 - table sort function for Last Contact columns
360 - drop options for generic boot images
361
362 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
363 - displays editable mac address for interfaces
364 - properly sorts bandwidths
365 - new 'controller' slice instantiation method
366 - bugfix, division by zero when displaying a just-changed node
367
368 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
369 - bugfix with linetabs
370
371 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
372 - fix add interface from the node page
373
374 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
375 - only add users that are enabled and not yet a member of the slice
376 - fix to plc_peers
377 - my sites, my nodes, my persons improvements for users with multiple sites
378 - adds a script to minimize the java script files.
379
380 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
381 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
382
383 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
384 - first draft for pcu-handling features
385 - lighter contrat for PLE/PLC toggles
386 - as many 'my site'-like  links as the user has sites
387
388 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
389 - fix for whitelisted nodes
390 - now links to the node register wizard
391 - can enable sites
392 - various other minor fixes, like broken planetlab.module for techs, and login link
393
394 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
395 - plekittable knows how to turn off sort-on-load, and the admin users pages do
396 - + various cosmetic fixes
397
398 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
399 - a few minor improvements pushed on PLE
400
401 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
402 - fix for sites that were displayed as not public
403 - improvements to the python interface to sortable tables for monitor
404
405 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
406 - various improvements
407
408 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
409 - sliver page now correctly shows sliver tags
410 - support for download-node-usb-partition and various other improvements
411
412 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
413 - a few tweaks and typos fixed on PLE
414
415 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
416 - slice_add & node_download dialogs use plekit
417 - slice_add can add people in the slice
418 - various improvements after rollout on PLE
419
420 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
421 - cosmetic fixes to be in 4.3-rc2
422 - also a first (unpackaged) draft of the plekit table in python
423
424 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
425 - search in tables more robust
426
427 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
428 - performance improvements
429
430 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
431 - detect expired session and redirect to the login page
432
433 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
434 - improve browser health - was using too many cycles
435
436 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
437 - more consistency between views, and cosmetic changes
438
439 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
440 - area for managing slice tags
441
442 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
443 - first checkpoint tag for PLEWWW
444 - mostly functionally complete, probably a lot of tweaks still needed
445
446 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
447 - everyone is welcome to add nodes
448
449 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
450 - node-specific bootcd images to include arch in their name
451
452 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
453 - remove explicit dep to bootcd as the rpm name has changed
454
455 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
456 - noarch
457
458 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
459 - should fix yum.conf on nodes after install
460
461 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
462 - uses different path for getbootmedium results - should be safer
463
464 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
465 - comon icon replaced with the one from the comon website
466
467 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
468 - displays rpms in the about page
469
470 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
471 - safer, reference-less, way to implement layout mechnism - see
472 - settings.php for details
473 - setting types properly displayed according to user's role
474 - setting deletion : fixed (was still using code from slice attribute)
475 - more comon buttons : in the nodes and peers index pages
476 - comon_button knows about peer_id
477
478 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
479 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
480
481 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
482 - Initial build.