Setting tag plewww-4.3-49
[plewww.git] / plewww.spec
1 #
2 # $Id$
3 #
4
5 # what the myplc rpm requires
6 %define name plewww
7 %define version 4.3
8 %define taglevel 49
9
10 # no need to mention pldistro as this module differs in both distros
11 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %define release %{taglevel}%{?date:.%{date}}
13
14 Summary: PlanetLab Europe (PLC) Web Pages
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: Applications/Systems
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 BuildArch: noarch
23 BuildRequires: python
24
25 Vendor: OneLab
26 Packager: OneLab <support@one-lab.org>
27 Distribution: PlanetLab %{version}
28 URL: http://svn.one-lab.org/svn/new_plc_www/
29
30 # We use set everywhere
31 #Requires: httpd >= 2.0
32 Requires: php >= 5.0
33 Requires: postgresql >= 8.0
34 Requires: PLCAPI >= 4.3
35 Requires: drupal = 4.7
36 Requires: plewww-plekit
37
38 # this is what MyPLC requires
39 Provides: PLCWWW
40
41 # on centos5, when rebuilding the full monty, we get:
42 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
43 # and the perl-GD rpm is nowhere to be found
44 AutoReqProv: no
45
46 %package plekit
47 Summary: Utilities used by the plewww pages
48 Group: Applications/Systems
49
50 %description
51 The plewww package is made of the web pages that run on top of the 
52 PLCAPI component to provide the Web Interface to MyPLC users.
53
54 %description plekit
55 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
56
57 %prep
58 %setup -q
59
60 %build
61 echo "Compressing javascript files"
62 make compress
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 #
68 # plewww
69 # xxx : uninstall should undo this
70 #
71
72 echo "* PLEWWW: Installing web pages"
73 mkdir -p $RPM_BUILD_ROOT/var/www/html
74 # exclude codebase just in case
75 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
76
77 echo "* PLEWWW: Installing conf files for httpd"
78 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
79 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
80
81 %post
82 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
83 drupal_settings_dir=/var/www/html/sites/default
84 if [ ! -d $drupal_settings_dir ] ; then
85     echo "Could not find directory $drupal_settings_dir"
86     echo "This suggests that you do not have a planetlab-custom drupal installed"
87     exit 1
88 fi
89 pushd $drupal_settings_dir
90 # tune $db_url
91 if [ ! -f settings.php.drupal ] ; then
92     cp settings.php settings.php.drupal
93     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
94         settings.php.drupal > settings.php
95 fi
96 popd
97 # append our own database creation hacks to the drupal database schema
98 pushd /var/www/html/database
99 if [ ! -f database.pgsql.drupal ] ; then
100     cp database.pgsql database.pgsql.drupal
101     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
102 fi
103 popd
104 # hack the welcome page for MyPLC
105 pushd /var/www/html/modules
106 for module in user node; do
107     # backup only once
108     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
109     # always update so a change in our file can make through
110     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
111 done
112 popd
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(-,root,root,-)
119 /var/www/html/modules
120 /var/www/html/planetlab
121 /var/www/html/googlemap
122 /var/www/html/drupal-hacks
123 /etc/httpd/conf.d
124
125 %files plekit
126 /var/www/html/plekit
127
128 %changelog
129 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
130 - bugfix in slice page, had wrong (null) expiration date
131 - upgraded to raphael-1.5.2, don't minimize this lib
132 - nicer layout for password fields as well
133 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
134 - marginally optimized slice page (2 GetNodes call down)
135 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
136 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
137 - reservations can cope with a bit more slots - will need scrolling someday
138 - omf text has hyperlinks to the tools
139
140 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
141 - reservation section now effective
142 - can set omf_control at slice-creation time
143 - can set node as reservable at node-creation time
144 - nicer text input fields + various tweaks
145
146 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
147 - show nodegroups form to add new groups
148
149 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
150 - just tagging plewww again to test module-tag on git
151
152 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
153 - encode strings properly in forms.
154
155 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
156 - Use readfile() function to reduce the memory footprint
157
158 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
159 - removed all deprecated functions for PHP-5.3 on fedora 12
160
161 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
162 - * exclude DNS from subnet checking
163 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
164 - * allow longer abbreviated names
165 - * don't let empty strings kill the server (postgresql and apache)
166
167 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
168 - disable drupal user registration (hard: patching the user module)
169
170 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
171 - * show error messages for update interface
172 - * 'Add Node' is admin only
173 - * add site selector for 'Add Node'
174
175 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
176 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
177 - this affects the settings of ifname and alias that were formerly set unconditionally
178 - review the interface-checking javascript code
179 - changed the interface to plekitform, method is now optional and part of an options hash
180
181 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
182 - can't use php objects for showing node status, this is too slow
183 - fix interface add page
184
185 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
186 - consistency in the way nodes status is displayed in the node and slice areas
187 - extra tags columns show up on the nodes page as well, tweaked in the process
188 - roles management in person page fixed
189
190 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
191 - displaying node tags in the nodes page as well
192 - table headers now can have a 'title' that shows up when hovering on the column header
193
194 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
195 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
196
197 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
198 - extensible set of columns in the nodes area of the (my)slice page
199 - nodegroups can be added/deleted/updated
200 - tags management improved marginally
201
202 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
203 - fix pending sites page - was getting fooled by ext_consortium_id=None
204
205 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
206 - resetting tag as something went wrong when setting 31
207
208 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
209 - nicer look for slice creation, (public) sites
210 - users show with all their sites in the persons page
211
212 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
213 - reviewed registration pages for persons and sites
214
215 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
216 - increase memory limit in the nodes page
217
218 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
219 - fixes one typo
220
221 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
222 - minor/cosmetic
223
224 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
225 - Add default Interface tags to extra interfaces.
226 - Add clearer 'Add New PCU' link on node page.
227 - Disable user registration for tech and PI roles.
228
229 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
230 - new 'controller' instantiation state available in add slice page
231
232 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
233 - exclude datepicler.js from jsmin
234 - table sort function for Last Contact columns
235 - drop options for generic boot images
236
237 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
238 - displays editable mac address for interfaces
239 - properly sorts bandwidths
240 - new 'controller' slice instantiation method
241 - bugfix, division by zero when displaying a just-changed node
242
243 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
244 - bugfix with linetabs
245
246 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
247 - fix add interface from the node page
248
249 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
250 - only add users that are enabled and not yet a member of the slice
251 - fix to plc_peers
252 - my sites, my nodes, my persons improvements for users with multiple sites
253 - adds a script to minimize the java script files.
254
255 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
256 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
257
258 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
259 - first draft for pcu-handling features
260 - lighter contrat for PLE/PLC toggles
261 - as many 'my site'-like  links as the user has sites
262
263 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
264 - fix for whitelisted nodes
265 - now links to the node register wizard
266 - can enable sites
267 - various other minor fixes, like broken planetlab.module for techs, and login link
268
269 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
270 - plekittable knows how to turn off sort-on-load, and the admin users pages do
271 - + various cosmetic fixes
272
273 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
274 - a few minor improvements pushed on PLE
275
276 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
277 - fix for sites that were displayed as not public
278 - improvements to the python interface to sortable tables for monitor
279
280 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
281 - various improvements
282
283 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
284 - sliver page now correctly shows sliver tags
285 - support for download-node-usb-partition and various other improvements
286
287 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
288 - a few tweaks and typos fixed on PLE
289
290 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
291 - slice_add & node_download dialogs use plekit
292 - slice_add can add people in the slice
293 - various improvements after rollout on PLE
294
295 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
296 - cosmetic fixes to be in 4.3-rc2
297 - also a first (unpackaged) draft of the plekit table in python
298
299 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
300 - search in tables more robust
301
302 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
303 - performance improvements
304
305 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
306 - detect expired session and redirect to the login page
307
308 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
309 - improve browser health - was using too many cycles
310
311 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
312 - more consistency between views, and cosmetic changes
313
314 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
315 - area for managing slice tags
316
317 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
318 - first checkpoint tag for PLEWWW
319 - mostly functionally complete, probably a lot of tweaks still needed
320
321 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
322 - everyone is welcome to add nodes
323
324 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
325 - node-specific bootcd images to include arch in their name
326
327 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
328 - remove explicit dep to bootcd as the rpm name has changed
329
330 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
331 - noarch
332
333 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
334 - should fix yum.conf on nodes after install
335
336 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
337 - uses different path for getbootmedium results - should be safer
338
339 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
340 - comon icon replaced with the one from the comon website
341
342 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
343 - displays rpms in the about page
344
345 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
346 - safer, reference-less, way to implement layout mechnism - see
347 - settings.php for details
348 - setting types properly displayed according to user's role
349 - setting deletion : fixed (was still using code from slice attribute)
350 - more comon buttons : in the nodes and peers index pages
351 - comon_button knows about peer_id
352
353 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
354 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
355
356 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
357 - Initial build.