Setting tag plewww-4.3-66
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 66
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
129 - uses a 2-week (!) session
130
131 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
132 - minor/cosmetic fixes in the leases area
133
134 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
135 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
136 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
137 - has a feature to 'test' pcu connection
138 - only admins can add users to different sites.
139 - remove dep. to outdated _gen_planetflow.php
140 - rephrased (disabled, or pending registration)
141 - + various fixes
142
143 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
144 - fix display glitch exposed with dimes initscript
145
146 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
147 - rename initscript_body into initscript_code
148
149 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
150 - bugfix for the reservation interface
151
152 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
153 - reservation page uses ajax - no need to reload after submit
154 - reservation dialogs for offset in the future & # slots
155 - fix the timezone in reservations (actually use php.ini)
156 - reservation visible (and hardwired) in nodes view
157 - have pulled prototype 1.7 but not in used yet
158
159 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
160 - set both 'omf_control' and 'vref' for omf-friendly slices
161
162 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
163 - display tags in alphabetic order in node view, tags section, the drop down menu
164
165 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
166 - on-the-fly retrieval of data at comon & tophat (unused so far)
167 - use accessors to store person's preference of columns
168 - fix in toggle.js for the '?' button, node table layout tab
169 - sort actions logging improved
170
171 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
172 - keep people from disabling or deleting themselves
173 - cannot become a disabled person
174 - outline people without a role
175
176 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
177 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
178
179 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
180 - tagging plewww for a new deployment
181
182 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
183 - add a 'report a problem' link for the RebootNode button
184 - new exp page nodes2.php with consistent selectable-columns layout as myslice
185 - tweaks in the exp. myslice (slices.php)
186
187 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
188 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
189 - my_slice with adjustable set of columns in slices/slice2.php
190 - fix for the 'site registration' page
191
192 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
193 - show message about leases - leases tab first in nodes section
194 - fix how reservable nodes show up
195
196 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
197 - cosmetic, rendering of textareas was like password fields
198
199 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
200 - bugfix in slice page, had wrong (null) expiration date
201 - upgraded to raphael-1.5.2, don't minimize this lib
202 - nicer layout for password fields as well
203 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
204 - marginally optimized slice page (2 GetNodes call down)
205 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
206 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
207 - reservations can cope with a bit more slots - will need scrolling someday
208 - omf text has hyperlinks to the tools
209
210 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
211 - reservation section now effective
212 - can set omf_control at slice-creation time
213 - can set node as reservable at node-creation time
214 - nicer text input fields + various tweaks
215
216 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
217 - show nodegroups form to add new groups
218
219 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
220 - just tagging plewww again to test module-tag on git
221
222 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
223 - encode strings properly in forms.
224
225 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
226 - Use readfile() function to reduce the memory footprint
227
228 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
229 - removed all deprecated functions for PHP-5.3 on fedora 12
230
231 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
232 - * exclude DNS from subnet checking
233 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
234 - * allow longer abbreviated names
235 - * don't let empty strings kill the server (postgresql and apache)
236
237 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
238 - disable drupal user registration (hard: patching the user module)
239
240 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
241 - * show error messages for update interface
242 - * 'Add Node' is admin only
243 - * add site selector for 'Add Node'
244
245 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
246 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
247 - this affects the settings of ifname and alias that were formerly set unconditionally
248 - review the interface-checking javascript code
249 - changed the interface to plekitform, method is now optional and part of an options hash
250
251 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
252 - can't use php objects for showing node status, this is too slow
253 - fix interface add page
254
255 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
256 - consistency in the way nodes status is displayed in the node and slice areas
257 - extra tags columns show up on the nodes page as well, tweaked in the process
258 - roles management in person page fixed
259
260 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
261 - displaying node tags in the nodes page as well
262 - table headers now can have a 'title' that shows up when hovering on the column header
263
264 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
265 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
266
267 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
268 - extensible set of columns in the nodes area of the (my)slice page
269 - nodegroups can be added/deleted/updated
270 - tags management improved marginally
271
272 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
273 - fix pending sites page - was getting fooled by ext_consortium_id=None
274
275 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
276 - resetting tag as something went wrong when setting 31
277
278 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
279 - nicer look for slice creation, (public) sites
280 - users show with all their sites in the persons page
281
282 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
283 - reviewed registration pages for persons and sites
284
285 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
286 - increase memory limit in the nodes page
287
288 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
289 - fixes one typo
290
291 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
292 - minor/cosmetic
293
294 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
295 - Add default Interface tags to extra interfaces.
296 - Add clearer 'Add New PCU' link on node page.
297 - Disable user registration for tech and PI roles.
298
299 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
300 - new 'controller' instantiation state available in add slice page
301
302 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
303 - exclude datepicler.js from jsmin
304 - table sort function for Last Contact columns
305 - drop options for generic boot images
306
307 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
308 - displays editable mac address for interfaces
309 - properly sorts bandwidths
310 - new 'controller' slice instantiation method
311 - bugfix, division by zero when displaying a just-changed node
312
313 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
314 - bugfix with linetabs
315
316 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
317 - fix add interface from the node page
318
319 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
320 - only add users that are enabled and not yet a member of the slice
321 - fix to plc_peers
322 - my sites, my nodes, my persons improvements for users with multiple sites
323 - adds a script to minimize the java script files.
324
325 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
326 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
327
328 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
329 - first draft for pcu-handling features
330 - lighter contrat for PLE/PLC toggles
331 - as many 'my site'-like  links as the user has sites
332
333 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
334 - fix for whitelisted nodes
335 - now links to the node register wizard
336 - can enable sites
337 - various other minor fixes, like broken planetlab.module for techs, and login link
338
339 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
340 - plekittable knows how to turn off sort-on-load, and the admin users pages do
341 - + various cosmetic fixes
342
343 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
344 - a few minor improvements pushed on PLE
345
346 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
347 - fix for sites that were displayed as not public
348 - improvements to the python interface to sortable tables for monitor
349
350 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
351 - various improvements
352
353 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
354 - sliver page now correctly shows sliver tags
355 - support for download-node-usb-partition and various other improvements
356
357 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
358 - a few tweaks and typos fixed on PLE
359
360 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
361 - slice_add & node_download dialogs use plekit
362 - slice_add can add people in the slice
363 - various improvements after rollout on PLE
364
365 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
366 - cosmetic fixes to be in 4.3-rc2
367 - also a first (unpackaged) draft of the plekit table in python
368
369 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
370 - search in tables more robust
371
372 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
373 - performance improvements
374
375 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
376 - detect expired session and redirect to the login page
377
378 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
379 - improve browser health - was using too many cycles
380
381 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
382 - more consistency between views, and cosmetic changes
383
384 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
385 - area for managing slice tags
386
387 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
388 - first checkpoint tag for PLEWWW
389 - mostly functionally complete, probably a lot of tweaks still needed
390
391 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
392 - everyone is welcome to add nodes
393
394 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
395 - node-specific bootcd images to include arch in their name
396
397 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
398 - remove explicit dep to bootcd as the rpm name has changed
399
400 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
401 - noarch
402
403 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
404 - should fix yum.conf on nodes after install
405
406 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
407 - uses different path for getbootmedium results - should be safer
408
409 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
410 - comon icon replaced with the one from the comon website
411
412 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
413 - displays rpms in the about page
414
415 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
416 - safer, reference-less, way to implement layout mechnism - see
417 - settings.php for details
418 - setting types properly displayed according to user's role
419 - setting deletion : fixed (was still using code from slice attribute)
420 - more comon buttons : in the nodes and peers index pages
421 - comon_button knows about peer_id
422
423 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
424 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
425
426 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
427 - Initial build.