Setting tag plewww-4.3-70
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 70
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
129 - refactoring for tophat/columns
130 - should take care of the irritating warning message about columns
131
132 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
133 - do not display the 'node' role when confusing
134
135 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
136 - support for setting nodes as reservable
137 - rely more on previous state when deciding to open or not toggles in a view
138 - remove statements for setting maximum memory usage, that sometimes
139
140 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
141 - node page can edit interfaces even when no interface
142
143 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
144 - uses a 2-week (!) session
145
146 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
147 - minor/cosmetic fixes in the leases area
148
149 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
150 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
151 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
152 - has a feature to 'test' pcu connection
153 - only admins can add users to different sites.
154 - remove dep. to outdated _gen_planetflow.php
155 - rephrased (disabled, or pending registration)
156 - + various fixes
157
158 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
159 - fix display glitch exposed with dimes initscript
160
161 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
162 - rename initscript_body into initscript_code
163
164 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
165 - bugfix for the reservation interface
166
167 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
168 - reservation page uses ajax - no need to reload after submit
169 - reservation dialogs for offset in the future & # slots
170 - fix the timezone in reservations (actually use php.ini)
171 - reservation visible (and hardwired) in nodes view
172 - have pulled prototype 1.7 but not in used yet
173
174 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
175 - set both 'omf_control' and 'vref' for omf-friendly slices
176
177 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
178 - display tags in alphabetic order in node view, tags section, the drop down menu
179
180 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
181 - on-the-fly retrieval of data at comon & tophat (unused so far)
182 - use accessors to store person's preference of columns
183 - fix in toggle.js for the '?' button, node table layout tab
184 - sort actions logging improved
185
186 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
187 - keep people from disabling or deleting themselves
188 - cannot become a disabled person
189 - outline people without a role
190
191 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
192 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
193
194 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
195 - tagging plewww for a new deployment
196
197 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
198 - add a 'report a problem' link for the RebootNode button
199 - new exp page nodes2.php with consistent selectable-columns layout as myslice
200 - tweaks in the exp. myslice (slices.php)
201
202 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
203 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
204 - my_slice with adjustable set of columns in slices/slice2.php
205 - fix for the 'site registration' page
206
207 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
208 - show message about leases - leases tab first in nodes section
209 - fix how reservable nodes show up
210
211 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
212 - cosmetic, rendering of textareas was like password fields
213
214 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
215 - bugfix in slice page, had wrong (null) expiration date
216 - upgraded to raphael-1.5.2, don't minimize this lib
217 - nicer layout for password fields as well
218 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
219 - marginally optimized slice page (2 GetNodes call down)
220 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
221 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
222 - reservations can cope with a bit more slots - will need scrolling someday
223 - omf text has hyperlinks to the tools
224
225 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
226 - reservation section now effective
227 - can set omf_control at slice-creation time
228 - can set node as reservable at node-creation time
229 - nicer text input fields + various tweaks
230
231 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
232 - show nodegroups form to add new groups
233
234 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
235 - just tagging plewww again to test module-tag on git
236
237 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
238 - encode strings properly in forms.
239
240 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
241 - Use readfile() function to reduce the memory footprint
242
243 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
244 - removed all deprecated functions for PHP-5.3 on fedora 12
245
246 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
247 - * exclude DNS from subnet checking
248 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
249 - * allow longer abbreviated names
250 - * don't let empty strings kill the server (postgresql and apache)
251
252 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
253 - disable drupal user registration (hard: patching the user module)
254
255 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
256 - * show error messages for update interface
257 - * 'Add Node' is admin only
258 - * add site selector for 'Add Node'
259
260 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
261 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
262 - this affects the settings of ifname and alias that were formerly set unconditionally
263 - review the interface-checking javascript code
264 - changed the interface to plekitform, method is now optional and part of an options hash
265
266 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
267 - can't use php objects for showing node status, this is too slow
268 - fix interface add page
269
270 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
271 - consistency in the way nodes status is displayed in the node and slice areas
272 - extra tags columns show up on the nodes page as well, tweaked in the process
273 - roles management in person page fixed
274
275 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
276 - displaying node tags in the nodes page as well
277 - table headers now can have a 'title' that shows up when hovering on the column header
278
279 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
280 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
281
282 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
283 - extensible set of columns in the nodes area of the (my)slice page
284 - nodegroups can be added/deleted/updated
285 - tags management improved marginally
286
287 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
288 - fix pending sites page - was getting fooled by ext_consortium_id=None
289
290 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
291 - resetting tag as something went wrong when setting 31
292
293 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
294 - nicer look for slice creation, (public) sites
295 - users show with all their sites in the persons page
296
297 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
298 - reviewed registration pages for persons and sites
299
300 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
301 - increase memory limit in the nodes page
302
303 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
304 - fixes one typo
305
306 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
307 - minor/cosmetic
308
309 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
310 - Add default Interface tags to extra interfaces.
311 - Add clearer 'Add New PCU' link on node page.
312 - Disable user registration for tech and PI roles.
313
314 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
315 - new 'controller' instantiation state available in add slice page
316
317 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
318 - exclude datepicler.js from jsmin
319 - table sort function for Last Contact columns
320 - drop options for generic boot images
321
322 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
323 - displays editable mac address for interfaces
324 - properly sorts bandwidths
325 - new 'controller' slice instantiation method
326 - bugfix, division by zero when displaying a just-changed node
327
328 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
329 - bugfix with linetabs
330
331 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
332 - fix add interface from the node page
333
334 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
335 - only add users that are enabled and not yet a member of the slice
336 - fix to plc_peers
337 - my sites, my nodes, my persons improvements for users with multiple sites
338 - adds a script to minimize the java script files.
339
340 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
341 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
342
343 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
344 - first draft for pcu-handling features
345 - lighter contrat for PLE/PLC toggles
346 - as many 'my site'-like  links as the user has sites
347
348 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
349 - fix for whitelisted nodes
350 - now links to the node register wizard
351 - can enable sites
352 - various other minor fixes, like broken planetlab.module for techs, and login link
353
354 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
355 - plekittable knows how to turn off sort-on-load, and the admin users pages do
356 - + various cosmetic fixes
357
358 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
359 - a few minor improvements pushed on PLE
360
361 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
362 - fix for sites that were displayed as not public
363 - improvements to the python interface to sortable tables for monitor
364
365 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
366 - various improvements
367
368 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
369 - sliver page now correctly shows sliver tags
370 - support for download-node-usb-partition and various other improvements
371
372 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
373 - a few tweaks and typos fixed on PLE
374
375 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
376 - slice_add & node_download dialogs use plekit
377 - slice_add can add people in the slice
378 - various improvements after rollout on PLE
379
380 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
381 - cosmetic fixes to be in 4.3-rc2
382 - also a first (unpackaged) draft of the plekit table in python
383
384 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
385 - search in tables more robust
386
387 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
388 - performance improvements
389
390 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
391 - detect expired session and redirect to the login page
392
393 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
394 - improve browser health - was using too many cycles
395
396 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
397 - more consistency between views, and cosmetic changes
398
399 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
400 - area for managing slice tags
401
402 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
403 - first checkpoint tag for PLEWWW
404 - mostly functionally complete, probably a lot of tweaks still needed
405
406 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
407 - everyone is welcome to add nodes
408
409 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
410 - node-specific bootcd images to include arch in their name
411
412 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
413 - remove explicit dep to bootcd as the rpm name has changed
414
415 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
416 - noarch
417
418 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
419 - should fix yum.conf on nodes after install
420
421 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
422 - uses different path for getbootmedium results - should be safer
423
424 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
425 - comon icon replaced with the one from the comon website
426
427 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
428 - displays rpms in the about page
429
430 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
431 - safer, reference-less, way to implement layout mechnism - see
432 - settings.php for details
433 - setting types properly displayed according to user's role
434 - setting deletion : fixed (was still using code from slice attribute)
435 - more comon buttons : in the nodes and peers index pages
436 - comon_button knows about peer_id
437
438 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
439 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
440
441 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
442 - Initial build.