Setting tag plewww-4.3-72
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 72
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
129 - ships with new default images for PLC/PLE from planet-lab.eu
130
131 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
132 - no change, just make sync for lxc-hosted tests
133
134 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
135 - refactoring for tophat/columns
136 - should take care of the irritating warning message about columns
137
138 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
139 - do not display the 'node' role when confusing
140
141 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
142 - support for setting nodes as reservable
143 - rely more on previous state when deciding to open or not toggles in a view
144 - remove statements for setting maximum memory usage, that sometimes
145
146 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
147 - node page can edit interfaces even when no interface
148
149 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
150 - uses a 2-week (!) session
151
152 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
153 - minor/cosmetic fixes in the leases area
154
155 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
156 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
157 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
158 - has a feature to 'test' pcu connection
159 - only admins can add users to different sites.
160 - remove dep. to outdated _gen_planetflow.php
161 - rephrased (disabled, or pending registration)
162 - + various fixes
163
164 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
165 - fix display glitch exposed with dimes initscript
166
167 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
168 - rename initscript_body into initscript_code
169
170 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
171 - bugfix for the reservation interface
172
173 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
174 - reservation page uses ajax - no need to reload after submit
175 - reservation dialogs for offset in the future & # slots
176 - fix the timezone in reservations (actually use php.ini)
177 - reservation visible (and hardwired) in nodes view
178 - have pulled prototype 1.7 but not in used yet
179
180 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
181 - set both 'omf_control' and 'vref' for omf-friendly slices
182
183 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
184 - display tags in alphabetic order in node view, tags section, the drop down menu
185
186 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
187 - on-the-fly retrieval of data at comon & tophat (unused so far)
188 - use accessors to store person's preference of columns
189 - fix in toggle.js for the '?' button, node table layout tab
190 - sort actions logging improved
191
192 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
193 - keep people from disabling or deleting themselves
194 - cannot become a disabled person
195 - outline people without a role
196
197 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
198 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
199
200 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
201 - tagging plewww for a new deployment
202
203 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
204 - add a 'report a problem' link for the RebootNode button
205 - new exp page nodes2.php with consistent selectable-columns layout as myslice
206 - tweaks in the exp. myslice (slices.php)
207
208 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
209 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
210 - my_slice with adjustable set of columns in slices/slice2.php
211 - fix for the 'site registration' page
212
213 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
214 - show message about leases - leases tab first in nodes section
215 - fix how reservable nodes show up
216
217 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
218 - cosmetic, rendering of textareas was like password fields
219
220 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
221 - bugfix in slice page, had wrong (null) expiration date
222 - upgraded to raphael-1.5.2, don't minimize this lib
223 - nicer layout for password fields as well
224 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
225 - marginally optimized slice page (2 GetNodes call down)
226 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
227 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
228 - reservations can cope with a bit more slots - will need scrolling someday
229 - omf text has hyperlinks to the tools
230
231 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
232 - reservation section now effective
233 - can set omf_control at slice-creation time
234 - can set node as reservable at node-creation time
235 - nicer text input fields + various tweaks
236
237 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
238 - show nodegroups form to add new groups
239
240 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
241 - just tagging plewww again to test module-tag on git
242
243 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
244 - encode strings properly in forms.
245
246 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
247 - Use readfile() function to reduce the memory footprint
248
249 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
250 - removed all deprecated functions for PHP-5.3 on fedora 12
251
252 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
253 - * exclude DNS from subnet checking
254 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
255 - * allow longer abbreviated names
256 - * don't let empty strings kill the server (postgresql and apache)
257
258 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
259 - disable drupal user registration (hard: patching the user module)
260
261 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
262 - * show error messages for update interface
263 - * 'Add Node' is admin only
264 - * add site selector for 'Add Node'
265
266 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
267 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
268 - this affects the settings of ifname and alias that were formerly set unconditionally
269 - review the interface-checking javascript code
270 - changed the interface to plekitform, method is now optional and part of an options hash
271
272 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
273 - can't use php objects for showing node status, this is too slow
274 - fix interface add page
275
276 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
277 - consistency in the way nodes status is displayed in the node and slice areas
278 - extra tags columns show up on the nodes page as well, tweaked in the process
279 - roles management in person page fixed
280
281 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
282 - displaying node tags in the nodes page as well
283 - table headers now can have a 'title' that shows up when hovering on the column header
284
285 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
286 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
287
288 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
289 - extensible set of columns in the nodes area of the (my)slice page
290 - nodegroups can be added/deleted/updated
291 - tags management improved marginally
292
293 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
294 - fix pending sites page - was getting fooled by ext_consortium_id=None
295
296 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
297 - resetting tag as something went wrong when setting 31
298
299 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
300 - nicer look for slice creation, (public) sites
301 - users show with all their sites in the persons page
302
303 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
304 - reviewed registration pages for persons and sites
305
306 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
307 - increase memory limit in the nodes page
308
309 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
310 - fixes one typo
311
312 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
313 - minor/cosmetic
314
315 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
316 - Add default Interface tags to extra interfaces.
317 - Add clearer 'Add New PCU' link on node page.
318 - Disable user registration for tech and PI roles.
319
320 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
321 - new 'controller' instantiation state available in add slice page
322
323 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
324 - exclude datepicler.js from jsmin
325 - table sort function for Last Contact columns
326 - drop options for generic boot images
327
328 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
329 - displays editable mac address for interfaces
330 - properly sorts bandwidths
331 - new 'controller' slice instantiation method
332 - bugfix, division by zero when displaying a just-changed node
333
334 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
335 - bugfix with linetabs
336
337 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
338 - fix add interface from the node page
339
340 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
341 - only add users that are enabled and not yet a member of the slice
342 - fix to plc_peers
343 - my sites, my nodes, my persons improvements for users with multiple sites
344 - adds a script to minimize the java script files.
345
346 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
347 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
348
349 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
350 - first draft for pcu-handling features
351 - lighter contrat for PLE/PLC toggles
352 - as many 'my site'-like  links as the user has sites
353
354 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
355 - fix for whitelisted nodes
356 - now links to the node register wizard
357 - can enable sites
358 - various other minor fixes, like broken planetlab.module for techs, and login link
359
360 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
361 - plekittable knows how to turn off sort-on-load, and the admin users pages do
362 - + various cosmetic fixes
363
364 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
365 - a few minor improvements pushed on PLE
366
367 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
368 - fix for sites that were displayed as not public
369 - improvements to the python interface to sortable tables for monitor
370
371 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
372 - various improvements
373
374 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
375 - sliver page now correctly shows sliver tags
376 - support for download-node-usb-partition and various other improvements
377
378 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
379 - a few tweaks and typos fixed on PLE
380
381 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
382 - slice_add & node_download dialogs use plekit
383 - slice_add can add people in the slice
384 - various improvements after rollout on PLE
385
386 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
387 - cosmetic fixes to be in 4.3-rc2
388 - also a first (unpackaged) draft of the plekit table in python
389
390 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
391 - search in tables more robust
392
393 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
394 - performance improvements
395
396 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
397 - detect expired session and redirect to the login page
398
399 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
400 - improve browser health - was using too many cycles
401
402 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
403 - more consistency between views, and cosmetic changes
404
405 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
406 - area for managing slice tags
407
408 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
409 - first checkpoint tag for PLEWWW
410 - mostly functionally complete, probably a lot of tweaks still needed
411
412 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
413 - everyone is welcome to add nodes
414
415 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
416 - node-specific bootcd images to include arch in their name
417
418 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
419 - remove explicit dep to bootcd as the rpm name has changed
420
421 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
422 - noarch
423
424 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
425 - should fix yum.conf on nodes after install
426
427 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
428 - uses different path for getbootmedium results - should be safer
429
430 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
431 - comon icon replaced with the one from the comon website
432
433 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
434 - displays rpms in the about page
435
436 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
437 - safer, reference-less, way to implement layout mechnism - see
438 - settings.php for details
439 - setting types properly displayed according to user's role
440 - setting deletion : fixed (was still using code from slice attribute)
441 - more comon buttons : in the nodes and peers index pages
442 - comon_button knows about peer_id
443
444 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
445 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
446
447 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
448 - Initial build.