Tagging module PLEWWW - PLEWWW-4.3-13
[plewww.git] / plewww.spec
1 #
2 # $Id$
3 #
4
5 # what the myplc rpm requires
6 %define name plewww
7 %define version 4.3
8 %define taglevel 13
9
10 # no need to mention pldistro as this module differs in both distros
11 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %define release %{taglevel}%{?date:.%{date}}
13
14 Summary: PlanetLab Europe (PLC) Web Pages
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: Applications/Systems
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 BuildArch: noarch
23
24 Vendor: OneLab
25 Packager: OneLab <support@one-lab.org>
26 Distribution: PlanetLab %{version}
27 URL: http://svn.one-lab.org/svn/new_plc_www/
28
29 # We use set everywhere
30 #Requires: httpd >= 2.0
31 Requires: php >= 5.0
32 Requires: postgresql >= 8.0
33 Requires: PLCAPI >= 4.3
34 Requires: drupal = 4.7
35 Requires: plewww-plekit
36
37 # this is what MyPLC requires
38 Provides: PLCWWW
39
40 # on centos5, when rebuilding the full monty, we get:
41 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
42 # and the perl-GD rpm is nowhere to be found
43 AutoReqProv: no
44
45 %package plekit
46 Summary: Utilities used by the plewww pages
47 Group: Applications/Systems
48
49 %description
50 The plewww package is made of the web pages that run on top of the 
51 PLCAPI component to provide the Web Interface to MyPLC users.
52
53 %description plekit
54 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
55
56 %prep
57 %setup -q
58
59 %build
60 echo "There is no build stage for this component"
61 echo "All files just need to be installed as is from the codebase"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 #
67 # plewww
68 # xxx : uninstall should undo this
69 #
70
71 echo "* PLEWWW: Installing web pages"
72 mkdir -p $RPM_BUILD_ROOT/var/www/html
73 # exclude codebase just in case
74 rsync -a --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
75
76 echo "* PLEWWW: Installing conf files for httpd"
77 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
78 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
79
80 %post
81 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
82 drupal_settings_dir=/var/www/html/sites/default
83 if [ ! -d $drupal_settings_dir ] ; then
84     echo "Could not find directory $drupal_settings_dir"
85     echo "This suggests that you do not have a planetlab-custom drupal installed"
86     exit 1
87 fi
88 pushd $drupal_settings_dir
89 # tune $db_url
90 if [ ! -f settings.php.drupal ] ; then
91     cp settings.php settings.php.drupal
92     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
93         settings.php.drupal > settings.php
94 fi
95 popd
96 # append our own database creation hacks to the drupal database schema
97 pushd /var/www/html/database
98 if [ ! -f database.pgsql.drupal ] ; then
99     cp database.pgsql database.pgsql.drupal
100     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
101 fi
102 popd
103 # hack the welcome page for MyPLC
104 pushd /var/www/html/modules
105 if [ ! -f node.module.drupal ] ; then
106     cp node.module node.module.drupal
107     [ -f /var/www/html/drupal-hacks/node.module ] && cp -f /var/www/html/drupal-hacks/node.module /var/www/html/modules/node.module
108 fi
109 popd
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(-,root,root,-)
116 /var/www/html/modules
117 /var/www/html/planetlab
118 /var/www/html/googlemap
119 /var/www/html/drupal-hacks
120 /etc/httpd/conf.d
121
122 %files plekit
123 /var/www/html/plekit
124
125 %changelog
126 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
127 - fix for sites that were displayed as not public
128 - improvements to the python interface to sortable tables for monitor
129
130 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
131 - various improvements
132
133 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
134 - sliver page now correctly shows sliver tags
135 - support for download-node-usb-partition and various other improvements
136
137 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
138 - a few tweaks and typos fixed on PLE
139
140 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
141 - slice_add & node_download dialogs use plekit
142 - slice_add can add people in the slice
143 - various improvements after rollout on PLE
144
145 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
146 - cosmetic fixes to be in 4.3-rc2
147 - also a first (unpackaged) draft of the plekit table in python
148
149 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
150 - search in tables more robust
151
152 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
153 - performance improvements
154
155 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
156 - detect expired session and redirect to the login page
157
158 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
159 - improve browser health - was using too many cycles
160
161 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
162 - more consistency between views, and cosmetic changes
163
164 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
165 - area for managing slice tags
166
167 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
168 - first checkpoint tag for PLEWWW
169 - mostly functionally complete, probably a lot of tweaks still needed
170
171 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
172 - everyone is welcome to add nodes
173
174 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
175 - node-specific bootcd images to include arch in their name
176
177 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
178 - remove explicit dep to bootcd as the rpm name has changed
179
180 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
181 - noarch
182
183 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
184 - should fix yum.conf on nodes after install
185
186 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
187 - uses different path for getbootmedium results - should be safer
188
189 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
190 - comon icon replaced with the one from the comon website
191
192 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
193 - displays rpms in the about page
194
195 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
196 - safer, reference-less, way to implement layout mechnism - see
197 - settings.php for details
198 - setting types properly displayed according to user's role
199 - setting deletion : fixed (was still using code from slice attribute)
200 - more comon buttons : in the nodes and peers index pages
201 - comon_button knows about peer_id
202
203 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
204 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
205
206 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
207 - Initial build.