Merge branch 'master' of git.onelab.eu:/git/plewww
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 53
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(-,root,root,-)
115 /var/www/html/modules
116 /var/www/html/planetlab
117 /var/www/html/googlemap
118 /var/www/html/drupal-hacks
119 /etc/httpd/conf.d
120
121 %files plekit
122 /var/www/html/plekit
123
124 %changelog
125 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
126 - add a 'report a problem' link for the RebootNode button
127 - new exp page nodes2.php with consistent selectable-columns layout as myslice
128 - tweaks in the exp. myslice (slices.php)
129
130 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
131 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
132 - my_slice with adjustable set of columns in slices/slice2.php
133 - fix for the 'site registration' page
134
135 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
136 - show message about leases - leases tab first in nodes section
137 - fix how reservable nodes show up
138
139 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
140 - cosmetic, rendering of textareas was like password fields
141
142 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
143 - bugfix in slice page, had wrong (null) expiration date
144 - upgraded to raphael-1.5.2, don't minimize this lib
145 - nicer layout for password fields as well
146 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
147 - marginally optimized slice page (2 GetNodes call down)
148 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
149 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
150 - reservations can cope with a bit more slots - will need scrolling someday
151 - omf text has hyperlinks to the tools
152
153 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
154 - reservation section now effective
155 - can set omf_control at slice-creation time
156 - can set node as reservable at node-creation time
157 - nicer text input fields + various tweaks
158
159 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
160 - show nodegroups form to add new groups
161
162 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
163 - just tagging plewww again to test module-tag on git
164
165 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
166 - encode strings properly in forms.
167
168 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
169 - Use readfile() function to reduce the memory footprint
170
171 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
172 - removed all deprecated functions for PHP-5.3 on fedora 12
173
174 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
175 - * exclude DNS from subnet checking
176 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
177 - * allow longer abbreviated names
178 - * don't let empty strings kill the server (postgresql and apache)
179
180 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
181 - disable drupal user registration (hard: patching the user module)
182
183 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
184 - * show error messages for update interface
185 - * 'Add Node' is admin only
186 - * add site selector for 'Add Node'
187
188 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
189 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
190 - this affects the settings of ifname and alias that were formerly set unconditionally
191 - review the interface-checking javascript code
192 - changed the interface to plekitform, method is now optional and part of an options hash
193
194 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
195 - can't use php objects for showing node status, this is too slow
196 - fix interface add page
197
198 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
199 - consistency in the way nodes status is displayed in the node and slice areas
200 - extra tags columns show up on the nodes page as well, tweaked in the process
201 - roles management in person page fixed
202
203 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
204 - displaying node tags in the nodes page as well
205 - table headers now can have a 'title' that shows up when hovering on the column header
206
207 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
208 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
209
210 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
211 - extensible set of columns in the nodes area of the (my)slice page
212 - nodegroups can be added/deleted/updated
213 - tags management improved marginally
214
215 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
216 - fix pending sites page - was getting fooled by ext_consortium_id=None
217
218 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
219 - resetting tag as something went wrong when setting 31
220
221 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
222 - nicer look for slice creation, (public) sites
223 - users show with all their sites in the persons page
224
225 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
226 - reviewed registration pages for persons and sites
227
228 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
229 - increase memory limit in the nodes page
230
231 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
232 - fixes one typo
233
234 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
235 - minor/cosmetic
236
237 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
238 - Add default Interface tags to extra interfaces.
239 - Add clearer 'Add New PCU' link on node page.
240 - Disable user registration for tech and PI roles.
241
242 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
243 - new 'controller' instantiation state available in add slice page
244
245 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
246 - exclude datepicler.js from jsmin
247 - table sort function for Last Contact columns
248 - drop options for generic boot images
249
250 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
251 - displays editable mac address for interfaces
252 - properly sorts bandwidths
253 - new 'controller' slice instantiation method
254 - bugfix, division by zero when displaying a just-changed node
255
256 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
257 - bugfix with linetabs
258
259 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
260 - fix add interface from the node page
261
262 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
263 - only add users that are enabled and not yet a member of the slice
264 - fix to plc_peers
265 - my sites, my nodes, my persons improvements for users with multiple sites
266 - adds a script to minimize the java script files.
267
268 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
269 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
270
271 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
272 - first draft for pcu-handling features
273 - lighter contrat for PLE/PLC toggles
274 - as many 'my site'-like  links as the user has sites
275
276 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
277 - fix for whitelisted nodes
278 - now links to the node register wizard
279 - can enable sites
280 - various other minor fixes, like broken planetlab.module for techs, and login link
281
282 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
283 - plekittable knows how to turn off sort-on-load, and the admin users pages do
284 - + various cosmetic fixes
285
286 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
287 - a few minor improvements pushed on PLE
288
289 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
290 - fix for sites that were displayed as not public
291 - improvements to the python interface to sortable tables for monitor
292
293 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
294 - various improvements
295
296 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
297 - sliver page now correctly shows sliver tags
298 - support for download-node-usb-partition and various other improvements
299
300 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
301 - a few tweaks and typos fixed on PLE
302
303 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
304 - slice_add & node_download dialogs use plekit
305 - slice_add can add people in the slice
306 - various improvements after rollout on PLE
307
308 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
309 - cosmetic fixes to be in 4.3-rc2
310 - also a first (unpackaged) draft of the plekit table in python
311
312 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
313 - search in tables more robust
314
315 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
316 - performance improvements
317
318 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
319 - detect expired session and redirect to the login page
320
321 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
322 - improve browser health - was using too many cycles
323
324 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
325 - more consistency between views, and cosmetic changes
326
327 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
328 - area for managing slice tags
329
330 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
331 - first checkpoint tag for PLEWWW
332 - mostly functionally complete, probably a lot of tweaks still needed
333
334 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
335 - everyone is welcome to add nodes
336
337 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
338 - node-specific bootcd images to include arch in their name
339
340 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
341 - remove explicit dep to bootcd as the rpm name has changed
342
343 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
344 - noarch
345
346 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
347 - should fix yum.conf on nodes after install
348
349 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
350 - uses different path for getbootmedium results - should be safer
351
352 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
353 - comon icon replaced with the one from the comon website
354
355 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
356 - displays rpms in the about page
357
358 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
359 - safer, reference-less, way to implement layout mechnism - see
360 - settings.php for details
361 - setting types properly displayed according to user's role
362 - setting deletion : fixed (was still using code from slice attribute)
363 - more comon buttons : in the nodes and peers index pages
364 - comon_button knows about peer_id
365
366 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
367 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
368
369 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
370 - Initial build.