Merge branch 'master' of git.onelab.eu:/git/plewww
[plewww.git] / plewww.spec
1 #
2 # $Id$
3 #
4
5 # what the myplc rpm requires
6 %define name plewww
7 %define version 4.3
8 %define taglevel 53
9
10 # no need to mention pldistro as this module differs in both distros
11 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %define release %{taglevel}%{?date:.%{date}}
13
14 Summary: PlanetLab Europe (PLC) Web Pages
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: Applications/Systems
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 BuildArch: noarch
23 BuildRequires: python
24
25 Vendor: OneLab
26 Packager: OneLab <support@one-lab.org>
27 Distribution: PlanetLab %{version}
28 URL: http://svn.one-lab.org/svn/new_plc_www/
29
30 # We use set everywhere
31 #Requires: httpd >= 2.0
32 Requires: php >= 5.0
33 Requires: postgresql >= 8.0
34 Requires: PLCAPI >= 4.3
35 Requires: drupal = 4.7
36 Requires: plewww-plekit
37
38 # this is what MyPLC requires
39 Provides: PLCWWW
40
41 # on centos5, when rebuilding the full monty, we get:
42 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
43 # and the perl-GD rpm is nowhere to be found
44 AutoReqProv: no
45
46 %package plekit
47 Summary: Utilities used by the plewww pages
48 Group: Applications/Systems
49
50 %description
51 The plewww package is made of the web pages that run on top of the 
52 PLCAPI component to provide the Web Interface to MyPLC users.
53
54 %description plekit
55 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
56
57 %prep
58 %setup -q
59
60 %build
61 echo "Compressing javascript files"
62 make compress
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 #
68 # plewww
69 # xxx : uninstall should undo this
70 #
71
72 echo "* PLEWWW: Installing web pages"
73 mkdir -p $RPM_BUILD_ROOT/var/www/html
74 # exclude codebase just in case
75 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
76
77 echo "* PLEWWW: Installing conf files for httpd"
78 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
79 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
80
81 %post
82 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
83 drupal_settings_dir=/var/www/html/sites/default
84 if [ ! -d $drupal_settings_dir ] ; then
85     echo "Could not find directory $drupal_settings_dir"
86     echo "This suggests that you do not have a planetlab-custom drupal installed"
87     exit 1
88 fi
89 pushd $drupal_settings_dir
90 # tune $db_url
91 if [ ! -f settings.php.drupal ] ; then
92     cp settings.php settings.php.drupal
93     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
94         settings.php.drupal > settings.php
95 fi
96 popd
97 # append our own database creation hacks to the drupal database schema
98 pushd /var/www/html/database
99 if [ ! -f database.pgsql.drupal ] ; then
100     cp database.pgsql database.pgsql.drupal
101     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
102 fi
103 popd
104 # hack the welcome page for MyPLC
105 pushd /var/www/html/modules
106 for module in user node; do
107     # backup only once
108     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
109     # always update so a change in our file can make through
110     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
111 done
112 popd
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(-,root,root,-)
119 /var/www/html/modules
120 /var/www/html/planetlab
121 /var/www/html/googlemap
122 /var/www/html/drupal-hacks
123 /etc/httpd/conf.d
124
125 %files plekit
126 /var/www/html/plekit
127
128 %changelog
129 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
130 - add a 'report a problem' link for the RebootNode button
131 - new exp page nodes2.php with consistent selectable-columns layout as myslice
132 - tweaks in the exp. myslice (slices.php)
133
134 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
135 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
136 - my_slice with adjustable set of columns in slices/slice2.php
137 - fix for the 'site registration' page
138
139 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
140 - show message about leases - leases tab first in nodes section
141 - fix how reservable nodes show up
142
143 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
144 - cosmetic, rendering of textareas was like password fields
145
146 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
147 - bugfix in slice page, had wrong (null) expiration date
148 - upgraded to raphael-1.5.2, don't minimize this lib
149 - nicer layout for password fields as well
150 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
151 - marginally optimized slice page (2 GetNodes call down)
152 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
153 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
154 - reservations can cope with a bit more slots - will need scrolling someday
155 - omf text has hyperlinks to the tools
156
157 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
158 - reservation section now effective
159 - can set omf_control at slice-creation time
160 - can set node as reservable at node-creation time
161 - nicer text input fields + various tweaks
162
163 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
164 - show nodegroups form to add new groups
165
166 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
167 - just tagging plewww again to test module-tag on git
168
169 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
170 - encode strings properly in forms.
171
172 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
173 - Use readfile() function to reduce the memory footprint
174
175 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
176 - removed all deprecated functions for PHP-5.3 on fedora 12
177
178 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
179 - * exclude DNS from subnet checking
180 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
181 - * allow longer abbreviated names
182 - * don't let empty strings kill the server (postgresql and apache)
183
184 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
185 - disable drupal user registration (hard: patching the user module)
186
187 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
188 - * show error messages for update interface
189 - * 'Add Node' is admin only
190 - * add site selector for 'Add Node'
191
192 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
193 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
194 - this affects the settings of ifname and alias that were formerly set unconditionally
195 - review the interface-checking javascript code
196 - changed the interface to plekitform, method is now optional and part of an options hash
197
198 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
199 - can't use php objects for showing node status, this is too slow
200 - fix interface add page
201
202 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
203 - consistency in the way nodes status is displayed in the node and slice areas
204 - extra tags columns show up on the nodes page as well, tweaked in the process
205 - roles management in person page fixed
206
207 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
208 - displaying node tags in the nodes page as well
209 - table headers now can have a 'title' that shows up when hovering on the column header
210
211 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
212 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
213
214 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
215 - extensible set of columns in the nodes area of the (my)slice page
216 - nodegroups can be added/deleted/updated
217 - tags management improved marginally
218
219 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
220 - fix pending sites page - was getting fooled by ext_consortium_id=None
221
222 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
223 - resetting tag as something went wrong when setting 31
224
225 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
226 - nicer look for slice creation, (public) sites
227 - users show with all their sites in the persons page
228
229 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
230 - reviewed registration pages for persons and sites
231
232 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
233 - increase memory limit in the nodes page
234
235 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
236 - fixes one typo
237
238 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
239 - minor/cosmetic
240
241 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
242 - Add default Interface tags to extra interfaces.
243 - Add clearer 'Add New PCU' link on node page.
244 - Disable user registration for tech and PI roles.
245
246 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
247 - new 'controller' instantiation state available in add slice page
248
249 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
250 - exclude datepicler.js from jsmin
251 - table sort function for Last Contact columns
252 - drop options for generic boot images
253
254 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
255 - displays editable mac address for interfaces
256 - properly sorts bandwidths
257 - new 'controller' slice instantiation method
258 - bugfix, division by zero when displaying a just-changed node
259
260 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
261 - bugfix with linetabs
262
263 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
264 - fix add interface from the node page
265
266 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
267 - only add users that are enabled and not yet a member of the slice
268 - fix to plc_peers
269 - my sites, my nodes, my persons improvements for users with multiple sites
270 - adds a script to minimize the java script files.
271
272 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
273 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
274
275 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
276 - first draft for pcu-handling features
277 - lighter contrat for PLE/PLC toggles
278 - as many 'my site'-like  links as the user has sites
279
280 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
281 - fix for whitelisted nodes
282 - now links to the node register wizard
283 - can enable sites
284 - various other minor fixes, like broken planetlab.module for techs, and login link
285
286 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
287 - plekittable knows how to turn off sort-on-load, and the admin users pages do
288 - + various cosmetic fixes
289
290 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
291 - a few minor improvements pushed on PLE
292
293 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
294 - fix for sites that were displayed as not public
295 - improvements to the python interface to sortable tables for monitor
296
297 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
298 - various improvements
299
300 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
301 - sliver page now correctly shows sliver tags
302 - support for download-node-usb-partition and various other improvements
303
304 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
305 - a few tweaks and typos fixed on PLE
306
307 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
308 - slice_add & node_download dialogs use plekit
309 - slice_add can add people in the slice
310 - various improvements after rollout on PLE
311
312 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
313 - cosmetic fixes to be in 4.3-rc2
314 - also a first (unpackaged) draft of the plekit table in python
315
316 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
317 - search in tables more robust
318
319 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
320 - performance improvements
321
322 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
323 - detect expired session and redirect to the login page
324
325 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
326 - improve browser health - was using too many cycles
327
328 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
329 - more consistency between views, and cosmetic changes
330
331 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
332 - area for managing slice tags
333
334 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
335 - first checkpoint tag for PLEWWW
336 - mostly functionally complete, probably a lot of tweaks still needed
337
338 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
339 - everyone is welcome to add nodes
340
341 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
342 - node-specific bootcd images to include arch in their name
343
344 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
345 - remove explicit dep to bootcd as the rpm name has changed
346
347 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
348 - noarch
349
350 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
351 - should fix yum.conf on nodes after install
352
353 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
354 - uses different path for getbootmedium results - should be safer
355
356 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
357 - comon icon replaced with the one from the comon website
358
359 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
360 - displays rpms in the about page
361
362 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
363 - safer, reference-less, way to implement layout mechnism - see
364 - settings.php for details
365 - setting types properly displayed according to user's role
366 - setting deletion : fixed (was still using code from slice attribute)
367 - more comon buttons : in the nodes and peers index pages
368 - comon_button knows about peer_id
369
370 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
371 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
372
373 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
374 - Initial build.