Merge branch 'master' of ssh://git.onelab.eu/git/plewww
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 64
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
129 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
130 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
131 - has a feature to 'test' pcu connection
132 - only admins can add users to different sites.
133 - remove dep. to outdated _gen_planetflow.php
134 - rephrased (disabled, or pending registration)
135 - + various fixes
136
137 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
138 - fix display glitch exposed with dimes initscript
139
140 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
141 - rename initscript_body into initscript_code
142
143 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
144 - bugfix for the reservation interface
145
146 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
147 - reservation page uses ajax - no need to reload after submit
148 - reservation dialogs for offset in the future & # slots
149 - fix the timezone in reservations (actually use php.ini)
150 - reservation visible (and hardwired) in nodes view
151 - have pulled prototype 1.7 but not in used yet
152
153 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
154 - set both 'omf_control' and 'vref' for omf-friendly slices
155
156 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
157 - display tags in alphabetic order in node view, tags section, the drop down menu
158
159 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
160 - on-the-fly retrieval of data at comon & tophat (unused so far)
161 - use accessors to store person's preference of columns
162 - fix in toggle.js for the '?' button, node table layout tab
163 - sort actions logging improved
164
165 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
166 - keep people from disabling or deleting themselves
167 - cannot become a disabled person
168 - outline people without a role
169
170 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
171 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
172
173 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
174 - tagging plewww for a new deployment
175
176 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
177 - add a 'report a problem' link for the RebootNode button
178 - new exp page nodes2.php with consistent selectable-columns layout as myslice
179 - tweaks in the exp. myslice (slices.php)
180
181 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
182 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
183 - my_slice with adjustable set of columns in slices/slice2.php
184 - fix for the 'site registration' page
185
186 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
187 - show message about leases - leases tab first in nodes section
188 - fix how reservable nodes show up
189
190 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
191 - cosmetic, rendering of textareas was like password fields
192
193 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
194 - bugfix in slice page, had wrong (null) expiration date
195 - upgraded to raphael-1.5.2, don't minimize this lib
196 - nicer layout for password fields as well
197 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
198 - marginally optimized slice page (2 GetNodes call down)
199 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
200 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
201 - reservations can cope with a bit more slots - will need scrolling someday
202 - omf text has hyperlinks to the tools
203
204 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
205 - reservation section now effective
206 - can set omf_control at slice-creation time
207 - can set node as reservable at node-creation time
208 - nicer text input fields + various tweaks
209
210 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
211 - show nodegroups form to add new groups
212
213 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
214 - just tagging plewww again to test module-tag on git
215
216 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
217 - encode strings properly in forms.
218
219 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
220 - Use readfile() function to reduce the memory footprint
221
222 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
223 - removed all deprecated functions for PHP-5.3 on fedora 12
224
225 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
226 - * exclude DNS from subnet checking
227 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
228 - * allow longer abbreviated names
229 - * don't let empty strings kill the server (postgresql and apache)
230
231 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
232 - disable drupal user registration (hard: patching the user module)
233
234 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
235 - * show error messages for update interface
236 - * 'Add Node' is admin only
237 - * add site selector for 'Add Node'
238
239 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
240 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
241 - this affects the settings of ifname and alias that were formerly set unconditionally
242 - review the interface-checking javascript code
243 - changed the interface to plekitform, method is now optional and part of an options hash
244
245 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
246 - can't use php objects for showing node status, this is too slow
247 - fix interface add page
248
249 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
250 - consistency in the way nodes status is displayed in the node and slice areas
251 - extra tags columns show up on the nodes page as well, tweaked in the process
252 - roles management in person page fixed
253
254 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
255 - displaying node tags in the nodes page as well
256 - table headers now can have a 'title' that shows up when hovering on the column header
257
258 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
259 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
260
261 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
262 - extensible set of columns in the nodes area of the (my)slice page
263 - nodegroups can be added/deleted/updated
264 - tags management improved marginally
265
266 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
267 - fix pending sites page - was getting fooled by ext_consortium_id=None
268
269 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
270 - resetting tag as something went wrong when setting 31
271
272 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
273 - nicer look for slice creation, (public) sites
274 - users show with all their sites in the persons page
275
276 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
277 - reviewed registration pages for persons and sites
278
279 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
280 - increase memory limit in the nodes page
281
282 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
283 - fixes one typo
284
285 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
286 - minor/cosmetic
287
288 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
289 - Add default Interface tags to extra interfaces.
290 - Add clearer 'Add New PCU' link on node page.
291 - Disable user registration for tech and PI roles.
292
293 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
294 - new 'controller' instantiation state available in add slice page
295
296 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
297 - exclude datepicler.js from jsmin
298 - table sort function for Last Contact columns
299 - drop options for generic boot images
300
301 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
302 - displays editable mac address for interfaces
303 - properly sorts bandwidths
304 - new 'controller' slice instantiation method
305 - bugfix, division by zero when displaying a just-changed node
306
307 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
308 - bugfix with linetabs
309
310 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
311 - fix add interface from the node page
312
313 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
314 - only add users that are enabled and not yet a member of the slice
315 - fix to plc_peers
316 - my sites, my nodes, my persons improvements for users with multiple sites
317 - adds a script to minimize the java script files.
318
319 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
320 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
321
322 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
323 - first draft for pcu-handling features
324 - lighter contrat for PLE/PLC toggles
325 - as many 'my site'-like  links as the user has sites
326
327 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
328 - fix for whitelisted nodes
329 - now links to the node register wizard
330 - can enable sites
331 - various other minor fixes, like broken planetlab.module for techs, and login link
332
333 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
334 - plekittable knows how to turn off sort-on-load, and the admin users pages do
335 - + various cosmetic fixes
336
337 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
338 - a few minor improvements pushed on PLE
339
340 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
341 - fix for sites that were displayed as not public
342 - improvements to the python interface to sortable tables for monitor
343
344 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
345 - various improvements
346
347 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
348 - sliver page now correctly shows sliver tags
349 - support for download-node-usb-partition and various other improvements
350
351 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
352 - a few tweaks and typos fixed on PLE
353
354 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
355 - slice_add & node_download dialogs use plekit
356 - slice_add can add people in the slice
357 - various improvements after rollout on PLE
358
359 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
360 - cosmetic fixes to be in 4.3-rc2
361 - also a first (unpackaged) draft of the plekit table in python
362
363 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
364 - search in tables more robust
365
366 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
367 - performance improvements
368
369 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
370 - detect expired session and redirect to the login page
371
372 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
373 - improve browser health - was using too many cycles
374
375 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
376 - more consistency between views, and cosmetic changes
377
378 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
379 - area for managing slice tags
380
381 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
382 - first checkpoint tag for PLEWWW
383 - mostly functionally complete, probably a lot of tweaks still needed
384
385 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
386 - everyone is welcome to add nodes
387
388 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
389 - node-specific bootcd images to include arch in their name
390
391 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
392 - remove explicit dep to bootcd as the rpm name has changed
393
394 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
395 - noarch
396
397 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
398 - should fix yum.conf on nodes after install
399
400 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
401 - uses different path for getbootmedium results - should be safer
402
403 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
404 - comon icon replaced with the one from the comon website
405
406 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
407 - displays rpms in the about page
408
409 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
410 - safer, reference-less, way to implement layout mechnism - see
411 - settings.php for details
412 - setting types properly displayed according to user's role
413 - setting deletion : fixed (was still using code from slice attribute)
414 - more comon buttons : in the nodes and peers index pages
415 - comon_button knows about peer_id
416
417 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
418 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
419
420 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
421 - Initial build.