Setting tag plewww-4.3-56
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 56
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
129 - keep people from disabling or deleting themselves
130 - cannot become a disabled person
131 - outline people without a role
132
133 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
134 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
135
136 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
137 - tagging plewww for a new deployment
138
139 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
140 - add a 'report a problem' link for the RebootNode button
141 - new exp page nodes2.php with consistent selectable-columns layout as myslice
142 - tweaks in the exp. myslice (slices.php)
143
144 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
145 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
146 - my_slice with adjustable set of columns in slices/slice2.php
147 - fix for the 'site registration' page
148
149 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
150 - show message about leases - leases tab first in nodes section
151 - fix how reservable nodes show up
152
153 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
154 - cosmetic, rendering of textareas was like password fields
155
156 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
157 - bugfix in slice page, had wrong (null) expiration date
158 - upgraded to raphael-1.5.2, don't minimize this lib
159 - nicer layout for password fields as well
160 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
161 - marginally optimized slice page (2 GetNodes call down)
162 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
163 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
164 - reservations can cope with a bit more slots - will need scrolling someday
165 - omf text has hyperlinks to the tools
166
167 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
168 - reservation section now effective
169 - can set omf_control at slice-creation time
170 - can set node as reservable at node-creation time
171 - nicer text input fields + various tweaks
172
173 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
174 - show nodegroups form to add new groups
175
176 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
177 - just tagging plewww again to test module-tag on git
178
179 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
180 - encode strings properly in forms.
181
182 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
183 - Use readfile() function to reduce the memory footprint
184
185 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
186 - removed all deprecated functions for PHP-5.3 on fedora 12
187
188 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
189 - * exclude DNS from subnet checking
190 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
191 - * allow longer abbreviated names
192 - * don't let empty strings kill the server (postgresql and apache)
193
194 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
195 - disable drupal user registration (hard: patching the user module)
196
197 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
198 - * show error messages for update interface
199 - * 'Add Node' is admin only
200 - * add site selector for 'Add Node'
201
202 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
203 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
204 - this affects the settings of ifname and alias that were formerly set unconditionally
205 - review the interface-checking javascript code
206 - changed the interface to plekitform, method is now optional and part of an options hash
207
208 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
209 - can't use php objects for showing node status, this is too slow
210 - fix interface add page
211
212 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
213 - consistency in the way nodes status is displayed in the node and slice areas
214 - extra tags columns show up on the nodes page as well, tweaked in the process
215 - roles management in person page fixed
216
217 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
218 - displaying node tags in the nodes page as well
219 - table headers now can have a 'title' that shows up when hovering on the column header
220
221 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
222 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
223
224 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
225 - extensible set of columns in the nodes area of the (my)slice page
226 - nodegroups can be added/deleted/updated
227 - tags management improved marginally
228
229 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
230 - fix pending sites page - was getting fooled by ext_consortium_id=None
231
232 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
233 - resetting tag as something went wrong when setting 31
234
235 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
236 - nicer look for slice creation, (public) sites
237 - users show with all their sites in the persons page
238
239 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
240 - reviewed registration pages for persons and sites
241
242 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
243 - increase memory limit in the nodes page
244
245 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
246 - fixes one typo
247
248 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
249 - minor/cosmetic
250
251 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
252 - Add default Interface tags to extra interfaces.
253 - Add clearer 'Add New PCU' link on node page.
254 - Disable user registration for tech and PI roles.
255
256 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
257 - new 'controller' instantiation state available in add slice page
258
259 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
260 - exclude datepicler.js from jsmin
261 - table sort function for Last Contact columns
262 - drop options for generic boot images
263
264 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
265 - displays editable mac address for interfaces
266 - properly sorts bandwidths
267 - new 'controller' slice instantiation method
268 - bugfix, division by zero when displaying a just-changed node
269
270 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
271 - bugfix with linetabs
272
273 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
274 - fix add interface from the node page
275
276 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
277 - only add users that are enabled and not yet a member of the slice
278 - fix to plc_peers
279 - my sites, my nodes, my persons improvements for users with multiple sites
280 - adds a script to minimize the java script files.
281
282 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
283 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
284
285 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
286 - first draft for pcu-handling features
287 - lighter contrat for PLE/PLC toggles
288 - as many 'my site'-like  links as the user has sites
289
290 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
291 - fix for whitelisted nodes
292 - now links to the node register wizard
293 - can enable sites
294 - various other minor fixes, like broken planetlab.module for techs, and login link
295
296 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
297 - plekittable knows how to turn off sort-on-load, and the admin users pages do
298 - + various cosmetic fixes
299
300 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
301 - a few minor improvements pushed on PLE
302
303 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
304 - fix for sites that were displayed as not public
305 - improvements to the python interface to sortable tables for monitor
306
307 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
308 - various improvements
309
310 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
311 - sliver page now correctly shows sliver tags
312 - support for download-node-usb-partition and various other improvements
313
314 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
315 - a few tweaks and typos fixed on PLE
316
317 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
318 - slice_add & node_download dialogs use plekit
319 - slice_add can add people in the slice
320 - various improvements after rollout on PLE
321
322 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
323 - cosmetic fixes to be in 4.3-rc2
324 - also a first (unpackaged) draft of the plekit table in python
325
326 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
327 - search in tables more robust
328
329 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
330 - performance improvements
331
332 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
333 - detect expired session and redirect to the login page
334
335 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
336 - improve browser health - was using too many cycles
337
338 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
339 - more consistency between views, and cosmetic changes
340
341 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
342 - area for managing slice tags
343
344 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
345 - first checkpoint tag for PLEWWW
346 - mostly functionally complete, probably a lot of tweaks still needed
347
348 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
349 - everyone is welcome to add nodes
350
351 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
352 - node-specific bootcd images to include arch in their name
353
354 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
355 - remove explicit dep to bootcd as the rpm name has changed
356
357 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
358 - noarch
359
360 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
361 - should fix yum.conf on nodes after install
362
363 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
364 - uses different path for getbootmedium results - should be safer
365
366 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
367 - comon icon replaced with the one from the comon website
368
369 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
370 - displays rpms in the about page
371
372 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
373 - safer, reference-less, way to implement layout mechnism - see
374 - settings.php for details
375 - setting types properly displayed according to user's role
376 - setting deletion : fixed (was still using code from slice attribute)
377 - more comon buttons : in the nodes and peers index pages
378 - comon_button knows about peer_id
379
380 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
381 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
382
383 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
384 - Initial build.