Setting tag plewww-5.2-9
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 9
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: plcapi >= 5.2
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Wed May 16 2018 Thierry <Parmentelat> - plewww-5.2-9
129 - not too clean patches for r2lab:
130 - * search for a file named /etc/planetlab/php/person-registration.txt
131 - that can override the text message for individuals registration
132 - * do not list sites that have the disabled_registration tag set
133 - when listing them for individuals registration
134 - remove omf-friendly checkbox in slice-creation dialog
135 - comment out {Min,Max}SpareServers settings in httpd config
136
137 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-8
138 - a few niceties, thanks to Ciro
139
140 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-7
141 - remove utf8_deode as per Thomas's suggestion
142
143 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-6
144 - Offer the option to set a node in 'upgrade' mode - like reinstall but leaving slices intact
145
146 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-5
147 - tweaks in node_downloads.php about memory size and compression scheme
148
149 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-4
150 - googlemap widget: support for gmap api v3 + various cosmetic tweaks
151 - can display site names with odd characters
152
153 * Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
154 - typo in help message about initscripts
155
156 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
157 - node page and person page show hrn in details
158
159 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
160 - late fix of registration for plcapi-5.1-6
161
162 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
163 - add extra code to prevent confidentiality leaks
164 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
165 - return_url for add-person and remove-person
166 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
167
168 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
169 - add tags section on site and person pages
170
171 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
172 - slightly tweak profiling points in slice.php
173
174 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
175 - ships with new default images for PLC/PLE from planet-lab.eu
176
177 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
178 - no change, just make sync for lxc-hosted tests
179
180 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
181 - refactoring for tophat/columns
182 - should take care of the irritating warning message about columns
183
184 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
185 - do not display the 'node' role when confusing
186
187 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
188 - support for setting nodes as reservable
189 - rely more on previous state when deciding to open or not toggles in a view
190 - remove statements for setting maximum memory usage, that sometimes
191
192 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
193 - node page can edit interfaces even when no interface
194
195 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
196 - uses a 2-week (!) session
197
198 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
199 - minor/cosmetic fixes in the leases area
200
201 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
202 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
203 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
204 - has a feature to 'test' pcu connection
205 - only admins can add users to different sites.
206 - remove dep. to outdated _gen_planetflow.php
207 - rephrased (disabled, or pending registration)
208 - + various fixes
209
210 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
211 - fix display glitch exposed with dimes initscript
212
213 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
214 - rename initscript_body into initscript_code
215
216 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
217 - bugfix for the reservation interface
218
219 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
220 - reservation page uses ajax - no need to reload after submit
221 - reservation dialogs for offset in the future & # slots
222 - fix the timezone in reservations (actually use php.ini)
223 - reservation visible (and hardwired) in nodes view
224 - have pulled prototype 1.7 but not in used yet
225
226 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
227 - set both 'omf_control' and 'vref' for omf-friendly slices
228
229 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
230 - display tags in alphabetic order in node view, tags section, the drop down menu
231
232 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
233 - on-the-fly retrieval of data at comon & tophat (unused so far)
234 - use accessors to store person's preference of columns
235 - fix in toggle.js for the '?' button, node table layout tab
236 - sort actions logging improved
237
238 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
239 - keep people from disabling or deleting themselves
240 - cannot become a disabled person
241 - outline people without a role
242
243 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
244 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
245
246 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
247 - tagging plewww for a new deployment
248
249 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
250 - add a 'report a problem' link for the RebootNode button
251 - new exp page nodes2.php with consistent selectable-columns layout as myslice
252 - tweaks in the exp. myslice (slices.php)
253
254 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
255 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
256 - my_slice with adjustable set of columns in slices/slice2.php
257 - fix for the 'site registration' page
258
259 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
260 - show message about leases - leases tab first in nodes section
261 - fix how reservable nodes show up
262
263 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
264 - cosmetic, rendering of textareas was like password fields
265
266 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
267 - bugfix in slice page, had wrong (null) expiration date
268 - upgraded to raphael-1.5.2, don't minimize this lib
269 - nicer layout for password fields as well
270 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
271 - marginally optimized slice page (2 GetNodes call down)
272 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
273 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
274 - reservations can cope with a bit more slots - will need scrolling someday
275 - omf text has hyperlinks to the tools
276
277 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
278 - reservation section now effective
279 - can set omf_control at slice-creation time
280 - can set node as reservable at node-creation time
281 - nicer text input fields + various tweaks
282
283 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
284 - show nodegroups form to add new groups
285
286 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
287 - just tagging plewww again to test module-tag on git
288
289 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
290 - encode strings properly in forms.
291
292 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
293 - Use readfile() function to reduce the memory footprint
294
295 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
296 - removed all deprecated functions for PHP-5.3 on fedora 12
297
298 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
299 - * exclude DNS from subnet checking
300 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
301 - * allow longer abbreviated names
302 - * don't let empty strings kill the server (postgresql and apache)
303
304 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
305 - disable drupal user registration (hard: patching the user module)
306
307 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
308 - * show error messages for update interface
309 - * 'Add Node' is admin only
310 - * add site selector for 'Add Node'
311
312 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
313 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
314 - this affects the settings of ifname and alias that were formerly set unconditionally
315 - review the interface-checking javascript code
316 - changed the interface to plekitform, method is now optional and part of an options hash
317
318 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
319 - can't use php objects for showing node status, this is too slow
320 - fix interface add page
321
322 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
323 - consistency in the way nodes status is displayed in the node and slice areas
324 - extra tags columns show up on the nodes page as well, tweaked in the process
325 - roles management in person page fixed
326
327 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
328 - displaying node tags in the nodes page as well
329 - table headers now can have a 'title' that shows up when hovering on the column header
330
331 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
332 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
333
334 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
335 - extensible set of columns in the nodes area of the (my)slice page
336 - nodegroups can be added/deleted/updated
337 - tags management improved marginally
338
339 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
340 - fix pending sites page - was getting fooled by ext_consortium_id=None
341
342 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
343 - resetting tag as something went wrong when setting 31
344
345 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
346 - nicer look for slice creation, (public) sites
347 - users show with all their sites in the persons page
348
349 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
350 - reviewed registration pages for persons and sites
351
352 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
353 - increase memory limit in the nodes page
354
355 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
356 - fixes one typo
357
358 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
359 - minor/cosmetic
360
361 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
362 - Add default Interface tags to extra interfaces.
363 - Add clearer 'Add New PCU' link on node page.
364 - Disable user registration for tech and PI roles.
365
366 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
367 - new 'controller' instantiation state available in add slice page
368
369 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
370 - exclude datepicler.js from jsmin
371 - table sort function for Last Contact columns
372 - drop options for generic boot images
373
374 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
375 - displays editable mac address for interfaces
376 - properly sorts bandwidths
377 - new 'controller' slice instantiation method
378 - bugfix, division by zero when displaying a just-changed node
379
380 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
381 - bugfix with linetabs
382
383 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
384 - fix add interface from the node page
385
386 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
387 - only add users that are enabled and not yet a member of the slice
388 - fix to plc_peers
389 - my sites, my nodes, my persons improvements for users with multiple sites
390 - adds a script to minimize the java script files.
391
392 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
393 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
394
395 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
396 - first draft for pcu-handling features
397 - lighter contrat for PLE/PLC toggles
398 - as many 'my site'-like  links as the user has sites
399
400 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
401 - fix for whitelisted nodes
402 - now links to the node register wizard
403 - can enable sites
404 - various other minor fixes, like broken planetlab.module for techs, and login link
405
406 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
407 - plekittable knows how to turn off sort-on-load, and the admin users pages do
408 - + various cosmetic fixes
409
410 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
411 - a few minor improvements pushed on PLE
412
413 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
414 - fix for sites that were displayed as not public
415 - improvements to the python interface to sortable tables for monitor
416
417 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
418 - various improvements
419
420 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
421 - sliver page now correctly shows sliver tags
422 - support for download-node-usb-partition and various other improvements
423
424 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
425 - a few tweaks and typos fixed on PLE
426
427 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
428 - slice_add & node_download dialogs use plekit
429 - slice_add can add people in the slice
430 - various improvements after rollout on PLE
431
432 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
433 - cosmetic fixes to be in 4.3-rc2
434 - also a first (unpackaged) draft of the plekit table in python
435
436 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
437 - search in tables more robust
438
439 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
440 - performance improvements
441
442 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
443 - detect expired session and redirect to the login page
444
445 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
446 - improve browser health - was using too many cycles
447
448 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
449 - more consistency between views, and cosmetic changes
450
451 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
452 - area for managing slice tags
453
454 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
455 - first checkpoint tag for PLEWWW
456 - mostly functionally complete, probably a lot of tweaks still needed
457
458 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
459 - everyone is welcome to add nodes
460
461 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
462 - node-specific bootcd images to include arch in their name
463
464 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
465 - remove explicit dep to bootcd as the rpm name has changed
466
467 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
468 - noarch
469
470 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
471 - should fix yum.conf on nodes after install
472
473 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
474 - uses different path for getbootmedium results - should be safer
475
476 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
477 - comon icon replaced with the one from the comon website
478
479 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
480 - displays rpms in the about page
481
482 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
483 - safer, reference-less, way to implement layout mechnism - see
484 - settings.php for details
485 - setting types properly displayed according to user's role
486 - setting deletion : fixed (was still using code from slice attribute)
487 - more comon buttons : in the nodes and peers index pages
488 - comon_button knows about peer_id
489
490 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
491 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
492
493 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
494 - Initial build.