Setting tag PLEWWW-4.3-43
[plewww.git] / plewww.spec
1 #
2 # $Id$
3 #
4
5 # what the myplc rpm requires
6 %define name plewww
7 %define version 4.3
8 %define taglevel 43
9
10 # no need to mention pldistro as this module differs in both distros
11 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %define release %{taglevel}%{?date:.%{date}}
13
14 Summary: PlanetLab Europe (PLC) Web Pages
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: Applications/Systems
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 BuildArch: noarch
23 BuildRequires: python
24
25 Vendor: OneLab
26 Packager: OneLab <support@one-lab.org>
27 Distribution: PlanetLab %{version}
28 URL: http://svn.one-lab.org/svn/new_plc_www/
29
30 # We use set everywhere
31 #Requires: httpd >= 2.0
32 Requires: php >= 5.0
33 Requires: postgresql >= 8.0
34 Requires: PLCAPI >= 4.3
35 Requires: drupal = 4.7
36 Requires: plewww-plekit
37
38 # this is what MyPLC requires
39 Provides: PLCWWW
40
41 # on centos5, when rebuilding the full monty, we get:
42 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
43 # and the perl-GD rpm is nowhere to be found
44 AutoReqProv: no
45
46 %package plekit
47 Summary: Utilities used by the plewww pages
48 Group: Applications/Systems
49
50 %description
51 The plewww package is made of the web pages that run on top of the 
52 PLCAPI component to provide the Web Interface to MyPLC users.
53
54 %description plekit
55 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
56
57 %prep
58 %setup -q
59
60 %build
61 echo "Compressing javascript files"
62 make compress
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 #
68 # plewww
69 # xxx : uninstall should undo this
70 #
71
72 echo "* PLEWWW: Installing web pages"
73 mkdir -p $RPM_BUILD_ROOT/var/www/html
74 # exclude codebase just in case
75 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
76
77 echo "* PLEWWW: Installing conf files for httpd"
78 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
79 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
80
81 %post
82 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
83 drupal_settings_dir=/var/www/html/sites/default
84 if [ ! -d $drupal_settings_dir ] ; then
85     echo "Could not find directory $drupal_settings_dir"
86     echo "This suggests that you do not have a planetlab-custom drupal installed"
87     exit 1
88 fi
89 pushd $drupal_settings_dir
90 # tune $db_url
91 if [ ! -f settings.php.drupal ] ; then
92     cp settings.php settings.php.drupal
93     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
94         settings.php.drupal > settings.php
95 fi
96 popd
97 # append our own database creation hacks to the drupal database schema
98 pushd /var/www/html/database
99 if [ ! -f database.pgsql.drupal ] ; then
100     cp database.pgsql database.pgsql.drupal
101     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
102 fi
103 popd
104 # hack the welcome page for MyPLC
105 pushd /var/www/html/modules
106 for module in user node; do
107     # backup only once
108     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
109     # always update so a change in our file can make through
110     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
111 done
112 popd
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(-,root,root,-)
119 /var/www/html/modules
120 /var/www/html/planetlab
121 /var/www/html/googlemap
122 /var/www/html/drupal-hacks
123 /etc/httpd/conf.d
124
125 %files plekit
126 /var/www/html/plekit
127
128 %changelog
129 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
130 - removed all deprecated functions for PHP-5.3 on fedora 12
131
132 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
133 - * exclude DNS from subnet checking
134 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
135 - * allow longer abbreviated names
136 - * don't let empty strings kill the server (postgresql and apache)
137
138 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
139 - disable drupal user registration (hard: patching the user module)
140
141 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
142 - * show error messages for update interface
143 - * 'Add Node' is admin only
144 - * add site selector for 'Add Node'
145
146 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
147 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
148 - this affects the settings of ifname and alias that were formerly set unconditionally
149 - review the interface-checking javascript code
150 - changed the interface to plekitform, method is now optional and part of an options hash
151
152 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
153 - can't use php objects for showing node status, this is too slow
154 - fix interface add page
155
156 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
157 - consistency in the way nodes status is displayed in the node and slice areas
158 - extra tags columns show up on the nodes page as well, tweaked in the process
159 - roles management in person page fixed
160
161 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
162 - displaying node tags in the nodes page as well
163 - table headers now can have a 'title' that shows up when hovering on the column header
164
165 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
166 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
167
168 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
169 - extensible set of columns in the nodes area of the (my)slice page
170 - nodegroups can be added/deleted/updated
171 - tags management improved marginally
172
173 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
174 - fix pending sites page - was getting fooled by ext_consortium_id=None
175
176 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
177 - resetting tag as something went wrong when setting 31
178
179 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
180 - nicer look for slice creation, (public) sites
181 - users show with all their sites in the persons page
182
183 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
184 - reviewed registration pages for persons and sites
185
186 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
187 - increase memory limit in the nodes page
188
189 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
190 - fixes one typo
191
192 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
193 - minor/cosmetic
194
195 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
196 - Add default Interface tags to extra interfaces.
197 - Add clearer 'Add New PCU' link on node page.
198 - Disable user registration for tech and PI roles.
199
200 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
201 - new 'controller' instantiation state available in add slice page
202
203 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
204 - exclude datepicler.js from jsmin
205 - table sort function for Last Contact columns
206 - drop options for generic boot images
207
208 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
209 - displays editable mac address for interfaces
210 - properly sorts bandwidths
211 - new 'controller' slice instantiation method
212 - bugfix, division by zero when displaying a just-changed node
213
214 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
215 - bugfix with linetabs
216
217 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
218 - fix add interface from the node page
219
220 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
221 - only add users that are enabled and not yet a member of the slice
222 - fix to plc_peers
223 - my sites, my nodes, my persons improvements for users with multiple sites
224 - adds a script to minimize the java script files.
225
226 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
227 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
228
229 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
230 - first draft for pcu-handling features
231 - lighter contrat for PLE/PLC toggles
232 - as many 'my site'-like  links as the user has sites
233
234 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
235 - fix for whitelisted nodes
236 - now links to the node register wizard
237 - can enable sites
238 - various other minor fixes, like broken planetlab.module for techs, and login link
239
240 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
241 - plekittable knows how to turn off sort-on-load, and the admin users pages do
242 - + various cosmetic fixes
243
244 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
245 - a few minor improvements pushed on PLE
246
247 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
248 - fix for sites that were displayed as not public
249 - improvements to the python interface to sortable tables for monitor
250
251 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
252 - various improvements
253
254 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
255 - sliver page now correctly shows sliver tags
256 - support for download-node-usb-partition and various other improvements
257
258 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
259 - a few tweaks and typos fixed on PLE
260
261 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
262 - slice_add & node_download dialogs use plekit
263 - slice_add can add people in the slice
264 - various improvements after rollout on PLE
265
266 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
267 - cosmetic fixes to be in 4.3-rc2
268 - also a first (unpackaged) draft of the plekit table in python
269
270 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
271 - search in tables more robust
272
273 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
274 - performance improvements
275
276 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
277 - detect expired session and redirect to the login page
278
279 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
280 - improve browser health - was using too many cycles
281
282 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
283 - more consistency between views, and cosmetic changes
284
285 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
286 - area for managing slice tags
287
288 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
289 - first checkpoint tag for PLEWWW
290 - mostly functionally complete, probably a lot of tweaks still needed
291
292 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
293 - everyone is welcome to add nodes
294
295 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
296 - node-specific bootcd images to include arch in their name
297
298 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
299 - remove explicit dep to bootcd as the rpm name has changed
300
301 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
302 - noarch
303
304 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
305 - should fix yum.conf on nodes after install
306
307 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
308 - uses different path for getbootmedium results - should be safer
309
310 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
311 - comon icon replaced with the one from the comon website
312
313 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
314 - displays rpms in the about page
315
316 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
317 - safer, reference-less, way to implement layout mechnism - see
318 - settings.php for details
319 - setting types properly displayed according to user's role
320 - setting deletion : fixed (was still using code from slice attribute)
321 - more comon buttons : in the nodes and peers index pages
322 - comon_button knows about peer_id
323
324 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
325 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
326
327 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
328 - Initial build.