Setting tag plewww-4.3-57
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 57
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
129 - on-the-fly retrieval of data at comon & tophat (unused so far)
130 - use accessors to store person's preference of columns
131 - fix in toggle.js for the '?' button, node table layout tab
132 - sort actions logging improved
133
134 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
135 - keep people from disabling or deleting themselves
136 - cannot become a disabled person
137 - outline people without a role
138
139 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
140 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
141
142 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
143 - tagging plewww for a new deployment
144
145 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
146 - add a 'report a problem' link for the RebootNode button
147 - new exp page nodes2.php with consistent selectable-columns layout as myslice
148 - tweaks in the exp. myslice (slices.php)
149
150 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
151 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
152 - my_slice with adjustable set of columns in slices/slice2.php
153 - fix for the 'site registration' page
154
155 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
156 - show message about leases - leases tab first in nodes section
157 - fix how reservable nodes show up
158
159 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
160 - cosmetic, rendering of textareas was like password fields
161
162 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
163 - bugfix in slice page, had wrong (null) expiration date
164 - upgraded to raphael-1.5.2, don't minimize this lib
165 - nicer layout for password fields as well
166 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
167 - marginally optimized slice page (2 GetNodes call down)
168 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
169 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
170 - reservations can cope with a bit more slots - will need scrolling someday
171 - omf text has hyperlinks to the tools
172
173 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
174 - reservation section now effective
175 - can set omf_control at slice-creation time
176 - can set node as reservable at node-creation time
177 - nicer text input fields + various tweaks
178
179 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
180 - show nodegroups form to add new groups
181
182 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
183 - just tagging plewww again to test module-tag on git
184
185 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
186 - encode strings properly in forms.
187
188 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
189 - Use readfile() function to reduce the memory footprint
190
191 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
192 - removed all deprecated functions for PHP-5.3 on fedora 12
193
194 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
195 - * exclude DNS from subnet checking
196 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
197 - * allow longer abbreviated names
198 - * don't let empty strings kill the server (postgresql and apache)
199
200 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
201 - disable drupal user registration (hard: patching the user module)
202
203 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
204 - * show error messages for update interface
205 - * 'Add Node' is admin only
206 - * add site selector for 'Add Node'
207
208 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
209 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
210 - this affects the settings of ifname and alias that were formerly set unconditionally
211 - review the interface-checking javascript code
212 - changed the interface to plekitform, method is now optional and part of an options hash
213
214 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
215 - can't use php objects for showing node status, this is too slow
216 - fix interface add page
217
218 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
219 - consistency in the way nodes status is displayed in the node and slice areas
220 - extra tags columns show up on the nodes page as well, tweaked in the process
221 - roles management in person page fixed
222
223 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
224 - displaying node tags in the nodes page as well
225 - table headers now can have a 'title' that shows up when hovering on the column header
226
227 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
228 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
229
230 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
231 - extensible set of columns in the nodes area of the (my)slice page
232 - nodegroups can be added/deleted/updated
233 - tags management improved marginally
234
235 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
236 - fix pending sites page - was getting fooled by ext_consortium_id=None
237
238 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
239 - resetting tag as something went wrong when setting 31
240
241 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
242 - nicer look for slice creation, (public) sites
243 - users show with all their sites in the persons page
244
245 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
246 - reviewed registration pages for persons and sites
247
248 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
249 - increase memory limit in the nodes page
250
251 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
252 - fixes one typo
253
254 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
255 - minor/cosmetic
256
257 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
258 - Add default Interface tags to extra interfaces.
259 - Add clearer 'Add New PCU' link on node page.
260 - Disable user registration for tech and PI roles.
261
262 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
263 - new 'controller' instantiation state available in add slice page
264
265 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
266 - exclude datepicler.js from jsmin
267 - table sort function for Last Contact columns
268 - drop options for generic boot images
269
270 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
271 - displays editable mac address for interfaces
272 - properly sorts bandwidths
273 - new 'controller' slice instantiation method
274 - bugfix, division by zero when displaying a just-changed node
275
276 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
277 - bugfix with linetabs
278
279 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
280 - fix add interface from the node page
281
282 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
283 - only add users that are enabled and not yet a member of the slice
284 - fix to plc_peers
285 - my sites, my nodes, my persons improvements for users with multiple sites
286 - adds a script to minimize the java script files.
287
288 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
289 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
290
291 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
292 - first draft for pcu-handling features
293 - lighter contrat for PLE/PLC toggles
294 - as many 'my site'-like  links as the user has sites
295
296 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
297 - fix for whitelisted nodes
298 - now links to the node register wizard
299 - can enable sites
300 - various other minor fixes, like broken planetlab.module for techs, and login link
301
302 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
303 - plekittable knows how to turn off sort-on-load, and the admin users pages do
304 - + various cosmetic fixes
305
306 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
307 - a few minor improvements pushed on PLE
308
309 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
310 - fix for sites that were displayed as not public
311 - improvements to the python interface to sortable tables for monitor
312
313 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
314 - various improvements
315
316 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
317 - sliver page now correctly shows sliver tags
318 - support for download-node-usb-partition and various other improvements
319
320 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
321 - a few tweaks and typos fixed on PLE
322
323 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
324 - slice_add & node_download dialogs use plekit
325 - slice_add can add people in the slice
326 - various improvements after rollout on PLE
327
328 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
329 - cosmetic fixes to be in 4.3-rc2
330 - also a first (unpackaged) draft of the plekit table in python
331
332 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
333 - search in tables more robust
334
335 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
336 - performance improvements
337
338 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
339 - detect expired session and redirect to the login page
340
341 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
342 - improve browser health - was using too many cycles
343
344 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
345 - more consistency between views, and cosmetic changes
346
347 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
348 - area for managing slice tags
349
350 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
351 - first checkpoint tag for PLEWWW
352 - mostly functionally complete, probably a lot of tweaks still needed
353
354 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
355 - everyone is welcome to add nodes
356
357 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
358 - node-specific bootcd images to include arch in their name
359
360 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
361 - remove explicit dep to bootcd as the rpm name has changed
362
363 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
364 - noarch
365
366 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
367 - should fix yum.conf on nodes after install
368
369 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
370 - uses different path for getbootmedium results - should be safer
371
372 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
373 - comon icon replaced with the one from the comon website
374
375 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
376 - displays rpms in the about page
377
378 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
379 - safer, reference-less, way to implement layout mechnism - see
380 - settings.php for details
381 - setting types properly displayed according to user's role
382 - setting deletion : fixed (was still using code from slice attribute)
383 - more comon buttons : in the nodes and peers index pages
384 - comon_button knows about peer_id
385
386 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
387 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
388
389 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
390 - Initial build.