Setting tag plewww-4.3-73
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 73
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
129 - slightly tweak profiling points in slice.php
130
131 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
132 - ships with new default images for PLC/PLE from planet-lab.eu
133
134 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
135 - no change, just make sync for lxc-hosted tests
136
137 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
138 - refactoring for tophat/columns
139 - should take care of the irritating warning message about columns
140
141 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
142 - do not display the 'node' role when confusing
143
144 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
145 - support for setting nodes as reservable
146 - rely more on previous state when deciding to open or not toggles in a view
147 - remove statements for setting maximum memory usage, that sometimes
148
149 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
150 - node page can edit interfaces even when no interface
151
152 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
153 - uses a 2-week (!) session
154
155 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
156 - minor/cosmetic fixes in the leases area
157
158 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
159 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
160 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
161 - has a feature to 'test' pcu connection
162 - only admins can add users to different sites.
163 - remove dep. to outdated _gen_planetflow.php
164 - rephrased (disabled, or pending registration)
165 - + various fixes
166
167 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
168 - fix display glitch exposed with dimes initscript
169
170 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
171 - rename initscript_body into initscript_code
172
173 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
174 - bugfix for the reservation interface
175
176 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
177 - reservation page uses ajax - no need to reload after submit
178 - reservation dialogs for offset in the future & # slots
179 - fix the timezone in reservations (actually use php.ini)
180 - reservation visible (and hardwired) in nodes view
181 - have pulled prototype 1.7 but not in used yet
182
183 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
184 - set both 'omf_control' and 'vref' for omf-friendly slices
185
186 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
187 - display tags in alphabetic order in node view, tags section, the drop down menu
188
189 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
190 - on-the-fly retrieval of data at comon & tophat (unused so far)
191 - use accessors to store person's preference of columns
192 - fix in toggle.js for the '?' button, node table layout tab
193 - sort actions logging improved
194
195 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
196 - keep people from disabling or deleting themselves
197 - cannot become a disabled person
198 - outline people without a role
199
200 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
201 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
202
203 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
204 - tagging plewww for a new deployment
205
206 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
207 - add a 'report a problem' link for the RebootNode button
208 - new exp page nodes2.php with consistent selectable-columns layout as myslice
209 - tweaks in the exp. myslice (slices.php)
210
211 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
212 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
213 - my_slice with adjustable set of columns in slices/slice2.php
214 - fix for the 'site registration' page
215
216 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
217 - show message about leases - leases tab first in nodes section
218 - fix how reservable nodes show up
219
220 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
221 - cosmetic, rendering of textareas was like password fields
222
223 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
224 - bugfix in slice page, had wrong (null) expiration date
225 - upgraded to raphael-1.5.2, don't minimize this lib
226 - nicer layout for password fields as well
227 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
228 - marginally optimized slice page (2 GetNodes call down)
229 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
230 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
231 - reservations can cope with a bit more slots - will need scrolling someday
232 - omf text has hyperlinks to the tools
233
234 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
235 - reservation section now effective
236 - can set omf_control at slice-creation time
237 - can set node as reservable at node-creation time
238 - nicer text input fields + various tweaks
239
240 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
241 - show nodegroups form to add new groups
242
243 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
244 - just tagging plewww again to test module-tag on git
245
246 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
247 - encode strings properly in forms.
248
249 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
250 - Use readfile() function to reduce the memory footprint
251
252 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
253 - removed all deprecated functions for PHP-5.3 on fedora 12
254
255 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
256 - * exclude DNS from subnet checking
257 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
258 - * allow longer abbreviated names
259 - * don't let empty strings kill the server (postgresql and apache)
260
261 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
262 - disable drupal user registration (hard: patching the user module)
263
264 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
265 - * show error messages for update interface
266 - * 'Add Node' is admin only
267 - * add site selector for 'Add Node'
268
269 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
270 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
271 - this affects the settings of ifname and alias that were formerly set unconditionally
272 - review the interface-checking javascript code
273 - changed the interface to plekitform, method is now optional and part of an options hash
274
275 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
276 - can't use php objects for showing node status, this is too slow
277 - fix interface add page
278
279 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
280 - consistency in the way nodes status is displayed in the node and slice areas
281 - extra tags columns show up on the nodes page as well, tweaked in the process
282 - roles management in person page fixed
283
284 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
285 - displaying node tags in the nodes page as well
286 - table headers now can have a 'title' that shows up when hovering on the column header
287
288 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
289 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
290
291 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
292 - extensible set of columns in the nodes area of the (my)slice page
293 - nodegroups can be added/deleted/updated
294 - tags management improved marginally
295
296 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
297 - fix pending sites page - was getting fooled by ext_consortium_id=None
298
299 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
300 - resetting tag as something went wrong when setting 31
301
302 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
303 - nicer look for slice creation, (public) sites
304 - users show with all their sites in the persons page
305
306 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
307 - reviewed registration pages for persons and sites
308
309 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
310 - increase memory limit in the nodes page
311
312 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
313 - fixes one typo
314
315 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
316 - minor/cosmetic
317
318 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
319 - Add default Interface tags to extra interfaces.
320 - Add clearer 'Add New PCU' link on node page.
321 - Disable user registration for tech and PI roles.
322
323 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
324 - new 'controller' instantiation state available in add slice page
325
326 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
327 - exclude datepicler.js from jsmin
328 - table sort function for Last Contact columns
329 - drop options for generic boot images
330
331 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
332 - displays editable mac address for interfaces
333 - properly sorts bandwidths
334 - new 'controller' slice instantiation method
335 - bugfix, division by zero when displaying a just-changed node
336
337 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
338 - bugfix with linetabs
339
340 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
341 - fix add interface from the node page
342
343 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
344 - only add users that are enabled and not yet a member of the slice
345 - fix to plc_peers
346 - my sites, my nodes, my persons improvements for users with multiple sites
347 - adds a script to minimize the java script files.
348
349 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
350 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
351
352 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
353 - first draft for pcu-handling features
354 - lighter contrat for PLE/PLC toggles
355 - as many 'my site'-like  links as the user has sites
356
357 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
358 - fix for whitelisted nodes
359 - now links to the node register wizard
360 - can enable sites
361 - various other minor fixes, like broken planetlab.module for techs, and login link
362
363 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
364 - plekittable knows how to turn off sort-on-load, and the admin users pages do
365 - + various cosmetic fixes
366
367 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
368 - a few minor improvements pushed on PLE
369
370 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
371 - fix for sites that were displayed as not public
372 - improvements to the python interface to sortable tables for monitor
373
374 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
375 - various improvements
376
377 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
378 - sliver page now correctly shows sliver tags
379 - support for download-node-usb-partition and various other improvements
380
381 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
382 - a few tweaks and typos fixed on PLE
383
384 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
385 - slice_add & node_download dialogs use plekit
386 - slice_add can add people in the slice
387 - various improvements after rollout on PLE
388
389 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
390 - cosmetic fixes to be in 4.3-rc2
391 - also a first (unpackaged) draft of the plekit table in python
392
393 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
394 - search in tables more robust
395
396 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
397 - performance improvements
398
399 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
400 - detect expired session and redirect to the login page
401
402 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
403 - improve browser health - was using too many cycles
404
405 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
406 - more consistency between views, and cosmetic changes
407
408 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
409 - area for managing slice tags
410
411 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
412 - first checkpoint tag for PLEWWW
413 - mostly functionally complete, probably a lot of tweaks still needed
414
415 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
416 - everyone is welcome to add nodes
417
418 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
419 - node-specific bootcd images to include arch in their name
420
421 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
422 - remove explicit dep to bootcd as the rpm name has changed
423
424 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
425 - noarch
426
427 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
428 - should fix yum.conf on nodes after install
429
430 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
431 - uses different path for getbootmedium results - should be safer
432
433 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
434 - comon icon replaced with the one from the comon website
435
436 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
437 - displays rpms in the about page
438
439 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
440 - safer, reference-less, way to implement layout mechnism - see
441 - settings.php for details
442 - setting types properly displayed according to user's role
443 - setting deletion : fixed (was still using code from slice attribute)
444 - more comon buttons : in the nodes and peers index pages
445 - comon_button knows about peer_id
446
447 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
448 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
449
450 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
451 - Initial build.