Setting tag plewww-5.2-3
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 3
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: plcapi >= 5.2
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
129 - typo in help message about initscripts
130
131 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
132 - node page and person page show hrn in details
133
134 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
135 - late fix of registration for plcapi-5.1-6
136
137 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
138 - add extra code to prevent confidentiality leaks
139 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
140 - return_url for add-person and remove-person
141 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
142
143 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
144 - add tags section on site and person pages
145
146 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
147 - slightly tweak profiling points in slice.php
148
149 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
150 - ships with new default images for PLC/PLE from planet-lab.eu
151
152 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
153 - no change, just make sync for lxc-hosted tests
154
155 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
156 - refactoring for tophat/columns
157 - should take care of the irritating warning message about columns
158
159 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
160 - do not display the 'node' role when confusing
161
162 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
163 - support for setting nodes as reservable
164 - rely more on previous state when deciding to open or not toggles in a view
165 - remove statements for setting maximum memory usage, that sometimes
166
167 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
168 - node page can edit interfaces even when no interface
169
170 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
171 - uses a 2-week (!) session
172
173 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
174 - minor/cosmetic fixes in the leases area
175
176 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
177 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
178 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
179 - has a feature to 'test' pcu connection
180 - only admins can add users to different sites.
181 - remove dep. to outdated _gen_planetflow.php
182 - rephrased (disabled, or pending registration)
183 - + various fixes
184
185 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
186 - fix display glitch exposed with dimes initscript
187
188 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
189 - rename initscript_body into initscript_code
190
191 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
192 - bugfix for the reservation interface
193
194 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
195 - reservation page uses ajax - no need to reload after submit
196 - reservation dialogs for offset in the future & # slots
197 - fix the timezone in reservations (actually use php.ini)
198 - reservation visible (and hardwired) in nodes view
199 - have pulled prototype 1.7 but not in used yet
200
201 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
202 - set both 'omf_control' and 'vref' for omf-friendly slices
203
204 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
205 - display tags in alphabetic order in node view, tags section, the drop down menu
206
207 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
208 - on-the-fly retrieval of data at comon & tophat (unused so far)
209 - use accessors to store person's preference of columns
210 - fix in toggle.js for the '?' button, node table layout tab
211 - sort actions logging improved
212
213 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
214 - keep people from disabling or deleting themselves
215 - cannot become a disabled person
216 - outline people without a role
217
218 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
219 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
220
221 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
222 - tagging plewww for a new deployment
223
224 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
225 - add a 'report a problem' link for the RebootNode button
226 - new exp page nodes2.php with consistent selectable-columns layout as myslice
227 - tweaks in the exp. myslice (slices.php)
228
229 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
230 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
231 - my_slice with adjustable set of columns in slices/slice2.php
232 - fix for the 'site registration' page
233
234 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
235 - show message about leases - leases tab first in nodes section
236 - fix how reservable nodes show up
237
238 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
239 - cosmetic, rendering of textareas was like password fields
240
241 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
242 - bugfix in slice page, had wrong (null) expiration date
243 - upgraded to raphael-1.5.2, don't minimize this lib
244 - nicer layout for password fields as well
245 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
246 - marginally optimized slice page (2 GetNodes call down)
247 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
248 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
249 - reservations can cope with a bit more slots - will need scrolling someday
250 - omf text has hyperlinks to the tools
251
252 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
253 - reservation section now effective
254 - can set omf_control at slice-creation time
255 - can set node as reservable at node-creation time
256 - nicer text input fields + various tweaks
257
258 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
259 - show nodegroups form to add new groups
260
261 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
262 - just tagging plewww again to test module-tag on git
263
264 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
265 - encode strings properly in forms.
266
267 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
268 - Use readfile() function to reduce the memory footprint
269
270 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
271 - removed all deprecated functions for PHP-5.3 on fedora 12
272
273 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
274 - * exclude DNS from subnet checking
275 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
276 - * allow longer abbreviated names
277 - * don't let empty strings kill the server (postgresql and apache)
278
279 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
280 - disable drupal user registration (hard: patching the user module)
281
282 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
283 - * show error messages for update interface
284 - * 'Add Node' is admin only
285 - * add site selector for 'Add Node'
286
287 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
288 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
289 - this affects the settings of ifname and alias that were formerly set unconditionally
290 - review the interface-checking javascript code
291 - changed the interface to plekitform, method is now optional and part of an options hash
292
293 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
294 - can't use php objects for showing node status, this is too slow
295 - fix interface add page
296
297 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
298 - consistency in the way nodes status is displayed in the node and slice areas
299 - extra tags columns show up on the nodes page as well, tweaked in the process
300 - roles management in person page fixed
301
302 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
303 - displaying node tags in the nodes page as well
304 - table headers now can have a 'title' that shows up when hovering on the column header
305
306 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
307 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
308
309 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
310 - extensible set of columns in the nodes area of the (my)slice page
311 - nodegroups can be added/deleted/updated
312 - tags management improved marginally
313
314 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
315 - fix pending sites page - was getting fooled by ext_consortium_id=None
316
317 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
318 - resetting tag as something went wrong when setting 31
319
320 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
321 - nicer look for slice creation, (public) sites
322 - users show with all their sites in the persons page
323
324 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
325 - reviewed registration pages for persons and sites
326
327 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
328 - increase memory limit in the nodes page
329
330 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
331 - fixes one typo
332
333 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
334 - minor/cosmetic
335
336 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
337 - Add default Interface tags to extra interfaces.
338 - Add clearer 'Add New PCU' link on node page.
339 - Disable user registration for tech and PI roles.
340
341 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
342 - new 'controller' instantiation state available in add slice page
343
344 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
345 - exclude datepicler.js from jsmin
346 - table sort function for Last Contact columns
347 - drop options for generic boot images
348
349 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
350 - displays editable mac address for interfaces
351 - properly sorts bandwidths
352 - new 'controller' slice instantiation method
353 - bugfix, division by zero when displaying a just-changed node
354
355 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
356 - bugfix with linetabs
357
358 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
359 - fix add interface from the node page
360
361 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
362 - only add users that are enabled and not yet a member of the slice
363 - fix to plc_peers
364 - my sites, my nodes, my persons improvements for users with multiple sites
365 - adds a script to minimize the java script files.
366
367 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
368 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
369
370 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
371 - first draft for pcu-handling features
372 - lighter contrat for PLE/PLC toggles
373 - as many 'my site'-like  links as the user has sites
374
375 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
376 - fix for whitelisted nodes
377 - now links to the node register wizard
378 - can enable sites
379 - various other minor fixes, like broken planetlab.module for techs, and login link
380
381 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
382 - plekittable knows how to turn off sort-on-load, and the admin users pages do
383 - + various cosmetic fixes
384
385 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
386 - a few minor improvements pushed on PLE
387
388 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
389 - fix for sites that were displayed as not public
390 - improvements to the python interface to sortable tables for monitor
391
392 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
393 - various improvements
394
395 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
396 - sliver page now correctly shows sliver tags
397 - support for download-node-usb-partition and various other improvements
398
399 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
400 - a few tweaks and typos fixed on PLE
401
402 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
403 - slice_add & node_download dialogs use plekit
404 - slice_add can add people in the slice
405 - various improvements after rollout on PLE
406
407 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
408 - cosmetic fixes to be in 4.3-rc2
409 - also a first (unpackaged) draft of the plekit table in python
410
411 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
412 - search in tables more robust
413
414 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
415 - performance improvements
416
417 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
418 - detect expired session and redirect to the login page
419
420 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
421 - improve browser health - was using too many cycles
422
423 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
424 - more consistency between views, and cosmetic changes
425
426 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
427 - area for managing slice tags
428
429 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
430 - first checkpoint tag for PLEWWW
431 - mostly functionally complete, probably a lot of tweaks still needed
432
433 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
434 - everyone is welcome to add nodes
435
436 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
437 - node-specific bootcd images to include arch in their name
438
439 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
440 - remove explicit dep to bootcd as the rpm name has changed
441
442 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
443 - noarch
444
445 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
446 - should fix yum.conf on nodes after install
447
448 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
449 - uses different path for getbootmedium results - should be safer
450
451 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
452 - comon icon replaced with the one from the comon website
453
454 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
455 - displays rpms in the about page
456
457 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
458 - safer, reference-less, way to implement layout mechnism - see
459 - settings.php for details
460 - setting types properly displayed according to user's role
461 - setting deletion : fixed (was still using code from slice attribute)
462 - more comon buttons : in the nodes and peers index pages
463 - comon_button knows about peer_id
464
465 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
466 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
467
468 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
469 - Initial build.