Setting tag plewww-4.3-58
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 58
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
129 - display tags in alphabetic order in node view, tags section, the drop down menu
130
131 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
132 - on-the-fly retrieval of data at comon & tophat (unused so far)
133 - use accessors to store person's preference of columns
134 - fix in toggle.js for the '?' button, node table layout tab
135 - sort actions logging improved
136
137 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
138 - keep people from disabling or deleting themselves
139 - cannot become a disabled person
140 - outline people without a role
141
142 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
143 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
144
145 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
146 - tagging plewww for a new deployment
147
148 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
149 - add a 'report a problem' link for the RebootNode button
150 - new exp page nodes2.php with consistent selectable-columns layout as myslice
151 - tweaks in the exp. myslice (slices.php)
152
153 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
154 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
155 - my_slice with adjustable set of columns in slices/slice2.php
156 - fix for the 'site registration' page
157
158 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
159 - show message about leases - leases tab first in nodes section
160 - fix how reservable nodes show up
161
162 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
163 - cosmetic, rendering of textareas was like password fields
164
165 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
166 - bugfix in slice page, had wrong (null) expiration date
167 - upgraded to raphael-1.5.2, don't minimize this lib
168 - nicer layout for password fields as well
169 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
170 - marginally optimized slice page (2 GetNodes call down)
171 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
172 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
173 - reservations can cope with a bit more slots - will need scrolling someday
174 - omf text has hyperlinks to the tools
175
176 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
177 - reservation section now effective
178 - can set omf_control at slice-creation time
179 - can set node as reservable at node-creation time
180 - nicer text input fields + various tweaks
181
182 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
183 - show nodegroups form to add new groups
184
185 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
186 - just tagging plewww again to test module-tag on git
187
188 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
189 - encode strings properly in forms.
190
191 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
192 - Use readfile() function to reduce the memory footprint
193
194 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
195 - removed all deprecated functions for PHP-5.3 on fedora 12
196
197 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
198 - * exclude DNS from subnet checking
199 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
200 - * allow longer abbreviated names
201 - * don't let empty strings kill the server (postgresql and apache)
202
203 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
204 - disable drupal user registration (hard: patching the user module)
205
206 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
207 - * show error messages for update interface
208 - * 'Add Node' is admin only
209 - * add site selector for 'Add Node'
210
211 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
212 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
213 - this affects the settings of ifname and alias that were formerly set unconditionally
214 - review the interface-checking javascript code
215 - changed the interface to plekitform, method is now optional and part of an options hash
216
217 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
218 - can't use php objects for showing node status, this is too slow
219 - fix interface add page
220
221 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
222 - consistency in the way nodes status is displayed in the node and slice areas
223 - extra tags columns show up on the nodes page as well, tweaked in the process
224 - roles management in person page fixed
225
226 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
227 - displaying node tags in the nodes page as well
228 - table headers now can have a 'title' that shows up when hovering on the column header
229
230 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
231 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
232
233 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
234 - extensible set of columns in the nodes area of the (my)slice page
235 - nodegroups can be added/deleted/updated
236 - tags management improved marginally
237
238 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
239 - fix pending sites page - was getting fooled by ext_consortium_id=None
240
241 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
242 - resetting tag as something went wrong when setting 31
243
244 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
245 - nicer look for slice creation, (public) sites
246 - users show with all their sites in the persons page
247
248 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
249 - reviewed registration pages for persons and sites
250
251 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
252 - increase memory limit in the nodes page
253
254 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
255 - fixes one typo
256
257 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
258 - minor/cosmetic
259
260 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
261 - Add default Interface tags to extra interfaces.
262 - Add clearer 'Add New PCU' link on node page.
263 - Disable user registration for tech and PI roles.
264
265 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
266 - new 'controller' instantiation state available in add slice page
267
268 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
269 - exclude datepicler.js from jsmin
270 - table sort function for Last Contact columns
271 - drop options for generic boot images
272
273 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
274 - displays editable mac address for interfaces
275 - properly sorts bandwidths
276 - new 'controller' slice instantiation method
277 - bugfix, division by zero when displaying a just-changed node
278
279 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
280 - bugfix with linetabs
281
282 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
283 - fix add interface from the node page
284
285 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
286 - only add users that are enabled and not yet a member of the slice
287 - fix to plc_peers
288 - my sites, my nodes, my persons improvements for users with multiple sites
289 - adds a script to minimize the java script files.
290
291 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
292 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
293
294 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
295 - first draft for pcu-handling features
296 - lighter contrat for PLE/PLC toggles
297 - as many 'my site'-like  links as the user has sites
298
299 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
300 - fix for whitelisted nodes
301 - now links to the node register wizard
302 - can enable sites
303 - various other minor fixes, like broken planetlab.module for techs, and login link
304
305 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
306 - plekittable knows how to turn off sort-on-load, and the admin users pages do
307 - + various cosmetic fixes
308
309 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
310 - a few minor improvements pushed on PLE
311
312 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
313 - fix for sites that were displayed as not public
314 - improvements to the python interface to sortable tables for monitor
315
316 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
317 - various improvements
318
319 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
320 - sliver page now correctly shows sliver tags
321 - support for download-node-usb-partition and various other improvements
322
323 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
324 - a few tweaks and typos fixed on PLE
325
326 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
327 - slice_add & node_download dialogs use plekit
328 - slice_add can add people in the slice
329 - various improvements after rollout on PLE
330
331 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
332 - cosmetic fixes to be in 4.3-rc2
333 - also a first (unpackaged) draft of the plekit table in python
334
335 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
336 - search in tables more robust
337
338 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
339 - performance improvements
340
341 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
342 - detect expired session and redirect to the login page
343
344 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
345 - improve browser health - was using too many cycles
346
347 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
348 - more consistency between views, and cosmetic changes
349
350 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
351 - area for managing slice tags
352
353 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
354 - first checkpoint tag for PLEWWW
355 - mostly functionally complete, probably a lot of tweaks still needed
356
357 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
358 - everyone is welcome to add nodes
359
360 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
361 - node-specific bootcd images to include arch in their name
362
363 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
364 - remove explicit dep to bootcd as the rpm name has changed
365
366 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
367 - noarch
368
369 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
370 - should fix yum.conf on nodes after install
371
372 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
373 - uses different path for getbootmedium results - should be safer
374
375 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
376 - comon icon replaced with the one from the comon website
377
378 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
379 - displays rpms in the about page
380
381 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
382 - safer, reference-less, way to implement layout mechnism - see
383 - settings.php for details
384 - setting types properly displayed according to user's role
385 - setting deletion : fixed (was still using code from slice attribute)
386 - more comon buttons : in the nodes and peers index pages
387 - comon_button knows about peer_id
388
389 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
390 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
391
392 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
393 - Initial build.