Setting tag plewww-4.3-65
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 65
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
129 - minor/cosmetic fixes in the leases area
130
131 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
132 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
133 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
134 - has a feature to 'test' pcu connection
135 - only admins can add users to different sites.
136 - remove dep. to outdated _gen_planetflow.php
137 - rephrased (disabled, or pending registration)
138 - + various fixes
139
140 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
141 - fix display glitch exposed with dimes initscript
142
143 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
144 - rename initscript_body into initscript_code
145
146 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
147 - bugfix for the reservation interface
148
149 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
150 - reservation page uses ajax - no need to reload after submit
151 - reservation dialogs for offset in the future & # slots
152 - fix the timezone in reservations (actually use php.ini)
153 - reservation visible (and hardwired) in nodes view
154 - have pulled prototype 1.7 but not in used yet
155
156 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
157 - set both 'omf_control' and 'vref' for omf-friendly slices
158
159 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
160 - display tags in alphabetic order in node view, tags section, the drop down menu
161
162 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
163 - on-the-fly retrieval of data at comon & tophat (unused so far)
164 - use accessors to store person's preference of columns
165 - fix in toggle.js for the '?' button, node table layout tab
166 - sort actions logging improved
167
168 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
169 - keep people from disabling or deleting themselves
170 - cannot become a disabled person
171 - outline people without a role
172
173 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
174 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
175
176 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
177 - tagging plewww for a new deployment
178
179 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
180 - add a 'report a problem' link for the RebootNode button
181 - new exp page nodes2.php with consistent selectable-columns layout as myslice
182 - tweaks in the exp. myslice (slices.php)
183
184 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
185 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
186 - my_slice with adjustable set of columns in slices/slice2.php
187 - fix for the 'site registration' page
188
189 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
190 - show message about leases - leases tab first in nodes section
191 - fix how reservable nodes show up
192
193 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
194 - cosmetic, rendering of textareas was like password fields
195
196 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
197 - bugfix in slice page, had wrong (null) expiration date
198 - upgraded to raphael-1.5.2, don't minimize this lib
199 - nicer layout for password fields as well
200 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
201 - marginally optimized slice page (2 GetNodes call down)
202 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
203 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
204 - reservations can cope with a bit more slots - will need scrolling someday
205 - omf text has hyperlinks to the tools
206
207 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
208 - reservation section now effective
209 - can set omf_control at slice-creation time
210 - can set node as reservable at node-creation time
211 - nicer text input fields + various tweaks
212
213 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
214 - show nodegroups form to add new groups
215
216 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
217 - just tagging plewww again to test module-tag on git
218
219 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
220 - encode strings properly in forms.
221
222 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
223 - Use readfile() function to reduce the memory footprint
224
225 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
226 - removed all deprecated functions for PHP-5.3 on fedora 12
227
228 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
229 - * exclude DNS from subnet checking
230 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
231 - * allow longer abbreviated names
232 - * don't let empty strings kill the server (postgresql and apache)
233
234 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
235 - disable drupal user registration (hard: patching the user module)
236
237 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
238 - * show error messages for update interface
239 - * 'Add Node' is admin only
240 - * add site selector for 'Add Node'
241
242 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
243 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
244 - this affects the settings of ifname and alias that were formerly set unconditionally
245 - review the interface-checking javascript code
246 - changed the interface to plekitform, method is now optional and part of an options hash
247
248 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
249 - can't use php objects for showing node status, this is too slow
250 - fix interface add page
251
252 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
253 - consistency in the way nodes status is displayed in the node and slice areas
254 - extra tags columns show up on the nodes page as well, tweaked in the process
255 - roles management in person page fixed
256
257 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
258 - displaying node tags in the nodes page as well
259 - table headers now can have a 'title' that shows up when hovering on the column header
260
261 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
262 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
263
264 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
265 - extensible set of columns in the nodes area of the (my)slice page
266 - nodegroups can be added/deleted/updated
267 - tags management improved marginally
268
269 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
270 - fix pending sites page - was getting fooled by ext_consortium_id=None
271
272 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
273 - resetting tag as something went wrong when setting 31
274
275 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
276 - nicer look for slice creation, (public) sites
277 - users show with all their sites in the persons page
278
279 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
280 - reviewed registration pages for persons and sites
281
282 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
283 - increase memory limit in the nodes page
284
285 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
286 - fixes one typo
287
288 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
289 - minor/cosmetic
290
291 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
292 - Add default Interface tags to extra interfaces.
293 - Add clearer 'Add New PCU' link on node page.
294 - Disable user registration for tech and PI roles.
295
296 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
297 - new 'controller' instantiation state available in add slice page
298
299 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
300 - exclude datepicler.js from jsmin
301 - table sort function for Last Contact columns
302 - drop options for generic boot images
303
304 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
305 - displays editable mac address for interfaces
306 - properly sorts bandwidths
307 - new 'controller' slice instantiation method
308 - bugfix, division by zero when displaying a just-changed node
309
310 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
311 - bugfix with linetabs
312
313 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
314 - fix add interface from the node page
315
316 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
317 - only add users that are enabled and not yet a member of the slice
318 - fix to plc_peers
319 - my sites, my nodes, my persons improvements for users with multiple sites
320 - adds a script to minimize the java script files.
321
322 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
323 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
324
325 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
326 - first draft for pcu-handling features
327 - lighter contrat for PLE/PLC toggles
328 - as many 'my site'-like  links as the user has sites
329
330 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
331 - fix for whitelisted nodes
332 - now links to the node register wizard
333 - can enable sites
334 - various other minor fixes, like broken planetlab.module for techs, and login link
335
336 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
337 - plekittable knows how to turn off sort-on-load, and the admin users pages do
338 - + various cosmetic fixes
339
340 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
341 - a few minor improvements pushed on PLE
342
343 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
344 - fix for sites that were displayed as not public
345 - improvements to the python interface to sortable tables for monitor
346
347 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
348 - various improvements
349
350 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
351 - sliver page now correctly shows sliver tags
352 - support for download-node-usb-partition and various other improvements
353
354 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
355 - a few tweaks and typos fixed on PLE
356
357 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
358 - slice_add & node_download dialogs use plekit
359 - slice_add can add people in the slice
360 - various improvements after rollout on PLE
361
362 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
363 - cosmetic fixes to be in 4.3-rc2
364 - also a first (unpackaged) draft of the plekit table in python
365
366 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
367 - search in tables more robust
368
369 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
370 - performance improvements
371
372 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
373 - detect expired session and redirect to the login page
374
375 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
376 - improve browser health - was using too many cycles
377
378 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
379 - more consistency between views, and cosmetic changes
380
381 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
382 - area for managing slice tags
383
384 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
385 - first checkpoint tag for PLEWWW
386 - mostly functionally complete, probably a lot of tweaks still needed
387
388 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
389 - everyone is welcome to add nodes
390
391 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
392 - node-specific bootcd images to include arch in their name
393
394 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
395 - remove explicit dep to bootcd as the rpm name has changed
396
397 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
398 - noarch
399
400 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
401 - should fix yum.conf on nodes after install
402
403 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
404 - uses different path for getbootmedium results - should be safer
405
406 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
407 - comon icon replaced with the one from the comon website
408
409 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
410 - displays rpms in the about page
411
412 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
413 - safer, reference-less, way to implement layout mechnism - see
414 - settings.php for details
415 - setting types properly displayed according to user's role
416 - setting deletion : fixed (was still using code from slice attribute)
417 - more comon buttons : in the nodes and peers index pages
418 - comon_button knows about peer_id
419
420 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
421 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
422
423 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
424 - Initial build.