Setting tag plewww-4.3-62
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 62
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
129 - rename initscript_body into initscript_code
130
131 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
132 - bugfix for the reservation interface
133
134 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
135 - reservation page uses ajax - no need to reload after submit
136 - reservation dialogs for offset in the future & # slots
137 - fix the timezone in reservations (actually use php.ini)
138 - reservation visible (and hardwired) in nodes view
139 - have pulled prototype 1.7 but not in used yet
140
141 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
142 - set both 'omf_control' and 'vref' for omf-friendly slices
143
144 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
145 - display tags in alphabetic order in node view, tags section, the drop down menu
146
147 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
148 - on-the-fly retrieval of data at comon & tophat (unused so far)
149 - use accessors to store person's preference of columns
150 - fix in toggle.js for the '?' button, node table layout tab
151 - sort actions logging improved
152
153 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
154 - keep people from disabling or deleting themselves
155 - cannot become a disabled person
156 - outline people without a role
157
158 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
159 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
160
161 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
162 - tagging plewww for a new deployment
163
164 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
165 - add a 'report a problem' link for the RebootNode button
166 - new exp page nodes2.php with consistent selectable-columns layout as myslice
167 - tweaks in the exp. myslice (slices.php)
168
169 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
170 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
171 - my_slice with adjustable set of columns in slices/slice2.php
172 - fix for the 'site registration' page
173
174 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
175 - show message about leases - leases tab first in nodes section
176 - fix how reservable nodes show up
177
178 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
179 - cosmetic, rendering of textareas was like password fields
180
181 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
182 - bugfix in slice page, had wrong (null) expiration date
183 - upgraded to raphael-1.5.2, don't minimize this lib
184 - nicer layout for password fields as well
185 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
186 - marginally optimized slice page (2 GetNodes call down)
187 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
188 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
189 - reservations can cope with a bit more slots - will need scrolling someday
190 - omf text has hyperlinks to the tools
191
192 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
193 - reservation section now effective
194 - can set omf_control at slice-creation time
195 - can set node as reservable at node-creation time
196 - nicer text input fields + various tweaks
197
198 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
199 - show nodegroups form to add new groups
200
201 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
202 - just tagging plewww again to test module-tag on git
203
204 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
205 - encode strings properly in forms.
206
207 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
208 - Use readfile() function to reduce the memory footprint
209
210 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
211 - removed all deprecated functions for PHP-5.3 on fedora 12
212
213 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
214 - * exclude DNS from subnet checking
215 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
216 - * allow longer abbreviated names
217 - * don't let empty strings kill the server (postgresql and apache)
218
219 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
220 - disable drupal user registration (hard: patching the user module)
221
222 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
223 - * show error messages for update interface
224 - * 'Add Node' is admin only
225 - * add site selector for 'Add Node'
226
227 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
228 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
229 - this affects the settings of ifname and alias that were formerly set unconditionally
230 - review the interface-checking javascript code
231 - changed the interface to plekitform, method is now optional and part of an options hash
232
233 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
234 - can't use php objects for showing node status, this is too slow
235 - fix interface add page
236
237 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
238 - consistency in the way nodes status is displayed in the node and slice areas
239 - extra tags columns show up on the nodes page as well, tweaked in the process
240 - roles management in person page fixed
241
242 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
243 - displaying node tags in the nodes page as well
244 - table headers now can have a 'title' that shows up when hovering on the column header
245
246 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
247 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
248
249 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
250 - extensible set of columns in the nodes area of the (my)slice page
251 - nodegroups can be added/deleted/updated
252 - tags management improved marginally
253
254 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
255 - fix pending sites page - was getting fooled by ext_consortium_id=None
256
257 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
258 - resetting tag as something went wrong when setting 31
259
260 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
261 - nicer look for slice creation, (public) sites
262 - users show with all their sites in the persons page
263
264 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
265 - reviewed registration pages for persons and sites
266
267 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
268 - increase memory limit in the nodes page
269
270 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
271 - fixes one typo
272
273 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
274 - minor/cosmetic
275
276 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
277 - Add default Interface tags to extra interfaces.
278 - Add clearer 'Add New PCU' link on node page.
279 - Disable user registration for tech and PI roles.
280
281 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
282 - new 'controller' instantiation state available in add slice page
283
284 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
285 - exclude datepicler.js from jsmin
286 - table sort function for Last Contact columns
287 - drop options for generic boot images
288
289 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
290 - displays editable mac address for interfaces
291 - properly sorts bandwidths
292 - new 'controller' slice instantiation method
293 - bugfix, division by zero when displaying a just-changed node
294
295 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
296 - bugfix with linetabs
297
298 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
299 - fix add interface from the node page
300
301 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
302 - only add users that are enabled and not yet a member of the slice
303 - fix to plc_peers
304 - my sites, my nodes, my persons improvements for users with multiple sites
305 - adds a script to minimize the java script files.
306
307 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
308 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
309
310 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
311 - first draft for pcu-handling features
312 - lighter contrat for PLE/PLC toggles
313 - as many 'my site'-like  links as the user has sites
314
315 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
316 - fix for whitelisted nodes
317 - now links to the node register wizard
318 - can enable sites
319 - various other minor fixes, like broken planetlab.module for techs, and login link
320
321 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
322 - plekittable knows how to turn off sort-on-load, and the admin users pages do
323 - + various cosmetic fixes
324
325 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
326 - a few minor improvements pushed on PLE
327
328 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
329 - fix for sites that were displayed as not public
330 - improvements to the python interface to sortable tables for monitor
331
332 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
333 - various improvements
334
335 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
336 - sliver page now correctly shows sliver tags
337 - support for download-node-usb-partition and various other improvements
338
339 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
340 - a few tweaks and typos fixed on PLE
341
342 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
343 - slice_add & node_download dialogs use plekit
344 - slice_add can add people in the slice
345 - various improvements after rollout on PLE
346
347 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
348 - cosmetic fixes to be in 4.3-rc2
349 - also a first (unpackaged) draft of the plekit table in python
350
351 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
352 - search in tables more robust
353
354 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
355 - performance improvements
356
357 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
358 - detect expired session and redirect to the login page
359
360 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
361 - improve browser health - was using too many cycles
362
363 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
364 - more consistency between views, and cosmetic changes
365
366 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
367 - area for managing slice tags
368
369 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
370 - first checkpoint tag for PLEWWW
371 - mostly functionally complete, probably a lot of tweaks still needed
372
373 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
374 - everyone is welcome to add nodes
375
376 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
377 - node-specific bootcd images to include arch in their name
378
379 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
380 - remove explicit dep to bootcd as the rpm name has changed
381
382 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
383 - noarch
384
385 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
386 - should fix yum.conf on nodes after install
387
388 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
389 - uses different path for getbootmedium results - should be safer
390
391 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
392 - comon icon replaced with the one from the comon website
393
394 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
395 - displays rpms in the about page
396
397 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
398 - safer, reference-less, way to implement layout mechnism - see
399 - settings.php for details
400 - setting types properly displayed according to user's role
401 - setting deletion : fixed (was still using code from slice attribute)
402 - more comon buttons : in the nodes and peers index pages
403 - comon_button knows about peer_id
404
405 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
406 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
407
408 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
409 - Initial build.