patch drupal's session handler for php8
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 9
5
6 # no need to mention pldistro as this module differs in both distros
7 %define release %{taglevel}%{?date:.%{date}}
8
9 Summary: PlanetLab Europe (PLC) Web Pages
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: Applications/Systems
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17 BuildArch: noarch
18 BuildRequires: python
19
20 Vendor: OneLab
21 Packager: OneLab <support@one-lab.org>
22 Distribution: PlanetLab %{version}
23 URL: %{SCMURL}
24
25 # We use set everywhere
26 #Requires: httpd >= 2.0
27 Requires: php >= 5.0
28 Requires: postgresql >= 8.0
29 Requires: plcapi >= 5.2
30 Requires: drupal = 4.7
31 Requires: plewww-plekit
32
33 # this is what MyPLC requires
34 Provides: PLCWWW
35
36 # on centos5, when rebuilding the full monty, we get:
37 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
38 # and the perl-GD rpm is nowhere to be found
39 AutoReqProv: no
40
41 %package plekit
42 Summary: Utilities used by the plewww pages
43 Group: Applications/Systems
44
45 %description
46 The plewww package is made of the web pages that run on top of the 
47 PLCAPI component to provide the Web Interface to MyPLC users.
48
49 %description plekit
50 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
51
52 %prep
53 %setup -q
54
55 %build
56 echo "Compressing javascript files"
57 make compress
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 #
63 # plewww
64 # xxx : uninstall should undo this
65 #
66
67 echo "* PLEWWW: Installing web pages"
68 mkdir -p $RPM_BUILD_ROOT/var/www/html
69 # exclude codebase just in case
70 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
71
72 echo "* PLEWWW: Installing conf files for httpd"
73 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
74 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
75
76 %post
77 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
78 drupal_settings_dir=/var/www/html/sites/default
79 if [ ! -d $drupal_settings_dir ] ; then
80     echo "Could not find directory $drupal_settings_dir"
81     echo "This suggests that you do not have a planetlab-custom drupal installed"
82     exit 1
83 fi
84 pushd $drupal_settings_dir
85 # tune $db_url
86 if [ ! -f settings.php.drupal ] ; then
87     cp settings.php settings.php.drupal
88     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
89         settings.php.drupal > settings.php
90 fi
91 popd
92 # append our own database creation hacks to the drupal database schema
93 pushd /var/www/html/database
94 if [ ! -f database.pgsql.drupal ] ; then
95     cp database.pgsql database.pgsql.drupal
96     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
97 fi
98 popd
99 # hack the welcome page for MyPLC
100 pushd /var/www/html/modules
101 for module in user node; do
102     # backup only once
103     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
104     # always update so a change in our file can make through
105     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
106 done
107 popd
108 # hack drupal's session handler for php8
109 pushd /var/www/html/includes
110 bash /var/www/html/drupal-hacks/patch-session-inc.sh
111 popd
112 # create myslice.log and change its ownership
113 mkdir -p /var/log/myslice
114 touch /var/log/myslice/myslice.log
115 chown apache:apache /var/log/myslice/myslice.log
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(-,root,root,-)
122 /var/www/html/modules
123 /var/www/html/planetlab
124 /var/www/html/googlemap
125 /var/www/html/drupal-hacks
126 /etc/httpd/conf.d
127
128 %files plekit
129 /var/www/html/plekit
130
131 %changelog
132 * Wed May 16 2018 Thierry <Parmentelat> - plewww-5.2-9
133 - not too clean patches for r2lab:
134 - * search for a file named /etc/planetlab/php/person-registration.txt
135 - that can override the text message for individuals registration
136 - * do not list sites that have the disabled_registration tag set
137 - when listing them for individuals registration
138 - remove omf-friendly checkbox in slice-creation dialog
139 - comment out {Min,Max}SpareServers settings in httpd config
140
141 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-8
142 - a few niceties, thanks to Ciro
143
144 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-7
145 - remove utf8_deode as per Thomas's suggestion
146
147 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-6
148 - Offer the option to set a node in 'upgrade' mode - like reinstall but leaving slices intact
149
150 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-5
151 - tweaks in node_downloads.php about memory size and compression scheme
152
153 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-4
154 - googlemap widget: support for gmap api v3 + various cosmetic tweaks
155 - can display site names with odd characters
156
157 * Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
158 - typo in help message about initscripts
159
160 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
161 - node page and person page show hrn in details
162
163 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
164 - late fix of registration for plcapi-5.1-6
165
166 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
167 - add extra code to prevent confidentiality leaks
168 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
169 - return_url for add-person and remove-person
170 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
171
172 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
173 - add tags section on site and person pages
174
175 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
176 - slightly tweak profiling points in slice.php
177
178 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
179 - ships with new default images for PLC/PLE from planet-lab.eu
180
181 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
182 - no change, just make sync for lxc-hosted tests
183
184 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
185 - refactoring for tophat/columns
186 - should take care of the irritating warning message about columns
187
188 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
189 - do not display the 'node' role when confusing
190
191 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
192 - support for setting nodes as reservable
193 - rely more on previous state when deciding to open or not toggles in a view
194 - remove statements for setting maximum memory usage, that sometimes
195
196 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
197 - node page can edit interfaces even when no interface
198
199 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
200 - uses a 2-week (!) session
201
202 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
203 - minor/cosmetic fixes in the leases area
204
205 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
206 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
207 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
208 - has a feature to 'test' pcu connection
209 - only admins can add users to different sites.
210 - remove dep. to outdated _gen_planetflow.php
211 - rephrased (disabled, or pending registration)
212 - + various fixes
213
214 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
215 - fix display glitch exposed with dimes initscript
216
217 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
218 - rename initscript_body into initscript_code
219
220 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
221 - bugfix for the reservation interface
222
223 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
224 - reservation page uses ajax - no need to reload after submit
225 - reservation dialogs for offset in the future & # slots
226 - fix the timezone in reservations (actually use php.ini)
227 - reservation visible (and hardwired) in nodes view
228 - have pulled prototype 1.7 but not in used yet
229
230 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
231 - set both 'omf_control' and 'vref' for omf-friendly slices
232
233 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
234 - display tags in alphabetic order in node view, tags section, the drop down menu
235
236 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
237 - on-the-fly retrieval of data at comon & tophat (unused so far)
238 - use accessors to store person's preference of columns
239 - fix in toggle.js for the '?' button, node table layout tab
240 - sort actions logging improved
241
242 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
243 - keep people from disabling or deleting themselves
244 - cannot become a disabled person
245 - outline people without a role
246
247 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
248 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
249
250 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
251 - tagging plewww for a new deployment
252
253 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
254 - add a 'report a problem' link for the RebootNode button
255 - new exp page nodes2.php with consistent selectable-columns layout as myslice
256 - tweaks in the exp. myslice (slices.php)
257
258 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
259 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
260 - my_slice with adjustable set of columns in slices/slice2.php
261 - fix for the 'site registration' page
262
263 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
264 - show message about leases - leases tab first in nodes section
265 - fix how reservable nodes show up
266
267 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
268 - cosmetic, rendering of textareas was like password fields
269
270 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
271 - bugfix in slice page, had wrong (null) expiration date
272 - upgraded to raphael-1.5.2, don't minimize this lib
273 - nicer layout for password fields as well
274 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
275 - marginally optimized slice page (2 GetNodes call down)
276 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
277 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
278 - reservations can cope with a bit more slots - will need scrolling someday
279 - omf text has hyperlinks to the tools
280
281 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
282 - reservation section now effective
283 - can set omf_control at slice-creation time
284 - can set node as reservable at node-creation time
285 - nicer text input fields + various tweaks
286
287 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
288 - show nodegroups form to add new groups
289
290 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
291 - just tagging plewww again to test module-tag on git
292
293 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
294 - encode strings properly in forms.
295
296 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
297 - Use readfile() function to reduce the memory footprint
298
299 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
300 - removed all deprecated functions for PHP-5.3 on fedora 12
301
302 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
303 - * exclude DNS from subnet checking
304 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
305 - * allow longer abbreviated names
306 - * don't let empty strings kill the server (postgresql and apache)
307
308 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
309 - disable drupal user registration (hard: patching the user module)
310
311 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
312 - * show error messages for update interface
313 - * 'Add Node' is admin only
314 - * add site selector for 'Add Node'
315
316 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
317 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
318 - this affects the settings of ifname and alias that were formerly set unconditionally
319 - review the interface-checking javascript code
320 - changed the interface to plekitform, method is now optional and part of an options hash
321
322 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
323 - can't use php objects for showing node status, this is too slow
324 - fix interface add page
325
326 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
327 - consistency in the way nodes status is displayed in the node and slice areas
328 - extra tags columns show up on the nodes page as well, tweaked in the process
329 - roles management in person page fixed
330
331 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
332 - displaying node tags in the nodes page as well
333 - table headers now can have a 'title' that shows up when hovering on the column header
334
335 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
336 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
337
338 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
339 - extensible set of columns in the nodes area of the (my)slice page
340 - nodegroups can be added/deleted/updated
341 - tags management improved marginally
342
343 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
344 - fix pending sites page - was getting fooled by ext_consortium_id=None
345
346 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
347 - resetting tag as something went wrong when setting 31
348
349 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
350 - nicer look for slice creation, (public) sites
351 - users show with all their sites in the persons page
352
353 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
354 - reviewed registration pages for persons and sites
355
356 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
357 - increase memory limit in the nodes page
358
359 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
360 - fixes one typo
361
362 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
363 - minor/cosmetic
364
365 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
366 - Add default Interface tags to extra interfaces.
367 - Add clearer 'Add New PCU' link on node page.
368 - Disable user registration for tech and PI roles.
369
370 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
371 - new 'controller' instantiation state available in add slice page
372
373 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
374 - exclude datepicler.js from jsmin
375 - table sort function for Last Contact columns
376 - drop options for generic boot images
377
378 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
379 - displays editable mac address for interfaces
380 - properly sorts bandwidths
381 - new 'controller' slice instantiation method
382 - bugfix, division by zero when displaying a just-changed node
383
384 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
385 - bugfix with linetabs
386
387 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
388 - fix add interface from the node page
389
390 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
391 - only add users that are enabled and not yet a member of the slice
392 - fix to plc_peers
393 - my sites, my nodes, my persons improvements for users with multiple sites
394 - adds a script to minimize the java script files.
395
396 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
397 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
398
399 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
400 - first draft for pcu-handling features
401 - lighter contrat for PLE/PLC toggles
402 - as many 'my site'-like  links as the user has sites
403
404 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
405 - fix for whitelisted nodes
406 - now links to the node register wizard
407 - can enable sites
408 - various other minor fixes, like broken planetlab.module for techs, and login link
409
410 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
411 - plekittable knows how to turn off sort-on-load, and the admin users pages do
412 - + various cosmetic fixes
413
414 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
415 - a few minor improvements pushed on PLE
416
417 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
418 - fix for sites that were displayed as not public
419 - improvements to the python interface to sortable tables for monitor
420
421 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
422 - various improvements
423
424 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
425 - sliver page now correctly shows sliver tags
426 - support for download-node-usb-partition and various other improvements
427
428 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
429 - a few tweaks and typos fixed on PLE
430
431 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
432 - slice_add & node_download dialogs use plekit
433 - slice_add can add people in the slice
434 - various improvements after rollout on PLE
435
436 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
437 - cosmetic fixes to be in 4.3-rc2
438 - also a first (unpackaged) draft of the plekit table in python
439
440 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
441 - search in tables more robust
442
443 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
444 - performance improvements
445
446 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
447 - detect expired session and redirect to the login page
448
449 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
450 - improve browser health - was using too many cycles
451
452 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
453 - more consistency between views, and cosmetic changes
454
455 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
456 - area for managing slice tags
457
458 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
459 - first checkpoint tag for PLEWWW
460 - mostly functionally complete, probably a lot of tweaks still needed
461
462 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
463 - everyone is welcome to add nodes
464
465 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
466 - node-specific bootcd images to include arch in their name
467
468 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
469 - remove explicit dep to bootcd as the rpm name has changed
470
471 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
472 - noarch
473
474 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
475 - should fix yum.conf on nodes after install
476
477 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
478 - uses different path for getbootmedium results - should be safer
479
480 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
481 - comon icon replaced with the one from the comon website
482
483 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
484 - displays rpms in the about page
485
486 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
487 - safer, reference-less, way to implement layout mechnism - see
488 - settings.php for details
489 - setting types properly displayed according to user's role
490 - setting deletion : fixed (was still using code from slice attribute)
491 - more comon buttons : in the nodes and peers index pages
492 - comon_button knows about peer_id
493
494 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
495 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
496
497 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
498 - Initial build.