change the myslice log file name and make it writable by apache
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 54
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
129 - tagging plewww for a new deployment
130
131 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
132 - add a 'report a problem' link for the RebootNode button
133 - new exp page nodes2.php with consistent selectable-columns layout as myslice
134 - tweaks in the exp. myslice (slices.php)
135
136 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
137 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
138 - my_slice with adjustable set of columns in slices/slice2.php
139 - fix for the 'site registration' page
140
141 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
142 - show message about leases - leases tab first in nodes section
143 - fix how reservable nodes show up
144
145 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
146 - cosmetic, rendering of textareas was like password fields
147
148 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
149 - bugfix in slice page, had wrong (null) expiration date
150 - upgraded to raphael-1.5.2, don't minimize this lib
151 - nicer layout for password fields as well
152 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
153 - marginally optimized slice page (2 GetNodes call down)
154 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
155 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
156 - reservations can cope with a bit more slots - will need scrolling someday
157 - omf text has hyperlinks to the tools
158
159 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
160 - reservation section now effective
161 - can set omf_control at slice-creation time
162 - can set node as reservable at node-creation time
163 - nicer text input fields + various tweaks
164
165 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
166 - show nodegroups form to add new groups
167
168 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
169 - just tagging plewww again to test module-tag on git
170
171 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
172 - encode strings properly in forms.
173
174 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
175 - Use readfile() function to reduce the memory footprint
176
177 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
178 - removed all deprecated functions for PHP-5.3 on fedora 12
179
180 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
181 - * exclude DNS from subnet checking
182 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
183 - * allow longer abbreviated names
184 - * don't let empty strings kill the server (postgresql and apache)
185
186 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
187 - disable drupal user registration (hard: patching the user module)
188
189 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
190 - * show error messages for update interface
191 - * 'Add Node' is admin only
192 - * add site selector for 'Add Node'
193
194 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
195 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
196 - this affects the settings of ifname and alias that were formerly set unconditionally
197 - review the interface-checking javascript code
198 - changed the interface to plekitform, method is now optional and part of an options hash
199
200 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
201 - can't use php objects for showing node status, this is too slow
202 - fix interface add page
203
204 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
205 - consistency in the way nodes status is displayed in the node and slice areas
206 - extra tags columns show up on the nodes page as well, tweaked in the process
207 - roles management in person page fixed
208
209 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
210 - displaying node tags in the nodes page as well
211 - table headers now can have a 'title' that shows up when hovering on the column header
212
213 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
214 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
215
216 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
217 - extensible set of columns in the nodes area of the (my)slice page
218 - nodegroups can be added/deleted/updated
219 - tags management improved marginally
220
221 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
222 - fix pending sites page - was getting fooled by ext_consortium_id=None
223
224 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
225 - resetting tag as something went wrong when setting 31
226
227 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
228 - nicer look for slice creation, (public) sites
229 - users show with all their sites in the persons page
230
231 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
232 - reviewed registration pages for persons and sites
233
234 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
235 - increase memory limit in the nodes page
236
237 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
238 - fixes one typo
239
240 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
241 - minor/cosmetic
242
243 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
244 - Add default Interface tags to extra interfaces.
245 - Add clearer 'Add New PCU' link on node page.
246 - Disable user registration for tech and PI roles.
247
248 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
249 - new 'controller' instantiation state available in add slice page
250
251 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
252 - exclude datepicler.js from jsmin
253 - table sort function for Last Contact columns
254 - drop options for generic boot images
255
256 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
257 - displays editable mac address for interfaces
258 - properly sorts bandwidths
259 - new 'controller' slice instantiation method
260 - bugfix, division by zero when displaying a just-changed node
261
262 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
263 - bugfix with linetabs
264
265 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
266 - fix add interface from the node page
267
268 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
269 - only add users that are enabled and not yet a member of the slice
270 - fix to plc_peers
271 - my sites, my nodes, my persons improvements for users with multiple sites
272 - adds a script to minimize the java script files.
273
274 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
275 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
276
277 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
278 - first draft for pcu-handling features
279 - lighter contrat for PLE/PLC toggles
280 - as many 'my site'-like  links as the user has sites
281
282 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
283 - fix for whitelisted nodes
284 - now links to the node register wizard
285 - can enable sites
286 - various other minor fixes, like broken planetlab.module for techs, and login link
287
288 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
289 - plekittable knows how to turn off sort-on-load, and the admin users pages do
290 - + various cosmetic fixes
291
292 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
293 - a few minor improvements pushed on PLE
294
295 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
296 - fix for sites that were displayed as not public
297 - improvements to the python interface to sortable tables for monitor
298
299 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
300 - various improvements
301
302 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
303 - sliver page now correctly shows sliver tags
304 - support for download-node-usb-partition and various other improvements
305
306 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
307 - a few tweaks and typos fixed on PLE
308
309 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
310 - slice_add & node_download dialogs use plekit
311 - slice_add can add people in the slice
312 - various improvements after rollout on PLE
313
314 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
315 - cosmetic fixes to be in 4.3-rc2
316 - also a first (unpackaged) draft of the plekit table in python
317
318 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
319 - search in tables more robust
320
321 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
322 - performance improvements
323
324 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
325 - detect expired session and redirect to the login page
326
327 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
328 - improve browser health - was using too many cycles
329
330 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
331 - more consistency between views, and cosmetic changes
332
333 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
334 - area for managing slice tags
335
336 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
337 - first checkpoint tag for PLEWWW
338 - mostly functionally complete, probably a lot of tweaks still needed
339
340 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
341 - everyone is welcome to add nodes
342
343 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
344 - node-specific bootcd images to include arch in their name
345
346 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
347 - remove explicit dep to bootcd as the rpm name has changed
348
349 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
350 - noarch
351
352 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
353 - should fix yum.conf on nodes after install
354
355 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
356 - uses different path for getbootmedium results - should be safer
357
358 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
359 - comon icon replaced with the one from the comon website
360
361 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
362 - displays rpms in the about page
363
364 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
365 - safer, reference-less, way to implement layout mechnism - see
366 - settings.php for details
367 - setting types properly displayed according to user's role
368 - setting deletion : fixed (was still using code from slice attribute)
369 - more comon buttons : in the nodes and peers index pages
370 - comon_button knows about peer_id
371
372 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
373 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
374
375 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
376 - Initial build.