Setting tag plewww-5.2-5
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 5.2
4 %define taglevel 5
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: plcapi >= 5.2
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-5
129 - tweaks in node_downloads.php about memory size and compression scheme
130
131 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-4
132 - googlemap widget: support for gmap api v3 + various cosmetic tweaks
133 - can display site names with odd characters
134
135 * Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
136 - typo in help message about initscripts
137
138 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
139 - node page and person page show hrn in details
140
141 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
142 - late fix of registration for plcapi-5.1-6
143
144 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
145 - add extra code to prevent confidentiality leaks
146 - for vicci: $plc->hide_planetlab_block, that should not affect mainstream
147 - return_url for add-person and remove-person
148 - myslice.log now in /var/log/myslice/ (should have been cleaned up..)
149
150 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
151 - add tags section on site and person pages
152
153 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
154 - slightly tweak profiling points in slice.php
155
156 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
157 - ships with new default images for PLC/PLE from planet-lab.eu
158
159 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
160 - no change, just make sync for lxc-hosted tests
161
162 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
163 - refactoring for tophat/columns
164 - should take care of the irritating warning message about columns
165
166 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
167 - do not display the 'node' role when confusing
168
169 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
170 - support for setting nodes as reservable
171 - rely more on previous state when deciding to open or not toggles in a view
172 - remove statements for setting maximum memory usage, that sometimes
173
174 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
175 - node page can edit interfaces even when no interface
176
177 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
178 - uses a 2-week (!) session
179
180 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
181 - minor/cosmetic fixes in the leases area
182
183 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
184 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
185 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
186 - has a feature to 'test' pcu connection
187 - only admins can add users to different sites.
188 - remove dep. to outdated _gen_planetflow.php
189 - rephrased (disabled, or pending registration)
190 - + various fixes
191
192 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
193 - fix display glitch exposed with dimes initscript
194
195 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
196 - rename initscript_body into initscript_code
197
198 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
199 - bugfix for the reservation interface
200
201 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
202 - reservation page uses ajax - no need to reload after submit
203 - reservation dialogs for offset in the future & # slots
204 - fix the timezone in reservations (actually use php.ini)
205 - reservation visible (and hardwired) in nodes view
206 - have pulled prototype 1.7 but not in used yet
207
208 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
209 - set both 'omf_control' and 'vref' for omf-friendly slices
210
211 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
212 - display tags in alphabetic order in node view, tags section, the drop down menu
213
214 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
215 - on-the-fly retrieval of data at comon & tophat (unused so far)
216 - use accessors to store person's preference of columns
217 - fix in toggle.js for the '?' button, node table layout tab
218 - sort actions logging improved
219
220 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
221 - keep people from disabling or deleting themselves
222 - cannot become a disabled person
223 - outline people without a role
224
225 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
226 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
227
228 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
229 - tagging plewww for a new deployment
230
231 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
232 - add a 'report a problem' link for the RebootNode button
233 - new exp page nodes2.php with consistent selectable-columns layout as myslice
234 - tweaks in the exp. myslice (slices.php)
235
236 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
237 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
238 - my_slice with adjustable set of columns in slices/slice2.php
239 - fix for the 'site registration' page
240
241 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
242 - show message about leases - leases tab first in nodes section
243 - fix how reservable nodes show up
244
245 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
246 - cosmetic, rendering of textareas was like password fields
247
248 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
249 - bugfix in slice page, had wrong (null) expiration date
250 - upgraded to raphael-1.5.2, don't minimize this lib
251 - nicer layout for password fields as well
252 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
253 - marginally optimized slice page (2 GetNodes call down)
254 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
255 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
256 - reservations can cope with a bit more slots - will need scrolling someday
257 - omf text has hyperlinks to the tools
258
259 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
260 - reservation section now effective
261 - can set omf_control at slice-creation time
262 - can set node as reservable at node-creation time
263 - nicer text input fields + various tweaks
264
265 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
266 - show nodegroups form to add new groups
267
268 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
269 - just tagging plewww again to test module-tag on git
270
271 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
272 - encode strings properly in forms.
273
274 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
275 - Use readfile() function to reduce the memory footprint
276
277 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
278 - removed all deprecated functions for PHP-5.3 on fedora 12
279
280 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
281 - * exclude DNS from subnet checking
282 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
283 - * allow longer abbreviated names
284 - * don't let empty strings kill the server (postgresql and apache)
285
286 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
287 - disable drupal user registration (hard: patching the user module)
288
289 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
290 - * show error messages for update interface
291 - * 'Add Node' is admin only
292 - * add site selector for 'Add Node'
293
294 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
295 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
296 - this affects the settings of ifname and alias that were formerly set unconditionally
297 - review the interface-checking javascript code
298 - changed the interface to plekitform, method is now optional and part of an options hash
299
300 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
301 - can't use php objects for showing node status, this is too slow
302 - fix interface add page
303
304 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
305 - consistency in the way nodes status is displayed in the node and slice areas
306 - extra tags columns show up on the nodes page as well, tweaked in the process
307 - roles management in person page fixed
308
309 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
310 - displaying node tags in the nodes page as well
311 - table headers now can have a 'title' that shows up when hovering on the column header
312
313 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
314 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
315
316 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
317 - extensible set of columns in the nodes area of the (my)slice page
318 - nodegroups can be added/deleted/updated
319 - tags management improved marginally
320
321 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
322 - fix pending sites page - was getting fooled by ext_consortium_id=None
323
324 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
325 - resetting tag as something went wrong when setting 31
326
327 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
328 - nicer look for slice creation, (public) sites
329 - users show with all their sites in the persons page
330
331 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
332 - reviewed registration pages for persons and sites
333
334 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
335 - increase memory limit in the nodes page
336
337 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
338 - fixes one typo
339
340 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
341 - minor/cosmetic
342
343 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
344 - Add default Interface tags to extra interfaces.
345 - Add clearer 'Add New PCU' link on node page.
346 - Disable user registration for tech and PI roles.
347
348 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
349 - new 'controller' instantiation state available in add slice page
350
351 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
352 - exclude datepicler.js from jsmin
353 - table sort function for Last Contact columns
354 - drop options for generic boot images
355
356 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
357 - displays editable mac address for interfaces
358 - properly sorts bandwidths
359 - new 'controller' slice instantiation method
360 - bugfix, division by zero when displaying a just-changed node
361
362 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
363 - bugfix with linetabs
364
365 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
366 - fix add interface from the node page
367
368 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
369 - only add users that are enabled and not yet a member of the slice
370 - fix to plc_peers
371 - my sites, my nodes, my persons improvements for users with multiple sites
372 - adds a script to minimize the java script files.
373
374 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
375 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
376
377 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
378 - first draft for pcu-handling features
379 - lighter contrat for PLE/PLC toggles
380 - as many 'my site'-like  links as the user has sites
381
382 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
383 - fix for whitelisted nodes
384 - now links to the node register wizard
385 - can enable sites
386 - various other minor fixes, like broken planetlab.module for techs, and login link
387
388 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
389 - plekittable knows how to turn off sort-on-load, and the admin users pages do
390 - + various cosmetic fixes
391
392 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
393 - a few minor improvements pushed on PLE
394
395 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
396 - fix for sites that were displayed as not public
397 - improvements to the python interface to sortable tables for monitor
398
399 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
400 - various improvements
401
402 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
403 - sliver page now correctly shows sliver tags
404 - support for download-node-usb-partition and various other improvements
405
406 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
407 - a few tweaks and typos fixed on PLE
408
409 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
410 - slice_add & node_download dialogs use plekit
411 - slice_add can add people in the slice
412 - various improvements after rollout on PLE
413
414 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
415 - cosmetic fixes to be in 4.3-rc2
416 - also a first (unpackaged) draft of the plekit table in python
417
418 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
419 - search in tables more robust
420
421 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
422 - performance improvements
423
424 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
425 - detect expired session and redirect to the login page
426
427 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
428 - improve browser health - was using too many cycles
429
430 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
431 - more consistency between views, and cosmetic changes
432
433 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
434 - area for managing slice tags
435
436 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
437 - first checkpoint tag for PLEWWW
438 - mostly functionally complete, probably a lot of tweaks still needed
439
440 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
441 - everyone is welcome to add nodes
442
443 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
444 - node-specific bootcd images to include arch in their name
445
446 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
447 - remove explicit dep to bootcd as the rpm name has changed
448
449 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
450 - noarch
451
452 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
453 - should fix yum.conf on nodes after install
454
455 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
456 - uses different path for getbootmedium results - should be safer
457
458 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
459 - comon icon replaced with the one from the comon website
460
461 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
462 - displays rpms in the about page
463
464 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
465 - safer, reference-less, way to implement layout mechnism - see
466 - settings.php for details
467 - setting types properly displayed according to user's role
468 - setting deletion : fixed (was still using code from slice attribute)
469 - more comon buttons : in the nodes and peers index pages
470 - comon_button knows about peer_id
471
472 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
473 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
474
475 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
476 - Initial build.